source: projects/specs/trunk/r/rrdtool/rrdtool-vl.spec @ 12475

Revision 12475, 7.5 KB checked in by tomop, 4 years ago (diff)

updated 3 packages

libboost-1.72.0-2

postgresql-12.4-2

rrdtool-1.7.2-2

Line 
1
2# Basic Information
3Name:           rrdtool
4Summary:        RRDtool - Round Robin Database tool
5Summary(ja):    RRDtool - ラウンドロビンデータベースツール
6Version:        1.7.2
7Release:        2%{?_dist_release}
8Group:          admin-tools,graphics
9Vendor:         Project Vine
10Distribution:   Vine Linux
11Packager:       yasumichi
12
13License:        GPLv2+ with exceptions
14URL:            http://oss.oetiker.ch/rrdtool/
15Source0:        http://oss.oetiker.ch/%{name}/pub/%{name}-%{version}.tar.gz
16Patch3:         rrdtool-1.6.0-ruby-2-fix.patch
17
18BuildRoot:      %{_tmppath}/%{name}-%{version}-root
19# Dependency
20BuildRequires:  glib2-devel
21BuildRequires:  glibc-devel
22BuildRequires:  libdbi-devel
23BuildRequires:  libxml2-devel
24BuildRequires:  lua-devel
25BuildRequires:  pango-devel
26BuildRequires:  perl(ExtUtils::MakeMaker)
27BuildRequires:  python-devel
28BuildRequires:  python-setuptools
29BuildRequires:  ruby-devel
30BuildRequires:  tcl-devel
31
32%description
33It is pretty easy to gather status information from all sorts of things,
34ranging from the temperature in your office to the number of octets which
35have passed through the FDDI interface of your router. But it is not so
36trivial to store this data in a efficient and systematic manner. This is
37where RRDtool kicks in. It lets you log and analyze the data you gather from
38all kinds of data-sources (DS). The data analysis part of RRDtool is based
39on the ability to quickly generate graphical representations of the data
40values collected over a definable time period.
41
42#%%description -l ja
43
44
45%package devel
46Summary:        Libraries and include files of RRDtool
47Group:          system
48Requires:       %{name} = %{version}-%{release}
49
50%description devel
51Libraries and include files of RRDtool
52
53
54%package doc
55Summary: RRDtool documentation
56Summary(ja): RRDtool のドキュメント
57Group: documentation
58BuildArch: noarch
59
60%description doc
61RRD is the Acronym for Round Robin Database. RRD is a system to store and
62display time-series data (i.e. network bandwidth, machine-room temperature,
63server load average). This package contains documentation on using RRD.
64
65
66%package tcl
67Summary:        RRDTool modules for tcl
68Group:          programming
69Requires:       %{name} = %{version}-%{release}
70
71%description tcl
72RRDTool bindings for Tcl.
73
74
75%package -n perl-rrdtool
76Summary:        Perl RRDtool bindings
77Summary(ja):    RRDTool の perl バインディング
78Group:          programming
79Requires:       %{name} = %{version}-%{release}
80Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
81
82%description -n perl-rrdtool
83The Perl RRDTool bindings.
84
85
86%package -n python-rrdtool
87Summary:        Python RRDTool bindings
88Summary(ja):    RRDTool の Python バインディング
89Group:          programming
90Requires:       %{name} = %{version}-%{release}
91
92%description -n python-rrdtool
93RDTool bindings for python.
94
95
96%package -n python3-rrdtool
97Summary:        Python3 RRDTool bindings
98Summary(ja):    RRDTool の Python3 バインディング
99Group:          programming
100BuildRequires: python3-devel
101BuildRequires: python3-rpm-macros
102BuildRequires: python3-setuptools
103Requires:       %{name} = %{version}-%{release}
104
105%description -n python3-rrdtool
106RDTool bindings for python3.
107
108
109%package -n ruby-rrdtool
110Summary:        Ruby RRDTool bindings
111Summary(ja):    RRDTool の ruby バインディング
112Group:          programming
113Requires:       %{name} = %{version}-%{release}
114
115%description -n ruby-rrdtool
116RRDtool bindings for Ruby.
117
118
119%prep
120%setup -q
121%patch3 -p1 -b .ruby-2-fix
122autoreconf -vif
123
124
125%build
126%configure \
127    --disable-rpath \
128    --disable-static \
129    --enable-perl-site-install \
130    --with-perl-options="INSTALLDIRS=vendor" \
131    --enable-ruby \
132    --enable-ruby-site-install \
133    --with-pic
134
135# Fix another rpath issue
136%{__perl} -pi.orig -e 's|-Wl,--rpath -Wl,\$rp||g' \
137    bindings/perl-shared/Makefile.PL
138
139# Remove Rpath from Ruby
140%{__perl} -pi.orig -e 's|-Wl,--rpath -Wl,\$\(EPREFIX\)/lib||g' \
141    bindings/ruby/extconf.rb
142sed -i 's|/ruby/extconf.rb|/ruby/extconf.rb --vendor |' bindings/Makefile
143
144perl -pi -e 's/(rrdcached_LDADD =)/$1 \$(ALL_LIBS) /' src/Makefile
145%{__make} %{?_smp_mflags}
146
147%{__make} %{?_smp_mflags} -C bindings python PYTHON=%{__python3}
148
149
150%install
151%{__rm} -rf ${RPM_BUILD_ROOT}
152%{__make} install DESTDIR=${RPM_BUILD_ROOT}
153pushd bindings/python
154%{py3_install}
155popd
156
157# Install ruby module by force
158mkdir -p $RPM_BUILD_ROOT/%{ruby_vendorarchdir}
159make -C bindings/ruby install DESTDIR=$RPM_BUILD_ROOT
160
161# We only want .txt and .html files for the main documentation
162rm -rf docs_to_be_included
163mkdir -p docs_to_be_included/html docs_to_be_included/txt
164mv $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/html/* docs_to_be_included/html/
165mv $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/txt/* docs_to_be_included/txt/
166
167# Put perl docs in perl package
168rm -rf docs_perl
169mkdir -p docs_perl/html
170mv docs_to_be_included/html/RRD*.html docs_perl/html/
171
172# Clean up
173%{__rm} -rf $RPM_BUILD_ROOT%{_docdir}/%{name}-*
174%{__rm} -f ${RPM_BUILD_ROOT}%{_libdir}/lua/*/rrd.la
175%{__rm} -f ${RPM_BUILD_ROOT}%{_libdir}/librrd*.la
176%{__rm} -f ${RPM_BUILD_ROOT}%{perl_archlib}/perllocal.pod
177%{__rm} -f ${RPM_BUILD_ROOT}%{perl_vendorarch}/auto/*/.packlist
178
179%find_lang %{name}
180
181
182%clean
183%{__rm} -rf ${RPM_BUILD_ROOT}
184
185
186%post -p /sbin/ldconfig
187%postun -p /sbin/ldconfig
188
189
190%files -f %{name}.lang
191%defattr(-,root,root)
192#doc COPYING NEWS README TODO
193%{_bindir}/rrd*
194%{_libdir}/lua/*/rrd.so.*
195%{_libdir}/librrd*.so.*
196%{_mandir}/man1/*.1*
197%{_datadir}/rrdtool/examples/cgi-demo.cgi
198
199%files devel
200%defattr(-,root,root)
201%{_includedir}/rrd*.h
202%{_libdir}/lua/*/rrd.so
203%{_libdir}/librrd.so
204%{_libdir}/pkgconfig/librrd.pc
205%{_mandir}/man3/librrd.3*
206
207%files doc
208%defattr(-,root,root,-)
209%license COPYRIGHT LICENSE
210%doc CONTRIBUTORS TODO NEWS THREADS
211%doc docs_to_be_included/html docs_to_be_included/txt
212
213%files tcl
214%defattr(-,root,root)
215%doc bindings/tcl/README
216#%{_datadir}/rrdtool/ifOctets.tcl
217#%{_datadir}/rrdtool/pkgIndex.tcl
218%{_libdir}/tclrrd*.so
219%{_libdir}/rrdtool/*.tcl
220
221%files -n perl-rrdtool
222%defattr(-,root,root)
223%{perl_vendorlib}/RRDp.pm
224%{perl_vendorarch}/RRDs.pm
225%{perl_vendorarch}/auto/RRDs/RRDs.so
226%{_datadir}/rrdtool/examples/*.pl
227%{_datadir}/rrdtool/examples/rrdcached/RRDCached.pm
228%{_datadir}/rrdtool/examples/rrdcached/rrdcached-size.pl
229%{_mandir}/man3/RRD?.3pm*
230
231%files -n python-rrdtool
232%defattr(-,root,root)
233%license bindings/python/COPYING
234%doc bindings/python/AUTHORS bindings/python/README
235%{python_sitearch}/rrdtool-*-py*.egg-info
236%{python_sitearch}/rrdtool.so
237
238%files -n python3-rrdtool
239%defattr(-,root,root)
240%license bindings/python/COPYING
241%doc bindings/python/AUTHORS bindings/python/README
242%{python3_sitearch}/rrdtool-*-py*.egg-info
243%{python3_sitearch}/rrdtool.*.so
244%{_datadir}/rrdtool/examples/*.py
245
246%files -n ruby-rrdtool
247%defattr(-,root,root,-)
248%doc bindings/ruby/README
249%{ruby_vendorarchdir}/RRD.so
250
251
252%changelog
253* Mon Aug 17 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.7.2-2
254- rebuilt with python-3.8.
255
256* Mon Mar 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.7.2-1
257- new upstream release.
258- built with ruby-2.6.5.
259- added python3 support.
260
261* Sat May 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.7.1-1
262- new upstream release.
263- rebuilt with perl-5.26.
264- rebuilt with ruby-2.4.6.
265- updated Patch3.
266
267* Sun Sep 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.9-3
268- rebuild with ruby-2.2.3
269
270* Sun Jan 25 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.9-2
271- rebuild with libdbi-0.9.0
272
273* Mon Jan  5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.4.9-1
274- new upstream release.
275- added Group tag to subpackages
276- added ruby subpackages
277- split documents into subpackages
278- added %%post and %%postun section
279
280* Tue Jul  1 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.8-1
281- new upstream release.
282
283* Fri Feb 17 2012 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.4.7-1
284- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.