source: projects/specs/trunk/r/rrdtool/rrdtool-vl.spec @ 12120

Revision 12120, 6.7 KB checked in by tomop, 5 years ago (diff)

perl-5.26 and friends

RevLine 
[5728]1
2# Basic Information
3Name:           rrdtool
[12120]4Version:        1.7.1
5Release:        1%{?_dist_release}
[9229]6License:        GPLv2+ with exceptions
7Group:          Applications/Databases
[5728]8URL:            http://oss.oetiker.ch/rrdtool/
[9229]9
[5728]10Source0:        http://oss.oetiker.ch/%{name}/pub/%{name}-%{version}.tar.gz
[12120]11Patch3:         rrdtool-1.6.0-ruby-2-fix.patch
[5728]12
13Summary:        RRDtool - Round Robin Database tool
14Summary(ja):    RRDtool - ラウンドロビンデータベースツール
15
[9229]16BuildRoot:      %{_tmppath}/%{name}-%{version}-root
[5728]17# Dependency
18BuildRequires:  glib2-devel
19BuildRequires:  glibc-devel
[9229]20BuildRequires:  libdbi-devel
[5728]21BuildRequires:  libxml2-devel
22BuildRequires:  lua-devel
23BuildRequires:  pango-devel
[9229]24BuildRequires:  perl(ExtUtils::MakeMaker)
25BuildRequires:  python-devel
[12120]26BuildRequires:  python-setuptools
[9229]27BuildRequires:  ruby-devel
[9748]28BuildRequires:  tcl-devel
[5728]29
[9229]30Vendor:         Project Vine
31Distribution:   Vine Linux
32Packager:       yasumichi
33
34
[5728]35%description
36It is pretty easy to gather status information from all sorts of things,
37ranging from the temperature in your office to the number of octets which
38have passed through the FDDI interface of your router. But it is not so
39trivial to store this data in a efficient and systematic manner. This is
40where RRDtool kicks in. It lets you log and analyze the data you gather from
41all kinds of data-sources (DS). The data analysis part of RRDtool is based
42on the ability to quickly generate graphical representations of the data
43values collected over a definable time period.
44
45#%%description -l ja
46
47%package devel
48Summary:        Libraries and include files of RRDtool
[9229]49Group:          Development/Libraries
50Requires:       %{name} = %{version}-%{release}
[5728]51
52%description devel
53Libraries and include files of RRDtool
54
[9229]55
56%package doc
57Summary: RRDtool documentation
58Summary(ja): RRDtool のドキュメント
59Group: Applications/Documentation
60BuildArch: noarch
61
62%description doc
63RRD is the Acronym for Round Robin Database. RRD is a system to store and
64display time-series data (i.e. network bandwidth, machine-room temperature,
65server load average). This package contains documentation on using RRD.
66
67
[5728]68%package tcl
69Summary:        RRDTool modules for tcl
[9229]70Group:          Development/Libraries
71Requires:       %{name} = %{version}-%{release}
[5728]72
73%description tcl
[9229]74RRDTool bindings for Tcl.
[5728]75
[9229]76
[5728]77%package -n perl-rrdtool
[9229]78Summary:        Perl RRDtool bindings
79Summary(ja):    RRDTool の perl バインディング
80Group:          Development/Libraries
81Requires:       %{name} = %{version}-%{release}
82Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
[5728]83
84%description -n perl-rrdtool
[9229]85The Perl RRDTool bindings.
[5728]86
[9229]87
[5728]88%package -n python-rrdtool
[9229]89Summary:        Python RRDTool bindings
90Summary(ja):    RRDTool の Python バインディング
91Group:          Development/Libraries
92Requires:       %{name} = %{version}-%{release}
[5728]93
94%description -n python-rrdtool
[9229]95RDTool bindings for python.
[5728]96
[9229]97
98%package -n ruby-rrdtool
99Summary:        Ruby RRDTool bindings
100Summary(ja):    RRDTool の ruby バインディング
101Group:          Development/Libraries
102Requires:       %{name} = %{version}-%{release}
103
104%description -n ruby-rrdtool
105RRDtool bindings for Ruby.
106
107
[5728]108%prep
109%setup -q
[9229]110%patch3 -p1 -b .ruby-2-fix
[12120]111autoreconf -vif
[5728]112
113%build
[8710]114%configure \
[9229]115    --disable-rpath \
116    --disable-static \
117    --enable-perl-site-install \
118    --with-perl-options="INSTALLDIRS=vendor" \
119    --enable-ruby \
[12120]120    --enable-ruby-site-install \
[9229]121    --with-pic
[8710]122
[9229]123# Fix another rpath issue
124%{__perl} -pi.orig -e 's|-Wl,--rpath -Wl,\$rp||g' \
125    bindings/perl-shared/Makefile.PL
126
127# Remove Rpath from Ruby
128%{__perl} -pi.orig -e 's|-Wl,--rpath -Wl,\$\(EPREFIX\)/lib||g' \
129    bindings/ruby/extconf.rb
[12120]130sed -i 's|/ruby/extconf.rb|/ruby/extconf.rb --vendor |' bindings/Makefile
[9229]131
[8710]132perl -pi -e 's/(rrdcached_LDADD =)/$1 \$(ALL_LIBS) /' src/Makefile
[5728]133%{__make} %{?_smp_mflags}
134
[9229]135
[5728]136%install
137%{__rm} -rf ${RPM_BUILD_ROOT}
138%{__make} install DESTDIR=${RPM_BUILD_ROOT}
139
[9229]140# Install ruby module by force
141mkdir -p $RPM_BUILD_ROOT/%{ruby_vendorarchdir}
142make -C bindings/ruby install DESTDIR=$RPM_BUILD_ROOT
143
144# We only want .txt and .html files for the main documentation
145rm -rf docs_to_be_included
146mkdir -p docs_to_be_included/html docs_to_be_included/txt
147mv $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/html/* docs_to_be_included/html/
148mv $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/txt/* docs_to_be_included/txt/
149
150# Put perl docs in perl package
151rm -rf docs_perl
152mkdir -p docs_perl/html
153mv docs_to_be_included/html/RRD*.html docs_perl/html/
154
155# Clean up
156%{__rm} -rf $RPM_BUILD_ROOT%{_docdir}/%{name}-*
[12120]157%{__rm} -f ${RPM_BUILD_ROOT}%{_libdir}/lua/*/rrd.la
[5728]158%{__rm} -f ${RPM_BUILD_ROOT}%{_libdir}/librrd*.la
159%{__rm} -f ${RPM_BUILD_ROOT}%{perl_archlib}/perllocal.pod
[9229]160%{__rm} -f ${RPM_BUILD_ROOT}%{perl_vendorarch}/auto/*/.packlist
[5728]161
[12120]162%find_lang %{name}
[5728]163
164%clean
165%{__rm} -rf ${RPM_BUILD_ROOT}
166
[9229]167%post -p /sbin/ldconfig
[5728]168
[9229]169%postun -p /sbin/ldconfig
170
[12120]171%files -f %{name}.lang
[5728]172%defattr(-,root,root)
[9229]173#doc COPYING NEWS README TODO
[5728]174%{_bindir}/rrd*
[12120]175%{_libdir}/lua/*/rrd.so.*
[5728]176%{_libdir}/librrd*.so.*
177%{_mandir}/man1/*.1*
178%{_datadir}/rrdtool/examples/cgi-demo.cgi
179
180%files devel
181%defattr(-,root,root)
182%{_includedir}/rrd*.h
[12120]183%{_libdir}/lua/*/rrd.so
[5728]184%{_libdir}/librrd.so
185%{_libdir}/pkgconfig/librrd.pc
[9229]186%{_mandir}/man3/librrd.3*
[5728]187
[9229]188%files doc
189%defattr(-,root,root,-)
[12120]190%license COPYRIGHT LICENSE
191%doc CONTRIBUTORS TODO NEWS THREADS
[9229]192%doc docs_to_be_included/html docs_to_be_included/txt
193
[5728]194%files tcl
195%defattr(-,root,root)
[9229]196%doc bindings/tcl/README
[12120]197#%{_datadir}/rrdtool/ifOctets.tcl
198#%{_datadir}/rrdtool/pkgIndex.tcl
[5728]199%{_libdir}/tclrrd*.so
[12120]200%{_libdir}/rrdtool/*.tcl
[5728]201
202%files -n perl-rrdtool
203%defattr(-,root,root)
[8710]204%{perl_vendorlib}/RRDp.pm
205%{perl_vendorarch}/RRDs.pm
206%{perl_vendorarch}/auto/RRDs/RRDs.so
[5728]207%{_datadir}/rrdtool/examples/*.pl
208%{_datadir}/rrdtool/examples/rrdcached/RRDCached.pm
209%{_datadir}/rrdtool/examples/rrdcached/rrdcached-size.pl
[9229]210%{_mandir}/man3/RRD?.3pm*
[5728]211
212%files -n python-rrdtool
213%defattr(-,root,root)
[9229]214%doc bindings/python/AUTHORS bindings/python/COPYING bindings/python/README
[12120]215%{python_sitearch}/rrdtool-*-py*.egg-info
216%{python_sitearch}/rrdtool.so
217%{_datadir}/rrdtool/examples/*.py
[5728]218
[9229]219%files -n ruby-rrdtool
220%defattr(-,root,root,-)
221%doc bindings/ruby/README
222%{ruby_vendorarchdir}/RRD.so
223
[5728]224%changelog
[12120]225* Sat May 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.7.1-1
226- new upstream release.
227- rebuilt with perl-5.26.
228- rebuilt with ruby-2.4.6.
229- updated Patch3.
230
[9748]231* Sun Sep 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.9-3
232- rebuild with ruby-2.2.3
233
[9291]234* Sun Jan 25 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.9-2
235- rebuild with libdbi-0.9.0
236
[9229]237* Mon Jan  5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.4.9-1
238- new upstream release.
239- added Group tag to subpackages
240- added ruby subpackages
241- split documents into subpackages
242- added %%post and %%postun section
243
[8710]244* Tue Jul  1 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.8-1
245- new upstream release.
246
[5728]247* Fri Feb 17 2012 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.4.7-1
248- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.