source: projects/specs/trunk/r/rhythmbox/rhythmbox-vl.spec @ 9572

Revision 9572, 20.6 KB checked in by inagaki, 9 years ago (diff)

2015-05-22 Ryoichi INAGAKI <ryo1@…>

  • digikam, libimobiledevice, libplist, libusbmuxd: updated
  • gnome-mplayer, gtkpod, gvfs, ifuse, libgpod, rhythmbox, upower, usbmuxd: rebuilt


Line 
1# -*- coding: utf-8-unix -*-
2%define desktop_file_utils_version 0.9
3
4%define enable_DLNA_UPnP 0
5
6Summary: Music Management Application
7Summary(ja): 音楽管理アプリケーション
8Name: rhythmbox
9Version: 3.2.1
10Release: 2%{?_dist_release}
11License: GPL2+ with exceptions and GFDL
12Group: Applications/Multimedia
13URL: http://projects.gnome.org/rhythmbox/
14Source0: http://download.gnome.org/sources/${name}/3.2/%{name}-%{version}.tar.xz
15
16Source101:      rhythmbox-png.tar.bz2
17
18Patch0: rhythmbox-3.0-disable-python3.patch
19
20BuildRoot: %{_tmppath}/%{name}-%{version}-root
21BuildRequires: gtk3-devel
22BuildRequires: avahi-glib-devel >= 0.6
23BuildRequires: brasero-devel >= 2.32.0
24BuildRequires: dbus-glib-devel
25BuildRequires: gstreamer1-plugins-base-devel
26BuildRequires: json-glib-devel
27BuildRequires: libSM-devel
28BuildRequires: libgnome-keyring-devel >= 2.30.0
29BuildRequires: libgpod-devel
30BuildRequires: eudev-libgudev1-devel
31BuildRequires: libmusicbrainz3-devel >= 3.0.2
32BuildRequires: libnotify-devel
33BuildRequires: libsoup-devel
34BuildRequires: pygobject3-devel
35BuildRequires: totem-pl-parser-devel
36BuildRequires: WebKit3-gtk-devel
37BuildRequires: libpeas-devel
38BuildRequires: clutter-gtk-devel
39BuildRequires: clutter-gst-devel
40BuildRequires: libmx-devel
41BuildRequires: check-devel
42BuildRequires: libmtp-devel
43BuildRequires: libtdb-devel
44BuildRequires: grilo-devel
45BuildRequires: libdmapsharing-devel
46BuildRequires: lirc
47BuildRequires: gnome-doc-utils >= 0.3.2
48BuildRequires: yelp-tools
49
50Requires: brasero
51Requires: libgnome-keyring
52%if %{enable_DLNA_UPnP}
53Requires: python-Coherence
54%endif
55Requires: desktop-file-utils >= %{desktop_file_utils_version}
56
57# # gstreamer-plugins-ffmpeg and gstreamer-plugins-ugly package provided by
58# # self-build-gstreamer-plugins-ffmpeg and self-build-gstreamer-plugins-ugly,
59# # respectively.
60# Requires: self-build-gstreamer-plugins-ffmpeg
61# Requires: self-build-gstreamer-plugins-ugly
62
63Vendor: Project Vine
64Distribution: Vine Linux
65
66
67%description
68Rhythmbox is an integrated music management application based on the powerful
69GStreamer media framework. It has a number of features, including an easy to
70use music browser, searching and sorting, comprehensive audio format support
71through GStreamer, Internet Radio support, playlists and more.
72
73Rhythmbox is extensible through a plugin system.
74
75%description -l ja
76Rhythmbox は、強力な GStreamer メディアフレームワークに基づいている
77統合音楽管理アプリケーションです。
78見やすいユーザインターフェースを備え、検索や整列ができ、
79GStreamer により数多くの音声フォーマットをサポート、
80インターネットラジオをサポート、プレイリスト管理などの
81数多くの特徴を持ちます。
82
83%package devel
84Summary: Development tools for rhythmbox applications.
85Summary(ja): rhythmbox アプリケーションの開発用ファイル
86Group: Development/Libraries
87Requires: %{name} = %{version}-%{release}
88Requires: pkgconfig
89Requires: libxml2-devel
90Requires: glib2-devel
91Requires: gtk3-devel
92Requires: libsoup-devel
93Requires: totem-pl-parser-devel
94Requires: gstreamer1-devel
95
96%description devel
97Header files and libraries for building a extension library for the rhythmbox.
98
99%description devel -l ja
100
101%prep
102%setup -q
103%patch0 -p1
104tar xjf %{SOURCE101}
105
106%build
107autoreconf -if
108intltoolize --force --copy
109%configure --with-ipod \
110    --with-mtp \
111    --enable-lirc \
112    --disable-python \
113    --disable-vala \
114    --disable-browser-plugin \
115    --disable-static \
116    --enable-browser-plugin \
117    --without-hal
118%__make %{?_smp_mflags}
119
120%install
121%__rm -rf $RPM_BUILD_ROOT
122%__make install DESTDIR=$RPM_BUILD_ROOT
123
124%__rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/*.{a,la}
125%__rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/librb-nautilus-context-menu.so
126%__rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
127%__rm -f $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*.{a,la}
128%__rm -f $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*/*.{a,la}
129%__rm -f $RPM_BUILD_ROOT%{_libdir}/librhythmbox-core.{a,la}
130%__rm -f $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins/*.{a,la}
131
132## Don't package DLNA/UPnP plugin
133%if !%{enable_DLNA_UPnP}
134%__rm -rf $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/upnp_coherence
135%endif
136
137%find_lang %{name} --all-name --with-gnome
138
139
140# Don't package api docs
141%__rm -rf $RPM_BUILD_ROOT%{_datadir}/gtk-doc/
142
143# And don't package vala
144%__rm -f %{buildroot}%{_libdir}/rhythmbox/plugins/libsample-vala.so \
145        %{buildroot}%{_libdir}/rhythmbox/plugins/sample-vala.rb-plugin
146
147# remove sample plugins
148rm -rf $RPM_BUILD_ROOT/%{_libdir}/%{name}/sample-plugins
149
150%clean
151%__rm -rf $RPM_BUILD_ROOT
152
153%post
154/sbin/ldconfig
155update-desktop-database -q
156touch --no-create %{_datadir}/icons/hicolor
157if [ -x /usr/bin/gtk-update-icon-cache ]; then
158  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
159fi
160
161%postun
162/sbin/ldconfig
163update-desktop-database -q
164touch --no-create %{_datadir}/icons/hicolor
165if [ -x /usr/bin/gtk-update-icon-cache ]; then
166  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
167fi
168glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
169
170%posttrans
171glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
172
173
174%files -f %{name}.lang
175%defattr(-, root, root)
176%doc AUTHORS COPYING ChangeLog README NEWS
177%{_bindir}/*
178%{_libdir}/girepository-1.0/*.typelib
179%{_libdir}/lib*.so.*
180%{_libdir}/mozilla/plugins/librhythmbox-itms-detection-plugin.so
181%{_libdir}/rhythmbox/plugins
182%{_datadir}/appdata/rhythmbox.appdata.xml
183%{_datadir}/applications/rhythmbox.desktop
184%{_datadir}/applications/rhythmbox-device.desktop
185%{_datadir}/dbus-1/services/org.gnome.Rhythmbox3.service
186%{_datadir}/glib-2.0/schemas/org.gnome.rhythmbox.gschema.xml
187%{_datadir}/icons/*
188%{_datadir}/rhythmbox
189%{_mandir}/man1/*
190%{_libexecdir}/rhythmbox-metadata
191
192%files devel
193%defattr(-, root, root)
194%{_includedir}/%{name}/*
195%{_libdir}/*.so
196%{_libdir}/pkgconfig/*.pc
197%{_datadir}/gir-1.0/*.gir
198
199
200%changelog
201* Thu May 21 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.2.1-2
202- rebuilt with libimobiledevice 1.2.0 and libplist 1.12
203
204* Sun May 03 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
205- new upstream release
206
207* Sat Apr 04 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2-1
208- new upstream release
209
210* Wed Jul 09 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 3.0.3-2
211- rebuild with new libimobiledevice
212
213* Sat Jun 07 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.3-1
214- new upstream release
215
216* Sun Mar 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.2-1
217- new upstream release
218
219* Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.1-2
220- rebuild with VineSeed environment
221
222* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.1-1
223- new upstream release
224
225* Fri Sep 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0-1
226- new upstream release
227- add Patch0 (rhythmbox-3.0-disable-python3.patch)
228
229* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.99.1-1
230- new upstream release
231- add BuildRequies: yelp-tools
232- change BuildRequires: gstreamer1-plugins-base-devel instead of gstreamer-plugins-base-devel
233
234* Sun Mar 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.98-2
235- rebuild with libimobiledevice-1.1.5
236
237* Mon Oct 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.98-1
238- new upstream release
239- add BuildRequires: grilo-devel, libdmapsharing-devel
240
241* Tue Jun 05 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.97-1
242- new upstream release
243
244* Wed Apr 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.96-1
245- new upstream release
246
247* Sat Jan 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.95-1
248- new upstream release
249- add BuildRequires: gtk3-devel, libtdb-devel, pygobject3-devel
250- remove BuildRequires: gnome-vfs2-devel, gstreamer-python-devel, libffi-devel, libgnome-media-profiles-devel, libgnomeui-devel, libsexy-devel, popt-devel, python-devel, pygtk2-devel, sqlite3-devel
251
252* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-4
253- rebuild with cogl-0.8.0
254
255* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-3
256- rebuild with libnotify-0.7
257- change BuildRequires: libmusicbrainz3-devel instead of libmusicbrainz-devel
258- change BuildRequires: libgnome-media-profiles-devel instead of gnome-media-devel
259- add BuildRequires: WebKit3-gtk-devel, libpeas-devel, clutter-gtk-devel, clutter-gst-devel, libmx-devel
260- add Patch0 (rhythmbox-0.13.3-git20110809.patch)
261- add Source101 (rhythmbox-png.tar.bz2)
262
263* Fri Aug 12 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-2
264- add BuildRequires: json-glib-devel
265- remove unrecognized configure option (--with-dbus, --with-cd-burning, --with-metadata-helper)
266
267* Sun Jan 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-1
268- new upstream release
269- change BuildRequires: gstreamer-python-devel instead of gstreamer-python
270
271* Sat Nov 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.2-1
272- new upstream release
273
274* Wed Oct 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-3
275- rebuild with brasero-2.32.0
276
277* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-2
278- rebuild with rpm-4.8.1 for pkg-config file
279
280* Sun Sep 12 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-1
281- new upstream release
282- fix %files (add rhythmbox-device.desktop)
283
284* Sun Aug 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.0-1
285- new upstream release
286- change BuildRequires: gnome-media-devel instead of gnome-media
287- add devel package
288- drop Patch0
289
290* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.8-1
291- new upstream release
292- drop Patch1, Patch2, Patch3
293- change BuildRequires: nautilus-cd-burner -> brasero-devel
294- change Requires: nautilus-cd-burner -> brasero
295- change BuildRequires: hal-devel -> libgudev1-devel
296- change BuildRequires: gnome-keyring-devel -> libgnome-keyring-devel
297- change Requires: gnome-keyring -> libgnome-keyring
298- add configure option (--without-hal)
299
300* Mon Feb 15 2010 Shu KONNO <owa@bg.wakwak.com> 0.12.6-2
301- rebuilt with new environment
302
303* Thu Jan 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.6-1
304- new upstream release
305  - dropped upstreamed/obsolete patches
306  - added patches applied Fedora development
307
308* Sun Oct 04 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.5-1
309- new upstream release
310- added configure options:
311  --disable-vala
312  --disable-browser-plugin
313
314* Thu Jul 30 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.2-2
315- added Japanese description
316
317* Thu Jul 02 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.12.2-1
318- new upstream release
319  - dropped rb-disable-power-plugin-by-default.patch
320- added BuildRequires:
321  - libSM-devel
322  - gnome-media
323
324* Wed Jun 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.12.1-2
325- rebuild with libgpod-0.7.2
326
327* Sun May 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.12.1-1
328- new upstream release
329- corrected License tag
330- dropped rhythmbox-0.11.6-libmtp.patch
331- added BuildRequires:
332  - sqlite3-devel
333  - libffi-devel
334
335* Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.11.6-2
336- defined enable_DLNA_UPnP = 0: unpacked DLNA/UPnP plugin
337- applied rhythmbox-0.11.6-libmtp.patch
338- added Requires:
339  - libgpod
340  - libnotify
341  - libsexy
342  - lirc
343  - libmtp
344  - libgnomeui
345  - nautilus-cd-burner
346  - gstreamer-python
347  - gnome-vfs2
348  - gnome-themes
349  - gnome-keyring
350  - python-Coherence, if enable_DLNA_UPnP = 1
351- added BuildRequires:
352  - libnotify-devel
353  - libsexy-devel
354  - lirc
355  - libmtp-devel
356  - gnome-vfs2-devel, instead of gnome-vfs2
357  - gnome-keyring-devel
358- dropped --with-internal-libsexy in configure options
359- added in configure options:
360  --with-mtp --with-libnautilus-burn --enable-lirc --disable-static
361- added %%preun to remove the schema
362
363* Sun Jan 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.11.6-1
364- new upstream release
365- changed to --with-metadata-helper in configure options
366- added BuildRequires:
367  - gstreamer-python
368  - intltool >= 0.35.0
369  - popt-devel
370
371* Sat Aug 09 2008 Shu KONNO <owa@bg.wakwak.com> 0.11.2-1vl5
372- added BuildRequires: totem-pl-parser-devel, instead of totem-devel
373- rebuilt with python-2.5.2
374- applied new versioning policy
375- spec in utf-8
376
377* Sun Jan 06 2008 Shu KONNO <owa@bg.wakwak.com> 0.11.2-0vl2
378- rebuilt with libgpod-0.6.0
379
380* Sun Aug 26 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.2-0vl1
381- new upstream release
382
383* Wed Jun 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.1-0vl1
384- new upstream release
385
386* Tue May 29 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.10.0-0vl2
387- rebuilt with new toolchain and libgpod-0.4.2
388- add BuildRequires: dbus-glib-devel
389
390* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.0-0vl1
391- new upstream release
392
393* Wed Mar 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8-0vl2
394- rebuilt for VineSeed
395
396* Wed Mar 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8-0vl1
397- new upstream release
398- added --enable-python option to %%configure
399- added Requires: gnome-python
400
401* Sun Jan 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.7-0vl1
402- new upstream release
403- built with libsoup 2.2.99
404
405* Thu Nov 23 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6-0vl4
406- added --with-cd-burner to configure
407- added BuildRequires: libsexy-devel hal-devel libsoup-devel
408
409* Wed Oct 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.6-0vl3
410- add BuildRequires:
411  - gnome-doc-utils >= 0.3.2
412  - python-devel
413  - pygtk2-devel
414  - check >= 0.8.2
415
416* Tue Oct 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.6-0vl2
417- rebuild with gnutls-1.4.1
418
419* Sun Oct  1 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6-0vl1
420- new upstream release
421
422* Mon Jun 19 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.5-0vl1
423- new upstream release
424- run scrollkeeper-update at %post and %postun
425- added BuildRequires: libnotify-devel
426
427* Sun May 14 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.4.1-0vl1
428- new upstream release (dropped patch0)
429- added --without-metadata-helper at configure
430
431* Mon Mar 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.3.1-0vl1
432- Initial build for Vine Linux based on FC pacakge
433
434* Fri Mar 03 2006 Ray Strode <rstrode@redhat.com> - 0.9.3.1-2
435- add patch from James "Doc" Livingston to stop a hang
436  for new users (bug 183883)
437
438* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3.1-1.2
439- bump again for double-long bug on ppc(64)
440
441* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3.1-1.1
442- rebuilt for new gcc4.1 snapshot and glibc changes
443
444* Sat Feb  4 2006 Christopher Aillon <caillon@redhat.com> 0.9.3.1-1
445- Update to 0.9.3.1
446- Use gstreamer (0.10)
447
448* Wed Feb  1 2006 Christopher Aillon <caillon@redhat.com> 0.9.3-2
449- Remove hack for 173869, as its no longer needed.
450
451* Wed Feb  1 2006 Christopher Aillon <caillon@redhat.com> 0.9.3-1
452- 0.9.3
453
454* Wed Feb  1 2006 Christopher Aillon <caillon@redhat.com> 0.9.2.cvs20060201-1
455- Newer CVS snapshot
456
457* Sun Jan 22 2006 Christopher Aillon <caillon@redhat.com> 0.9.2.cvs20060123-1
458- Update to latest CVS
459- Add hack to workaround bug #173869
460
461* Thu Jan 19 2006 Christopher Aillon <caillon@redhat.com> 0.9.2-8
462- Rebuild, now that gstreamer08-plugins has been fixed
463
464* Thu Jan 19 2006 Ray Strode <rstrode@redhat.com> 0.9.2-7
465- bonobo multilib issue (bug 156982)
466
467* Wed Jan 04 2006 John (J5) Palmieri <johnp@redhat.com> 0.9.2-5
468- rebuild with ipod support
469
470* Tue Jan 03 2006 Jesse Keating <jkeating@redhat.com> 0.9.2-4
471- rebuilt again
472
473* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
474- rebuilt
475
476* Mon Dec  5 2005 Matthias Clasen <mclasen@redhat.com>
477- rebuild
478
479* Thu Dec 01 2005 John (J5) Palmieri <johnp@redhat.com>
480- rebuild for new dbus
481
482* Wed Nov 30 2005 Matthias Clasen <mclasen@redhat.com>
483- Update to 0.9.2
484
485* Tue Oct 25 2005 Matthias Clasen <mclasen@redhat.com>
486- Update to 0.9.1
487
488* Fri Sep 02 2005 Colin Walters <walters@redhat.com>
489- Add configure flags --with-bonobo --with-dbus
490- BR nautilus-cd-burner-devel
491- New upstream CVS snapshot for testing
492- Drop IDL file and ui .xml
493- Add dbus service file
494- Drop upstreamed rhythmbox-bluecurve.tar.gz
495- Drop upstreamed rhythmbox-0.8.8-cell-renderer.patch
496
497* Mon Jun 13 2005 Colin Walters <walters@redhat.com> - 0.8.8-3
498- Add Bluecurve-ized icons from Jeff Schroeder (157716)
499- Add rhythmbox-0.8.8-cell-renderer.patch to remove use of custom
500  cell renderer for playback icon (no longer necessary) and
501  changes the rating renderer to work with non-b&w icons
502
503* Mon Mar 14 2005 Colin Walters <walters@redhat.com> - 0.8.8-2
504- Rebuild for GCC4
505
506* Tue Oct 05 2004 Colin Walters <walters@redhat.com> - 0.8.8-1
507- New upstream version
508- Remove librb-nautilus-context-menu.so, killed upstream
509
510* Thu Sep 30 2004 Christopher Aillon <caillon@redhat.com> 0.8.7-2
511- PreReq desktop-file-utils >= 0.9
512
513* Wed Sep 29 2004 Colin Walters <walters@redhat.com> - 0.8.7-1
514- New upstream version
515
516* Sat Sep 18 2004 Colin Walters <walters@redhat.com> - 0.8.6-2
517- Fix postun to use correct syntax, thanks Nils Philippsen
518
519* Sat Sep 18 2004 Colin Walters <walters@redhat.com> - 0.8.6-1
520- New upstream version
521- Call update-desktop-database in post and postun
522
523* Thu Jun 24 2004 Colin Walters <walters@redhat.com> - 0.8.5-1
524- New upstream version
525
526* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
527- rebuilt
528
529* Tue May 18 2004 Colin Walters <walters@redhat.com> - 0.8.4-1
530- New upstream version
531- Remove backported patches
532- Gratuitiously bump various BuildRequires versions
533
534* Mon May 10 2004 Colin Walters <walters@redhat.com> - 0.8.3-4
535- Remove code to unregister GConf schema for now (Closes: #122532)
536
537* Fri May 07 2004 Colin Walters <walters@redhat.com> - 0.8.3-3
538- Apply tiny patch from 0.8 arch to fix GConf key used
539  for initial sorting
540
541* Fri May 07 2004 Colin Walters <walters@redhat.com> - 0.8.3-2
542- Apply patch from 0.8 arch tree to fix a number of memleaks
543
544* Sun May 02 2004 Colin Walters <walters@redhat.com> - 0.8.3-1
545- Update to 0.8.3: fixes showstopper bug with internet radio
546
547* Fri Apr 30 2004 Colin Walters <walters@redhat.com> - 0.8.2-1
548- Update to 0.8.2
549- Fix Source url
550- Add smp_mflags
551- Bump BuildRequires on gstreamer to 0.8.1
552
553* Fri Apr 23 2004 Colin Walters <walters@redhat.com> - 0.8.1-2
554- Uninstall GConf schemas on removal
555
556* Tue Apr 20 2004 Colin Walters <walters@redhat.com> - 0.8.1-1
557- Update to 0.8.1
558
559* Fri Apr 16 2004 Colin Walters <walters@redhat.com> - 0.8.0-1
560- Update to 0.8.0
561
562* Fri Apr 02 2004 Colin Walters <walters@redhat.com> - 0.7.2-1
563- Update to 0.7.2
564
565* Mon Mar 29 2004 Colin Walters <walters@redhat.com> - 0.7.1-2
566- Remove BuildRequires on autoconf and libvorbis-devel
567
568* Mon Mar 29 2004 Colin Walters <walters@redhat.com> - 0.7.1-1
569- New major version - I know we are past major version slush, but
570  this should have been done two weeks ago along with the GNOME 2.6
571  upload.  As upstream author as well, I believe this version is
572  good enough for FC2.
573- Remove --disable-mp3
574- Remove id3, flac variables
575- Remove GStreamer major version patch
576- Fix typo in description
577
578* Tue Mar 16 2004 Jeremy Katz <katzj@redhat.com> - 0.6.8-2
579- rebuild for new gstreamer
580
581* Thu Mar 11 2004 Alex Larsson <alexl@redhat.com> 0.6.8-1
582- update to 0.6.8
583
584* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
585- rebuilt
586
587* Mon Mar  1 2004 Alexander Larsson <alexl@redhat.com> 0.6.7-1
588- update to 0.6.7
589
590* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
591- rebuilt
592
593* Mon Jan 12 2004 Colin Walters <walters@verbum.org> 0.6.4-1
594- New upstream version
595- Don't re-run the autotools; upstream incorporates newer versions.
596* Tue Oct 28 2003 Jonathan Blandford <jrb@redhat.com> 0.5.4-1
597- new version
598- remove smp_flags
599
600* Fri Oct 24 2003 Jonathan Blandford <jrb@redhat.com> 0.5.3-5
601- remove the initial iradio channels as they all are mp3 based.
602
603* Wed Oct  8 2003 Matthias Saou <matthias@rpmforge.net> 0.5.3-3
604- Fix category from Development/Libraries to Applications/Multimedia.
605- Use bz2 instead of gz as ftp.gnome.org has both, 300k saved in the src.rpm.
606- Fix SCHEMES vs. SCHEMAS in the post scriplet.
607- Added gstreamer-plugins-devel, libvorbis-devel, scrollkeeper and gettext deps.
608- Removed unnecessary date expansion define.
609- Updated description, including mp3 reference removal.
610- Added libid3tag and flac optional support for convenient rebuild.
611- Removed obsolete omf.make and xmldocs.make (included ones are the same now).
612
613* Mon Sep 22 2003 Jonathan Blandford <jrb@redhat.com> 0.5.3-1
614- new version
615- use %{_sysconfdir} instead of /etc
616
617* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
618- rebuilt
619
620* Wed Dec 18 2002 Jonathan Blandford <jrb@redhat.com>
621- gave up on other archs for the Beta
622- new version
623- remove werror and add missing files
624
625* Thu Nov  7 2002 Jeremy Katz <katzj@redhat.com>
626- update to newer cvs snap
627
628* Mon Sep 23 2002 Jeremy Katz <katzj@redhat.com>
629- update to cvs snap
630
631* Sun Sep 22 2002 Jeremy Katz <katzj@redhat.com>
632- use %%(lang)
633
634* Sun Aug 11 2002 Jeremy Katz <katzj@redhat.com>
635- fix post to actually install the schema
636
637* Sat Jun 22 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
638- Added gconf file
639- Added i18n directory
640
641* Sat Jun 15 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
642- Updated for new rewrite of rhythmbox, thanks to Jeroen
643
644* Mon Mar 18 2002 Jorn Baayen <jorn@nl.linux.org>
645- removed bonobo dependency
646* Sat Mar 02 2002 Christian Schaller <Uraeus@linuxrising.org>
647- created new spec file
Note: See TracBrowser for help on using the repository browser.