source: projects/specs/trunk/r/rhythmbox/rhythmbox-vl.spec @ 9536

Revision 9536, 20.5 KB checked in by Takemikaduchi, 9 years ago (diff)

new upstream release

Line 
1# -*- coding: utf-8-unix -*-
2%define desktop_file_utils_version 0.9
3
4%define enable_DLNA_UPnP 0
5
6Summary: Music Management Application
7Summary(ja): 音楽管理アプリケーション
8Name: rhythmbox
9Version: 3.2.1
10Release: 1%{?_dist_release}
11License: GPL2+ with exceptions and GFDL
12Group: Applications/Multimedia
13URL: http://projects.gnome.org/rhythmbox/
14Source0: http://download.gnome.org/sources/${name}/3.2/%{name}-%{version}.tar.xz
15
16Source101:      rhythmbox-png.tar.bz2
17
18Patch0: rhythmbox-3.0-disable-python3.patch
19
20BuildRoot: %{_tmppath}/%{name}-%{version}-root
21BuildRequires: gtk3-devel
22BuildRequires: avahi-glib-devel >= 0.6
23BuildRequires: brasero-devel >= 2.32.0
24BuildRequires: dbus-glib-devel
25BuildRequires: gstreamer1-plugins-base-devel
26BuildRequires: json-glib-devel
27BuildRequires: libSM-devel
28BuildRequires: libgnome-keyring-devel >= 2.30.0
29BuildRequires: libgpod-devel
30BuildRequires: eudev-libgudev1-devel
31BuildRequires: libmusicbrainz3-devel >= 3.0.2
32BuildRequires: libnotify-devel
33BuildRequires: libsoup-devel
34BuildRequires: pygobject3-devel
35BuildRequires: totem-pl-parser-devel
36BuildRequires: WebKit3-gtk-devel
37BuildRequires: libpeas-devel
38BuildRequires: clutter-gtk-devel
39BuildRequires: clutter-gst-devel
40BuildRequires: libmx-devel
41BuildRequires: check-devel
42BuildRequires: libmtp-devel
43BuildRequires: libtdb-devel
44BuildRequires: grilo-devel
45BuildRequires: libdmapsharing-devel
46BuildRequires: lirc
47BuildRequires: gnome-doc-utils >= 0.3.2
48BuildRequires: yelp-tools
49
50Requires: brasero
51Requires: libgnome-keyring
52%if %{enable_DLNA_UPnP}
53Requires: python-Coherence
54%endif
55Requires: desktop-file-utils >= %{desktop_file_utils_version}
56
57# # gstreamer-plugins-ffmpeg and gstreamer-plugins-ugly package provided by
58# # self-build-gstreamer-plugins-ffmpeg and self-build-gstreamer-plugins-ugly,
59# # respectively.
60# Requires: self-build-gstreamer-plugins-ffmpeg
61# Requires: self-build-gstreamer-plugins-ugly
62
63Vendor: Project Vine
64Distribution: Vine Linux
65
66
67%description
68Rhythmbox is an integrated music management application based on the powerful
69GStreamer media framework. It has a number of features, including an easy to
70use music browser, searching and sorting, comprehensive audio format support
71through GStreamer, Internet Radio support, playlists and more.
72
73Rhythmbox is extensible through a plugin system.
74
75%description -l ja
76Rhythmbox は、強力な GStreamer メディアフレームワークに基づいている
77統合音楽管理アプリケーションです。
78見やすいユーザインターフェースを備え、検索や整列ができ、
79GStreamer により数多くの音声フォーマットをサポート、
80インターネットラジオをサポート、プレイリスト管理などの
81数多くの特徴を持ちます。
82
83%package devel
84Summary: Development tools for rhythmbox applications.
85Summary(ja): rhythmbox アプリケーションの開発用ファイル
86Group: Development/Libraries
87Requires: %{name} = %{version}-%{release}
88Requires: pkgconfig
89Requires: libxml2-devel
90Requires: glib2-devel
91Requires: gtk3-devel
92Requires: libsoup-devel
93Requires: totem-pl-parser-devel
94Requires: gstreamer1-devel
95
96%description devel
97Header files and libraries for building a extension library for the rhythmbox.
98
99%description devel -l ja
100
101%prep
102%setup -q
103%patch0 -p1
104tar xjf %{SOURCE101}
105
106%build
107autoreconf -if
108intltoolize --force --copy
109%configure --with-ipod \
110    --with-mtp \
111    --enable-lirc \
112    --disable-python \
113    --disable-vala \
114    --disable-browser-plugin \
115    --disable-static \
116    --enable-browser-plugin \
117    --without-hal
118%__make %{?_smp_mflags}
119
120%install
121%__rm -rf $RPM_BUILD_ROOT
122%__make install DESTDIR=$RPM_BUILD_ROOT
123
124%__rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/*.{a,la}
125%__rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/librb-nautilus-context-menu.so
126%__rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
127%__rm -f $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*.{a,la}
128%__rm -f $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*/*.{a,la}
129%__rm -f $RPM_BUILD_ROOT%{_libdir}/librhythmbox-core.{a,la}
130%__rm -f $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins/*.{a,la}
131
132## Don't package DLNA/UPnP plugin
133%if !%{enable_DLNA_UPnP}
134%__rm -rf $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/upnp_coherence
135%endif
136
137%find_lang %{name} --all-name --with-gnome
138
139
140# Don't package api docs
141%__rm -rf $RPM_BUILD_ROOT%{_datadir}/gtk-doc/
142
143# And don't package vala
144%__rm -f %{buildroot}%{_libdir}/rhythmbox/plugins/libsample-vala.so \
145        %{buildroot}%{_libdir}/rhythmbox/plugins/sample-vala.rb-plugin
146
147# remove sample plugins
148rm -rf $RPM_BUILD_ROOT/%{_libdir}/%{name}/sample-plugins
149
150%clean
151%__rm -rf $RPM_BUILD_ROOT
152
153%post
154/sbin/ldconfig
155update-desktop-database -q
156touch --no-create %{_datadir}/icons/hicolor
157if [ -x /usr/bin/gtk-update-icon-cache ]; then
158  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
159fi
160
161%postun
162/sbin/ldconfig
163update-desktop-database -q
164touch --no-create %{_datadir}/icons/hicolor
165if [ -x /usr/bin/gtk-update-icon-cache ]; then
166  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
167fi
168glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
169
170%posttrans
171glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
172
173
174%files -f %{name}.lang
175%defattr(-, root, root)
176%doc AUTHORS COPYING ChangeLog README NEWS
177%{_bindir}/*
178%{_libdir}/girepository-1.0/*.typelib
179%{_libdir}/lib*.so.*
180%{_libdir}/mozilla/plugins/librhythmbox-itms-detection-plugin.so
181%{_libdir}/rhythmbox/plugins
182%{_datadir}/appdata/rhythmbox.appdata.xml
183%{_datadir}/applications/rhythmbox.desktop
184%{_datadir}/applications/rhythmbox-device.desktop
185%{_datadir}/dbus-1/services/org.gnome.Rhythmbox3.service
186%{_datadir}/glib-2.0/schemas/org.gnome.rhythmbox.gschema.xml
187%{_datadir}/icons/*
188%{_datadir}/rhythmbox
189%{_mandir}/man1/*
190%{_libexecdir}/rhythmbox-metadata
191
192%files devel
193%defattr(-, root, root)
194%{_includedir}/%{name}/*
195%{_libdir}/*.so
196%{_libdir}/pkgconfig/*.pc
197%{_datadir}/gir-1.0/*.gir
198
199
200%changelog
201* Sun May 03 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
202- new upstream release
203
204* Sat Apr 04 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2-1
205- new upstream release
206
207* Wed Jul 09 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 3.0.3-2
208- rebuild with new libimobiledevice
209
210* Sat Jun 07 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.3-1
211- new upstream release
212
213* Sun Mar 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.2-1
214- new upstream release
215
216* Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.1-2
217- rebuild with VineSeed environment
218
219* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.1-1
220- new upstream release
221
222* Fri Sep 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0-1
223- new upstream release
224- add Patch0 (rhythmbox-3.0-disable-python3.patch)
225
226* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.99.1-1
227- new upstream release
228- add BuildRequies: yelp-tools
229- change BuildRequires: gstreamer1-plugins-base-devel instead of gstreamer-plugins-base-devel
230
231* Sun Mar 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.98-2
232- rebuild with libimobiledevice-1.1.5
233
234* Mon Oct 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.98-1
235- new upstream release
236- add BuildRequires: grilo-devel, libdmapsharing-devel
237
238* Tue Jun 05 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.97-1
239- new upstream release
240
241* Wed Apr 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.96-1
242- new upstream release
243
244* Sat Jan 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.95-1
245- new upstream release
246- add BuildRequires: gtk3-devel, libtdb-devel, pygobject3-devel
247- remove BuildRequires: gnome-vfs2-devel, gstreamer-python-devel, libffi-devel, libgnome-media-profiles-devel, libgnomeui-devel, libsexy-devel, popt-devel, python-devel, pygtk2-devel, sqlite3-devel
248
249* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-4
250- rebuild with cogl-0.8.0
251
252* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-3
253- rebuild with libnotify-0.7
254- change BuildRequires: libmusicbrainz3-devel instead of libmusicbrainz-devel
255- change BuildRequires: libgnome-media-profiles-devel instead of gnome-media-devel
256- add BuildRequires: WebKit3-gtk-devel, libpeas-devel, clutter-gtk-devel, clutter-gst-devel, libmx-devel
257- add Patch0 (rhythmbox-0.13.3-git20110809.patch)
258- add Source101 (rhythmbox-png.tar.bz2)
259
260* Fri Aug 12 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-2
261- add BuildRequires: json-glib-devel
262- remove unrecognized configure option (--with-dbus, --with-cd-burning, --with-metadata-helper)
263
264* Sun Jan 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-1
265- new upstream release
266- change BuildRequires: gstreamer-python-devel instead of gstreamer-python
267
268* Sat Nov 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.2-1
269- new upstream release
270
271* Wed Oct 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-3
272- rebuild with brasero-2.32.0
273
274* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-2
275- rebuild with rpm-4.8.1 for pkg-config file
276
277* Sun Sep 12 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-1
278- new upstream release
279- fix %files (add rhythmbox-device.desktop)
280
281* Sun Aug 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.0-1
282- new upstream release
283- change BuildRequires: gnome-media-devel instead of gnome-media
284- add devel package
285- drop Patch0
286
287* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.8-1
288- new upstream release
289- drop Patch1, Patch2, Patch3
290- change BuildRequires: nautilus-cd-burner -> brasero-devel
291- change Requires: nautilus-cd-burner -> brasero
292- change BuildRequires: hal-devel -> libgudev1-devel
293- change BuildRequires: gnome-keyring-devel -> libgnome-keyring-devel
294- change Requires: gnome-keyring -> libgnome-keyring
295- add configure option (--without-hal)
296
297* Mon Feb 15 2010 Shu KONNO <owa@bg.wakwak.com> 0.12.6-2
298- rebuilt with new environment
299
300* Thu Jan 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.6-1
301- new upstream release
302  - dropped upstreamed/obsolete patches
303  - added patches applied Fedora development
304
305* Sun Oct 04 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.5-1
306- new upstream release
307- added configure options:
308  --disable-vala
309  --disable-browser-plugin
310
311* Thu Jul 30 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.2-2
312- added Japanese description
313
314* Thu Jul 02 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.12.2-1
315- new upstream release
316  - dropped rb-disable-power-plugin-by-default.patch
317- added BuildRequires:
318  - libSM-devel
319  - gnome-media
320
321* Wed Jun 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.12.1-2
322- rebuild with libgpod-0.7.2
323
324* Sun May 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.12.1-1
325- new upstream release
326- corrected License tag
327- dropped rhythmbox-0.11.6-libmtp.patch
328- added BuildRequires:
329  - sqlite3-devel
330  - libffi-devel
331
332* Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.11.6-2
333- defined enable_DLNA_UPnP = 0: unpacked DLNA/UPnP plugin
334- applied rhythmbox-0.11.6-libmtp.patch
335- added Requires:
336  - libgpod
337  - libnotify
338  - libsexy
339  - lirc
340  - libmtp
341  - libgnomeui
342  - nautilus-cd-burner
343  - gstreamer-python
344  - gnome-vfs2
345  - gnome-themes
346  - gnome-keyring
347  - python-Coherence, if enable_DLNA_UPnP = 1
348- added BuildRequires:
349  - libnotify-devel
350  - libsexy-devel
351  - lirc
352  - libmtp-devel
353  - gnome-vfs2-devel, instead of gnome-vfs2
354  - gnome-keyring-devel
355- dropped --with-internal-libsexy in configure options
356- added in configure options:
357  --with-mtp --with-libnautilus-burn --enable-lirc --disable-static
358- added %%preun to remove the schema
359
360* Sun Jan 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.11.6-1
361- new upstream release
362- changed to --with-metadata-helper in configure options
363- added BuildRequires:
364  - gstreamer-python
365  - intltool >= 0.35.0
366  - popt-devel
367
368* Sat Aug 09 2008 Shu KONNO <owa@bg.wakwak.com> 0.11.2-1vl5
369- added BuildRequires: totem-pl-parser-devel, instead of totem-devel
370- rebuilt with python-2.5.2
371- applied new versioning policy
372- spec in utf-8
373
374* Sun Jan 06 2008 Shu KONNO <owa@bg.wakwak.com> 0.11.2-0vl2
375- rebuilt with libgpod-0.6.0
376
377* Sun Aug 26 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.2-0vl1
378- new upstream release
379
380* Wed Jun 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.1-0vl1
381- new upstream release
382
383* Tue May 29 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.10.0-0vl2
384- rebuilt with new toolchain and libgpod-0.4.2
385- add BuildRequires: dbus-glib-devel
386
387* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.0-0vl1
388- new upstream release
389
390* Wed Mar 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8-0vl2
391- rebuilt for VineSeed
392
393* Wed Mar 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8-0vl1
394- new upstream release
395- added --enable-python option to %%configure
396- added Requires: gnome-python
397
398* Sun Jan 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.7-0vl1
399- new upstream release
400- built with libsoup 2.2.99
401
402* Thu Nov 23 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6-0vl4
403- added --with-cd-burner to configure
404- added BuildRequires: libsexy-devel hal-devel libsoup-devel
405
406* Wed Oct 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.6-0vl3
407- add BuildRequires:
408  - gnome-doc-utils >= 0.3.2
409  - python-devel
410  - pygtk2-devel
411  - check >= 0.8.2
412
413* Tue Oct 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.6-0vl2
414- rebuild with gnutls-1.4.1
415
416* Sun Oct  1 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6-0vl1
417- new upstream release
418
419* Mon Jun 19 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.5-0vl1
420- new upstream release
421- run scrollkeeper-update at %post and %postun
422- added BuildRequires: libnotify-devel
423
424* Sun May 14 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.4.1-0vl1
425- new upstream release (dropped patch0)
426- added --without-metadata-helper at configure
427
428* Mon Mar 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.3.1-0vl1
429- Initial build for Vine Linux based on FC pacakge
430
431* Fri Mar 03 2006 Ray Strode <rstrode@redhat.com> - 0.9.3.1-2
432- add patch from James "Doc" Livingston to stop a hang
433  for new users (bug 183883)
434
435* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3.1-1.2
436- bump again for double-long bug on ppc(64)
437
438* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3.1-1.1
439- rebuilt for new gcc4.1 snapshot and glibc changes
440
441* Sat Feb  4 2006 Christopher Aillon <caillon@redhat.com> 0.9.3.1-1
442- Update to 0.9.3.1
443- Use gstreamer (0.10)
444
445* Wed Feb  1 2006 Christopher Aillon <caillon@redhat.com> 0.9.3-2
446- Remove hack for 173869, as its no longer needed.
447
448* Wed Feb  1 2006 Christopher Aillon <caillon@redhat.com> 0.9.3-1
449- 0.9.3
450
451* Wed Feb  1 2006 Christopher Aillon <caillon@redhat.com> 0.9.2.cvs20060201-1
452- Newer CVS snapshot
453
454* Sun Jan 22 2006 Christopher Aillon <caillon@redhat.com> 0.9.2.cvs20060123-1
455- Update to latest CVS
456- Add hack to workaround bug #173869
457
458* Thu Jan 19 2006 Christopher Aillon <caillon@redhat.com> 0.9.2-8
459- Rebuild, now that gstreamer08-plugins has been fixed
460
461* Thu Jan 19 2006 Ray Strode <rstrode@redhat.com> 0.9.2-7
462- bonobo multilib issue (bug 156982)
463
464* Wed Jan 04 2006 John (J5) Palmieri <johnp@redhat.com> 0.9.2-5
465- rebuild with ipod support
466
467* Tue Jan 03 2006 Jesse Keating <jkeating@redhat.com> 0.9.2-4
468- rebuilt again
469
470* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
471- rebuilt
472
473* Mon Dec  5 2005 Matthias Clasen <mclasen@redhat.com>
474- rebuild
475
476* Thu Dec 01 2005 John (J5) Palmieri <johnp@redhat.com>
477- rebuild for new dbus
478
479* Wed Nov 30 2005 Matthias Clasen <mclasen@redhat.com>
480- Update to 0.9.2
481
482* Tue Oct 25 2005 Matthias Clasen <mclasen@redhat.com>
483- Update to 0.9.1
484
485* Fri Sep 02 2005 Colin Walters <walters@redhat.com>
486- Add configure flags --with-bonobo --with-dbus
487- BR nautilus-cd-burner-devel
488- New upstream CVS snapshot for testing
489- Drop IDL file and ui .xml
490- Add dbus service file
491- Drop upstreamed rhythmbox-bluecurve.tar.gz
492- Drop upstreamed rhythmbox-0.8.8-cell-renderer.patch
493
494* Mon Jun 13 2005 Colin Walters <walters@redhat.com> - 0.8.8-3
495- Add Bluecurve-ized icons from Jeff Schroeder (157716)
496- Add rhythmbox-0.8.8-cell-renderer.patch to remove use of custom
497  cell renderer for playback icon (no longer necessary) and
498  changes the rating renderer to work with non-b&w icons
499
500* Mon Mar 14 2005 Colin Walters <walters@redhat.com> - 0.8.8-2
501- Rebuild for GCC4
502
503* Tue Oct 05 2004 Colin Walters <walters@redhat.com> - 0.8.8-1
504- New upstream version
505- Remove librb-nautilus-context-menu.so, killed upstream
506
507* Thu Sep 30 2004 Christopher Aillon <caillon@redhat.com> 0.8.7-2
508- PreReq desktop-file-utils >= 0.9
509
510* Wed Sep 29 2004 Colin Walters <walters@redhat.com> - 0.8.7-1
511- New upstream version
512
513* Sat Sep 18 2004 Colin Walters <walters@redhat.com> - 0.8.6-2
514- Fix postun to use correct syntax, thanks Nils Philippsen
515
516* Sat Sep 18 2004 Colin Walters <walters@redhat.com> - 0.8.6-1
517- New upstream version
518- Call update-desktop-database in post and postun
519
520* Thu Jun 24 2004 Colin Walters <walters@redhat.com> - 0.8.5-1
521- New upstream version
522
523* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
524- rebuilt
525
526* Tue May 18 2004 Colin Walters <walters@redhat.com> - 0.8.4-1
527- New upstream version
528- Remove backported patches
529- Gratuitiously bump various BuildRequires versions
530
531* Mon May 10 2004 Colin Walters <walters@redhat.com> - 0.8.3-4
532- Remove code to unregister GConf schema for now (Closes: #122532)
533
534* Fri May 07 2004 Colin Walters <walters@redhat.com> - 0.8.3-3
535- Apply tiny patch from 0.8 arch to fix GConf key used
536  for initial sorting
537
538* Fri May 07 2004 Colin Walters <walters@redhat.com> - 0.8.3-2
539- Apply patch from 0.8 arch tree to fix a number of memleaks
540
541* Sun May 02 2004 Colin Walters <walters@redhat.com> - 0.8.3-1
542- Update to 0.8.3: fixes showstopper bug with internet radio
543
544* Fri Apr 30 2004 Colin Walters <walters@redhat.com> - 0.8.2-1
545- Update to 0.8.2
546- Fix Source url
547- Add smp_mflags
548- Bump BuildRequires on gstreamer to 0.8.1
549
550* Fri Apr 23 2004 Colin Walters <walters@redhat.com> - 0.8.1-2
551- Uninstall GConf schemas on removal
552
553* Tue Apr 20 2004 Colin Walters <walters@redhat.com> - 0.8.1-1
554- Update to 0.8.1
555
556* Fri Apr 16 2004 Colin Walters <walters@redhat.com> - 0.8.0-1
557- Update to 0.8.0
558
559* Fri Apr 02 2004 Colin Walters <walters@redhat.com> - 0.7.2-1
560- Update to 0.7.2
561
562* Mon Mar 29 2004 Colin Walters <walters@redhat.com> - 0.7.1-2
563- Remove BuildRequires on autoconf and libvorbis-devel
564
565* Mon Mar 29 2004 Colin Walters <walters@redhat.com> - 0.7.1-1
566- New major version - I know we are past major version slush, but
567  this should have been done two weeks ago along with the GNOME 2.6
568  upload.  As upstream author as well, I believe this version is
569  good enough for FC2.
570- Remove --disable-mp3
571- Remove id3, flac variables
572- Remove GStreamer major version patch
573- Fix typo in description
574
575* Tue Mar 16 2004 Jeremy Katz <katzj@redhat.com> - 0.6.8-2
576- rebuild for new gstreamer
577
578* Thu Mar 11 2004 Alex Larsson <alexl@redhat.com> 0.6.8-1
579- update to 0.6.8
580
581* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
582- rebuilt
583
584* Mon Mar  1 2004 Alexander Larsson <alexl@redhat.com> 0.6.7-1
585- update to 0.6.7
586
587* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
588- rebuilt
589
590* Mon Jan 12 2004 Colin Walters <walters@verbum.org> 0.6.4-1
591- New upstream version
592- Don't re-run the autotools; upstream incorporates newer versions.
593* Tue Oct 28 2003 Jonathan Blandford <jrb@redhat.com> 0.5.4-1
594- new version
595- remove smp_flags
596
597* Fri Oct 24 2003 Jonathan Blandford <jrb@redhat.com> 0.5.3-5
598- remove the initial iradio channels as they all are mp3 based.
599
600* Wed Oct  8 2003 Matthias Saou <matthias@rpmforge.net> 0.5.3-3
601- Fix category from Development/Libraries to Applications/Multimedia.
602- Use bz2 instead of gz as ftp.gnome.org has both, 300k saved in the src.rpm.
603- Fix SCHEMES vs. SCHEMAS in the post scriplet.
604- Added gstreamer-plugins-devel, libvorbis-devel, scrollkeeper and gettext deps.
605- Removed unnecessary date expansion define.
606- Updated description, including mp3 reference removal.
607- Added libid3tag and flac optional support for convenient rebuild.
608- Removed obsolete omf.make and xmldocs.make (included ones are the same now).
609
610* Mon Sep 22 2003 Jonathan Blandford <jrb@redhat.com> 0.5.3-1
611- new version
612- use %{_sysconfdir} instead of /etc
613
614* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
615- rebuilt
616
617* Wed Dec 18 2002 Jonathan Blandford <jrb@redhat.com>
618- gave up on other archs for the Beta
619- new version
620- remove werror and add missing files
621
622* Thu Nov  7 2002 Jeremy Katz <katzj@redhat.com>
623- update to newer cvs snap
624
625* Mon Sep 23 2002 Jeremy Katz <katzj@redhat.com>
626- update to cvs snap
627
628* Sun Sep 22 2002 Jeremy Katz <katzj@redhat.com>
629- use %%(lang)
630
631* Sun Aug 11 2002 Jeremy Katz <katzj@redhat.com>
632- fix post to actually install the schema
633
634* Sat Jun 22 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
635- Added gconf file
636- Added i18n directory
637
638* Sat Jun 15 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
639- Updated for new rewrite of rhythmbox, thanks to Jeroen
640
641* Mon Mar 18 2002 Jorn Baayen <jorn@nl.linux.org>
642- removed bonobo dependency
643* Sat Mar 02 2002 Christian Schaller <Uraeus@linuxrising.org>
644- created new spec file
Note: See TracBrowser for help on using the repository browser.