source: projects/specs/trunk/r/rhythmbox/rhythmbox-vl.spec @ 9486

Revision 9486, 20.4 KB checked in by Takemikaduchi, 9 years ago (diff)

new upstream release

Line 
1# -*- coding: utf-8-unix -*-
2%define desktop_file_utils_version 0.9
3
4%define enable_DLNA_UPnP 0
5
6Summary: Music Management Application
7Summary(ja): 音楽管理アプリケーション
8Name: rhythmbox
9Version: 3.2
10Release: 1%{?_dist_release}
11License: GPL2+ with exceptions and GFDL
12Group: Applications/Multimedia
13URL: http://projects.gnome.org/rhythmbox/
14Source0: http://download.gnome.org/sources/${name}/3.2/%{name}-%{version}.tar.xz
15
16Source101:      rhythmbox-png.tar.bz2
17
18Patch0: rhythmbox-3.0-disable-python3.patch
19
20BuildRoot: %{_tmppath}/%{name}-%{version}-root
21BuildRequires: gtk3-devel
22BuildRequires: avahi-glib-devel >= 0.6
23BuildRequires: brasero-devel >= 2.32.0
24BuildRequires: dbus-glib-devel
25BuildRequires: gstreamer1-plugins-base-devel
26BuildRequires: json-glib-devel
27BuildRequires: libSM-devel
28BuildRequires: libgnome-keyring-devel >= 2.30.0
29BuildRequires: libgpod-devel
30BuildRequires: eudev-libgudev1-devel
31BuildRequires: libmusicbrainz3-devel >= 3.0.2
32BuildRequires: libnotify-devel
33BuildRequires: libsoup-devel
34BuildRequires: pygobject3-devel
35BuildRequires: totem-pl-parser-devel
36BuildRequires: WebKit3-gtk-devel
37BuildRequires: libpeas-devel
38BuildRequires: clutter-gtk-devel
39BuildRequires: clutter-gst-devel
40BuildRequires: libmx-devel
41BuildRequires: check-devel
42BuildRequires: libmtp-devel
43BuildRequires: libtdb-devel
44BuildRequires: grilo-devel
45BuildRequires: libdmapsharing-devel
46BuildRequires: lirc
47BuildRequires: gnome-doc-utils >= 0.3.2
48BuildRequires: yelp-tools
49
50Requires: brasero
51Requires: libgnome-keyring
52%if %{enable_DLNA_UPnP}
53Requires: python-Coherence
54%endif
55Requires: desktop-file-utils >= %{desktop_file_utils_version}
56
57# # gstreamer-plugins-ffmpeg and gstreamer-plugins-ugly package provided by
58# # self-build-gstreamer-plugins-ffmpeg and self-build-gstreamer-plugins-ugly,
59# # respectively.
60# Requires: self-build-gstreamer-plugins-ffmpeg
61# Requires: self-build-gstreamer-plugins-ugly
62
63Vendor: Project Vine
64Distribution: Vine Linux
65
66
67%description
68Rhythmbox is an integrated music management application based on the powerful
69GStreamer media framework. It has a number of features, including an easy to
70use music browser, searching and sorting, comprehensive audio format support
71through GStreamer, Internet Radio support, playlists and more.
72
73Rhythmbox is extensible through a plugin system.
74
75%description -l ja
76Rhythmbox は、強力な GStreamer メディアフレームワークに基づいている
77統合音楽管理アプリケーションです。
78見やすいユーザインターフェースを備え、検索や整列ができ、
79GStreamer により数多くの音声フォーマットをサポート、
80インターネットラジオをサポート、プレイリスト管理などの
81数多くの特徴を持ちます。
82
83%package devel
84Summary: Development tools for rhythmbox applications.
85Summary(ja): rhythmbox アプリケーションの開発用ファイル
86Group: Development/Libraries
87Requires: %{name} = %{version}-%{release}
88Requires: pkgconfig
89Requires: libxml2-devel
90Requires: glib2-devel
91Requires: gtk3-devel
92Requires: libsoup-devel
93Requires: totem-pl-parser-devel
94Requires: gstreamer1-devel
95
96%description devel
97Header files and libraries for building a extension library for the rhythmbox.
98
99%description devel -l ja
100
101%prep
102%setup -q
103%patch0 -p1
104tar xjf %{SOURCE101}
105
106%build
107autoreconf -if
108intltoolize --force --copy
109%configure --with-ipod \
110    --with-mtp \
111    --enable-lirc \
112    --disable-python \
113    --disable-vala \
114    --disable-browser-plugin \
115    --disable-static \
116    --enable-browser-plugin \
117    --without-hal
118%__make %{?_smp_mflags}
119
120%install
121%__rm -rf $RPM_BUILD_ROOT
122%__make install DESTDIR=$RPM_BUILD_ROOT
123
124%__rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/*.{a,la}
125%__rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/librb-nautilus-context-menu.so
126%__rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
127%__rm -f $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*.{a,la}
128%__rm -f $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*/*.{a,la}
129%__rm -f $RPM_BUILD_ROOT%{_libdir}/librhythmbox-core.{a,la}
130%__rm -f $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins/*.{a,la}
131
132## Don't package DLNA/UPnP plugin
133%if !%{enable_DLNA_UPnP}
134%__rm -rf $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/upnp_coherence
135%endif
136
137%find_lang %{name} --all-name --with-gnome
138
139
140# Don't package api docs
141%__rm -rf $RPM_BUILD_ROOT%{_datadir}/gtk-doc/
142
143# And don't package vala
144%__rm -f %{buildroot}%{_libdir}/rhythmbox/plugins/libsample-vala.so \
145        %{buildroot}%{_libdir}/rhythmbox/plugins/sample-vala.rb-plugin
146
147# remove sample plugins
148rm -rf $RPM_BUILD_ROOT/%{_libdir}/%{name}/sample-plugins
149
150%clean
151%__rm -rf $RPM_BUILD_ROOT
152
153%post
154/sbin/ldconfig
155update-desktop-database -q
156touch --no-create %{_datadir}/icons/hicolor
157if [ -x /usr/bin/gtk-update-icon-cache ]; then
158  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
159fi
160
161%postun
162/sbin/ldconfig
163update-desktop-database -q
164touch --no-create %{_datadir}/icons/hicolor
165if [ -x /usr/bin/gtk-update-icon-cache ]; then
166  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
167fi
168glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
169
170%posttrans
171glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
172
173
174%files -f %{name}.lang
175%defattr(-, root, root)
176%doc AUTHORS COPYING ChangeLog README NEWS
177%{_bindir}/*
178%{_libdir}/girepository-1.0/*.typelib
179%{_libdir}/lib*.so.*
180%{_libdir}/mozilla/plugins/librhythmbox-itms-detection-plugin.so
181%{_libdir}/rhythmbox/plugins
182%{_datadir}/appdata/rhythmbox.appdata.xml
183%{_datadir}/applications/rhythmbox.desktop
184%{_datadir}/applications/rhythmbox-device.desktop
185%{_datadir}/dbus-1/services/org.gnome.Rhythmbox3.service
186%{_datadir}/glib-2.0/schemas/org.gnome.rhythmbox.gschema.xml
187%{_datadir}/icons/*
188%{_datadir}/rhythmbox
189%{_mandir}/man1/*
190%{_libexecdir}/rhythmbox-metadata
191
192%files devel
193%defattr(-, root, root)
194%{_includedir}/%{name}/*
195%{_libdir}/*.so
196%{_libdir}/pkgconfig/*.pc
197%{_datadir}/gir-1.0/*.gir
198
199
200%changelog
201* Sat Apr 04 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2-1
202- new upstream release
203
204* Wed Jul 09 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 3.0.3-2
205- rebuild with new libimobiledevice
206
207* Sat Jun 07 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.3-1
208- new upstream release
209
210* Sun Mar 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.2-1
211- new upstream release
212
213* Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.1-2
214- rebuild with VineSeed environment
215
216* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.1-1
217- new upstream release
218
219* Fri Sep 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0-1
220- new upstream release
221- add Patch0 (rhythmbox-3.0-disable-python3.patch)
222
223* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.99.1-1
224- new upstream release
225- add BuildRequies: yelp-tools
226- change BuildRequires: gstreamer1-plugins-base-devel instead of gstreamer-plugins-base-devel
227
228* Sun Mar 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.98-2
229- rebuild with libimobiledevice-1.1.5
230
231* Mon Oct 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.98-1
232- new upstream release
233- add BuildRequires: grilo-devel, libdmapsharing-devel
234
235* Tue Jun 05 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.97-1
236- new upstream release
237
238* Wed Apr 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.96-1
239- new upstream release
240
241* Sat Jan 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.95-1
242- new upstream release
243- add BuildRequires: gtk3-devel, libtdb-devel, pygobject3-devel
244- remove BuildRequires: gnome-vfs2-devel, gstreamer-python-devel, libffi-devel, libgnome-media-profiles-devel, libgnomeui-devel, libsexy-devel, popt-devel, python-devel, pygtk2-devel, sqlite3-devel
245
246* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-4
247- rebuild with cogl-0.8.0
248
249* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-3
250- rebuild with libnotify-0.7
251- change BuildRequires: libmusicbrainz3-devel instead of libmusicbrainz-devel
252- change BuildRequires: libgnome-media-profiles-devel instead of gnome-media-devel
253- add BuildRequires: WebKit3-gtk-devel, libpeas-devel, clutter-gtk-devel, clutter-gst-devel, libmx-devel
254- add Patch0 (rhythmbox-0.13.3-git20110809.patch)
255- add Source101 (rhythmbox-png.tar.bz2)
256
257* Fri Aug 12 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-2
258- add BuildRequires: json-glib-devel
259- remove unrecognized configure option (--with-dbus, --with-cd-burning, --with-metadata-helper)
260
261* Sun Jan 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-1
262- new upstream release
263- change BuildRequires: gstreamer-python-devel instead of gstreamer-python
264
265* Sat Nov 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.2-1
266- new upstream release
267
268* Wed Oct 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-3
269- rebuild with brasero-2.32.0
270
271* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-2
272- rebuild with rpm-4.8.1 for pkg-config file
273
274* Sun Sep 12 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-1
275- new upstream release
276- fix %files (add rhythmbox-device.desktop)
277
278* Sun Aug 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.0-1
279- new upstream release
280- change BuildRequires: gnome-media-devel instead of gnome-media
281- add devel package
282- drop Patch0
283
284* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.8-1
285- new upstream release
286- drop Patch1, Patch2, Patch3
287- change BuildRequires: nautilus-cd-burner -> brasero-devel
288- change Requires: nautilus-cd-burner -> brasero
289- change BuildRequires: hal-devel -> libgudev1-devel
290- change BuildRequires: gnome-keyring-devel -> libgnome-keyring-devel
291- change Requires: gnome-keyring -> libgnome-keyring
292- add configure option (--without-hal)
293
294* Mon Feb 15 2010 Shu KONNO <owa@bg.wakwak.com> 0.12.6-2
295- rebuilt with new environment
296
297* Thu Jan 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.6-1
298- new upstream release
299  - dropped upstreamed/obsolete patches
300  - added patches applied Fedora development
301
302* Sun Oct 04 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.5-1
303- new upstream release
304- added configure options:
305  --disable-vala
306  --disable-browser-plugin
307
308* Thu Jul 30 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.2-2
309- added Japanese description
310
311* Thu Jul 02 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.12.2-1
312- new upstream release
313  - dropped rb-disable-power-plugin-by-default.patch
314- added BuildRequires:
315  - libSM-devel
316  - gnome-media
317
318* Wed Jun 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.12.1-2
319- rebuild with libgpod-0.7.2
320
321* Sun May 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.12.1-1
322- new upstream release
323- corrected License tag
324- dropped rhythmbox-0.11.6-libmtp.patch
325- added BuildRequires:
326  - sqlite3-devel
327  - libffi-devel
328
329* Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.11.6-2
330- defined enable_DLNA_UPnP = 0: unpacked DLNA/UPnP plugin
331- applied rhythmbox-0.11.6-libmtp.patch
332- added Requires:
333  - libgpod
334  - libnotify
335  - libsexy
336  - lirc
337  - libmtp
338  - libgnomeui
339  - nautilus-cd-burner
340  - gstreamer-python
341  - gnome-vfs2
342  - gnome-themes
343  - gnome-keyring
344  - python-Coherence, if enable_DLNA_UPnP = 1
345- added BuildRequires:
346  - libnotify-devel
347  - libsexy-devel
348  - lirc
349  - libmtp-devel
350  - gnome-vfs2-devel, instead of gnome-vfs2
351  - gnome-keyring-devel
352- dropped --with-internal-libsexy in configure options
353- added in configure options:
354  --with-mtp --with-libnautilus-burn --enable-lirc --disable-static
355- added %%preun to remove the schema
356
357* Sun Jan 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.11.6-1
358- new upstream release
359- changed to --with-metadata-helper in configure options
360- added BuildRequires:
361  - gstreamer-python
362  - intltool >= 0.35.0
363  - popt-devel
364
365* Sat Aug 09 2008 Shu KONNO <owa@bg.wakwak.com> 0.11.2-1vl5
366- added BuildRequires: totem-pl-parser-devel, instead of totem-devel
367- rebuilt with python-2.5.2
368- applied new versioning policy
369- spec in utf-8
370
371* Sun Jan 06 2008 Shu KONNO <owa@bg.wakwak.com> 0.11.2-0vl2
372- rebuilt with libgpod-0.6.0
373
374* Sun Aug 26 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.2-0vl1
375- new upstream release
376
377* Wed Jun 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.1-0vl1
378- new upstream release
379
380* Tue May 29 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.10.0-0vl2
381- rebuilt with new toolchain and libgpod-0.4.2
382- add BuildRequires: dbus-glib-devel
383
384* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.0-0vl1
385- new upstream release
386
387* Wed Mar 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8-0vl2
388- rebuilt for VineSeed
389
390* Wed Mar 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8-0vl1
391- new upstream release
392- added --enable-python option to %%configure
393- added Requires: gnome-python
394
395* Sun Jan 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.7-0vl1
396- new upstream release
397- built with libsoup 2.2.99
398
399* Thu Nov 23 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6-0vl4
400- added --with-cd-burner to configure
401- added BuildRequires: libsexy-devel hal-devel libsoup-devel
402
403* Wed Oct 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.6-0vl3
404- add BuildRequires:
405  - gnome-doc-utils >= 0.3.2
406  - python-devel
407  - pygtk2-devel
408  - check >= 0.8.2
409
410* Tue Oct 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.6-0vl2
411- rebuild with gnutls-1.4.1
412
413* Sun Oct  1 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6-0vl1
414- new upstream release
415
416* Mon Jun 19 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.5-0vl1
417- new upstream release
418- run scrollkeeper-update at %post and %postun
419- added BuildRequires: libnotify-devel
420
421* Sun May 14 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.4.1-0vl1
422- new upstream release (dropped patch0)
423- added --without-metadata-helper at configure
424
425* Mon Mar 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.3.1-0vl1
426- Initial build for Vine Linux based on FC pacakge
427
428* Fri Mar 03 2006 Ray Strode <rstrode@redhat.com> - 0.9.3.1-2
429- add patch from James "Doc" Livingston to stop a hang
430  for new users (bug 183883)
431
432* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3.1-1.2
433- bump again for double-long bug on ppc(64)
434
435* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3.1-1.1
436- rebuilt for new gcc4.1 snapshot and glibc changes
437
438* Sat Feb  4 2006 Christopher Aillon <caillon@redhat.com> 0.9.3.1-1
439- Update to 0.9.3.1
440- Use gstreamer (0.10)
441
442* Wed Feb  1 2006 Christopher Aillon <caillon@redhat.com> 0.9.3-2
443- Remove hack for 173869, as its no longer needed.
444
445* Wed Feb  1 2006 Christopher Aillon <caillon@redhat.com> 0.9.3-1
446- 0.9.3
447
448* Wed Feb  1 2006 Christopher Aillon <caillon@redhat.com> 0.9.2.cvs20060201-1
449- Newer CVS snapshot
450
451* Sun Jan 22 2006 Christopher Aillon <caillon@redhat.com> 0.9.2.cvs20060123-1
452- Update to latest CVS
453- Add hack to workaround bug #173869
454
455* Thu Jan 19 2006 Christopher Aillon <caillon@redhat.com> 0.9.2-8
456- Rebuild, now that gstreamer08-plugins has been fixed
457
458* Thu Jan 19 2006 Ray Strode <rstrode@redhat.com> 0.9.2-7
459- bonobo multilib issue (bug 156982)
460
461* Wed Jan 04 2006 John (J5) Palmieri <johnp@redhat.com> 0.9.2-5
462- rebuild with ipod support
463
464* Tue Jan 03 2006 Jesse Keating <jkeating@redhat.com> 0.9.2-4
465- rebuilt again
466
467* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
468- rebuilt
469
470* Mon Dec  5 2005 Matthias Clasen <mclasen@redhat.com>
471- rebuild
472
473* Thu Dec 01 2005 John (J5) Palmieri <johnp@redhat.com>
474- rebuild for new dbus
475
476* Wed Nov 30 2005 Matthias Clasen <mclasen@redhat.com>
477- Update to 0.9.2
478
479* Tue Oct 25 2005 Matthias Clasen <mclasen@redhat.com>
480- Update to 0.9.1
481
482* Fri Sep 02 2005 Colin Walters <walters@redhat.com>
483- Add configure flags --with-bonobo --with-dbus
484- BR nautilus-cd-burner-devel
485- New upstream CVS snapshot for testing
486- Drop IDL file and ui .xml
487- Add dbus service file
488- Drop upstreamed rhythmbox-bluecurve.tar.gz
489- Drop upstreamed rhythmbox-0.8.8-cell-renderer.patch
490
491* Mon Jun 13 2005 Colin Walters <walters@redhat.com> - 0.8.8-3
492- Add Bluecurve-ized icons from Jeff Schroeder (157716)
493- Add rhythmbox-0.8.8-cell-renderer.patch to remove use of custom
494  cell renderer for playback icon (no longer necessary) and
495  changes the rating renderer to work with non-b&w icons
496
497* Mon Mar 14 2005 Colin Walters <walters@redhat.com> - 0.8.8-2
498- Rebuild for GCC4
499
500* Tue Oct 05 2004 Colin Walters <walters@redhat.com> - 0.8.8-1
501- New upstream version
502- Remove librb-nautilus-context-menu.so, killed upstream
503
504* Thu Sep 30 2004 Christopher Aillon <caillon@redhat.com> 0.8.7-2
505- PreReq desktop-file-utils >= 0.9
506
507* Wed Sep 29 2004 Colin Walters <walters@redhat.com> - 0.8.7-1
508- New upstream version
509
510* Sat Sep 18 2004 Colin Walters <walters@redhat.com> - 0.8.6-2
511- Fix postun to use correct syntax, thanks Nils Philippsen
512
513* Sat Sep 18 2004 Colin Walters <walters@redhat.com> - 0.8.6-1
514- New upstream version
515- Call update-desktop-database in post and postun
516
517* Thu Jun 24 2004 Colin Walters <walters@redhat.com> - 0.8.5-1
518- New upstream version
519
520* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
521- rebuilt
522
523* Tue May 18 2004 Colin Walters <walters@redhat.com> - 0.8.4-1
524- New upstream version
525- Remove backported patches
526- Gratuitiously bump various BuildRequires versions
527
528* Mon May 10 2004 Colin Walters <walters@redhat.com> - 0.8.3-4
529- Remove code to unregister GConf schema for now (Closes: #122532)
530
531* Fri May 07 2004 Colin Walters <walters@redhat.com> - 0.8.3-3
532- Apply tiny patch from 0.8 arch to fix GConf key used
533  for initial sorting
534
535* Fri May 07 2004 Colin Walters <walters@redhat.com> - 0.8.3-2
536- Apply patch from 0.8 arch tree to fix a number of memleaks
537
538* Sun May 02 2004 Colin Walters <walters@redhat.com> - 0.8.3-1
539- Update to 0.8.3: fixes showstopper bug with internet radio
540
541* Fri Apr 30 2004 Colin Walters <walters@redhat.com> - 0.8.2-1
542- Update to 0.8.2
543- Fix Source url
544- Add smp_mflags
545- Bump BuildRequires on gstreamer to 0.8.1
546
547* Fri Apr 23 2004 Colin Walters <walters@redhat.com> - 0.8.1-2
548- Uninstall GConf schemas on removal
549
550* Tue Apr 20 2004 Colin Walters <walters@redhat.com> - 0.8.1-1
551- Update to 0.8.1
552
553* Fri Apr 16 2004 Colin Walters <walters@redhat.com> - 0.8.0-1
554- Update to 0.8.0
555
556* Fri Apr 02 2004 Colin Walters <walters@redhat.com> - 0.7.2-1
557- Update to 0.7.2
558
559* Mon Mar 29 2004 Colin Walters <walters@redhat.com> - 0.7.1-2
560- Remove BuildRequires on autoconf and libvorbis-devel
561
562* Mon Mar 29 2004 Colin Walters <walters@redhat.com> - 0.7.1-1
563- New major version - I know we are past major version slush, but
564  this should have been done two weeks ago along with the GNOME 2.6
565  upload.  As upstream author as well, I believe this version is
566  good enough for FC2.
567- Remove --disable-mp3
568- Remove id3, flac variables
569- Remove GStreamer major version patch
570- Fix typo in description
571
572* Tue Mar 16 2004 Jeremy Katz <katzj@redhat.com> - 0.6.8-2
573- rebuild for new gstreamer
574
575* Thu Mar 11 2004 Alex Larsson <alexl@redhat.com> 0.6.8-1
576- update to 0.6.8
577
578* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
579- rebuilt
580
581* Mon Mar  1 2004 Alexander Larsson <alexl@redhat.com> 0.6.7-1
582- update to 0.6.7
583
584* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
585- rebuilt
586
587* Mon Jan 12 2004 Colin Walters <walters@verbum.org> 0.6.4-1
588- New upstream version
589- Don't re-run the autotools; upstream incorporates newer versions.
590* Tue Oct 28 2003 Jonathan Blandford <jrb@redhat.com> 0.5.4-1
591- new version
592- remove smp_flags
593
594* Fri Oct 24 2003 Jonathan Blandford <jrb@redhat.com> 0.5.3-5
595- remove the initial iradio channels as they all are mp3 based.
596
597* Wed Oct  8 2003 Matthias Saou <matthias@rpmforge.net> 0.5.3-3
598- Fix category from Development/Libraries to Applications/Multimedia.
599- Use bz2 instead of gz as ftp.gnome.org has both, 300k saved in the src.rpm.
600- Fix SCHEMES vs. SCHEMAS in the post scriplet.
601- Added gstreamer-plugins-devel, libvorbis-devel, scrollkeeper and gettext deps.
602- Removed unnecessary date expansion define.
603- Updated description, including mp3 reference removal.
604- Added libid3tag and flac optional support for convenient rebuild.
605- Removed obsolete omf.make and xmldocs.make (included ones are the same now).
606
607* Mon Sep 22 2003 Jonathan Blandford <jrb@redhat.com> 0.5.3-1
608- new version
609- use %{_sysconfdir} instead of /etc
610
611* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
612- rebuilt
613
614* Wed Dec 18 2002 Jonathan Blandford <jrb@redhat.com>
615- gave up on other archs for the Beta
616- new version
617- remove werror and add missing files
618
619* Thu Nov  7 2002 Jeremy Katz <katzj@redhat.com>
620- update to newer cvs snap
621
622* Mon Sep 23 2002 Jeremy Katz <katzj@redhat.com>
623- update to cvs snap
624
625* Sun Sep 22 2002 Jeremy Katz <katzj@redhat.com>
626- use %%(lang)
627
628* Sun Aug 11 2002 Jeremy Katz <katzj@redhat.com>
629- fix post to actually install the schema
630
631* Sat Jun 22 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
632- Added gconf file
633- Added i18n directory
634
635* Sat Jun 15 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
636- Updated for new rewrite of rhythmbox, thanks to Jeroen
637
638* Mon Mar 18 2002 Jorn Baayen <jorn@nl.linux.org>
639- removed bonobo dependency
640* Sat Mar 02 2002 Christian Schaller <Uraeus@linuxrising.org>
641- created new spec file
Note: See TracBrowser for help on using the repository browser.