source: projects/specs/trunk/r/rhythmbox/rhythmbox-vl.spec @ 8535

Revision 8535, 20.2 KB checked in by Takemikaduchi, 10 years ago (diff)

task-mate: remove mate-system-tools
others: new upstream release

Line 
1# -*- coding: utf-8-unix -*-
2%define desktop_file_utils_version 0.9
3
4%define enable_DLNA_UPnP 0
5
6Summary: Music Management Application
7Summary(ja): 音楽管理アプリケーション
8Name: rhythmbox
9Version: 3.0.3
10Release: 1%{?_dist_release}
11License: GPL2+ with exceptions and GFDL
12Group: Applications/Multimedia
13URL: http://projects.gnome.org/rhythmbox/
14Source0: http://download.gnome.org/sources/${name}/3.0/%{name}-%{version}.tar.xz
15
16Source101:      rhythmbox-png.tar.bz2
17
18Patch0: rhythmbox-3.0-disable-python3.patch
19
20BuildRoot: %{_tmppath}/%{name}-%{version}-root
21BuildRequires: gtk3-devel
22BuildRequires: avahi-glib-devel >= 0.6
23BuildRequires: brasero-devel >= 2.32.0
24BuildRequires: dbus-glib-devel
25BuildRequires: gstreamer1-plugins-base-devel
26BuildRequires: json-glib-devel
27BuildRequires: libSM-devel
28BuildRequires: libgnome-keyring-devel >= 2.30.0
29BuildRequires: libgpod-devel
30BuildRequires: libgudev1-devel
31BuildRequires: libmusicbrainz3-devel >= 3.0.2
32BuildRequires: libnotify-devel
33BuildRequires: libsoup-devel
34BuildRequires: pygobject3-devel
35BuildRequires: totem-pl-parser-devel
36BuildRequires: WebKit3-gtk-devel
37BuildRequires: libpeas-devel
38BuildRequires: clutter-gtk-devel
39BuildRequires: clutter-gst-devel
40BuildRequires: libmx-devel
41BuildRequires: check-devel
42BuildRequires: libmtp-devel
43BuildRequires: libtdb-devel
44BuildRequires: grilo-devel
45BuildRequires: libdmapsharing-devel
46BuildRequires: lirc
47BuildRequires: gnome-doc-utils >= 0.3.2
48BuildRequires: yelp-tools
49
50Requires: libgpod
51Requires: libnotify
52Requires: lirc
53Requires: libmtp
54Requires: brasero
55Requires: libgnome-keyring
56%if %{enable_DLNA_UPnP}
57Requires: python-Coherence
58%endif
59Requires: desktop-file-utils >= %{desktop_file_utils_version}
60
61# # gstreamer-plugins-ffmpeg and gstreamer-plugins-ugly package provided by
62# # self-build-gstreamer-plugins-ffmpeg and self-build-gstreamer-plugins-ugly,
63# # respectively.
64# Requires: self-build-gstreamer-plugins-ffmpeg
65# Requires: self-build-gstreamer-plugins-ugly
66
67Vendor: Project Vine
68Distribution: Vine Linux
69
70
71%description
72Rhythmbox is an integrated music management application based on the powerful
73GStreamer media framework. It has a number of features, including an easy to
74use music browser, searching and sorting, comprehensive audio format support
75through GStreamer, Internet Radio support, playlists and more.
76
77Rhythmbox is extensible through a plugin system.
78
79%description -l ja
80Rhythmbox は、強力な GStreamer メディアフレームワークに基づいている
81統合音楽管理アプリケーションです。
82見やすいユーザインターフェースを備え、検索や整列ができ、
83GStreamer により数多くの音声フォーマットをサポート、
84インターネットラジオをサポート、プレイリスト管理などの
85数多くの特徴を持ちます。
86
87%package devel
88Summary: Development tools for rhythmbox applications.
89Summary(ja): rhythmbox アプリケーションの開発用ファイル
90Group: Development/Libraries
91Requires: %{name} = %{version}-%{release}
92Requires: pkgconfig
93Requires: libxml2-devel
94Requires: glib2-devel
95Requires: gtk3-devel
96Requires: libsoup-devel
97Requires: totem-pl-parser-devel
98Requires: gstreamer1-devel
99
100%description devel
101Header files and libraries for building a extension library for the rhythmbox.
102
103%description devel -l ja
104
105%prep
106%setup -q
107%patch0 -p1
108tar xjf %{SOURCE101}
109
110%build
111autoreconf -if
112intltoolize --force --copy
113%configure --with-ipod \
114    --with-mtp \
115    --enable-lirc \
116    --disable-python \
117    --disable-vala \
118    --disable-browser-plugin \
119    --disable-static \
120    --enable-browser-plugin \
121    --without-hal
122%__make %{?_smp_mflags}
123
124%install
125%__rm -rf $RPM_BUILD_ROOT
126%__make install DESTDIR=$RPM_BUILD_ROOT
127
128%__rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/*.{a,la}
129%__rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/librb-nautilus-context-menu.so
130%__rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
131%__rm -f $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*.{a,la}
132%__rm -f $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*/*.{a,la}
133%__rm -f $RPM_BUILD_ROOT%{_libdir}/librhythmbox-core.{a,la}
134%__rm -f $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins/*.{a,la}
135
136## Don't package DLNA/UPnP plugin
137%if !%{enable_DLNA_UPnP}
138%__rm -rf $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/upnp_coherence
139%endif
140
141%find_lang %{name} --all-name --with-gnome
142
143
144# Don't package api docs
145%__rm -rf $RPM_BUILD_ROOT%{_datadir}/gtk-doc/
146
147# And don't package vala
148%__rm -f %{buildroot}%{_libdir}/rhythmbox/plugins/libsample-vala.so \
149        %{buildroot}%{_libdir}/rhythmbox/plugins/sample-vala.rb-plugin
150
151# remove sample plugins
152rm -rf $RPM_BUILD_ROOT/%{_libdir}/%{name}/sample-plugins
153
154%clean
155%__rm -rf $RPM_BUILD_ROOT
156
157%post
158/sbin/ldconfig
159update-desktop-database -q
160touch --no-create %{_datadir}/icons/hicolor
161if [ -x /usr/bin/gtk-update-icon-cache ]; then
162  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
163fi
164
165%postun
166/sbin/ldconfig
167update-desktop-database -q
168touch --no-create %{_datadir}/icons/hicolor
169if [ -x /usr/bin/gtk-update-icon-cache ]; then
170  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
171fi
172glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
173
174%posttrans
175glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
176
177
178%files -f %{name}.lang
179%defattr(-, root, root)
180%doc AUTHORS COPYING ChangeLog README NEWS
181%{_bindir}/*
182%{_libdir}/girepository-1.0/*.typelib
183%{_libdir}/lib*.so.*
184%{_libdir}/mozilla/plugins/librhythmbox-itms-detection-plugin.so
185%{_libdir}/rhythmbox/plugins
186%{_datadir}/applications/rhythmbox.desktop
187%{_datadir}/applications/rhythmbox-device.desktop
188%{_datadir}/dbus-1/services/org.gnome.Rhythmbox3.service
189%{_datadir}/glib-2.0/schemas/org.gnome.rhythmbox.gschema.xml
190%{_datadir}/icons/*
191%{_datadir}/rhythmbox
192%{_mandir}/man1/*
193%{_libexecdir}/rhythmbox-metadata
194
195%files devel
196%defattr(-, root, root)
197%{_includedir}/%{name}/*
198%{_libdir}/*.so
199%{_libdir}/pkgconfig/*.pc
200%{_datadir}/gir-1.0/*.gir
201
202
203%changelog
204* Sat Jun 07 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.3-1
205- new upstream release
206
207* Sun Mar 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.2-1
208- new upstream release
209
210* Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.1-2
211- rebuild with VineSeed environment
212
213* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.1-1
214- new upstream release
215
216* Fri Sep 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0-1
217- new upstream release
218- add Patch0 (rhythmbox-3.0-disable-python3.patch)
219
220* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.99.1-1
221- new upstream release
222- add BuildRequies: yelp-tools
223- change BuildRequires: gstreamer1-plugins-base-devel instead of gstreamer-plugins-base-devel
224
225* Sun Mar 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.98-2
226- rebuild with libimobiledevice-1.1.5
227
228* Mon Oct 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.98-1
229- new upstream release
230- add BuildRequires: grilo-devel, libdmapsharing-devel
231
232* Tue Jun 05 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.97-1
233- new upstream release
234
235* Wed Apr 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.96-1
236- new upstream release
237
238* Sat Jan 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.95-1
239- new upstream release
240- add BuildRequires: gtk3-devel, libtdb-devel, pygobject3-devel
241- remove BuildRequires: gnome-vfs2-devel, gstreamer-python-devel, libffi-devel, libgnome-media-profiles-devel, libgnomeui-devel, libsexy-devel, popt-devel, python-devel, pygtk2-devel, sqlite3-devel
242
243* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-4
244- rebuild with cogl-0.8.0
245
246* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-3
247- rebuild with libnotify-0.7
248- change BuildRequires: libmusicbrainz3-devel instead of libmusicbrainz-devel
249- change BuildRequires: libgnome-media-profiles-devel instead of gnome-media-devel
250- add BuildRequires: WebKit3-gtk-devel, libpeas-devel, clutter-gtk-devel, clutter-gst-devel, libmx-devel
251- add Patch0 (rhythmbox-0.13.3-git20110809.patch)
252- add Source101 (rhythmbox-png.tar.bz2)
253
254* Fri Aug 12 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-2
255- add BuildRequires: json-glib-devel
256- remove unrecognized configure option (--with-dbus, --with-cd-burning, --with-metadata-helper)
257
258* Sun Jan 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-1
259- new upstream release
260- change BuildRequires: gstreamer-python-devel instead of gstreamer-python
261
262* Sat Nov 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.2-1
263- new upstream release
264
265* Wed Oct 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-3
266- rebuild with brasero-2.32.0
267
268* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-2
269- rebuild with rpm-4.8.1 for pkg-config file
270
271* Sun Sep 12 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-1
272- new upstream release
273- fix %files (add rhythmbox-device.desktop)
274
275* Sun Aug 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.0-1
276- new upstream release
277- change BuildRequires: gnome-media-devel instead of gnome-media
278- add devel package
279- drop Patch0
280
281* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.8-1
282- new upstream release
283- drop Patch1, Patch2, Patch3
284- change BuildRequires: nautilus-cd-burner -> brasero-devel
285- change Requires: nautilus-cd-burner -> brasero
286- change BuildRequires: hal-devel -> libgudev1-devel
287- change BuildRequires: gnome-keyring-devel -> libgnome-keyring-devel
288- change Requires: gnome-keyring -> libgnome-keyring
289- add configure option (--without-hal)
290
291* Mon Feb 15 2010 Shu KONNO <owa@bg.wakwak.com> 0.12.6-2
292- rebuilt with new environment
293
294* Thu Jan 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.6-1
295- new upstream release
296  - dropped upstreamed/obsolete patches
297  - added patches applied Fedora development
298
299* Sun Oct 04 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.5-1
300- new upstream release
301- added configure options:
302  --disable-vala
303  --disable-browser-plugin
304
305* Thu Jul 30 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.2-2
306- added Japanese description
307
308* Thu Jul 02 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.12.2-1
309- new upstream release
310  - dropped rb-disable-power-plugin-by-default.patch
311- added BuildRequires:
312  - libSM-devel
313  - gnome-media
314
315* Wed Jun 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.12.1-2
316- rebuild with libgpod-0.7.2
317
318* Sun May 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.12.1-1
319- new upstream release
320- corrected License tag
321- dropped rhythmbox-0.11.6-libmtp.patch
322- added BuildRequires:
323  - sqlite3-devel
324  - libffi-devel
325
326* Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.11.6-2
327- defined enable_DLNA_UPnP = 0: unpacked DLNA/UPnP plugin
328- applied rhythmbox-0.11.6-libmtp.patch
329- added Requires:
330  - libgpod
331  - libnotify
332  - libsexy
333  - lirc
334  - libmtp
335  - libgnomeui
336  - nautilus-cd-burner
337  - gstreamer-python
338  - gnome-vfs2
339  - gnome-themes
340  - gnome-keyring
341  - python-Coherence, if enable_DLNA_UPnP = 1
342- added BuildRequires:
343  - libnotify-devel
344  - libsexy-devel
345  - lirc
346  - libmtp-devel
347  - gnome-vfs2-devel, instead of gnome-vfs2
348  - gnome-keyring-devel
349- dropped --with-internal-libsexy in configure options
350- added in configure options:
351  --with-mtp --with-libnautilus-burn --enable-lirc --disable-static
352- added %%preun to remove the schema
353
354* Sun Jan 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.11.6-1
355- new upstream release
356- changed to --with-metadata-helper in configure options
357- added BuildRequires:
358  - gstreamer-python
359  - intltool >= 0.35.0
360  - popt-devel
361
362* Sat Aug 09 2008 Shu KONNO <owa@bg.wakwak.com> 0.11.2-1vl5
363- added BuildRequires: totem-pl-parser-devel, instead of totem-devel
364- rebuilt with python-2.5.2
365- applied new versioning policy
366- spec in utf-8
367
368* Sun Jan 06 2008 Shu KONNO <owa@bg.wakwak.com> 0.11.2-0vl2
369- rebuilt with libgpod-0.6.0
370
371* Sun Aug 26 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.2-0vl1
372- new upstream release
373
374* Wed Jun 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.1-0vl1
375- new upstream release
376
377* Tue May 29 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.10.0-0vl2
378- rebuilt with new toolchain and libgpod-0.4.2
379- add BuildRequires: dbus-glib-devel
380
381* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.0-0vl1
382- new upstream release
383
384* Wed Mar 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8-0vl2
385- rebuilt for VineSeed
386
387* Wed Mar 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8-0vl1
388- new upstream release
389- added --enable-python option to %%configure
390- added Requires: gnome-python
391
392* Sun Jan 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.7-0vl1
393- new upstream release
394- built with libsoup 2.2.99
395
396* Thu Nov 23 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6-0vl4
397- added --with-cd-burner to configure
398- added BuildRequires: libsexy-devel hal-devel libsoup-devel
399
400* Wed Oct 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.6-0vl3
401- add BuildRequires:
402  - gnome-doc-utils >= 0.3.2
403  - python-devel
404  - pygtk2-devel
405  - check >= 0.8.2
406
407* Tue Oct 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.6-0vl2
408- rebuild with gnutls-1.4.1
409
410* Sun Oct  1 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6-0vl1
411- new upstream release
412
413* Mon Jun 19 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.5-0vl1
414- new upstream release
415- run scrollkeeper-update at %post and %postun
416- added BuildRequires: libnotify-devel
417
418* Sun May 14 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.4.1-0vl1
419- new upstream release (dropped patch0)
420- added --without-metadata-helper at configure
421
422* Mon Mar 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.3.1-0vl1
423- Initial build for Vine Linux based on FC pacakge
424
425* Fri Mar 03 2006 Ray Strode <rstrode@redhat.com> - 0.9.3.1-2
426- add patch from James "Doc" Livingston to stop a hang
427  for new users (bug 183883)
428
429* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3.1-1.2
430- bump again for double-long bug on ppc(64)
431
432* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3.1-1.1
433- rebuilt for new gcc4.1 snapshot and glibc changes
434
435* Sat Feb  4 2006 Christopher Aillon <caillon@redhat.com> 0.9.3.1-1
436- Update to 0.9.3.1
437- Use gstreamer (0.10)
438
439* Wed Feb  1 2006 Christopher Aillon <caillon@redhat.com> 0.9.3-2
440- Remove hack for 173869, as its no longer needed.
441
442* Wed Feb  1 2006 Christopher Aillon <caillon@redhat.com> 0.9.3-1
443- 0.9.3
444
445* Wed Feb  1 2006 Christopher Aillon <caillon@redhat.com> 0.9.2.cvs20060201-1
446- Newer CVS snapshot
447
448* Sun Jan 22 2006 Christopher Aillon <caillon@redhat.com> 0.9.2.cvs20060123-1
449- Update to latest CVS
450- Add hack to workaround bug #173869
451
452* Thu Jan 19 2006 Christopher Aillon <caillon@redhat.com> 0.9.2-8
453- Rebuild, now that gstreamer08-plugins has been fixed
454
455* Thu Jan 19 2006 Ray Strode <rstrode@redhat.com> 0.9.2-7
456- bonobo multilib issue (bug 156982)
457
458* Wed Jan 04 2006 John (J5) Palmieri <johnp@redhat.com> 0.9.2-5
459- rebuild with ipod support
460
461* Tue Jan 03 2006 Jesse Keating <jkeating@redhat.com> 0.9.2-4
462- rebuilt again
463
464* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
465- rebuilt
466
467* Mon Dec  5 2005 Matthias Clasen <mclasen@redhat.com>
468- rebuild
469
470* Thu Dec 01 2005 John (J5) Palmieri <johnp@redhat.com>
471- rebuild for new dbus
472
473* Wed Nov 30 2005 Matthias Clasen <mclasen@redhat.com>
474- Update to 0.9.2
475
476* Tue Oct 25 2005 Matthias Clasen <mclasen@redhat.com>
477- Update to 0.9.1
478
479* Fri Sep 02 2005 Colin Walters <walters@redhat.com>
480- Add configure flags --with-bonobo --with-dbus
481- BR nautilus-cd-burner-devel
482- New upstream CVS snapshot for testing
483- Drop IDL file and ui .xml
484- Add dbus service file
485- Drop upstreamed rhythmbox-bluecurve.tar.gz
486- Drop upstreamed rhythmbox-0.8.8-cell-renderer.patch
487
488* Mon Jun 13 2005 Colin Walters <walters@redhat.com> - 0.8.8-3
489- Add Bluecurve-ized icons from Jeff Schroeder (157716)
490- Add rhythmbox-0.8.8-cell-renderer.patch to remove use of custom
491  cell renderer for playback icon (no longer necessary) and
492  changes the rating renderer to work with non-b&w icons
493
494* Mon Mar 14 2005 Colin Walters <walters@redhat.com> - 0.8.8-2
495- Rebuild for GCC4
496
497* Tue Oct 05 2004 Colin Walters <walters@redhat.com> - 0.8.8-1
498- New upstream version
499- Remove librb-nautilus-context-menu.so, killed upstream
500
501* Thu Sep 30 2004 Christopher Aillon <caillon@redhat.com> 0.8.7-2
502- PreReq desktop-file-utils >= 0.9
503
504* Wed Sep 29 2004 Colin Walters <walters@redhat.com> - 0.8.7-1
505- New upstream version
506
507* Sat Sep 18 2004 Colin Walters <walters@redhat.com> - 0.8.6-2
508- Fix postun to use correct syntax, thanks Nils Philippsen
509
510* Sat Sep 18 2004 Colin Walters <walters@redhat.com> - 0.8.6-1
511- New upstream version
512- Call update-desktop-database in post and postun
513
514* Thu Jun 24 2004 Colin Walters <walters@redhat.com> - 0.8.5-1
515- New upstream version
516
517* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
518- rebuilt
519
520* Tue May 18 2004 Colin Walters <walters@redhat.com> - 0.8.4-1
521- New upstream version
522- Remove backported patches
523- Gratuitiously bump various BuildRequires versions
524
525* Mon May 10 2004 Colin Walters <walters@redhat.com> - 0.8.3-4
526- Remove code to unregister GConf schema for now (Closes: #122532)
527
528* Fri May 07 2004 Colin Walters <walters@redhat.com> - 0.8.3-3
529- Apply tiny patch from 0.8 arch to fix GConf key used
530  for initial sorting
531
532* Fri May 07 2004 Colin Walters <walters@redhat.com> - 0.8.3-2
533- Apply patch from 0.8 arch tree to fix a number of memleaks
534
535* Sun May 02 2004 Colin Walters <walters@redhat.com> - 0.8.3-1
536- Update to 0.8.3: fixes showstopper bug with internet radio
537
538* Fri Apr 30 2004 Colin Walters <walters@redhat.com> - 0.8.2-1
539- Update to 0.8.2
540- Fix Source url
541- Add smp_mflags
542- Bump BuildRequires on gstreamer to 0.8.1
543
544* Fri Apr 23 2004 Colin Walters <walters@redhat.com> - 0.8.1-2
545- Uninstall GConf schemas on removal
546
547* Tue Apr 20 2004 Colin Walters <walters@redhat.com> - 0.8.1-1
548- Update to 0.8.1
549
550* Fri Apr 16 2004 Colin Walters <walters@redhat.com> - 0.8.0-1
551- Update to 0.8.0
552
553* Fri Apr 02 2004 Colin Walters <walters@redhat.com> - 0.7.2-1
554- Update to 0.7.2
555
556* Mon Mar 29 2004 Colin Walters <walters@redhat.com> - 0.7.1-2
557- Remove BuildRequires on autoconf and libvorbis-devel
558
559* Mon Mar 29 2004 Colin Walters <walters@redhat.com> - 0.7.1-1
560- New major version - I know we are past major version slush, but
561  this should have been done two weeks ago along with the GNOME 2.6
562  upload.  As upstream author as well, I believe this version is
563  good enough for FC2.
564- Remove --disable-mp3
565- Remove id3, flac variables
566- Remove GStreamer major version patch
567- Fix typo in description
568
569* Tue Mar 16 2004 Jeremy Katz <katzj@redhat.com> - 0.6.8-2
570- rebuild for new gstreamer
571
572* Thu Mar 11 2004 Alex Larsson <alexl@redhat.com> 0.6.8-1
573- update to 0.6.8
574
575* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
576- rebuilt
577
578* Mon Mar  1 2004 Alexander Larsson <alexl@redhat.com> 0.6.7-1
579- update to 0.6.7
580
581* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
582- rebuilt
583
584* Mon Jan 12 2004 Colin Walters <walters@verbum.org> 0.6.4-1
585- New upstream version
586- Don't re-run the autotools; upstream incorporates newer versions.
587* Tue Oct 28 2003 Jonathan Blandford <jrb@redhat.com> 0.5.4-1
588- new version
589- remove smp_flags
590
591* Fri Oct 24 2003 Jonathan Blandford <jrb@redhat.com> 0.5.3-5
592- remove the initial iradio channels as they all are mp3 based.
593
594* Wed Oct  8 2003 Matthias Saou <matthias@rpmforge.net> 0.5.3-3
595- Fix category from Development/Libraries to Applications/Multimedia.
596- Use bz2 instead of gz as ftp.gnome.org has both, 300k saved in the src.rpm.
597- Fix SCHEMES vs. SCHEMAS in the post scriplet.
598- Added gstreamer-plugins-devel, libvorbis-devel, scrollkeeper and gettext deps.
599- Removed unnecessary date expansion define.
600- Updated description, including mp3 reference removal.
601- Added libid3tag and flac optional support for convenient rebuild.
602- Removed obsolete omf.make and xmldocs.make (included ones are the same now).
603
604* Mon Sep 22 2003 Jonathan Blandford <jrb@redhat.com> 0.5.3-1
605- new version
606- use %{_sysconfdir} instead of /etc
607
608* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
609- rebuilt
610
611* Wed Dec 18 2002 Jonathan Blandford <jrb@redhat.com>
612- gave up on other archs for the Beta
613- new version
614- remove werror and add missing files
615
616* Thu Nov  7 2002 Jeremy Katz <katzj@redhat.com>
617- update to newer cvs snap
618
619* Mon Sep 23 2002 Jeremy Katz <katzj@redhat.com>
620- update to cvs snap
621
622* Sun Sep 22 2002 Jeremy Katz <katzj@redhat.com>
623- use %%(lang)
624
625* Sun Aug 11 2002 Jeremy Katz <katzj@redhat.com>
626- fix post to actually install the schema
627
628* Sat Jun 22 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
629- Added gconf file
630- Added i18n directory
631
632* Sat Jun 15 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
633- Updated for new rewrite of rhythmbox, thanks to Jeroen
634
635* Mon Mar 18 2002 Jorn Baayen <jorn@nl.linux.org>
636- removed bonobo dependency
637* Sat Mar 02 2002 Christian Schaller <Uraeus@linuxrising.org>
638- created new spec file
Note: See TracBrowser for help on using the repository browser.