source: projects/specs/trunk/r/rhythmbox/rhythmbox-vl.spec @ 8353

Revision 8353, 20.1 KB checked in by Takemikaduchi, 10 years ago (diff)

GNOME-3.12.0

Line 
1# -*- coding: utf-8-unix -*-
2%define desktop_file_utils_version 0.9
3
4%define enable_DLNA_UPnP 0
5
6Summary: Music Management Application
7Summary(ja): 音楽管理アプリケーション
8Name: rhythmbox
9Version: 3.0.2
10Release: 1%{?_dist_release}
11License: GPL2+ with exceptions and GFDL
12Group: Applications/Multimedia
13URL: http://projects.gnome.org/rhythmbox/
14Source0: http://download.gnome.org/sources/${name}/3.0/%{name}-%{version}.tar.xz
15
16Source101:      rhythmbox-png.tar.bz2
17
18Patch0: rhythmbox-3.0-disable-python3.patch
19
20BuildRoot: %{_tmppath}/%{name}-%{version}-root
21BuildRequires: gtk3-devel
22BuildRequires: avahi-glib-devel >= 0.6
23BuildRequires: brasero-devel >= 2.32.0
24BuildRequires: dbus-glib-devel
25BuildRequires: gstreamer1-plugins-base-devel
26BuildRequires: json-glib-devel
27BuildRequires: libSM-devel
28BuildRequires: libgnome-keyring-devel >= 2.30.0
29BuildRequires: libgpod-devel
30BuildRequires: libgudev1-devel
31BuildRequires: libmusicbrainz3-devel >= 3.0.2
32BuildRequires: libnotify-devel
33BuildRequires: libsoup-devel
34BuildRequires: pygobject3-devel
35BuildRequires: totem-pl-parser-devel
36BuildRequires: WebKit3-gtk-devel
37BuildRequires: libpeas-devel
38BuildRequires: clutter-gtk-devel
39BuildRequires: clutter-gst-devel
40BuildRequires: libmx-devel
41BuildRequires: check-devel
42BuildRequires: libmtp-devel
43BuildRequires: libtdb-devel
44BuildRequires: grilo-devel
45BuildRequires: libdmapsharing-devel
46BuildRequires: lirc
47BuildRequires: gnome-doc-utils >= 0.3.2
48BuildRequires: yelp-tools
49
50Requires: libgpod
51Requires: libnotify
52Requires: lirc
53Requires: libmtp
54Requires: brasero
55Requires: libgnome-keyring
56%if %{enable_DLNA_UPnP}
57Requires: python-Coherence
58%endif
59Requires: desktop-file-utils >= %{desktop_file_utils_version}
60
61# # gstreamer-plugins-ffmpeg and gstreamer-plugins-ugly package provided by
62# # self-build-gstreamer-plugins-ffmpeg and self-build-gstreamer-plugins-ugly,
63# # respectively.
64# Requires: self-build-gstreamer-plugins-ffmpeg
65# Requires: self-build-gstreamer-plugins-ugly
66
67Vendor: Project Vine
68Distribution: Vine Linux
69
70
71%description
72Rhythmbox is an integrated music management application based on the powerful
73GStreamer media framework. It has a number of features, including an easy to
74use music browser, searching and sorting, comprehensive audio format support
75through GStreamer, Internet Radio support, playlists and more.
76
77Rhythmbox is extensible through a plugin system.
78
79%description -l ja
80Rhythmbox は、強力な GStreamer メディアフレームワークに基づいている
81統合音楽管理アプリケーションです。
82見やすいユーザインターフェースを備え、検索や整列ができ、
83GStreamer により数多くの音声フォーマットをサポート、
84インターネットラジオをサポート、プレイリスト管理などの
85数多くの特徴を持ちます。
86
87%package devel
88Summary: Development tools for rhythmbox applications.
89Summary(ja): rhythmbox アプリケーションの開発用ファイル
90Group: Development/Libraries
91Requires: %{name} = %{version}-%{release}
92Requires: pkgconfig
93Requires: libxml2-devel
94Requires: glib2-devel
95Requires: gtk3-devel
96Requires: libsoup-devel
97Requires: totem-pl-parser-devel
98Requires: gstreamer1-devel
99
100%description devel
101Header files and libraries for building a extension library for the rhythmbox.
102
103%description devel -l ja
104
105%prep
106%setup -q
107%patch0 -p1
108tar xjf %{SOURCE101}
109
110%build
111autoreconf -if
112intltoolize --force --copy
113%configure --with-ipod \
114    --with-mtp \
115    --enable-lirc \
116    --disable-python \
117    --disable-vala \
118    --disable-browser-plugin \
119    --disable-static \
120    --enable-browser-plugin \
121    --without-hal
122%__make %{?_smp_mflags}
123
124%install
125%__rm -rf $RPM_BUILD_ROOT
126%__make install DESTDIR=$RPM_BUILD_ROOT
127
128%__rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/*.{a,la}
129%__rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/librb-nautilus-context-menu.so
130%__rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
131%__rm -f $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*.{a,la}
132%__rm -f $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*/*.{a,la}
133%__rm -f $RPM_BUILD_ROOT%{_libdir}/librhythmbox-core.{a,la}
134%__rm -f $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins/*.{a,la}
135
136## Don't package DLNA/UPnP plugin
137%if !%{enable_DLNA_UPnP}
138%__rm -rf $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/upnp_coherence
139%endif
140
141%find_lang %{name} --all-name --with-gnome
142
143
144# Don't package api docs
145%__rm -rf $RPM_BUILD_ROOT%{_datadir}/gtk-doc/
146
147# And don't package vala
148%__rm -f %{buildroot}%{_libdir}/rhythmbox/plugins/libsample-vala.so \
149        %{buildroot}%{_libdir}/rhythmbox/plugins/sample-vala.rb-plugin
150
151# remove sample plugins
152rm -rf $RPM_BUILD_ROOT/%{_libdir}/%{name}/sample-plugins
153
154%clean
155%__rm -rf $RPM_BUILD_ROOT
156
157%post
158/sbin/ldconfig
159update-desktop-database -q
160touch --no-create %{_datadir}/icons/hicolor
161if [ -x /usr/bin/gtk-update-icon-cache ]; then
162  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
163fi
164
165%postun
166/sbin/ldconfig
167update-desktop-database -q
168touch --no-create %{_datadir}/icons/hicolor
169if [ -x /usr/bin/gtk-update-icon-cache ]; then
170  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
171fi
172glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
173
174%posttrans
175glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
176
177
178%files -f %{name}.lang
179%defattr(-, root, root)
180%doc AUTHORS COPYING ChangeLog README NEWS
181%{_bindir}/*
182%{_libdir}/girepository-1.0/*.typelib
183%{_libdir}/lib*.so.*
184%{_libdir}/mozilla/plugins/librhythmbox-itms-detection-plugin.so
185%{_libdir}/rhythmbox/plugins
186%{_datadir}/applications/rhythmbox.desktop
187%{_datadir}/applications/rhythmbox-device.desktop
188%{_datadir}/dbus-1/services/org.gnome.Rhythmbox3.service
189%{_datadir}/glib-2.0/schemas/org.gnome.rhythmbox.gschema.xml
190%{_datadir}/icons/*
191%{_datadir}/rhythmbox
192%{_mandir}/man1/*
193%{_libexecdir}/rhythmbox-metadata
194
195%files devel
196%defattr(-, root, root)
197%{_includedir}/%{name}/*
198%{_libdir}/*.so
199%{_libdir}/pkgconfig/*.pc
200%{_datadir}/gir-1.0/*.gir
201
202
203%changelog
204* Sun Mar 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.2-1
205- new upstream release
206
207* Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.1-2
208- rebuild with VineSeed environment
209
210* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.1-1
211- new upstream release
212
213* Fri Sep 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0-1
214- new upstream release
215- add Patch0 (rhythmbox-3.0-disable-python3.patch)
216
217* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.99.1-1
218- new upstream release
219- add BuildRequies: yelp-tools
220- change BuildRequires: gstreamer1-plugins-base-devel instead of gstreamer-plugins-base-devel
221
222* Sun Mar 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.98-2
223- rebuild with libimobiledevice-1.1.5
224
225* Mon Oct 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.98-1
226- new upstream release
227- add BuildRequires: grilo-devel, libdmapsharing-devel
228
229* Tue Jun 05 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.97-1
230- new upstream release
231
232* Wed Apr 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.96-1
233- new upstream release
234
235* Sat Jan 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.95-1
236- new upstream release
237- add BuildRequires: gtk3-devel, libtdb-devel, pygobject3-devel
238- remove BuildRequires: gnome-vfs2-devel, gstreamer-python-devel, libffi-devel, libgnome-media-profiles-devel, libgnomeui-devel, libsexy-devel, popt-devel, python-devel, pygtk2-devel, sqlite3-devel
239
240* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-4
241- rebuild with cogl-0.8.0
242
243* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-3
244- rebuild with libnotify-0.7
245- change BuildRequires: libmusicbrainz3-devel instead of libmusicbrainz-devel
246- change BuildRequires: libgnome-media-profiles-devel instead of gnome-media-devel
247- add BuildRequires: WebKit3-gtk-devel, libpeas-devel, clutter-gtk-devel, clutter-gst-devel, libmx-devel
248- add Patch0 (rhythmbox-0.13.3-git20110809.patch)
249- add Source101 (rhythmbox-png.tar.bz2)
250
251* Fri Aug 12 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-2
252- add BuildRequires: json-glib-devel
253- remove unrecognized configure option (--with-dbus, --with-cd-burning, --with-metadata-helper)
254
255* Sun Jan 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-1
256- new upstream release
257- change BuildRequires: gstreamer-python-devel instead of gstreamer-python
258
259* Sat Nov 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.2-1
260- new upstream release
261
262* Wed Oct 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-3
263- rebuild with brasero-2.32.0
264
265* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-2
266- rebuild with rpm-4.8.1 for pkg-config file
267
268* Sun Sep 12 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-1
269- new upstream release
270- fix %files (add rhythmbox-device.desktop)
271
272* Sun Aug 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.0-1
273- new upstream release
274- change BuildRequires: gnome-media-devel instead of gnome-media
275- add devel package
276- drop Patch0
277
278* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.8-1
279- new upstream release
280- drop Patch1, Patch2, Patch3
281- change BuildRequires: nautilus-cd-burner -> brasero-devel
282- change Requires: nautilus-cd-burner -> brasero
283- change BuildRequires: hal-devel -> libgudev1-devel
284- change BuildRequires: gnome-keyring-devel -> libgnome-keyring-devel
285- change Requires: gnome-keyring -> libgnome-keyring
286- add configure option (--without-hal)
287
288* Mon Feb 15 2010 Shu KONNO <owa@bg.wakwak.com> 0.12.6-2
289- rebuilt with new environment
290
291* Thu Jan 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.6-1
292- new upstream release
293  - dropped upstreamed/obsolete patches
294  - added patches applied Fedora development
295
296* Sun Oct 04 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.5-1
297- new upstream release
298- added configure options:
299  --disable-vala
300  --disable-browser-plugin
301
302* Thu Jul 30 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.2-2
303- added Japanese description
304
305* Thu Jul 02 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.12.2-1
306- new upstream release
307  - dropped rb-disable-power-plugin-by-default.patch
308- added BuildRequires:
309  - libSM-devel
310  - gnome-media
311
312* Wed Jun 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.12.1-2
313- rebuild with libgpod-0.7.2
314
315* Sun May 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.12.1-1
316- new upstream release
317- corrected License tag
318- dropped rhythmbox-0.11.6-libmtp.patch
319- added BuildRequires:
320  - sqlite3-devel
321  - libffi-devel
322
323* Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.11.6-2
324- defined enable_DLNA_UPnP = 0: unpacked DLNA/UPnP plugin
325- applied rhythmbox-0.11.6-libmtp.patch
326- added Requires:
327  - libgpod
328  - libnotify
329  - libsexy
330  - lirc
331  - libmtp
332  - libgnomeui
333  - nautilus-cd-burner
334  - gstreamer-python
335  - gnome-vfs2
336  - gnome-themes
337  - gnome-keyring
338  - python-Coherence, if enable_DLNA_UPnP = 1
339- added BuildRequires:
340  - libnotify-devel
341  - libsexy-devel
342  - lirc
343  - libmtp-devel
344  - gnome-vfs2-devel, instead of gnome-vfs2
345  - gnome-keyring-devel
346- dropped --with-internal-libsexy in configure options
347- added in configure options:
348  --with-mtp --with-libnautilus-burn --enable-lirc --disable-static
349- added %%preun to remove the schema
350
351* Sun Jan 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.11.6-1
352- new upstream release
353- changed to --with-metadata-helper in configure options
354- added BuildRequires:
355  - gstreamer-python
356  - intltool >= 0.35.0
357  - popt-devel
358
359* Sat Aug 09 2008 Shu KONNO <owa@bg.wakwak.com> 0.11.2-1vl5
360- added BuildRequires: totem-pl-parser-devel, instead of totem-devel
361- rebuilt with python-2.5.2
362- applied new versioning policy
363- spec in utf-8
364
365* Sun Jan 06 2008 Shu KONNO <owa@bg.wakwak.com> 0.11.2-0vl2
366- rebuilt with libgpod-0.6.0
367
368* Sun Aug 26 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.2-0vl1
369- new upstream release
370
371* Wed Jun 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.1-0vl1
372- new upstream release
373
374* Tue May 29 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.10.0-0vl2
375- rebuilt with new toolchain and libgpod-0.4.2
376- add BuildRequires: dbus-glib-devel
377
378* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.0-0vl1
379- new upstream release
380
381* Wed Mar 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8-0vl2
382- rebuilt for VineSeed
383
384* Wed Mar 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8-0vl1
385- new upstream release
386- added --enable-python option to %%configure
387- added Requires: gnome-python
388
389* Sun Jan 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.7-0vl1
390- new upstream release
391- built with libsoup 2.2.99
392
393* Thu Nov 23 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6-0vl4
394- added --with-cd-burner to configure
395- added BuildRequires: libsexy-devel hal-devel libsoup-devel
396
397* Wed Oct 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.6-0vl3
398- add BuildRequires:
399  - gnome-doc-utils >= 0.3.2
400  - python-devel
401  - pygtk2-devel
402  - check >= 0.8.2
403
404* Tue Oct 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.6-0vl2
405- rebuild with gnutls-1.4.1
406
407* Sun Oct  1 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6-0vl1
408- new upstream release
409
410* Mon Jun 19 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.5-0vl1
411- new upstream release
412- run scrollkeeper-update at %post and %postun
413- added BuildRequires: libnotify-devel
414
415* Sun May 14 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.4.1-0vl1
416- new upstream release (dropped patch0)
417- added --without-metadata-helper at configure
418
419* Mon Mar 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.3.1-0vl1
420- Initial build for Vine Linux based on FC pacakge
421
422* Fri Mar 03 2006 Ray Strode <rstrode@redhat.com> - 0.9.3.1-2
423- add patch from James "Doc" Livingston to stop a hang
424  for new users (bug 183883)
425
426* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3.1-1.2
427- bump again for double-long bug on ppc(64)
428
429* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3.1-1.1
430- rebuilt for new gcc4.1 snapshot and glibc changes
431
432* Sat Feb  4 2006 Christopher Aillon <caillon@redhat.com> 0.9.3.1-1
433- Update to 0.9.3.1
434- Use gstreamer (0.10)
435
436* Wed Feb  1 2006 Christopher Aillon <caillon@redhat.com> 0.9.3-2
437- Remove hack for 173869, as its no longer needed.
438
439* Wed Feb  1 2006 Christopher Aillon <caillon@redhat.com> 0.9.3-1
440- 0.9.3
441
442* Wed Feb  1 2006 Christopher Aillon <caillon@redhat.com> 0.9.2.cvs20060201-1
443- Newer CVS snapshot
444
445* Sun Jan 22 2006 Christopher Aillon <caillon@redhat.com> 0.9.2.cvs20060123-1
446- Update to latest CVS
447- Add hack to workaround bug #173869
448
449* Thu Jan 19 2006 Christopher Aillon <caillon@redhat.com> 0.9.2-8
450- Rebuild, now that gstreamer08-plugins has been fixed
451
452* Thu Jan 19 2006 Ray Strode <rstrode@redhat.com> 0.9.2-7
453- bonobo multilib issue (bug 156982)
454
455* Wed Jan 04 2006 John (J5) Palmieri <johnp@redhat.com> 0.9.2-5
456- rebuild with ipod support
457
458* Tue Jan 03 2006 Jesse Keating <jkeating@redhat.com> 0.9.2-4
459- rebuilt again
460
461* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
462- rebuilt
463
464* Mon Dec  5 2005 Matthias Clasen <mclasen@redhat.com>
465- rebuild
466
467* Thu Dec 01 2005 John (J5) Palmieri <johnp@redhat.com>
468- rebuild for new dbus
469
470* Wed Nov 30 2005 Matthias Clasen <mclasen@redhat.com>
471- Update to 0.9.2
472
473* Tue Oct 25 2005 Matthias Clasen <mclasen@redhat.com>
474- Update to 0.9.1
475
476* Fri Sep 02 2005 Colin Walters <walters@redhat.com>
477- Add configure flags --with-bonobo --with-dbus
478- BR nautilus-cd-burner-devel
479- New upstream CVS snapshot for testing
480- Drop IDL file and ui .xml
481- Add dbus service file
482- Drop upstreamed rhythmbox-bluecurve.tar.gz
483- Drop upstreamed rhythmbox-0.8.8-cell-renderer.patch
484
485* Mon Jun 13 2005 Colin Walters <walters@redhat.com> - 0.8.8-3
486- Add Bluecurve-ized icons from Jeff Schroeder (157716)
487- Add rhythmbox-0.8.8-cell-renderer.patch to remove use of custom
488  cell renderer for playback icon (no longer necessary) and
489  changes the rating renderer to work with non-b&w icons
490
491* Mon Mar 14 2005 Colin Walters <walters@redhat.com> - 0.8.8-2
492- Rebuild for GCC4
493
494* Tue Oct 05 2004 Colin Walters <walters@redhat.com> - 0.8.8-1
495- New upstream version
496- Remove librb-nautilus-context-menu.so, killed upstream
497
498* Thu Sep 30 2004 Christopher Aillon <caillon@redhat.com> 0.8.7-2
499- PreReq desktop-file-utils >= 0.9
500
501* Wed Sep 29 2004 Colin Walters <walters@redhat.com> - 0.8.7-1
502- New upstream version
503
504* Sat Sep 18 2004 Colin Walters <walters@redhat.com> - 0.8.6-2
505- Fix postun to use correct syntax, thanks Nils Philippsen
506
507* Sat Sep 18 2004 Colin Walters <walters@redhat.com> - 0.8.6-1
508- New upstream version
509- Call update-desktop-database in post and postun
510
511* Thu Jun 24 2004 Colin Walters <walters@redhat.com> - 0.8.5-1
512- New upstream version
513
514* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
515- rebuilt
516
517* Tue May 18 2004 Colin Walters <walters@redhat.com> - 0.8.4-1
518- New upstream version
519- Remove backported patches
520- Gratuitiously bump various BuildRequires versions
521
522* Mon May 10 2004 Colin Walters <walters@redhat.com> - 0.8.3-4
523- Remove code to unregister GConf schema for now (Closes: #122532)
524
525* Fri May 07 2004 Colin Walters <walters@redhat.com> - 0.8.3-3
526- Apply tiny patch from 0.8 arch to fix GConf key used
527  for initial sorting
528
529* Fri May 07 2004 Colin Walters <walters@redhat.com> - 0.8.3-2
530- Apply patch from 0.8 arch tree to fix a number of memleaks
531
532* Sun May 02 2004 Colin Walters <walters@redhat.com> - 0.8.3-1
533- Update to 0.8.3: fixes showstopper bug with internet radio
534
535* Fri Apr 30 2004 Colin Walters <walters@redhat.com> - 0.8.2-1
536- Update to 0.8.2
537- Fix Source url
538- Add smp_mflags
539- Bump BuildRequires on gstreamer to 0.8.1
540
541* Fri Apr 23 2004 Colin Walters <walters@redhat.com> - 0.8.1-2
542- Uninstall GConf schemas on removal
543
544* Tue Apr 20 2004 Colin Walters <walters@redhat.com> - 0.8.1-1
545- Update to 0.8.1
546
547* Fri Apr 16 2004 Colin Walters <walters@redhat.com> - 0.8.0-1
548- Update to 0.8.0
549
550* Fri Apr 02 2004 Colin Walters <walters@redhat.com> - 0.7.2-1
551- Update to 0.7.2
552
553* Mon Mar 29 2004 Colin Walters <walters@redhat.com> - 0.7.1-2
554- Remove BuildRequires on autoconf and libvorbis-devel
555
556* Mon Mar 29 2004 Colin Walters <walters@redhat.com> - 0.7.1-1
557- New major version - I know we are past major version slush, but
558  this should have been done two weeks ago along with the GNOME 2.6
559  upload.  As upstream author as well, I believe this version is
560  good enough for FC2.
561- Remove --disable-mp3
562- Remove id3, flac variables
563- Remove GStreamer major version patch
564- Fix typo in description
565
566* Tue Mar 16 2004 Jeremy Katz <katzj@redhat.com> - 0.6.8-2
567- rebuild for new gstreamer
568
569* Thu Mar 11 2004 Alex Larsson <alexl@redhat.com> 0.6.8-1
570- update to 0.6.8
571
572* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
573- rebuilt
574
575* Mon Mar  1 2004 Alexander Larsson <alexl@redhat.com> 0.6.7-1
576- update to 0.6.7
577
578* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
579- rebuilt
580
581* Mon Jan 12 2004 Colin Walters <walters@verbum.org> 0.6.4-1
582- New upstream version
583- Don't re-run the autotools; upstream incorporates newer versions.
584* Tue Oct 28 2003 Jonathan Blandford <jrb@redhat.com> 0.5.4-1
585- new version
586- remove smp_flags
587
588* Fri Oct 24 2003 Jonathan Blandford <jrb@redhat.com> 0.5.3-5
589- remove the initial iradio channels as they all are mp3 based.
590
591* Wed Oct  8 2003 Matthias Saou <matthias@rpmforge.net> 0.5.3-3
592- Fix category from Development/Libraries to Applications/Multimedia.
593- Use bz2 instead of gz as ftp.gnome.org has both, 300k saved in the src.rpm.
594- Fix SCHEMES vs. SCHEMAS in the post scriplet.
595- Added gstreamer-plugins-devel, libvorbis-devel, scrollkeeper and gettext deps.
596- Removed unnecessary date expansion define.
597- Updated description, including mp3 reference removal.
598- Added libid3tag and flac optional support for convenient rebuild.
599- Removed obsolete omf.make and xmldocs.make (included ones are the same now).
600
601* Mon Sep 22 2003 Jonathan Blandford <jrb@redhat.com> 0.5.3-1
602- new version
603- use %{_sysconfdir} instead of /etc
604
605* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
606- rebuilt
607
608* Wed Dec 18 2002 Jonathan Blandford <jrb@redhat.com>
609- gave up on other archs for the Beta
610- new version
611- remove werror and add missing files
612
613* Thu Nov  7 2002 Jeremy Katz <katzj@redhat.com>
614- update to newer cvs snap
615
616* Mon Sep 23 2002 Jeremy Katz <katzj@redhat.com>
617- update to cvs snap
618
619* Sun Sep 22 2002 Jeremy Katz <katzj@redhat.com>
620- use %%(lang)
621
622* Sun Aug 11 2002 Jeremy Katz <katzj@redhat.com>
623- fix post to actually install the schema
624
625* Sat Jun 22 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
626- Added gconf file
627- Added i18n directory
628
629* Sat Jun 15 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
630- Updated for new rewrite of rhythmbox, thanks to Jeroen
631
632* Mon Mar 18 2002 Jorn Baayen <jorn@nl.linux.org>
633- removed bonobo dependency
634* Sat Mar 02 2002 Christian Schaller <Uraeus@linuxrising.org>
635- created new spec file
Note: See TracBrowser for help on using the repository browser.