source: projects/specs/trunk/r/rhythmbox/rhythmbox-vl.spec @ 8119

Revision 8119, 20.0 KB checked in by Takemikaduchi, 10 years ago (diff)

rebuild or new upstream release

Line 
1# -*- coding: utf-8-unix -*-
2%define desktop_file_utils_version 0.9
3
4%define enable_DLNA_UPnP 0
5
6Summary: Music Management Application
7Summary(ja): 音楽管理アプリケーション
8Name: rhythmbox
9Version: 3.0.1
10Release: 2%{?_dist_release}
11License: GPL2+ with exceptions and GFDL
12Group: Applications/Multimedia
13URL: http://projects.gnome.org/rhythmbox/
14Source0: http://download.gnome.org/sources/${name}/3.0/%{name}-%{version}.tar.xz
15
16Source101:      rhythmbox-png.tar.bz2
17
18Patch0: rhythmbox-3.0-disable-python3.patch
19
20BuildRoot: %{_tmppath}/%{name}-%{version}-root
21BuildRequires: gtk3-devel
22BuildRequires: avahi-glib-devel >= 0.6
23BuildRequires: brasero-devel >= 2.32.0
24BuildRequires: dbus-glib-devel
25BuildRequires: gstreamer1-plugins-base-devel
26BuildRequires: json-glib-devel
27BuildRequires: libSM-devel
28BuildRequires: libgnome-keyring-devel >= 2.30.0
29BuildRequires: libgpod-devel
30BuildRequires: libgudev1-devel
31BuildRequires: libmusicbrainz3-devel >= 3.0.2
32BuildRequires: libnotify-devel
33BuildRequires: libsoup-devel
34BuildRequires: pygobject3-devel
35BuildRequires: totem-pl-parser-devel
36BuildRequires: WebKit3-gtk-devel
37BuildRequires: libpeas-devel
38BuildRequires: clutter-gtk-devel
39BuildRequires: clutter-gst-devel
40BuildRequires: libmx-devel
41BuildRequires: check-devel
42BuildRequires: libmtp-devel
43BuildRequires: libtdb-devel
44BuildRequires: grilo-devel
45BuildRequires: libdmapsharing-devel
46BuildRequires: lirc
47BuildRequires: gnome-doc-utils >= 0.3.2
48BuildRequires: yelp-tools
49
50Requires: libgpod
51Requires: libnotify
52Requires: lirc
53Requires: libmtp
54Requires: brasero
55Requires: libgnome-keyring
56%if %{enable_DLNA_UPnP}
57Requires: python-Coherence
58%endif
59Requires: desktop-file-utils >= %{desktop_file_utils_version}
60
61# # gstreamer-plugins-ffmpeg and gstreamer-plugins-ugly package provided by
62# # self-build-gstreamer-plugins-ffmpeg and self-build-gstreamer-plugins-ugly,
63# # respectively.
64# Requires: self-build-gstreamer-plugins-ffmpeg
65# Requires: self-build-gstreamer-plugins-ugly
66
67Vendor: Project Vine
68Distribution: Vine Linux
69
70
71%description
72Rhythmbox is an integrated music management application based on the powerful
73GStreamer media framework. It has a number of features, including an easy to
74use music browser, searching and sorting, comprehensive audio format support
75through GStreamer, Internet Radio support, playlists and more.
76
77Rhythmbox is extensible through a plugin system.
78
79%description -l ja
80Rhythmbox は、強力な GStreamer メディアフレームワークに基づいている
81統合音楽管理アプリケーションです。
82見やすいユーザインターフェースを備え、検索や整列ができ、
83GStreamer により数多くの音声フォーマットをサポート、
84インターネットラジオをサポート、プレイリスト管理などの
85数多くの特徴を持ちます。
86
87%package devel
88Summary: Development tools for rhythmbox applications.
89Summary(ja): rhythmbox アプリケーションの開発用ファイル
90Group: Development/Libraries
91Requires: %{name} = %{version}-%{release}
92Requires: pkgconfig
93Requires: libxml2-devel
94Requires: glib2-devel
95Requires: gtk3-devel
96Requires: libsoup-devel
97Requires: totem-pl-parser-devel
98Requires: gstreamer1-devel
99
100%description devel
101Header files and libraries for building a extension library for the rhythmbox.
102
103%description devel -l ja
104
105%prep
106%setup -q
107%patch0 -p1
108tar xjf %{SOURCE101}
109
110%build
111autoreconf -if
112intltoolize --force --copy
113%configure --with-ipod \
114    --with-mtp \
115    --enable-lirc \
116    --disable-python \
117    --disable-vala \
118    --disable-browser-plugin \
119    --disable-static \
120    --enable-browser-plugin \
121    --without-hal
122%__make %{?_smp_mflags}
123
124%install
125%__rm -rf $RPM_BUILD_ROOT
126%__make install DESTDIR=$RPM_BUILD_ROOT
127
128%__rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/*.{a,la}
129%__rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/librb-nautilus-context-menu.so
130%__rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
131%__rm -f $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*.{a,la}
132%__rm -f $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*/*.{a,la}
133%__rm -f $RPM_BUILD_ROOT%{_libdir}/librhythmbox-core.{a,la}
134%__rm -f $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins/*.{a,la}
135
136## Don't package DLNA/UPnP plugin
137%if !%{enable_DLNA_UPnP}
138%__rm -rf $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/upnp_coherence
139%endif
140
141%find_lang %{name} --all-name --with-gnome
142
143
144# Don't package api docs
145%__rm -rf $RPM_BUILD_ROOT%{_datadir}/gtk-doc/
146
147# And don't package vala
148%__rm -f %{buildroot}%{_libdir}/rhythmbox/plugins/libsample-vala.so \
149        %{buildroot}%{_libdir}/rhythmbox/plugins/sample-vala.rb-plugin
150
151# remove sample plugins
152rm -rf $RPM_BUILD_ROOT/%{_libdir}/%{name}/sample-plugins
153
154%clean
155%__rm -rf $RPM_BUILD_ROOT
156
157%post
158/sbin/ldconfig
159update-desktop-database -q
160touch --no-create %{_datadir}/icons/hicolor
161if [ -x /usr/bin/gtk-update-icon-cache ]; then
162  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
163fi
164
165%postun
166/sbin/ldconfig
167update-desktop-database -q
168touch --no-create %{_datadir}/icons/hicolor
169if [ -x /usr/bin/gtk-update-icon-cache ]; then
170  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
171fi
172glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
173
174%posttrans
175glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
176
177
178%files -f %{name}.lang
179%defattr(-, root, root)
180%doc AUTHORS COPYING ChangeLog README NEWS
181%{_bindir}/*
182%{_libdir}/girepository-1.0/*.typelib
183%{_libdir}/lib*.so.*
184%{_libdir}/mozilla/plugins/librhythmbox-itms-detection-plugin.so
185%{_libdir}/rhythmbox/plugins
186%{_datadir}/applications/rhythmbox.desktop
187%{_datadir}/applications/rhythmbox-device.desktop
188%{_datadir}/dbus-1/services/org.gnome.Rhythmbox3.service
189%{_datadir}/glib-2.0/schemas/org.gnome.rhythmbox.gschema.xml
190%{_datadir}/icons/*
191%{_datadir}/rhythmbox
192%{_mandir}/man1/*
193%{_libexecdir}/rhythmbox-metadata
194
195%files devel
196%defattr(-, root, root)
197%{_includedir}/%{name}/*
198%{_libdir}/*.so
199%{_libdir}/pkgconfig/*.pc
200%{_datadir}/gir-1.0/*.gir
201
202
203%changelog
204* Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.1-2
205- rebuild with VineSeed environment
206
207* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.1-1
208- new upstream release
209
210* Fri Sep 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0-1
211- new upstream release
212- add Patch0 (rhythmbox-3.0-disable-python3.patch)
213
214* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.99.1-1
215- new upstream release
216- add BuildRequies: yelp-tools
217- change BuildRequires: gstreamer1-plugins-base-devel instead of gstreamer-plugins-base-devel
218
219* Sun Mar 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.98-2
220- rebuild with libimobiledevice-1.1.5
221
222* Mon Oct 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.98-1
223- new upstream release
224- add BuildRequires: grilo-devel, libdmapsharing-devel
225
226* Tue Jun 05 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.97-1
227- new upstream release
228
229* Wed Apr 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.96-1
230- new upstream release
231
232* Sat Jan 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.95-1
233- new upstream release
234- add BuildRequires: gtk3-devel, libtdb-devel, pygobject3-devel
235- remove BuildRequires: gnome-vfs2-devel, gstreamer-python-devel, libffi-devel, libgnome-media-profiles-devel, libgnomeui-devel, libsexy-devel, popt-devel, python-devel, pygtk2-devel, sqlite3-devel
236
237* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-4
238- rebuild with cogl-0.8.0
239
240* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-3
241- rebuild with libnotify-0.7
242- change BuildRequires: libmusicbrainz3-devel instead of libmusicbrainz-devel
243- change BuildRequires: libgnome-media-profiles-devel instead of gnome-media-devel
244- add BuildRequires: WebKit3-gtk-devel, libpeas-devel, clutter-gtk-devel, clutter-gst-devel, libmx-devel
245- add Patch0 (rhythmbox-0.13.3-git20110809.patch)
246- add Source101 (rhythmbox-png.tar.bz2)
247
248* Fri Aug 12 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-2
249- add BuildRequires: json-glib-devel
250- remove unrecognized configure option (--with-dbus, --with-cd-burning, --with-metadata-helper)
251
252* Sun Jan 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-1
253- new upstream release
254- change BuildRequires: gstreamer-python-devel instead of gstreamer-python
255
256* Sat Nov 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.2-1
257- new upstream release
258
259* Wed Oct 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-3
260- rebuild with brasero-2.32.0
261
262* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-2
263- rebuild with rpm-4.8.1 for pkg-config file
264
265* Sun Sep 12 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-1
266- new upstream release
267- fix %files (add rhythmbox-device.desktop)
268
269* Sun Aug 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.0-1
270- new upstream release
271- change BuildRequires: gnome-media-devel instead of gnome-media
272- add devel package
273- drop Patch0
274
275* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.8-1
276- new upstream release
277- drop Patch1, Patch2, Patch3
278- change BuildRequires: nautilus-cd-burner -> brasero-devel
279- change Requires: nautilus-cd-burner -> brasero
280- change BuildRequires: hal-devel -> libgudev1-devel
281- change BuildRequires: gnome-keyring-devel -> libgnome-keyring-devel
282- change Requires: gnome-keyring -> libgnome-keyring
283- add configure option (--without-hal)
284
285* Mon Feb 15 2010 Shu KONNO <owa@bg.wakwak.com> 0.12.6-2
286- rebuilt with new environment
287
288* Thu Jan 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.6-1
289- new upstream release
290  - dropped upstreamed/obsolete patches
291  - added patches applied Fedora development
292
293* Sun Oct 04 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.5-1
294- new upstream release
295- added configure options:
296  --disable-vala
297  --disable-browser-plugin
298
299* Thu Jul 30 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.2-2
300- added Japanese description
301
302* Thu Jul 02 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.12.2-1
303- new upstream release
304  - dropped rb-disable-power-plugin-by-default.patch
305- added BuildRequires:
306  - libSM-devel
307  - gnome-media
308
309* Wed Jun 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.12.1-2
310- rebuild with libgpod-0.7.2
311
312* Sun May 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.12.1-1
313- new upstream release
314- corrected License tag
315- dropped rhythmbox-0.11.6-libmtp.patch
316- added BuildRequires:
317  - sqlite3-devel
318  - libffi-devel
319
320* Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.11.6-2
321- defined enable_DLNA_UPnP = 0: unpacked DLNA/UPnP plugin
322- applied rhythmbox-0.11.6-libmtp.patch
323- added Requires:
324  - libgpod
325  - libnotify
326  - libsexy
327  - lirc
328  - libmtp
329  - libgnomeui
330  - nautilus-cd-burner
331  - gstreamer-python
332  - gnome-vfs2
333  - gnome-themes
334  - gnome-keyring
335  - python-Coherence, if enable_DLNA_UPnP = 1
336- added BuildRequires:
337  - libnotify-devel
338  - libsexy-devel
339  - lirc
340  - libmtp-devel
341  - gnome-vfs2-devel, instead of gnome-vfs2
342  - gnome-keyring-devel
343- dropped --with-internal-libsexy in configure options
344- added in configure options:
345  --with-mtp --with-libnautilus-burn --enable-lirc --disable-static
346- added %%preun to remove the schema
347
348* Sun Jan 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.11.6-1
349- new upstream release
350- changed to --with-metadata-helper in configure options
351- added BuildRequires:
352  - gstreamer-python
353  - intltool >= 0.35.0
354  - popt-devel
355
356* Sat Aug 09 2008 Shu KONNO <owa@bg.wakwak.com> 0.11.2-1vl5
357- added BuildRequires: totem-pl-parser-devel, instead of totem-devel
358- rebuilt with python-2.5.2
359- applied new versioning policy
360- spec in utf-8
361
362* Sun Jan 06 2008 Shu KONNO <owa@bg.wakwak.com> 0.11.2-0vl2
363- rebuilt with libgpod-0.6.0
364
365* Sun Aug 26 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.2-0vl1
366- new upstream release
367
368* Wed Jun 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.1-0vl1
369- new upstream release
370
371* Tue May 29 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.10.0-0vl2
372- rebuilt with new toolchain and libgpod-0.4.2
373- add BuildRequires: dbus-glib-devel
374
375* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.0-0vl1
376- new upstream release
377
378* Wed Mar 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8-0vl2
379- rebuilt for VineSeed
380
381* Wed Mar 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8-0vl1
382- new upstream release
383- added --enable-python option to %%configure
384- added Requires: gnome-python
385
386* Sun Jan 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.7-0vl1
387- new upstream release
388- built with libsoup 2.2.99
389
390* Thu Nov 23 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6-0vl4
391- added --with-cd-burner to configure
392- added BuildRequires: libsexy-devel hal-devel libsoup-devel
393
394* Wed Oct 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.6-0vl3
395- add BuildRequires:
396  - gnome-doc-utils >= 0.3.2
397  - python-devel
398  - pygtk2-devel
399  - check >= 0.8.2
400
401* Tue Oct 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.6-0vl2
402- rebuild with gnutls-1.4.1
403
404* Sun Oct  1 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6-0vl1
405- new upstream release
406
407* Mon Jun 19 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.5-0vl1
408- new upstream release
409- run scrollkeeper-update at %post and %postun
410- added BuildRequires: libnotify-devel
411
412* Sun May 14 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.4.1-0vl1
413- new upstream release (dropped patch0)
414- added --without-metadata-helper at configure
415
416* Mon Mar 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.3.1-0vl1
417- Initial build for Vine Linux based on FC pacakge
418
419* Fri Mar 03 2006 Ray Strode <rstrode@redhat.com> - 0.9.3.1-2
420- add patch from James "Doc" Livingston to stop a hang
421  for new users (bug 183883)
422
423* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3.1-1.2
424- bump again for double-long bug on ppc(64)
425
426* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3.1-1.1
427- rebuilt for new gcc4.1 snapshot and glibc changes
428
429* Sat Feb  4 2006 Christopher Aillon <caillon@redhat.com> 0.9.3.1-1
430- Update to 0.9.3.1
431- Use gstreamer (0.10)
432
433* Wed Feb  1 2006 Christopher Aillon <caillon@redhat.com> 0.9.3-2
434- Remove hack for 173869, as its no longer needed.
435
436* Wed Feb  1 2006 Christopher Aillon <caillon@redhat.com> 0.9.3-1
437- 0.9.3
438
439* Wed Feb  1 2006 Christopher Aillon <caillon@redhat.com> 0.9.2.cvs20060201-1
440- Newer CVS snapshot
441
442* Sun Jan 22 2006 Christopher Aillon <caillon@redhat.com> 0.9.2.cvs20060123-1
443- Update to latest CVS
444- Add hack to workaround bug #173869
445
446* Thu Jan 19 2006 Christopher Aillon <caillon@redhat.com> 0.9.2-8
447- Rebuild, now that gstreamer08-plugins has been fixed
448
449* Thu Jan 19 2006 Ray Strode <rstrode@redhat.com> 0.9.2-7
450- bonobo multilib issue (bug 156982)
451
452* Wed Jan 04 2006 John (J5) Palmieri <johnp@redhat.com> 0.9.2-5
453- rebuild with ipod support
454
455* Tue Jan 03 2006 Jesse Keating <jkeating@redhat.com> 0.9.2-4
456- rebuilt again
457
458* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
459- rebuilt
460
461* Mon Dec  5 2005 Matthias Clasen <mclasen@redhat.com>
462- rebuild
463
464* Thu Dec 01 2005 John (J5) Palmieri <johnp@redhat.com>
465- rebuild for new dbus
466
467* Wed Nov 30 2005 Matthias Clasen <mclasen@redhat.com>
468- Update to 0.9.2
469
470* Tue Oct 25 2005 Matthias Clasen <mclasen@redhat.com>
471- Update to 0.9.1
472
473* Fri Sep 02 2005 Colin Walters <walters@redhat.com>
474- Add configure flags --with-bonobo --with-dbus
475- BR nautilus-cd-burner-devel
476- New upstream CVS snapshot for testing
477- Drop IDL file and ui .xml
478- Add dbus service file
479- Drop upstreamed rhythmbox-bluecurve.tar.gz
480- Drop upstreamed rhythmbox-0.8.8-cell-renderer.patch
481
482* Mon Jun 13 2005 Colin Walters <walters@redhat.com> - 0.8.8-3
483- Add Bluecurve-ized icons from Jeff Schroeder (157716)
484- Add rhythmbox-0.8.8-cell-renderer.patch to remove use of custom
485  cell renderer for playback icon (no longer necessary) and
486  changes the rating renderer to work with non-b&w icons
487
488* Mon Mar 14 2005 Colin Walters <walters@redhat.com> - 0.8.8-2
489- Rebuild for GCC4
490
491* Tue Oct 05 2004 Colin Walters <walters@redhat.com> - 0.8.8-1
492- New upstream version
493- Remove librb-nautilus-context-menu.so, killed upstream
494
495* Thu Sep 30 2004 Christopher Aillon <caillon@redhat.com> 0.8.7-2
496- PreReq desktop-file-utils >= 0.9
497
498* Wed Sep 29 2004 Colin Walters <walters@redhat.com> - 0.8.7-1
499- New upstream version
500
501* Sat Sep 18 2004 Colin Walters <walters@redhat.com> - 0.8.6-2
502- Fix postun to use correct syntax, thanks Nils Philippsen
503
504* Sat Sep 18 2004 Colin Walters <walters@redhat.com> - 0.8.6-1
505- New upstream version
506- Call update-desktop-database in post and postun
507
508* Thu Jun 24 2004 Colin Walters <walters@redhat.com> - 0.8.5-1
509- New upstream version
510
511* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
512- rebuilt
513
514* Tue May 18 2004 Colin Walters <walters@redhat.com> - 0.8.4-1
515- New upstream version
516- Remove backported patches
517- Gratuitiously bump various BuildRequires versions
518
519* Mon May 10 2004 Colin Walters <walters@redhat.com> - 0.8.3-4
520- Remove code to unregister GConf schema for now (Closes: #122532)
521
522* Fri May 07 2004 Colin Walters <walters@redhat.com> - 0.8.3-3
523- Apply tiny patch from 0.8 arch to fix GConf key used
524  for initial sorting
525
526* Fri May 07 2004 Colin Walters <walters@redhat.com> - 0.8.3-2
527- Apply patch from 0.8 arch tree to fix a number of memleaks
528
529* Sun May 02 2004 Colin Walters <walters@redhat.com> - 0.8.3-1
530- Update to 0.8.3: fixes showstopper bug with internet radio
531
532* Fri Apr 30 2004 Colin Walters <walters@redhat.com> - 0.8.2-1
533- Update to 0.8.2
534- Fix Source url
535- Add smp_mflags
536- Bump BuildRequires on gstreamer to 0.8.1
537
538* Fri Apr 23 2004 Colin Walters <walters@redhat.com> - 0.8.1-2
539- Uninstall GConf schemas on removal
540
541* Tue Apr 20 2004 Colin Walters <walters@redhat.com> - 0.8.1-1
542- Update to 0.8.1
543
544* Fri Apr 16 2004 Colin Walters <walters@redhat.com> - 0.8.0-1
545- Update to 0.8.0
546
547* Fri Apr 02 2004 Colin Walters <walters@redhat.com> - 0.7.2-1
548- Update to 0.7.2
549
550* Mon Mar 29 2004 Colin Walters <walters@redhat.com> - 0.7.1-2
551- Remove BuildRequires on autoconf and libvorbis-devel
552
553* Mon Mar 29 2004 Colin Walters <walters@redhat.com> - 0.7.1-1
554- New major version - I know we are past major version slush, but
555  this should have been done two weeks ago along with the GNOME 2.6
556  upload.  As upstream author as well, I believe this version is
557  good enough for FC2.
558- Remove --disable-mp3
559- Remove id3, flac variables
560- Remove GStreamer major version patch
561- Fix typo in description
562
563* Tue Mar 16 2004 Jeremy Katz <katzj@redhat.com> - 0.6.8-2
564- rebuild for new gstreamer
565
566* Thu Mar 11 2004 Alex Larsson <alexl@redhat.com> 0.6.8-1
567- update to 0.6.8
568
569* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
570- rebuilt
571
572* Mon Mar  1 2004 Alexander Larsson <alexl@redhat.com> 0.6.7-1
573- update to 0.6.7
574
575* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
576- rebuilt
577
578* Mon Jan 12 2004 Colin Walters <walters@verbum.org> 0.6.4-1
579- New upstream version
580- Don't re-run the autotools; upstream incorporates newer versions.
581* Tue Oct 28 2003 Jonathan Blandford <jrb@redhat.com> 0.5.4-1
582- new version
583- remove smp_flags
584
585* Fri Oct 24 2003 Jonathan Blandford <jrb@redhat.com> 0.5.3-5
586- remove the initial iradio channels as they all are mp3 based.
587
588* Wed Oct  8 2003 Matthias Saou <matthias@rpmforge.net> 0.5.3-3
589- Fix category from Development/Libraries to Applications/Multimedia.
590- Use bz2 instead of gz as ftp.gnome.org has both, 300k saved in the src.rpm.
591- Fix SCHEMES vs. SCHEMAS in the post scriplet.
592- Added gstreamer-plugins-devel, libvorbis-devel, scrollkeeper and gettext deps.
593- Removed unnecessary date expansion define.
594- Updated description, including mp3 reference removal.
595- Added libid3tag and flac optional support for convenient rebuild.
596- Removed obsolete omf.make and xmldocs.make (included ones are the same now).
597
598* Mon Sep 22 2003 Jonathan Blandford <jrb@redhat.com> 0.5.3-1
599- new version
600- use %{_sysconfdir} instead of /etc
601
602* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
603- rebuilt
604
605* Wed Dec 18 2002 Jonathan Blandford <jrb@redhat.com>
606- gave up on other archs for the Beta
607- new version
608- remove werror and add missing files
609
610* Thu Nov  7 2002 Jeremy Katz <katzj@redhat.com>
611- update to newer cvs snap
612
613* Mon Sep 23 2002 Jeremy Katz <katzj@redhat.com>
614- update to cvs snap
615
616* Sun Sep 22 2002 Jeremy Katz <katzj@redhat.com>
617- use %%(lang)
618
619* Sun Aug 11 2002 Jeremy Katz <katzj@redhat.com>
620- fix post to actually install the schema
621
622* Sat Jun 22 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
623- Added gconf file
624- Added i18n directory
625
626* Sat Jun 15 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
627- Updated for new rewrite of rhythmbox, thanks to Jeroen
628
629* Mon Mar 18 2002 Jorn Baayen <jorn@nl.linux.org>
630- removed bonobo dependency
631* Sat Mar 02 2002 Christian Schaller <Uraeus@linuxrising.org>
632- created new spec file
Note: See TracBrowser for help on using the repository browser.