source: projects/specs/trunk/r/rhythmbox/rhythmbox-vl.spec @ 6890

Revision 6890, 19.6 KB checked in by Takemikaduchi, 12 years ago (diff)

GNOME-3.6.0 & Cinnamon-1.6.1

Line 
1# -*- coding: utf-8-unix -*-
2%define desktop_file_utils_version 0.9
3
4%define enable_DLNA_UPnP 0
5
6Summary: Music Management Application
7Summary(ja): 音楽管理アプリケーション
8Name: rhythmbox
9Version: 2.98
10Release: 1%{?_dist_release}
11License: GPL2+ with exceptions and GFDL
12Group: Applications/Multimedia
13URL: http://projects.gnome.org/rhythmbox/
14Source0: http://download.gnome.org/sources/rhythmbox/2.98/%{name}-%{version}.tar.xz
15
16Source101:      rhythmbox-png.tar.bz2
17
18BuildRoot: %{_tmppath}/%{name}-%{version}-root
19BuildRequires: gtk3-devel
20BuildRequires: avahi-glib-devel >= 0.6
21BuildRequires: brasero-devel >= 2.32.0
22BuildRequires: dbus-glib-devel
23BuildRequires: gstreamer-plugins-base-devel >= 0.10
24BuildRequires: json-glib-devel
25BuildRequires: libSM-devel
26BuildRequires: libgnome-keyring-devel >= 2.30.0
27BuildRequires: libgpod-devel
28BuildRequires: libgudev1-devel
29BuildRequires: libmusicbrainz3-devel >= 3.0.2
30BuildRequires: libnotify-devel
31BuildRequires: libsoup-devel
32BuildRequires: pygobject3-devel
33BuildRequires: totem-pl-parser-devel
34BuildRequires: WebKit3-gtk-devel
35BuildRequires: libpeas-devel
36BuildRequires: clutter-gtk-devel
37BuildRequires: clutter-gst-devel
38BuildRequires: libmx-devel
39BuildRequires: check-devel
40BuildRequires: libmtp-devel
41BuildRequires: libtdb-devel
42BuildRequires: grilo-devel
43BuildRequires: libdmapsharing-devel
44BuildRequires: lirc
45BuildRequires: gnome-doc-utils >= 0.3.2
46Requires: libgpod
47Requires: libnotify
48Requires: lirc
49Requires: libmtp
50Requires: brasero
51Requires: gnome-themes
52Requires: libgnome-keyring
53%if %{enable_DLNA_UPnP}
54Requires: python-Coherence
55%endif
56Requires: desktop-file-utils >= %{desktop_file_utils_version}
57Requires: scrollkeeper
58
59# # gstreamer-plugins-ffmpeg and gstreamer-plugins-ugly package provided by
60# # self-build-gstreamer-plugins-ffmpeg and self-build-gstreamer-plugins-ugly,
61# # respectively.
62# Requires: self-build-gstreamer-plugins-ffmpeg
63# Requires: self-build-gstreamer-plugins-ugly
64
65Vendor: Project Vine
66Distribution: Vine Linux
67
68
69%description
70Rhythmbox is an integrated music management application based on the powerful
71GStreamer media framework. It has a number of features, including an easy to
72use music browser, searching and sorting, comprehensive audio format support
73through GStreamer, Internet Radio support, playlists and more.
74
75Rhythmbox is extensible through a plugin system.
76
77%description -l ja
78Rhythmbox は、強力な GStreamer メディアフレームワークに基づいている
79統合音楽管理アプリケーションです。
80見やすいユーザインターフェースを備え、検索や整列ができ、
81GStreamer により数多くの音声フォーマットをサポート、
82インターネットラジオをサポート、プレイリスト管理などの
83数多くの特徴を持ちます。
84
85%package devel
86Summary: Development tools for rhythmbox applications.
87Summary(ja): rhythmbox アプリケーションの開発用ファイル
88Group: Development/Libraries
89Requires: %{name} = %{version}-%{release}
90Requires: pkgconfig
91Requires: libxml2-devel
92Requires: glib2-devel
93Requires: gtk3-devel
94Requires: libsoup-devel
95Requires: totem-pl-parser-devel
96Requires: gstreamer-devel
97
98%description devel
99Header files and libraries for building a extension library for the rhythmbox.
100
101%description devel -l ja
102
103%prep
104%setup -q
105tar xjf %{SOURCE101}
106
107%build
108# work around a gstreamer bug
109/usr/bin/gst-inspect-0.10 --print-all >& /dev/null || :
110
111libtoolize --force --copy
112autoreconf
113%configure --with-ipod \
114    --with-mtp \
115    --with-mdns=avahi \
116    --enable-lirc \
117    --enable-python \
118    --disable-vala \
119    --disable-browser-plugin \
120    --disable-static \
121    --disable-scrollkeeper \
122    --enable-browser-plugin \
123    --without-hal
124%__make %{?_smp_mflags}
125
126%install
127%__rm -rf $RPM_BUILD_ROOT
128%__make install DESTDIR=$RPM_BUILD_ROOT
129
130%__rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/*.{a,la}
131%__rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/librb-nautilus-context-menu.so
132%__rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
133%__rm -f $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*.{a,la}
134%__rm -f $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*/*.{a,la}
135%__rm -f $RPM_BUILD_ROOT%{_libdir}/librhythmbox-core.{a,la}
136%__rm -f $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins/*.{a,la}
137
138## Don't package DLNA/UPnP plugin
139%if !%{enable_DLNA_UPnP}
140%__rm -rf $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/upnp_coherence
141%endif
142
143%find_lang %{name} --all-name --with-gnome
144
145
146# Don't package api docs
147%__rm -rf $RPM_BUILD_ROOT%{_datadir}/gtk-doc/
148
149# Don't package scrollkeeper catalogs
150%__rm -rf $RPM_BUILD_ROOT%{_localstatedir}
151
152# And don't package vala
153%__rm -f %{buildroot}%{_libdir}/rhythmbox/plugins/libsample-vala.so \
154        %{buildroot}%{_libdir}/rhythmbox/plugins/sample-vala.rb-plugin
155
156# remove sample plugins
157rm -rf $RPM_BUILD_ROOT/%{_libdir}/%{name}/sample-plugins
158
159%clean
160%__rm -rf $RPM_BUILD_ROOT
161
162%post
163/sbin/ldconfig
164update-desktop-database -q
165scrollkeeper-update -q
166touch --no-create %{_datadir}/icons/hicolor
167if [ -x /usr/bin/gtk-update-icon-cache ]; then
168  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
169fi
170
171%postun
172/sbin/ldconfig
173update-desktop-database -q
174scrollkeeper-update -q
175touch --no-create %{_datadir}/icons/hicolor
176if [ -x /usr/bin/gtk-update-icon-cache ]; then
177  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
178fi
179glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
180
181%posttrans
182glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
183
184
185%files -f %{name}.lang
186%defattr(-, root, root)
187%doc AUTHORS COPYING ChangeLog README NEWS
188%{_bindir}/*
189%{_libdir}/girepository-1.0/*.typelib
190%{_libdir}/lib*.so.*
191%{_libdir}/mozilla/plugins/librhythmbox-itms-detection-plugin.so
192%{_libdir}/rhythmbox/plugins
193%{_datadir}/applications/rhythmbox.desktop
194%{_datadir}/applications/rhythmbox-device.desktop
195%{_datadir}/dbus-1/services/org.gnome.Rhythmbox3.service
196%{_datadir}/glib-2.0/schemas/org.gnome.rhythmbox.gschema.xml
197%{_datadir}/icons/*
198%{_datadir}/rhythmbox
199%{_mandir}/man1/*
200%{_libexecdir}/rhythmbox-metadata
201
202%files devel
203%defattr(-, root, root)
204%{_includedir}/%{name}/*
205%{_libdir}/*.so
206%{_libdir}/pkgconfig/*.pc
207%{_datadir}/gir-1.0/*.gir
208
209
210%changelog
211* Mon Oct 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.98-1
212- new upstream release
213- add BuildRequires: grilo-devel, libdmapsharing-devel
214
215* Tue Jun 05 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.97-1
216- new upstream release
217
218* Wed Apr 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.96-1
219- new upstream release
220
221* Sat Jan 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.95-1
222- new upstream release
223- add BuildRequires: gtk3-devel, libtdb-devel, pygobject3-devel
224- remove BuildRequires: gnome-vfs2-devel, gstreamer-python-devel, libffi-devel, libgnome-media-profiles-devel, libgnomeui-devel, libsexy-devel, popt-devel, python-devel, pygtk2-devel, sqlite3-devel
225
226* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-4
227- rebuild with cogl-0.8.0
228
229* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-3
230- rebuild with libnotify-0.7
231- change BuildRequires: libmusicbrainz3-devel instead of libmusicbrainz-devel
232- change BuildRequires: libgnome-media-profiles-devel instead of gnome-media-devel
233- add BuildRequires: WebKit3-gtk-devel, libpeas-devel, clutter-gtk-devel, clutter-gst-devel, libmx-devel
234- add Patch0 (rhythmbox-0.13.3-git20110809.patch)
235- add Source101 (rhythmbox-png.tar.bz2)
236
237* Fri Aug 12 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-2
238- add BuildRequires: json-glib-devel
239- remove unrecognized configure option (--with-dbus, --with-cd-burning, --with-metadata-helper)
240
241* Sun Jan 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-1
242- new upstream release
243- change BuildRequires: gstreamer-python-devel instead of gstreamer-python
244
245* Sat Nov 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.2-1
246- new upstream release
247
248* Wed Oct 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-3
249- rebuild with brasero-2.32.0
250
251* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-2
252- rebuild with rpm-4.8.1 for pkg-config file
253
254* Sun Sep 12 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-1
255- new upstream release
256- fix %files (add rhythmbox-device.desktop)
257
258* Sun Aug 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.0-1
259- new upstream release
260- change BuildRequires: gnome-media-devel instead of gnome-media
261- add devel package
262- drop Patch0
263
264* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.8-1
265- new upstream release
266- drop Patch1, Patch2, Patch3
267- change BuildRequires: nautilus-cd-burner -> brasero-devel
268- change Requires: nautilus-cd-burner -> brasero
269- change BuildRequires: hal-devel -> libgudev1-devel
270- change BuildRequires: gnome-keyring-devel -> libgnome-keyring-devel
271- change Requires: gnome-keyring -> libgnome-keyring
272- add configure option (--without-hal)
273
274* Mon Feb 15 2010 Shu KONNO <owa@bg.wakwak.com> 0.12.6-2
275- rebuilt with new environment
276
277* Thu Jan 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.6-1
278- new upstream release
279  - dropped upstreamed/obsolete patches
280  - added patches applied Fedora development
281
282* Sun Oct 04 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.5-1
283- new upstream release
284- added configure options:
285  --disable-vala
286  --disable-browser-plugin
287
288* Thu Jul 30 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.2-2
289- added Japanese description
290
291* Thu Jul 02 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.12.2-1
292- new upstream release
293  - dropped rb-disable-power-plugin-by-default.patch
294- added BuildRequires:
295  - libSM-devel
296  - gnome-media
297
298* Wed Jun 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.12.1-2
299- rebuild with libgpod-0.7.2
300
301* Sun May 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.12.1-1
302- new upstream release
303- corrected License tag
304- dropped rhythmbox-0.11.6-libmtp.patch
305- added BuildRequires:
306  - sqlite3-devel
307  - libffi-devel
308
309* Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.11.6-2
310- defined enable_DLNA_UPnP = 0: unpacked DLNA/UPnP plugin
311- applied rhythmbox-0.11.6-libmtp.patch
312- added Requires:
313  - libgpod
314  - libnotify
315  - libsexy
316  - lirc
317  - libmtp
318  - libgnomeui
319  - nautilus-cd-burner
320  - gstreamer-python
321  - gnome-vfs2
322  - gnome-themes
323  - gnome-keyring
324  - python-Coherence, if enable_DLNA_UPnP = 1
325- added BuildRequires:
326  - libnotify-devel
327  - libsexy-devel
328  - lirc
329  - libmtp-devel
330  - gnome-vfs2-devel, instead of gnome-vfs2
331  - gnome-keyring-devel
332- dropped --with-internal-libsexy in configure options
333- added in configure options:
334  --with-mtp --with-libnautilus-burn --enable-lirc --disable-static
335- added %%preun to remove the schema
336
337* Sun Jan 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.11.6-1
338- new upstream release
339- changed to --with-metadata-helper in configure options
340- added BuildRequires:
341  - gstreamer-python
342  - intltool >= 0.35.0
343  - popt-devel
344
345* Sat Aug 09 2008 Shu KONNO <owa@bg.wakwak.com> 0.11.2-1vl5
346- added BuildRequires: totem-pl-parser-devel, instead of totem-devel
347- rebuilt with python-2.5.2
348- applied new versioning policy
349- spec in utf-8
350
351* Sun Jan 06 2008 Shu KONNO <owa@bg.wakwak.com> 0.11.2-0vl2
352- rebuilt with libgpod-0.6.0
353
354* Sun Aug 26 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.2-0vl1
355- new upstream release
356
357* Wed Jun 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.1-0vl1
358- new upstream release
359
360* Tue May 29 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.10.0-0vl2
361- rebuilt with new toolchain and libgpod-0.4.2
362- add BuildRequires: dbus-glib-devel
363
364* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.0-0vl1
365- new upstream release
366
367* Wed Mar 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8-0vl2
368- rebuilt for VineSeed
369
370* Wed Mar 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8-0vl1
371- new upstream release
372- added --enable-python option to %%configure
373- added Requires: gnome-python
374
375* Sun Jan 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.7-0vl1
376- new upstream release
377- built with libsoup 2.2.99
378
379* Thu Nov 23 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6-0vl4
380- added --with-cd-burner to configure
381- added BuildRequires: libsexy-devel hal-devel libsoup-devel
382
383* Wed Oct 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.6-0vl3
384- add BuildRequires:
385  - gnome-doc-utils >= 0.3.2
386  - python-devel
387  - pygtk2-devel
388  - check >= 0.8.2
389
390* Tue Oct 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.6-0vl2
391- rebuild with gnutls-1.4.1
392
393* Sun Oct  1 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6-0vl1
394- new upstream release
395
396* Mon Jun 19 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.5-0vl1
397- new upstream release
398- run scrollkeeper-update at %post and %postun
399- added BuildRequires: libnotify-devel
400
401* Sun May 14 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.4.1-0vl1
402- new upstream release (dropped patch0)
403- added --without-metadata-helper at configure
404
405* Mon Mar 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.3.1-0vl1
406- Initial build for Vine Linux based on FC pacakge
407
408* Fri Mar 03 2006 Ray Strode <rstrode@redhat.com> - 0.9.3.1-2
409- add patch from James "Doc" Livingston to stop a hang
410  for new users (bug 183883)
411
412* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3.1-1.2
413- bump again for double-long bug on ppc(64)
414
415* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3.1-1.1
416- rebuilt for new gcc4.1 snapshot and glibc changes
417
418* Sat Feb  4 2006 Christopher Aillon <caillon@redhat.com> 0.9.3.1-1
419- Update to 0.9.3.1
420- Use gstreamer (0.10)
421
422* Wed Feb  1 2006 Christopher Aillon <caillon@redhat.com> 0.9.3-2
423- Remove hack for 173869, as its no longer needed.
424
425* Wed Feb  1 2006 Christopher Aillon <caillon@redhat.com> 0.9.3-1
426- 0.9.3
427
428* Wed Feb  1 2006 Christopher Aillon <caillon@redhat.com> 0.9.2.cvs20060201-1
429- Newer CVS snapshot
430
431* Sun Jan 22 2006 Christopher Aillon <caillon@redhat.com> 0.9.2.cvs20060123-1
432- Update to latest CVS
433- Add hack to workaround bug #173869
434
435* Thu Jan 19 2006 Christopher Aillon <caillon@redhat.com> 0.9.2-8
436- Rebuild, now that gstreamer08-plugins has been fixed
437
438* Thu Jan 19 2006 Ray Strode <rstrode@redhat.com> 0.9.2-7
439- bonobo multilib issue (bug 156982)
440
441* Wed Jan 04 2006 John (J5) Palmieri <johnp@redhat.com> 0.9.2-5
442- rebuild with ipod support
443
444* Tue Jan 03 2006 Jesse Keating <jkeating@redhat.com> 0.9.2-4
445- rebuilt again
446
447* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
448- rebuilt
449
450* Mon Dec  5 2005 Matthias Clasen <mclasen@redhat.com>
451- rebuild
452
453* Thu Dec 01 2005 John (J5) Palmieri <johnp@redhat.com>
454- rebuild for new dbus
455
456* Wed Nov 30 2005 Matthias Clasen <mclasen@redhat.com>
457- Update to 0.9.2
458
459* Tue Oct 25 2005 Matthias Clasen <mclasen@redhat.com>
460- Update to 0.9.1
461
462* Fri Sep 02 2005 Colin Walters <walters@redhat.com>
463- Add configure flags --with-bonobo --with-dbus
464- BR nautilus-cd-burner-devel
465- New upstream CVS snapshot for testing
466- Drop IDL file and ui .xml
467- Add dbus service file
468- Drop upstreamed rhythmbox-bluecurve.tar.gz
469- Drop upstreamed rhythmbox-0.8.8-cell-renderer.patch
470
471* Fri Jun 13 2005 Colin Walters <walters@redhat.com> - 0.8.8-3
472- Add Bluecurve-ized icons from Jeff Schroeder (157716)
473- Add rhythmbox-0.8.8-cell-renderer.patch to remove use of custom
474  cell renderer for playback icon (no longer necessary) and
475  changes the rating renderer to work with non-b&w icons
476
477* Mon Mar 14 2005 Colin Walters <walters@redhat.com> - 0.8.8-2
478- Rebuild for GCC4
479
480* Tue Oct 05 2004 Colin Walters <walters@redhat.com> - 0.8.8-1
481- New upstream version
482- Remove librb-nautilus-context-menu.so, killed upstream
483
484* Thu Sep 30 2004 Christopher Aillon <caillon@redhat.com> 0.8.7-2
485- PreReq desktop-file-utils >= 0.9
486
487* Sat Sep 29 2004 Colin Walters <walters@redhat.com> - 0.8.7-1
488- New upstream version
489
490* Sat Sep 18 2004 Colin Walters <walters@redhat.com> - 0.8.6-2
491- Fix postun to use correct syntax, thanks Nils Philippsen
492
493* Sat Sep 18 2004 Colin Walters <walters@redhat.com> - 0.8.6-1
494- New upstream version
495- Call update-desktop-database in post and postun
496
497* Thu Jun 24 2004 Colin Walters <walters@redhat.com> - 0.8.5-1
498- New upstream version
499
500* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
501- rebuilt
502
503* Tue May 18 2004 Colin Walters <walters@redhat.com> - 0.8.4-1
504- New upstream version
505- Remove backported patches
506- Gratuitiously bump various BuildRequires versions
507
508* Mon May 10 2004 Colin Walters <walters@redhat.com> - 0.8.3-4
509- Remove code to unregister GConf schema for now (Closes: #122532)
510
511* Thu May 07 2004 Colin Walters <walters@redhat.com> - 0.8.3-3
512- Apply tiny patch from 0.8 arch to fix GConf key used
513  for initial sorting
514
515* Thu May 07 2004 Colin Walters <walters@redhat.com> - 0.8.3-2
516- Apply patch from 0.8 arch tree to fix a number of memleaks
517
518* Thu May 02 2004 Colin Walters <walters@redhat.com> - 0.8.3-1
519- Update to 0.8.3: fixes showstopper bug with internet radio
520
521* Thu Apr 30 2004 Colin Walters <walters@redhat.com> - 0.8.2-1
522- Update to 0.8.2
523- Fix Source url
524- Add smp_mflags
525- Bump BuildRequires on gstreamer to 0.8.1
526
527* Tue Apr 23 2004 Colin Walters <walters@redhat.com> - 0.8.1-2
528- Uninstall GConf schemas on removal
529
530* Tue Apr 20 2004 Colin Walters <walters@redhat.com> - 0.8.1-1
531- Update to 0.8.1
532
533* Fri Apr 16 2004 Colin Walters <walters@redhat.com> - 0.8.0-1
534- Update to 0.8.0
535
536* Fri Apr 02 2004 Colin Walters <walters@redhat.com> - 0.7.2-1
537- Update to 0.7.2
538
539* Mon Mar 29 2004 Colin Walters <walters@redhat.com> - 0.7.1-2
540- Remove BuildRequires on autoconf and libvorbis-devel
541
542* Mon Mar 29 2004 Colin Walters <walters@redhat.com> - 0.7.1-1
543- New major version - I know we are past major version slush, but
544  this should have been done two weeks ago along with the GNOME 2.6
545  upload.  As upstream author as well, I believe this version is
546  good enough for FC2.
547- Remove --disable-mp3
548- Remove id3, flac variables
549- Remove GStreamer major version patch
550- Fix typo in description
551
552* Tue Mar 16 2004 Jeremy Katz <katzj@redhat.com> - 0.6.8-2
553- rebuild for new gstreamer
554
555* Thu Mar 11 2004 Alex Larsson <alexl@redhat.com> 0.6.8-1
556- update to 0.6.8
557
558* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
559- rebuilt
560
561* Mon Mar  1 2004 Alexander Larsson <alexl@redhat.com> 0.6.7-1
562- update to 0.6.7
563
564* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
565- rebuilt
566
567* Mon Jan 12 2004 Colin Walters <walters@verbum.org> 0.6.4-1
568- New upstream version
569- Don't re-run the autotools; upstream incorporates newer versions.
570* Tue Oct 28 2003 Jonathan Blandford <jrb@redhat.com> 0.5.4-1
571- new version
572- remove smp_flags
573
574* Fri Oct 24 2003 Jonathan Blandford <jrb@redhat.com> 0.5.3-5
575- remove the initial iradio channels as they all are mp3 based.
576
577* Wed Oct  8 2003 Matthias Saou <matthias@rpmforge.net> 0.5.3-3
578- Fix category from Development/Libraries to Applications/Multimedia.
579- Use bz2 instead of gz as ftp.gnome.org has both, 300k saved in the src.rpm.
580- Fix SCHEMES vs. SCHEMAS in the post scriplet.
581- Added gstreamer-plugins-devel, libvorbis-devel, scrollkeeper and gettext deps.
582- Removed unnecessary date expansion define.
583- Updated description, including mp3 reference removal.
584- Added libid3tag and flac optional support for convenient rebuild.
585- Removed obsolete omf.make and xmldocs.make (included ones are the same now).
586
587* Mon Sep 22 2003 Jonathan Blandford <jrb@redhat.com> 0.5.3-1
588- new version
589- use %{_sysconfdir} instead of /etc
590
591* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
592- rebuilt
593
594* Wed Dec 18 2002 Jonathan Blandford <jrb@redhat.com>
595- gave up on other archs for the Beta
596- new version
597- remove werror and add missing files
598
599* Thu Nov  7 2002 Jeremy Katz <katzj@redhat.com>
600- update to newer cvs snap
601
602* Mon Sep 23 2002 Jeremy Katz <katzj@redhat.com>
603- update to cvs snap
604
605* Sun Sep 22 2002 Jeremy Katz <katzj@redhat.com>
606- use %%(lang)
607
608* Sun Aug 11 2002 Jeremy Katz <katzj@redhat.com>
609- fix post to actually install the schema
610
611* Sat Jun 22 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
612- Added gconf file
613- Added i18n directory
614
615* Sat Jun 15 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
616- Updated for new rewrite of rhythmbox, thanks to Jeroen
617
618* Mon Mar 18 2002 Jorn Baayen <jorn@nl.linux.org>
619- removed bonobo dependency
620* Sat Mar 02 2002 Christian Schaller <Uraeus@linuxrising.org>
621- created new spec file
Note: See TracBrowser for help on using the repository browser.