source: projects/specs/trunk/r/rhythmbox/rhythmbox-vl.spec @ 7582

Revision 7582, 19.7 KB checked in by Takemikaduchi, 11 years ago (diff)

Cython,gparted,gstreamer1,libimobiledevice,libplist,thunderbird,udisks2,upower: new upstream release
others: rebuild with libimobiledevice-1.1.5

Line 
1# -*- coding: utf-8-unix -*-
2%define desktop_file_utils_version 0.9
3
4%define enable_DLNA_UPnP 0
5
6Summary: Music Management Application
7Summary(ja): 音楽管理アプリケーション
8Name: rhythmbox
9Version: 2.98
10Release: 2%{?_dist_release}
11License: GPL2+ with exceptions and GFDL
12Group: Applications/Multimedia
13URL: http://projects.gnome.org/rhythmbox/
14Source0: http://download.gnome.org/sources/rhythmbox/2.98/%{name}-%{version}.tar.xz
15
16Source101:      rhythmbox-png.tar.bz2
17
18BuildRoot: %{_tmppath}/%{name}-%{version}-root
19BuildRequires: gtk3-devel
20BuildRequires: avahi-glib-devel >= 0.6
21BuildRequires: brasero-devel >= 2.32.0
22BuildRequires: dbus-glib-devel
23BuildRequires: gstreamer-plugins-base-devel >= 0.10
24BuildRequires: json-glib-devel
25BuildRequires: libSM-devel
26BuildRequires: libgnome-keyring-devel >= 2.30.0
27BuildRequires: libgpod-devel
28BuildRequires: libgudev1-devel
29BuildRequires: libmusicbrainz3-devel >= 3.0.2
30BuildRequires: libnotify-devel
31BuildRequires: libsoup-devel
32BuildRequires: pygobject3-devel
33BuildRequires: totem-pl-parser-devel
34BuildRequires: WebKit3-gtk-devel
35BuildRequires: libpeas-devel
36BuildRequires: clutter-gtk-devel
37BuildRequires: clutter-gst-devel
38BuildRequires: libmx-devel
39BuildRequires: check-devel
40BuildRequires: libmtp-devel
41BuildRequires: libtdb-devel
42BuildRequires: grilo-devel
43BuildRequires: libdmapsharing-devel
44BuildRequires: lirc
45BuildRequires: gnome-doc-utils >= 0.3.2
46Requires: libgpod
47Requires: libnotify
48Requires: lirc
49Requires: libmtp
50Requires: brasero
51Requires: gnome-themes
52Requires: libgnome-keyring
53%if %{enable_DLNA_UPnP}
54Requires: python-Coherence
55%endif
56Requires: desktop-file-utils >= %{desktop_file_utils_version}
57Requires: scrollkeeper
58
59# # gstreamer-plugins-ffmpeg and gstreamer-plugins-ugly package provided by
60# # self-build-gstreamer-plugins-ffmpeg and self-build-gstreamer-plugins-ugly,
61# # respectively.
62# Requires: self-build-gstreamer-plugins-ffmpeg
63# Requires: self-build-gstreamer-plugins-ugly
64
65Vendor: Project Vine
66Distribution: Vine Linux
67
68
69%description
70Rhythmbox is an integrated music management application based on the powerful
71GStreamer media framework. It has a number of features, including an easy to
72use music browser, searching and sorting, comprehensive audio format support
73through GStreamer, Internet Radio support, playlists and more.
74
75Rhythmbox is extensible through a plugin system.
76
77%description -l ja
78Rhythmbox は、強力な GStreamer メディアフレームワークに基づいている
79統合音楽管理アプリケーションです。
80見やすいユーザインターフェースを備え、検索や整列ができ、
81GStreamer により数多くの音声フォーマットをサポート、
82インターネットラジオをサポート、プレイリスト管理などの
83数多くの特徴を持ちます。
84
85%package devel
86Summary: Development tools for rhythmbox applications.
87Summary(ja): rhythmbox アプリケーションの開発用ファイル
88Group: Development/Libraries
89Requires: %{name} = %{version}-%{release}
90Requires: pkgconfig
91Requires: libxml2-devel
92Requires: glib2-devel
93Requires: gtk3-devel
94Requires: libsoup-devel
95Requires: totem-pl-parser-devel
96Requires: gstreamer-devel
97
98%description devel
99Header files and libraries for building a extension library for the rhythmbox.
100
101%description devel -l ja
102
103%prep
104%setup -q
105tar xjf %{SOURCE101}
106
107%build
108# work around a gstreamer bug
109/usr/bin/gst-inspect-0.10 --print-all >& /dev/null || :
110
111libtoolize --force --copy
112autoreconf
113%configure --with-ipod \
114    --with-mtp \
115    --with-mdns=avahi \
116    --enable-lirc \
117    --enable-python \
118    --disable-vala \
119    --disable-browser-plugin \
120    --disable-static \
121    --disable-scrollkeeper \
122    --enable-browser-plugin \
123    --without-hal
124%__make %{?_smp_mflags}
125
126%install
127%__rm -rf $RPM_BUILD_ROOT
128%__make install DESTDIR=$RPM_BUILD_ROOT
129
130%__rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/*.{a,la}
131%__rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/librb-nautilus-context-menu.so
132%__rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
133%__rm -f $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*.{a,la}
134%__rm -f $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*/*.{a,la}
135%__rm -f $RPM_BUILD_ROOT%{_libdir}/librhythmbox-core.{a,la}
136%__rm -f $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins/*.{a,la}
137
138## Don't package DLNA/UPnP plugin
139%if !%{enable_DLNA_UPnP}
140%__rm -rf $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/upnp_coherence
141%endif
142
143%find_lang %{name} --all-name --with-gnome
144
145
146# Don't package api docs
147%__rm -rf $RPM_BUILD_ROOT%{_datadir}/gtk-doc/
148
149# Don't package scrollkeeper catalogs
150%__rm -rf $RPM_BUILD_ROOT%{_localstatedir}
151
152# And don't package vala
153%__rm -f %{buildroot}%{_libdir}/rhythmbox/plugins/libsample-vala.so \
154        %{buildroot}%{_libdir}/rhythmbox/plugins/sample-vala.rb-plugin
155
156# remove sample plugins
157rm -rf $RPM_BUILD_ROOT/%{_libdir}/%{name}/sample-plugins
158
159%clean
160%__rm -rf $RPM_BUILD_ROOT
161
162%post
163/sbin/ldconfig
164update-desktop-database -q
165scrollkeeper-update -q
166touch --no-create %{_datadir}/icons/hicolor
167if [ -x /usr/bin/gtk-update-icon-cache ]; then
168  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
169fi
170
171%postun
172/sbin/ldconfig
173update-desktop-database -q
174scrollkeeper-update -q
175touch --no-create %{_datadir}/icons/hicolor
176if [ -x /usr/bin/gtk-update-icon-cache ]; then
177  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
178fi
179glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
180
181%posttrans
182glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
183
184
185%files -f %{name}.lang
186%defattr(-, root, root)
187%doc AUTHORS COPYING ChangeLog README NEWS
188%{_bindir}/*
189%{_libdir}/girepository-1.0/*.typelib
190%{_libdir}/lib*.so.*
191%{_libdir}/mozilla/plugins/librhythmbox-itms-detection-plugin.so
192%{_libdir}/rhythmbox/plugins
193%{_datadir}/applications/rhythmbox.desktop
194%{_datadir}/applications/rhythmbox-device.desktop
195%{_datadir}/dbus-1/services/org.gnome.Rhythmbox3.service
196%{_datadir}/glib-2.0/schemas/org.gnome.rhythmbox.gschema.xml
197%{_datadir}/icons/*
198%{_datadir}/rhythmbox
199%{_mandir}/man1/*
200%{_libexecdir}/rhythmbox-metadata
201
202%files devel
203%defattr(-, root, root)
204%{_includedir}/%{name}/*
205%{_libdir}/*.so
206%{_libdir}/pkgconfig/*.pc
207%{_datadir}/gir-1.0/*.gir
208
209
210%changelog
211* Sun Mar 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.98-2
212- rebuild with libimobiledevice-1.1.5
213
214* Mon Oct 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.98-1
215- new upstream release
216- add BuildRequires: grilo-devel, libdmapsharing-devel
217
218* Tue Jun 05 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.97-1
219- new upstream release
220
221* Wed Apr 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.96-1
222- new upstream release
223
224* Sat Jan 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.95-1
225- new upstream release
226- add BuildRequires: gtk3-devel, libtdb-devel, pygobject3-devel
227- remove BuildRequires: gnome-vfs2-devel, gstreamer-python-devel, libffi-devel, libgnome-media-profiles-devel, libgnomeui-devel, libsexy-devel, popt-devel, python-devel, pygtk2-devel, sqlite3-devel
228
229* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-4
230- rebuild with cogl-0.8.0
231
232* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-3
233- rebuild with libnotify-0.7
234- change BuildRequires: libmusicbrainz3-devel instead of libmusicbrainz-devel
235- change BuildRequires: libgnome-media-profiles-devel instead of gnome-media-devel
236- add BuildRequires: WebKit3-gtk-devel, libpeas-devel, clutter-gtk-devel, clutter-gst-devel, libmx-devel
237- add Patch0 (rhythmbox-0.13.3-git20110809.patch)
238- add Source101 (rhythmbox-png.tar.bz2)
239
240* Fri Aug 12 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-2
241- add BuildRequires: json-glib-devel
242- remove unrecognized configure option (--with-dbus, --with-cd-burning, --with-metadata-helper)
243
244* Sun Jan 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-1
245- new upstream release
246- change BuildRequires: gstreamer-python-devel instead of gstreamer-python
247
248* Sat Nov 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.2-1
249- new upstream release
250
251* Wed Oct 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-3
252- rebuild with brasero-2.32.0
253
254* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-2
255- rebuild with rpm-4.8.1 for pkg-config file
256
257* Sun Sep 12 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-1
258- new upstream release
259- fix %files (add rhythmbox-device.desktop)
260
261* Sun Aug 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.0-1
262- new upstream release
263- change BuildRequires: gnome-media-devel instead of gnome-media
264- add devel package
265- drop Patch0
266
267* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.8-1
268- new upstream release
269- drop Patch1, Patch2, Patch3
270- change BuildRequires: nautilus-cd-burner -> brasero-devel
271- change Requires: nautilus-cd-burner -> brasero
272- change BuildRequires: hal-devel -> libgudev1-devel
273- change BuildRequires: gnome-keyring-devel -> libgnome-keyring-devel
274- change Requires: gnome-keyring -> libgnome-keyring
275- add configure option (--without-hal)
276
277* Mon Feb 15 2010 Shu KONNO <owa@bg.wakwak.com> 0.12.6-2
278- rebuilt with new environment
279
280* Thu Jan 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.6-1
281- new upstream release
282  - dropped upstreamed/obsolete patches
283  - added patches applied Fedora development
284
285* Sun Oct 04 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.5-1
286- new upstream release
287- added configure options:
288  --disable-vala
289  --disable-browser-plugin
290
291* Thu Jul 30 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.2-2
292- added Japanese description
293
294* Thu Jul 02 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.12.2-1
295- new upstream release
296  - dropped rb-disable-power-plugin-by-default.patch
297- added BuildRequires:
298  - libSM-devel
299  - gnome-media
300
301* Wed Jun 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.12.1-2
302- rebuild with libgpod-0.7.2
303
304* Sun May 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.12.1-1
305- new upstream release
306- corrected License tag
307- dropped rhythmbox-0.11.6-libmtp.patch
308- added BuildRequires:
309  - sqlite3-devel
310  - libffi-devel
311
312* Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.11.6-2
313- defined enable_DLNA_UPnP = 0: unpacked DLNA/UPnP plugin
314- applied rhythmbox-0.11.6-libmtp.patch
315- added Requires:
316  - libgpod
317  - libnotify
318  - libsexy
319  - lirc
320  - libmtp
321  - libgnomeui
322  - nautilus-cd-burner
323  - gstreamer-python
324  - gnome-vfs2
325  - gnome-themes
326  - gnome-keyring
327  - python-Coherence, if enable_DLNA_UPnP = 1
328- added BuildRequires:
329  - libnotify-devel
330  - libsexy-devel
331  - lirc
332  - libmtp-devel
333  - gnome-vfs2-devel, instead of gnome-vfs2
334  - gnome-keyring-devel
335- dropped --with-internal-libsexy in configure options
336- added in configure options:
337  --with-mtp --with-libnautilus-burn --enable-lirc --disable-static
338- added %%preun to remove the schema
339
340* Sun Jan 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.11.6-1
341- new upstream release
342- changed to --with-metadata-helper in configure options
343- added BuildRequires:
344  - gstreamer-python
345  - intltool >= 0.35.0
346  - popt-devel
347
348* Sat Aug 09 2008 Shu KONNO <owa@bg.wakwak.com> 0.11.2-1vl5
349- added BuildRequires: totem-pl-parser-devel, instead of totem-devel
350- rebuilt with python-2.5.2
351- applied new versioning policy
352- spec in utf-8
353
354* Sun Jan 06 2008 Shu KONNO <owa@bg.wakwak.com> 0.11.2-0vl2
355- rebuilt with libgpod-0.6.0
356
357* Sun Aug 26 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.2-0vl1
358- new upstream release
359
360* Wed Jun 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.1-0vl1
361- new upstream release
362
363* Tue May 29 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.10.0-0vl2
364- rebuilt with new toolchain and libgpod-0.4.2
365- add BuildRequires: dbus-glib-devel
366
367* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.0-0vl1
368- new upstream release
369
370* Wed Mar 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8-0vl2
371- rebuilt for VineSeed
372
373* Wed Mar 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8-0vl1
374- new upstream release
375- added --enable-python option to %%configure
376- added Requires: gnome-python
377
378* Sun Jan 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.7-0vl1
379- new upstream release
380- built with libsoup 2.2.99
381
382* Thu Nov 23 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6-0vl4
383- added --with-cd-burner to configure
384- added BuildRequires: libsexy-devel hal-devel libsoup-devel
385
386* Wed Oct 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.6-0vl3
387- add BuildRequires:
388  - gnome-doc-utils >= 0.3.2
389  - python-devel
390  - pygtk2-devel
391  - check >= 0.8.2
392
393* Tue Oct 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.6-0vl2
394- rebuild with gnutls-1.4.1
395
396* Sun Oct  1 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6-0vl1
397- new upstream release
398
399* Mon Jun 19 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.5-0vl1
400- new upstream release
401- run scrollkeeper-update at %post and %postun
402- added BuildRequires: libnotify-devel
403
404* Sun May 14 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.4.1-0vl1
405- new upstream release (dropped patch0)
406- added --without-metadata-helper at configure
407
408* Mon Mar 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.3.1-0vl1
409- Initial build for Vine Linux based on FC pacakge
410
411* Fri Mar 03 2006 Ray Strode <rstrode@redhat.com> - 0.9.3.1-2
412- add patch from James "Doc" Livingston to stop a hang
413  for new users (bug 183883)
414
415* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3.1-1.2
416- bump again for double-long bug on ppc(64)
417
418* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3.1-1.1
419- rebuilt for new gcc4.1 snapshot and glibc changes
420
421* Sat Feb  4 2006 Christopher Aillon <caillon@redhat.com> 0.9.3.1-1
422- Update to 0.9.3.1
423- Use gstreamer (0.10)
424
425* Wed Feb  1 2006 Christopher Aillon <caillon@redhat.com> 0.9.3-2
426- Remove hack for 173869, as its no longer needed.
427
428* Wed Feb  1 2006 Christopher Aillon <caillon@redhat.com> 0.9.3-1
429- 0.9.3
430
431* Wed Feb  1 2006 Christopher Aillon <caillon@redhat.com> 0.9.2.cvs20060201-1
432- Newer CVS snapshot
433
434* Sun Jan 22 2006 Christopher Aillon <caillon@redhat.com> 0.9.2.cvs20060123-1
435- Update to latest CVS
436- Add hack to workaround bug #173869
437
438* Thu Jan 19 2006 Christopher Aillon <caillon@redhat.com> 0.9.2-8
439- Rebuild, now that gstreamer08-plugins has been fixed
440
441* Thu Jan 19 2006 Ray Strode <rstrode@redhat.com> 0.9.2-7
442- bonobo multilib issue (bug 156982)
443
444* Wed Jan 04 2006 John (J5) Palmieri <johnp@redhat.com> 0.9.2-5
445- rebuild with ipod support
446
447* Tue Jan 03 2006 Jesse Keating <jkeating@redhat.com> 0.9.2-4
448- rebuilt again
449
450* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
451- rebuilt
452
453* Mon Dec  5 2005 Matthias Clasen <mclasen@redhat.com>
454- rebuild
455
456* Thu Dec 01 2005 John (J5) Palmieri <johnp@redhat.com>
457- rebuild for new dbus
458
459* Wed Nov 30 2005 Matthias Clasen <mclasen@redhat.com>
460- Update to 0.9.2
461
462* Tue Oct 25 2005 Matthias Clasen <mclasen@redhat.com>
463- Update to 0.9.1
464
465* Fri Sep 02 2005 Colin Walters <walters@redhat.com>
466- Add configure flags --with-bonobo --with-dbus
467- BR nautilus-cd-burner-devel
468- New upstream CVS snapshot for testing
469- Drop IDL file and ui .xml
470- Add dbus service file
471- Drop upstreamed rhythmbox-bluecurve.tar.gz
472- Drop upstreamed rhythmbox-0.8.8-cell-renderer.patch
473
474* Fri Jun 13 2005 Colin Walters <walters@redhat.com> - 0.8.8-3
475- Add Bluecurve-ized icons from Jeff Schroeder (157716)
476- Add rhythmbox-0.8.8-cell-renderer.patch to remove use of custom
477  cell renderer for playback icon (no longer necessary) and
478  changes the rating renderer to work with non-b&w icons
479
480* Mon Mar 14 2005 Colin Walters <walters@redhat.com> - 0.8.8-2
481- Rebuild for GCC4
482
483* Tue Oct 05 2004 Colin Walters <walters@redhat.com> - 0.8.8-1
484- New upstream version
485- Remove librb-nautilus-context-menu.so, killed upstream
486
487* Thu Sep 30 2004 Christopher Aillon <caillon@redhat.com> 0.8.7-2
488- PreReq desktop-file-utils >= 0.9
489
490* Sat Sep 29 2004 Colin Walters <walters@redhat.com> - 0.8.7-1
491- New upstream version
492
493* Sat Sep 18 2004 Colin Walters <walters@redhat.com> - 0.8.6-2
494- Fix postun to use correct syntax, thanks Nils Philippsen
495
496* Sat Sep 18 2004 Colin Walters <walters@redhat.com> - 0.8.6-1
497- New upstream version
498- Call update-desktop-database in post and postun
499
500* Thu Jun 24 2004 Colin Walters <walters@redhat.com> - 0.8.5-1
501- New upstream version
502
503* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
504- rebuilt
505
506* Tue May 18 2004 Colin Walters <walters@redhat.com> - 0.8.4-1
507- New upstream version
508- Remove backported patches
509- Gratuitiously bump various BuildRequires versions
510
511* Mon May 10 2004 Colin Walters <walters@redhat.com> - 0.8.3-4
512- Remove code to unregister GConf schema for now (Closes: #122532)
513
514* Thu May 07 2004 Colin Walters <walters@redhat.com> - 0.8.3-3
515- Apply tiny patch from 0.8 arch to fix GConf key used
516  for initial sorting
517
518* Thu May 07 2004 Colin Walters <walters@redhat.com> - 0.8.3-2
519- Apply patch from 0.8 arch tree to fix a number of memleaks
520
521* Thu May 02 2004 Colin Walters <walters@redhat.com> - 0.8.3-1
522- Update to 0.8.3: fixes showstopper bug with internet radio
523
524* Thu Apr 30 2004 Colin Walters <walters@redhat.com> - 0.8.2-1
525- Update to 0.8.2
526- Fix Source url
527- Add smp_mflags
528- Bump BuildRequires on gstreamer to 0.8.1
529
530* Tue Apr 23 2004 Colin Walters <walters@redhat.com> - 0.8.1-2
531- Uninstall GConf schemas on removal
532
533* Tue Apr 20 2004 Colin Walters <walters@redhat.com> - 0.8.1-1
534- Update to 0.8.1
535
536* Fri Apr 16 2004 Colin Walters <walters@redhat.com> - 0.8.0-1
537- Update to 0.8.0
538
539* Fri Apr 02 2004 Colin Walters <walters@redhat.com> - 0.7.2-1
540- Update to 0.7.2
541
542* Mon Mar 29 2004 Colin Walters <walters@redhat.com> - 0.7.1-2
543- Remove BuildRequires on autoconf and libvorbis-devel
544
545* Mon Mar 29 2004 Colin Walters <walters@redhat.com> - 0.7.1-1
546- New major version - I know we are past major version slush, but
547  this should have been done two weeks ago along with the GNOME 2.6
548  upload.  As upstream author as well, I believe this version is
549  good enough for FC2.
550- Remove --disable-mp3
551- Remove id3, flac variables
552- Remove GStreamer major version patch
553- Fix typo in description
554
555* Tue Mar 16 2004 Jeremy Katz <katzj@redhat.com> - 0.6.8-2
556- rebuild for new gstreamer
557
558* Thu Mar 11 2004 Alex Larsson <alexl@redhat.com> 0.6.8-1
559- update to 0.6.8
560
561* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
562- rebuilt
563
564* Mon Mar  1 2004 Alexander Larsson <alexl@redhat.com> 0.6.7-1
565- update to 0.6.7
566
567* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
568- rebuilt
569
570* Mon Jan 12 2004 Colin Walters <walters@verbum.org> 0.6.4-1
571- New upstream version
572- Don't re-run the autotools; upstream incorporates newer versions.
573* Tue Oct 28 2003 Jonathan Blandford <jrb@redhat.com> 0.5.4-1
574- new version
575- remove smp_flags
576
577* Fri Oct 24 2003 Jonathan Blandford <jrb@redhat.com> 0.5.3-5
578- remove the initial iradio channels as they all are mp3 based.
579
580* Wed Oct  8 2003 Matthias Saou <matthias@rpmforge.net> 0.5.3-3
581- Fix category from Development/Libraries to Applications/Multimedia.
582- Use bz2 instead of gz as ftp.gnome.org has both, 300k saved in the src.rpm.
583- Fix SCHEMES vs. SCHEMAS in the post scriplet.
584- Added gstreamer-plugins-devel, libvorbis-devel, scrollkeeper and gettext deps.
585- Removed unnecessary date expansion define.
586- Updated description, including mp3 reference removal.
587- Added libid3tag and flac optional support for convenient rebuild.
588- Removed obsolete omf.make and xmldocs.make (included ones are the same now).
589
590* Mon Sep 22 2003 Jonathan Blandford <jrb@redhat.com> 0.5.3-1
591- new version
592- use %{_sysconfdir} instead of /etc
593
594* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
595- rebuilt
596
597* Wed Dec 18 2002 Jonathan Blandford <jrb@redhat.com>
598- gave up on other archs for the Beta
599- new version
600- remove werror and add missing files
601
602* Thu Nov  7 2002 Jeremy Katz <katzj@redhat.com>
603- update to newer cvs snap
604
605* Mon Sep 23 2002 Jeremy Katz <katzj@redhat.com>
606- update to cvs snap
607
608* Sun Sep 22 2002 Jeremy Katz <katzj@redhat.com>
609- use %%(lang)
610
611* Sun Aug 11 2002 Jeremy Katz <katzj@redhat.com>
612- fix post to actually install the schema
613
614* Sat Jun 22 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
615- Added gconf file
616- Added i18n directory
617
618* Sat Jun 15 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
619- Updated for new rewrite of rhythmbox, thanks to Jeroen
620
621* Mon Mar 18 2002 Jorn Baayen <jorn@nl.linux.org>
622- removed bonobo dependency
623* Sat Mar 02 2002 Christian Schaller <Uraeus@linuxrising.org>
624- created new spec file
Note: See TracBrowser for help on using the repository browser.