source: projects/specs/trunk/r/rhythmbox/rhythmbox-vl.spec @ 5448

Revision 5448, 19.7 KB checked in by Takemikaduchi, 12 years ago (diff)

new upstream release

Line 
1# -*- coding: utf-8-unix -*-
2%define desktop_file_utils_version 0.9
3
4%define enable_DLNA_UPnP 0
5
6Summary: Music Management Application
7Summary(ja): 音楽管理アプリケーション
8Name: rhythmbox
9Version: 2.95
10Release: 1%{?_dist_release}
11License: GPL2+ with exceptions and GFDL
12Group: Applications/Multimedia
13URL: http://projects.gnome.org/rhythmbox/
14Source0: http://download.gnome.org/sources/rhythmbox/0.13/%{name}-%{version}.tar.xz
15
16Source101:      rhythmbox-png.tar.bz2
17
18BuildRoot: %{_tmppath}/%{name}-%{version}-root
19BuildRequires: gtk3-devel
20BuildRequires: avahi-glib-devel >= 0.6
21BuildRequires: brasero-devel >= 2.32.0
22BuildRequires: dbus-glib-devel
23BuildRequires: gstreamer-plugins-base-devel >= 0.10
24BuildRequires: json-glib-devel
25BuildRequires: libSM-devel
26BuildRequires: libgnome-keyring-devel >= 2.30.0
27BuildRequires: libgpod-devel
28BuildRequires: libgudev1-devel
29BuildRequires: libmusicbrainz3-devel >= 3.0.2
30BuildRequires: libnotify-devel
31BuildRequires: libsoup-devel
32BuildRequires: pygobject3-devel
33BuildRequires: totem-pl-parser-devel
34BuildRequires: WebKit3-gtk-devel
35BuildRequires: libpeas-devel
36BuildRequires: clutter-gtk-devel
37BuildRequires: clutter-gst-devel
38BuildRequires: libmx-devel
39BuildRequires: check-devel
40BuildRequires: libmtp-devel
41BuildRequires: libtdb-devel
42BuildRequires: lirc
43BuildRequires: gnome-doc-utils >= 0.3.2
44Requires: libgpod
45Requires: libnotify
46Requires: lirc
47Requires: libmtp
48Requires: brasero
49Requires: gnome-themes
50Requires: libgnome-keyring
51%if %{enable_DLNA_UPnP}
52Requires: python-Coherence
53%endif
54Requires: desktop-file-utils >= %{desktop_file_utils_version}
55Requires: scrollkeeper
56
57# # gstreamer-plugins-ffmpeg and gstreamer-plugins-ugly package provided by
58# # self-build-gstreamer-plugins-ffmpeg and self-build-gstreamer-plugins-ugly,
59# # respectively.
60# Requires: self-build-gstreamer-plugins-ffmpeg
61# Requires: self-build-gstreamer-plugins-ugly
62
63Vendor: Project Vine
64Distribution: Vine Linux
65
66
67%description
68Rhythmbox is an integrated music management application based on the powerful
69GStreamer media framework. It has a number of features, including an easy to
70use music browser, searching and sorting, comprehensive audio format support
71through GStreamer, Internet Radio support, playlists and more.
72
73Rhythmbox is extensible through a plugin system.
74
75%description -l ja
76Rhythmbox は、強力な GStreamer メディアフレームワークに基づいている
77統合音楽管理アプリケーションです。
78見やすいユーザインターフェースを備え、検索や整列ができ、
79GStreamer により数多くの音声フォーマットをサポート、
80インターネットラジオをサポート、プレイリスト管理などの
81数多くの特徴を持ちます。
82
83%package devel
84Summary: Development tools for rhythmbox applications.
85Summary(ja): rhythmbox アプリケーションの開発用ファイル
86Group: Development/Libraries
87Requires: %{name} = %{version}-%{release}
88Requires: pkgconfig
89Requires: libxml2-devel
90Requires: glib2-devel
91Requires: gtk3-devel
92Requires: libsoup-devel
93Requires: totem-pl-parser-devel
94Requires: gstreamer-devel
95
96%description devel
97Header files and libraries for building a extension library for the rhythmbox.
98
99%description devel -l ja
100
101%prep
102%setup -q
103tar xjf %{SOURCE101}
104
105%build
106# work around a gstreamer bug
107/usr/bin/gst-inspect-0.10 --print-all >& /dev/null || :
108
109libtoolize --force --copy
110autoreconf
111%configure --with-ipod \
112    --with-mtp \
113    --with-mdns=avahi \
114    --enable-lirc \
115    --enable-python \
116    --disable-vala \
117    --disable-browser-plugin \
118    --disable-static \
119    --disable-scrollkeeper \
120    --disable-schemas-install \
121    --enable-browser-plugin \
122    --without-hal
123%__make %{?_smp_mflags}
124
125%install
126%__rm -rf $RPM_BUILD_ROOT
127export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
128%__make install DESTDIR=$RPM_BUILD_ROOT
129unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
130
131%__rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/*.{a,la}
132%__rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/librb-nautilus-context-menu.so
133%__rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
134%__rm -f $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*.{a,la}
135%__rm -f $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*/*.{a,la}
136%__rm -f $RPM_BUILD_ROOT%{_libdir}/librhythmbox-core.{a,la}
137%__rm -f $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins/*.{a,la}
138
139## Don't package DLNA/UPnP plugin
140%if !%{enable_DLNA_UPnP}
141%__rm -rf $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/upnp_coherence
142%endif
143
144%find_lang %{name}
145
146
147# Don't package api docs
148%__rm -rf $RPM_BUILD_ROOT%{_datadir}/gtk-doc/
149
150# Don't package scrollkeeper catalogs
151%__rm -rf $RPM_BUILD_ROOT%{_localstatedir}
152
153# And don't package vala
154%__rm -f %{buildroot}%{_libdir}/rhythmbox/plugins/libsample-vala.so \
155        %{buildroot}%{_libdir}/rhythmbox/plugins/sample-vala.rb-plugin
156
157# save space by linking identical images in translated docs
158helpdir=$RPM_BUILD_ROOT%{_datadir}/gnome/help/%{name}
159for f in $helpdir/C/figures/*.png; do
160  b="$(basename $f)"
161  for d in $helpdir/*; do
162    if [ -d "$d" -a "$d" != "$helpdir/C" ]; then
163      g="$d/figures/$b"
164      if [ -f "$g" ]; then
165        if cmp -s $f $g; then
166          %__rm "$g"; ln -s "../../C/figures/$b" "$g"
167        fi
168      fi
169    fi
170  done
171done
172
173
174%clean
175%__rm -rf $RPM_BUILD_ROOT
176
177%post
178/sbin/ldconfig
179update-desktop-database -q
180scrollkeeper-update -q
181touch --no-create %{_datadir}/icons/hicolor
182if [ -x /usr/bin/gtk-update-icon-cache ]; then
183  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
184fi
185
186%postun
187/sbin/ldconfig
188update-desktop-database -q
189scrollkeeper-update -q
190touch --no-create %{_datadir}/icons/hicolor
191if [ -x /usr/bin/gtk-update-icon-cache ]; then
192  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
193fi
194glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
195
196%posttrans
197glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
198
199
200%files -f %{name}.lang
201%defattr(-, root, root)
202%doc AUTHORS COPYING ChangeLog README NEWS
203%{_bindir}/*
204%{_libdir}/girepository-1.0/*.typelib
205%{_libdir}/lib*.so.*
206%{_libdir}/mozilla/plugins/librhythmbox-itms-detection-plugin.so
207%{_libdir}/rhythmbox/plugins
208%{_datadir}/applications/rhythmbox.desktop
209%{_datadir}/applications/rhythmbox-device.desktop
210%{_datadir}/dbus-1/services/org.gnome.Rhythmbox3.service
211%{_datadir}/glib-2.0/schemas/org.gnome.rhythmbox.gschema.xml
212%{_datadir}/gnome/help/rhythmbox
213%{_datadir}/icons/*
214%{_datadir}/omf/rhythmbox
215%{_datadir}/rhythmbox
216%{_mandir}/man1/*
217%{_libexecdir}/rhythmbox-metadata
218
219%files devel
220%defattr(-, root, root)
221%{_includedir}/%{name}/*
222%{_libdir}/*.so
223%{_libdir}/pkgconfig/*.pc
224%{_datadir}/gir-1.0/*.gir
225
226
227%changelog
228* Sat Jan 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.95-1
229- new upstream release
230- add BuildRequires: gtk3-devel, libtdb-devel, pygobject3-devel
231- remove BuildRequires: gnome-vfs2-devel, gstreamer-python-devel, libffi-devel, libgnome-media-profiles-devel, libgnomeui-devel, libsexy-devel, popt-devel, python-devel, pygtk2-devel, sqlite3-devel
232
233* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-4
234- rebuild with cogl-0.8.0
235
236* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-3
237- rebuild with libnotify-0.7
238- change BuildRequires: libmusicbrainz3-devel instead of libmusicbrainz-devel
239- change BuildRequires: libgnome-media-profiles-devel instead of gnome-media-devel
240- add BuildRequires: WebKit3-gtk-devel, libpeas-devel, clutter-gtk-devel, clutter-gst-devel, libmx-devel
241- add Patch0 (rhythmbox-0.13.3-git20110809.patch)
242- add Source101 (rhythmbox-png.tar.bz2)
243
244* Fri Aug 12 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-2
245- add BuildRequires: json-glib-devel
246- remove unrecognized configure option (--with-dbus, --with-cd-burning, --with-metadata-helper)
247
248* Sun Jan 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-1
249- new upstream release
250- change BuildRequires: gstreamer-python-devel instead of gstreamer-python
251
252* Sat Nov 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.2-1
253- new upstream release
254
255* Wed Oct 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-3
256- rebuild with brasero-2.32.0
257
258* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-2
259- rebuild with rpm-4.8.1 for pkg-config file
260
261* Sun Sep 12 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-1
262- new upstream release
263- fix %files (add rhythmbox-device.desktop)
264
265* Sun Aug 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.0-1
266- new upstream release
267- change BuildRequires: gnome-media-devel instead of gnome-media
268- add devel package
269- drop Patch0
270
271* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.8-1
272- new upstream release
273- drop Patch1, Patch2, Patch3
274- change BuildRequires: nautilus-cd-burner -> brasero-devel
275- change Requires: nautilus-cd-burner -> brasero
276- change BuildRequires: hal-devel -> libgudev1-devel
277- change BuildRequires: gnome-keyring-devel -> libgnome-keyring-devel
278- change Requires: gnome-keyring -> libgnome-keyring
279- add configure option (--without-hal)
280
281* Mon Feb 15 2010 Shu KONNO <owa@bg.wakwak.com> 0.12.6-2
282- rebuilt with new environment
283
284* Thu Jan 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.6-1
285- new upstream release
286  - dropped upstreamed/obsolete patches
287  - added patches applied Fedora development
288
289* Sun Oct 04 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.5-1
290- new upstream release
291- added configure options:
292  --disable-vala
293  --disable-browser-plugin
294
295* Thu Jul 30 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.2-2
296- added Japanese description
297
298* Thu Jul 02 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.12.2-1
299- new upstream release
300  - dropped rb-disable-power-plugin-by-default.patch
301- added BuildRequires:
302  - libSM-devel
303  - gnome-media
304
305* Wed Jun 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.12.1-2
306- rebuild with libgpod-0.7.2
307
308* Sun May 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.12.1-1
309- new upstream release
310- corrected License tag
311- dropped rhythmbox-0.11.6-libmtp.patch
312- added BuildRequires:
313  - sqlite3-devel
314  - libffi-devel
315
316* Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.11.6-2
317- defined enable_DLNA_UPnP = 0: unpacked DLNA/UPnP plugin
318- applied rhythmbox-0.11.6-libmtp.patch
319- added Requires:
320  - libgpod
321  - libnotify
322  - libsexy
323  - lirc
324  - libmtp
325  - libgnomeui
326  - nautilus-cd-burner
327  - gstreamer-python
328  - gnome-vfs2
329  - gnome-themes
330  - gnome-keyring
331  - python-Coherence, if enable_DLNA_UPnP = 1
332- added BuildRequires:
333  - libnotify-devel
334  - libsexy-devel
335  - lirc
336  - libmtp-devel
337  - gnome-vfs2-devel, instead of gnome-vfs2
338  - gnome-keyring-devel
339- dropped --with-internal-libsexy in configure options
340- added in configure options:
341  --with-mtp --with-libnautilus-burn --enable-lirc --disable-static
342- added %%preun to remove the schema
343
344* Sun Jan 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.11.6-1
345- new upstream release
346- changed to --with-metadata-helper in configure options
347- added BuildRequires:
348  - gstreamer-python
349  - intltool >= 0.35.0
350  - popt-devel
351
352* Sat Aug 09 2008 Shu KONNO <owa@bg.wakwak.com> 0.11.2-1vl5
353- added BuildRequires: totem-pl-parser-devel, instead of totem-devel
354- rebuilt with python-2.5.2
355- applied new versioning policy
356- spec in utf-8
357
358* Sun Jan 06 2008 Shu KONNO <owa@bg.wakwak.com> 0.11.2-0vl2
359- rebuilt with libgpod-0.6.0
360
361* Sun Aug 26 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.2-0vl1
362- new upstream release
363
364* Wed Jun 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.1-0vl1
365- new upstream release
366
367* Tue May 29 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.10.0-0vl2
368- rebuilt with new toolchain and libgpod-0.4.2
369- add BuildRequires: dbus-glib-devel
370
371* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.0-0vl1
372- new upstream release
373
374* Wed Mar 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8-0vl2
375- rebuilt for VineSeed
376
377* Wed Mar 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8-0vl1
378- new upstream release
379- added --enable-python option to %%configure
380- added Requires: gnome-python
381
382* Sun Jan 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.7-0vl1
383- new upstream release
384- built with libsoup 2.2.99
385
386* Thu Nov 23 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6-0vl4
387- added --with-cd-burner to configure
388- added BuildRequires: libsexy-devel hal-devel libsoup-devel
389
390* Wed Oct 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.6-0vl3
391- add BuildRequires:
392  - gnome-doc-utils >= 0.3.2
393  - python-devel
394  - pygtk2-devel
395  - check >= 0.8.2
396
397* Tue Oct 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.6-0vl2
398- rebuild with gnutls-1.4.1
399
400* Sun Oct  1 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6-0vl1
401- new upstream release
402
403* Mon Jun 19 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.5-0vl1
404- new upstream release
405- run scrollkeeper-update at %post and %postun
406- added BuildRequires: libnotify-devel
407
408* Sun May 14 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.4.1-0vl1
409- new upstream release (dropped patch0)
410- added --without-metadata-helper at configure
411
412* Mon Mar 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.3.1-0vl1
413- Initial build for Vine Linux based on FC pacakge
414
415* Fri Mar 03 2006 Ray Strode <rstrode@redhat.com> - 0.9.3.1-2
416- add patch from James "Doc" Livingston to stop a hang
417  for new users (bug 183883)
418
419* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3.1-1.2
420- bump again for double-long bug on ppc(64)
421
422* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3.1-1.1
423- rebuilt for new gcc4.1 snapshot and glibc changes
424
425* Sat Feb  4 2006 Christopher Aillon <caillon@redhat.com> 0.9.3.1-1
426- Update to 0.9.3.1
427- Use gstreamer (0.10)
428
429* Wed Feb  1 2006 Christopher Aillon <caillon@redhat.com> 0.9.3-2
430- Remove hack for 173869, as its no longer needed.
431
432* Wed Feb  1 2006 Christopher Aillon <caillon@redhat.com> 0.9.3-1
433- 0.9.3
434
435* Wed Feb  1 2006 Christopher Aillon <caillon@redhat.com> 0.9.2.cvs20060201-1
436- Newer CVS snapshot
437
438* Sun Jan 22 2006 Christopher Aillon <caillon@redhat.com> 0.9.2.cvs20060123-1
439- Update to latest CVS
440- Add hack to workaround bug #173869
441
442* Thu Jan 19 2006 Christopher Aillon <caillon@redhat.com> 0.9.2-8
443- Rebuild, now that gstreamer08-plugins has been fixed
444
445* Thu Jan 19 2006 Ray Strode <rstrode@redhat.com> 0.9.2-7
446- bonobo multilib issue (bug 156982)
447
448* Wed Jan 04 2006 John (J5) Palmieri <johnp@redhat.com> 0.9.2-5
449- rebuild with ipod support
450
451* Tue Jan 03 2006 Jesse Keating <jkeating@redhat.com> 0.9.2-4
452- rebuilt again
453
454* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
455- rebuilt
456
457* Mon Dec  5 2005 Matthias Clasen <mclasen@redhat.com>
458- rebuild
459
460* Thu Dec 01 2005 John (J5) Palmieri <johnp@redhat.com>
461- rebuild for new dbus
462
463* Wed Nov 30 2005 Matthias Clasen <mclasen@redhat.com>
464- Update to 0.9.2
465
466* Tue Oct 25 2005 Matthias Clasen <mclasen@redhat.com>
467- Update to 0.9.1
468
469* Fri Sep 02 2005 Colin Walters <walters@redhat.com>
470- Add configure flags --with-bonobo --with-dbus
471- BR nautilus-cd-burner-devel
472- New upstream CVS snapshot for testing
473- Drop IDL file and ui .xml
474- Add dbus service file
475- Drop upstreamed rhythmbox-bluecurve.tar.gz
476- Drop upstreamed rhythmbox-0.8.8-cell-renderer.patch
477
478* Fri Jun 13 2005 Colin Walters <walters@redhat.com> - 0.8.8-3
479- Add Bluecurve-ized icons from Jeff Schroeder (157716)
480- Add rhythmbox-0.8.8-cell-renderer.patch to remove use of custom
481  cell renderer for playback icon (no longer necessary) and
482  changes the rating renderer to work with non-b&w icons
483
484* Mon Mar 14 2005 Colin Walters <walters@redhat.com> - 0.8.8-2
485- Rebuild for GCC4
486
487* Tue Oct 05 2004 Colin Walters <walters@redhat.com> - 0.8.8-1
488- New upstream version
489- Remove librb-nautilus-context-menu.so, killed upstream
490
491* Thu Sep 30 2004 Christopher Aillon <caillon@redhat.com> 0.8.7-2
492- PreReq desktop-file-utils >= 0.9
493
494* Sat Sep 29 2004 Colin Walters <walters@redhat.com> - 0.8.7-1
495- New upstream version
496
497* Sat Sep 18 2004 Colin Walters <walters@redhat.com> - 0.8.6-2
498- Fix postun to use correct syntax, thanks Nils Philippsen
499
500* Sat Sep 18 2004 Colin Walters <walters@redhat.com> - 0.8.6-1
501- New upstream version
502- Call update-desktop-database in post and postun
503
504* Thu Jun 24 2004 Colin Walters <walters@redhat.com> - 0.8.5-1
505- New upstream version
506
507* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
508- rebuilt
509
510* Tue May 18 2004 Colin Walters <walters@redhat.com> - 0.8.4-1
511- New upstream version
512- Remove backported patches
513- Gratuitiously bump various BuildRequires versions
514
515* Mon May 10 2004 Colin Walters <walters@redhat.com> - 0.8.3-4
516- Remove code to unregister GConf schema for now (Closes: #122532)
517
518* Thu May 07 2004 Colin Walters <walters@redhat.com> - 0.8.3-3
519- Apply tiny patch from 0.8 arch to fix GConf key used
520  for initial sorting
521
522* Thu May 07 2004 Colin Walters <walters@redhat.com> - 0.8.3-2
523- Apply patch from 0.8 arch tree to fix a number of memleaks
524
525* Thu May 02 2004 Colin Walters <walters@redhat.com> - 0.8.3-1
526- Update to 0.8.3: fixes showstopper bug with internet radio
527
528* Thu Apr 30 2004 Colin Walters <walters@redhat.com> - 0.8.2-1
529- Update to 0.8.2
530- Fix Source url
531- Add smp_mflags
532- Bump BuildRequires on gstreamer to 0.8.1
533
534* Tue Apr 23 2004 Colin Walters <walters@redhat.com> - 0.8.1-2
535- Uninstall GConf schemas on removal
536
537* Tue Apr 20 2004 Colin Walters <walters@redhat.com> - 0.8.1-1
538- Update to 0.8.1
539
540* Fri Apr 16 2004 Colin Walters <walters@redhat.com> - 0.8.0-1
541- Update to 0.8.0
542
543* Fri Apr 02 2004 Colin Walters <walters@redhat.com> - 0.7.2-1
544- Update to 0.7.2
545
546* Mon Mar 29 2004 Colin Walters <walters@redhat.com> - 0.7.1-2
547- Remove BuildRequires on autoconf and libvorbis-devel
548
549* Mon Mar 29 2004 Colin Walters <walters@redhat.com> - 0.7.1-1
550- New major version - I know we are past major version slush, but
551  this should have been done two weeks ago along with the GNOME 2.6
552  upload.  As upstream author as well, I believe this version is
553  good enough for FC2.
554- Remove --disable-mp3
555- Remove id3, flac variables
556- Remove GStreamer major version patch
557- Fix typo in description
558
559* Tue Mar 16 2004 Jeremy Katz <katzj@redhat.com> - 0.6.8-2
560- rebuild for new gstreamer
561
562* Thu Mar 11 2004 Alex Larsson <alexl@redhat.com> 0.6.8-1
563- update to 0.6.8
564
565* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
566- rebuilt
567
568* Mon Mar  1 2004 Alexander Larsson <alexl@redhat.com> 0.6.7-1
569- update to 0.6.7
570
571* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
572- rebuilt
573
574* Mon Jan 12 2004 Colin Walters <walters@verbum.org> 0.6.4-1
575- New upstream version
576- Don't re-run the autotools; upstream incorporates newer versions.
577* Tue Oct 28 2003 Jonathan Blandford <jrb@redhat.com> 0.5.4-1
578- new version
579- remove smp_flags
580
581* Fri Oct 24 2003 Jonathan Blandford <jrb@redhat.com> 0.5.3-5
582- remove the initial iradio channels as they all are mp3 based.
583
584* Wed Oct  8 2003 Matthias Saou <matthias@rpmforge.net> 0.5.3-3
585- Fix category from Development/Libraries to Applications/Multimedia.
586- Use bz2 instead of gz as ftp.gnome.org has both, 300k saved in the src.rpm.
587- Fix SCHEMES vs. SCHEMAS in the post scriplet.
588- Added gstreamer-plugins-devel, libvorbis-devel, scrollkeeper and gettext deps.
589- Removed unnecessary date expansion define.
590- Updated description, including mp3 reference removal.
591- Added libid3tag and flac optional support for convenient rebuild.
592- Removed obsolete omf.make and xmldocs.make (included ones are the same now).
593
594* Mon Sep 22 2003 Jonathan Blandford <jrb@redhat.com> 0.5.3-1
595- new version
596- use %{_sysconfdir} instead of /etc
597
598* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
599- rebuilt
600
601* Wed Dec 18 2002 Jonathan Blandford <jrb@redhat.com>
602- gave up on other archs for the Beta
603- new version
604- remove werror and add missing files
605
606* Thu Nov  7 2002 Jeremy Katz <katzj@redhat.com>
607- update to newer cvs snap
608
609* Mon Sep 23 2002 Jeremy Katz <katzj@redhat.com>
610- update to cvs snap
611
612* Sun Sep 22 2002 Jeremy Katz <katzj@redhat.com>
613- use %%(lang)
614
615* Sun Aug 11 2002 Jeremy Katz <katzj@redhat.com>
616- fix post to actually install the schema
617
618* Sat Jun 22 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
619- Added gconf file
620- Added i18n directory
621
622* Sat Jun 15 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
623- Updated for new rewrite of rhythmbox, thanks to Jeroen
624
625* Mon Mar 18 2002 Jorn Baayen <jorn@nl.linux.org>
626- removed bonobo dependency
627* Sat Mar 02 2002 Christian Schaller <Uraeus@linuxrising.org>
628- created new spec file
Note: See TracBrowser for help on using the repository browser.