source: projects/specs/trunk/r/rhythmbox/rhythmbox-vl.spec @ 6011

Revision 6011, 19.8 KB checked in by Takemikaduchi, 12 years ago (diff)

new upstream release

Line 
1# -*- coding: utf-8-unix -*-
2%define desktop_file_utils_version 0.9
3
4%define enable_DLNA_UPnP 0
5
6Summary: Music Management Application
7Summary(ja): 音楽管理アプリケーション
8Name: rhythmbox
9Version: 2.96
10Release: 1%{?_dist_release}
11License: GPL2+ with exceptions and GFDL
12Group: Applications/Multimedia
13URL: http://projects.gnome.org/rhythmbox/
14Source0: http://download.gnome.org/sources/rhythmbox/2.96/%{name}-%{version}.tar.xz
15
16Source101:      rhythmbox-png.tar.bz2
17
18BuildRoot: %{_tmppath}/%{name}-%{version}-root
19BuildRequires: gtk3-devel
20BuildRequires: avahi-glib-devel >= 0.6
21BuildRequires: brasero-devel >= 2.32.0
22BuildRequires: dbus-glib-devel
23BuildRequires: gstreamer-plugins-base-devel >= 0.10
24BuildRequires: json-glib-devel
25BuildRequires: libSM-devel
26BuildRequires: libgnome-keyring-devel >= 2.30.0
27BuildRequires: libgpod-devel
28BuildRequires: libgudev1-devel
29BuildRequires: libmusicbrainz3-devel >= 3.0.2
30BuildRequires: libnotify-devel
31BuildRequires: libsoup-devel
32BuildRequires: pygobject3-devel
33BuildRequires: totem-pl-parser-devel
34BuildRequires: WebKit3-gtk-devel
35BuildRequires: libpeas-devel
36BuildRequires: clutter-gtk-devel
37BuildRequires: clutter-gst-devel
38BuildRequires: libmx-devel
39BuildRequires: check-devel
40BuildRequires: libmtp-devel
41BuildRequires: libtdb-devel
42BuildRequires: lirc
43BuildRequires: gnome-doc-utils >= 0.3.2
44Requires: libgpod
45Requires: libnotify
46Requires: lirc
47Requires: libmtp
48Requires: brasero
49Requires: gnome-themes
50Requires: libgnome-keyring
51%if %{enable_DLNA_UPnP}
52Requires: python-Coherence
53%endif
54Requires: desktop-file-utils >= %{desktop_file_utils_version}
55Requires: scrollkeeper
56
57# # gstreamer-plugins-ffmpeg and gstreamer-plugins-ugly package provided by
58# # self-build-gstreamer-plugins-ffmpeg and self-build-gstreamer-plugins-ugly,
59# # respectively.
60# Requires: self-build-gstreamer-plugins-ffmpeg
61# Requires: self-build-gstreamer-plugins-ugly
62
63Vendor: Project Vine
64Distribution: Vine Linux
65
66
67%description
68Rhythmbox is an integrated music management application based on the powerful
69GStreamer media framework. It has a number of features, including an easy to
70use music browser, searching and sorting, comprehensive audio format support
71through GStreamer, Internet Radio support, playlists and more.
72
73Rhythmbox is extensible through a plugin system.
74
75%description -l ja
76Rhythmbox は、強力な GStreamer メディアフレームワークに基づいている
77統合音楽管理アプリケーションです。
78見やすいユーザインターフェースを備え、検索や整列ができ、
79GStreamer により数多くの音声フォーマットをサポート、
80インターネットラジオをサポート、プレイリスト管理などの
81数多くの特徴を持ちます。
82
83%package devel
84Summary: Development tools for rhythmbox applications.
85Summary(ja): rhythmbox アプリケーションの開発用ファイル
86Group: Development/Libraries
87Requires: %{name} = %{version}-%{release}
88Requires: pkgconfig
89Requires: libxml2-devel
90Requires: glib2-devel
91Requires: gtk3-devel
92Requires: libsoup-devel
93Requires: totem-pl-parser-devel
94Requires: gstreamer-devel
95
96%description devel
97Header files and libraries for building a extension library for the rhythmbox.
98
99%description devel -l ja
100
101%prep
102%setup -q
103tar xjf %{SOURCE101}
104
105%build
106# work around a gstreamer bug
107/usr/bin/gst-inspect-0.10 --print-all >& /dev/null || :
108
109libtoolize --force --copy
110autoreconf
111%configure --with-ipod \
112    --with-mtp \
113    --with-mdns=avahi \
114    --enable-lirc \
115    --enable-python \
116    --disable-vala \
117    --disable-browser-plugin \
118    --disable-static \
119    --disable-scrollkeeper \
120    --disable-schemas-install \
121    --enable-browser-plugin \
122    --without-hal
123%__make %{?_smp_mflags}
124
125%install
126%__rm -rf $RPM_BUILD_ROOT
127export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
128%__make install DESTDIR=$RPM_BUILD_ROOT
129unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
130
131%__rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/*.{a,la}
132%__rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/librb-nautilus-context-menu.so
133%__rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
134%__rm -f $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*.{a,la}
135%__rm -f $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*/*.{a,la}
136%__rm -f $RPM_BUILD_ROOT%{_libdir}/librhythmbox-core.{a,la}
137%__rm -f $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins/*.{a,la}
138
139## Don't package DLNA/UPnP plugin
140%if !%{enable_DLNA_UPnP}
141%__rm -rf $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/upnp_coherence
142%endif
143
144%find_lang %{name}
145
146
147# Don't package api docs
148%__rm -rf $RPM_BUILD_ROOT%{_datadir}/gtk-doc/
149
150# Don't package scrollkeeper catalogs
151%__rm -rf $RPM_BUILD_ROOT%{_localstatedir}
152
153# And don't package vala
154%__rm -f %{buildroot}%{_libdir}/rhythmbox/plugins/libsample-vala.so \
155        %{buildroot}%{_libdir}/rhythmbox/plugins/sample-vala.rb-plugin
156
157# save space by linking identical images in translated docs
158helpdir=$RPM_BUILD_ROOT%{_datadir}/gnome/help/%{name}
159for f in $helpdir/C/figures/*.png; do
160  b="$(basename $f)"
161  for d in $helpdir/*; do
162    if [ -d "$d" -a "$d" != "$helpdir/C" ]; then
163      g="$d/figures/$b"
164      if [ -f "$g" ]; then
165        if cmp -s $f $g; then
166          %__rm "$g"; ln -s "../../C/figures/$b" "$g"
167        fi
168      fi
169    fi
170  done
171done
172
173
174%clean
175%__rm -rf $RPM_BUILD_ROOT
176
177%post
178/sbin/ldconfig
179update-desktop-database -q
180scrollkeeper-update -q
181touch --no-create %{_datadir}/icons/hicolor
182if [ -x /usr/bin/gtk-update-icon-cache ]; then
183  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
184fi
185
186%postun
187/sbin/ldconfig
188update-desktop-database -q
189scrollkeeper-update -q
190touch --no-create %{_datadir}/icons/hicolor
191if [ -x /usr/bin/gtk-update-icon-cache ]; then
192  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
193fi
194glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
195
196%posttrans
197glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
198
199
200%files -f %{name}.lang
201%defattr(-, root, root)
202%doc AUTHORS COPYING ChangeLog README NEWS
203%{_bindir}/*
204%{_libdir}/girepository-1.0/*.typelib
205%{_libdir}/lib*.so.*
206%{_libdir}/mozilla/plugins/librhythmbox-itms-detection-plugin.so
207%{_libdir}/rhythmbox/plugins
208%{_datadir}/applications/rhythmbox.desktop
209%{_datadir}/applications/rhythmbox-device.desktop
210%{_datadir}/dbus-1/services/org.gnome.Rhythmbox3.service
211%{_datadir}/glib-2.0/schemas/org.gnome.rhythmbox.gschema.xml
212%{_datadir}/gnome/help/rhythmbox
213%{_datadir}/icons/*
214%{_datadir}/omf/rhythmbox
215%{_datadir}/rhythmbox
216%{_mandir}/man1/*
217%{_libexecdir}/rhythmbox-metadata
218
219%files devel
220%defattr(-, root, root)
221%{_includedir}/%{name}/*
222%{_libdir}/*.so
223%{_libdir}/pkgconfig/*.pc
224%{_datadir}/gir-1.0/*.gir
225
226
227%changelog
228* Wed Apr 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.96-1
229- new upstream release
230
231* Sat Jan 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.95-1
232- new upstream release
233- add BuildRequires: gtk3-devel, libtdb-devel, pygobject3-devel
234- remove BuildRequires: gnome-vfs2-devel, gstreamer-python-devel, libffi-devel, libgnome-media-profiles-devel, libgnomeui-devel, libsexy-devel, popt-devel, python-devel, pygtk2-devel, sqlite3-devel
235
236* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-4
237- rebuild with cogl-0.8.0
238
239* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-3
240- rebuild with libnotify-0.7
241- change BuildRequires: libmusicbrainz3-devel instead of libmusicbrainz-devel
242- change BuildRequires: libgnome-media-profiles-devel instead of gnome-media-devel
243- add BuildRequires: WebKit3-gtk-devel, libpeas-devel, clutter-gtk-devel, clutter-gst-devel, libmx-devel
244- add Patch0 (rhythmbox-0.13.3-git20110809.patch)
245- add Source101 (rhythmbox-png.tar.bz2)
246
247* Fri Aug 12 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-2
248- add BuildRequires: json-glib-devel
249- remove unrecognized configure option (--with-dbus, --with-cd-burning, --with-metadata-helper)
250
251* Sun Jan 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-1
252- new upstream release
253- change BuildRequires: gstreamer-python-devel instead of gstreamer-python
254
255* Sat Nov 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.2-1
256- new upstream release
257
258* Wed Oct 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-3
259- rebuild with brasero-2.32.0
260
261* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-2
262- rebuild with rpm-4.8.1 for pkg-config file
263
264* Sun Sep 12 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-1
265- new upstream release
266- fix %files (add rhythmbox-device.desktop)
267
268* Sun Aug 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.0-1
269- new upstream release
270- change BuildRequires: gnome-media-devel instead of gnome-media
271- add devel package
272- drop Patch0
273
274* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.8-1
275- new upstream release
276- drop Patch1, Patch2, Patch3
277- change BuildRequires: nautilus-cd-burner -> brasero-devel
278- change Requires: nautilus-cd-burner -> brasero
279- change BuildRequires: hal-devel -> libgudev1-devel
280- change BuildRequires: gnome-keyring-devel -> libgnome-keyring-devel
281- change Requires: gnome-keyring -> libgnome-keyring
282- add configure option (--without-hal)
283
284* Mon Feb 15 2010 Shu KONNO <owa@bg.wakwak.com> 0.12.6-2
285- rebuilt with new environment
286
287* Thu Jan 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.6-1
288- new upstream release
289  - dropped upstreamed/obsolete patches
290  - added patches applied Fedora development
291
292* Sun Oct 04 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.5-1
293- new upstream release
294- added configure options:
295  --disable-vala
296  --disable-browser-plugin
297
298* Thu Jul 30 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.2-2
299- added Japanese description
300
301* Thu Jul 02 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.12.2-1
302- new upstream release
303  - dropped rb-disable-power-plugin-by-default.patch
304- added BuildRequires:
305  - libSM-devel
306  - gnome-media
307
308* Wed Jun 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.12.1-2
309- rebuild with libgpod-0.7.2
310
311* Sun May 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.12.1-1
312- new upstream release
313- corrected License tag
314- dropped rhythmbox-0.11.6-libmtp.patch
315- added BuildRequires:
316  - sqlite3-devel
317  - libffi-devel
318
319* Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.11.6-2
320- defined enable_DLNA_UPnP = 0: unpacked DLNA/UPnP plugin
321- applied rhythmbox-0.11.6-libmtp.patch
322- added Requires:
323  - libgpod
324  - libnotify
325  - libsexy
326  - lirc
327  - libmtp
328  - libgnomeui
329  - nautilus-cd-burner
330  - gstreamer-python
331  - gnome-vfs2
332  - gnome-themes
333  - gnome-keyring
334  - python-Coherence, if enable_DLNA_UPnP = 1
335- added BuildRequires:
336  - libnotify-devel
337  - libsexy-devel
338  - lirc
339  - libmtp-devel
340  - gnome-vfs2-devel, instead of gnome-vfs2
341  - gnome-keyring-devel
342- dropped --with-internal-libsexy in configure options
343- added in configure options:
344  --with-mtp --with-libnautilus-burn --enable-lirc --disable-static
345- added %%preun to remove the schema
346
347* Sun Jan 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.11.6-1
348- new upstream release
349- changed to --with-metadata-helper in configure options
350- added BuildRequires:
351  - gstreamer-python
352  - intltool >= 0.35.0
353  - popt-devel
354
355* Sat Aug 09 2008 Shu KONNO <owa@bg.wakwak.com> 0.11.2-1vl5
356- added BuildRequires: totem-pl-parser-devel, instead of totem-devel
357- rebuilt with python-2.5.2
358- applied new versioning policy
359- spec in utf-8
360
361* Sun Jan 06 2008 Shu KONNO <owa@bg.wakwak.com> 0.11.2-0vl2
362- rebuilt with libgpod-0.6.0
363
364* Sun Aug 26 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.2-0vl1
365- new upstream release
366
367* Wed Jun 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.1-0vl1
368- new upstream release
369
370* Tue May 29 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.10.0-0vl2
371- rebuilt with new toolchain and libgpod-0.4.2
372- add BuildRequires: dbus-glib-devel
373
374* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.0-0vl1
375- new upstream release
376
377* Wed Mar 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8-0vl2
378- rebuilt for VineSeed
379
380* Wed Mar 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8-0vl1
381- new upstream release
382- added --enable-python option to %%configure
383- added Requires: gnome-python
384
385* Sun Jan 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.7-0vl1
386- new upstream release
387- built with libsoup 2.2.99
388
389* Thu Nov 23 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6-0vl4
390- added --with-cd-burner to configure
391- added BuildRequires: libsexy-devel hal-devel libsoup-devel
392
393* Wed Oct 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.6-0vl3
394- add BuildRequires:
395  - gnome-doc-utils >= 0.3.2
396  - python-devel
397  - pygtk2-devel
398  - check >= 0.8.2
399
400* Tue Oct 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.6-0vl2
401- rebuild with gnutls-1.4.1
402
403* Sun Oct  1 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6-0vl1
404- new upstream release
405
406* Mon Jun 19 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.5-0vl1
407- new upstream release
408- run scrollkeeper-update at %post and %postun
409- added BuildRequires: libnotify-devel
410
411* Sun May 14 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.4.1-0vl1
412- new upstream release (dropped patch0)
413- added --without-metadata-helper at configure
414
415* Mon Mar 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.3.1-0vl1
416- Initial build for Vine Linux based on FC pacakge
417
418* Fri Mar 03 2006 Ray Strode <rstrode@redhat.com> - 0.9.3.1-2
419- add patch from James "Doc" Livingston to stop a hang
420  for new users (bug 183883)
421
422* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3.1-1.2
423- bump again for double-long bug on ppc(64)
424
425* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3.1-1.1
426- rebuilt for new gcc4.1 snapshot and glibc changes
427
428* Sat Feb  4 2006 Christopher Aillon <caillon@redhat.com> 0.9.3.1-1
429- Update to 0.9.3.1
430- Use gstreamer (0.10)
431
432* Wed Feb  1 2006 Christopher Aillon <caillon@redhat.com> 0.9.3-2
433- Remove hack for 173869, as its no longer needed.
434
435* Wed Feb  1 2006 Christopher Aillon <caillon@redhat.com> 0.9.3-1
436- 0.9.3
437
438* Wed Feb  1 2006 Christopher Aillon <caillon@redhat.com> 0.9.2.cvs20060201-1
439- Newer CVS snapshot
440
441* Sun Jan 22 2006 Christopher Aillon <caillon@redhat.com> 0.9.2.cvs20060123-1
442- Update to latest CVS
443- Add hack to workaround bug #173869
444
445* Thu Jan 19 2006 Christopher Aillon <caillon@redhat.com> 0.9.2-8
446- Rebuild, now that gstreamer08-plugins has been fixed
447
448* Thu Jan 19 2006 Ray Strode <rstrode@redhat.com> 0.9.2-7
449- bonobo multilib issue (bug 156982)
450
451* Wed Jan 04 2006 John (J5) Palmieri <johnp@redhat.com> 0.9.2-5
452- rebuild with ipod support
453
454* Tue Jan 03 2006 Jesse Keating <jkeating@redhat.com> 0.9.2-4
455- rebuilt again
456
457* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
458- rebuilt
459
460* Mon Dec  5 2005 Matthias Clasen <mclasen@redhat.com>
461- rebuild
462
463* Thu Dec 01 2005 John (J5) Palmieri <johnp@redhat.com>
464- rebuild for new dbus
465
466* Wed Nov 30 2005 Matthias Clasen <mclasen@redhat.com>
467- Update to 0.9.2
468
469* Tue Oct 25 2005 Matthias Clasen <mclasen@redhat.com>
470- Update to 0.9.1
471
472* Fri Sep 02 2005 Colin Walters <walters@redhat.com>
473- Add configure flags --with-bonobo --with-dbus
474- BR nautilus-cd-burner-devel
475- New upstream CVS snapshot for testing
476- Drop IDL file and ui .xml
477- Add dbus service file
478- Drop upstreamed rhythmbox-bluecurve.tar.gz
479- Drop upstreamed rhythmbox-0.8.8-cell-renderer.patch
480
481* Fri Jun 13 2005 Colin Walters <walters@redhat.com> - 0.8.8-3
482- Add Bluecurve-ized icons from Jeff Schroeder (157716)
483- Add rhythmbox-0.8.8-cell-renderer.patch to remove use of custom
484  cell renderer for playback icon (no longer necessary) and
485  changes the rating renderer to work with non-b&w icons
486
487* Mon Mar 14 2005 Colin Walters <walters@redhat.com> - 0.8.8-2
488- Rebuild for GCC4
489
490* Tue Oct 05 2004 Colin Walters <walters@redhat.com> - 0.8.8-1
491- New upstream version
492- Remove librb-nautilus-context-menu.so, killed upstream
493
494* Thu Sep 30 2004 Christopher Aillon <caillon@redhat.com> 0.8.7-2
495- PreReq desktop-file-utils >= 0.9
496
497* Sat Sep 29 2004 Colin Walters <walters@redhat.com> - 0.8.7-1
498- New upstream version
499
500* Sat Sep 18 2004 Colin Walters <walters@redhat.com> - 0.8.6-2
501- Fix postun to use correct syntax, thanks Nils Philippsen
502
503* Sat Sep 18 2004 Colin Walters <walters@redhat.com> - 0.8.6-1
504- New upstream version
505- Call update-desktop-database in post and postun
506
507* Thu Jun 24 2004 Colin Walters <walters@redhat.com> - 0.8.5-1
508- New upstream version
509
510* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
511- rebuilt
512
513* Tue May 18 2004 Colin Walters <walters@redhat.com> - 0.8.4-1
514- New upstream version
515- Remove backported patches
516- Gratuitiously bump various BuildRequires versions
517
518* Mon May 10 2004 Colin Walters <walters@redhat.com> - 0.8.3-4
519- Remove code to unregister GConf schema for now (Closes: #122532)
520
521* Thu May 07 2004 Colin Walters <walters@redhat.com> - 0.8.3-3
522- Apply tiny patch from 0.8 arch to fix GConf key used
523  for initial sorting
524
525* Thu May 07 2004 Colin Walters <walters@redhat.com> - 0.8.3-2
526- Apply patch from 0.8 arch tree to fix a number of memleaks
527
528* Thu May 02 2004 Colin Walters <walters@redhat.com> - 0.8.3-1
529- Update to 0.8.3: fixes showstopper bug with internet radio
530
531* Thu Apr 30 2004 Colin Walters <walters@redhat.com> - 0.8.2-1
532- Update to 0.8.2
533- Fix Source url
534- Add smp_mflags
535- Bump BuildRequires on gstreamer to 0.8.1
536
537* Tue Apr 23 2004 Colin Walters <walters@redhat.com> - 0.8.1-2
538- Uninstall GConf schemas on removal
539
540* Tue Apr 20 2004 Colin Walters <walters@redhat.com> - 0.8.1-1
541- Update to 0.8.1
542
543* Fri Apr 16 2004 Colin Walters <walters@redhat.com> - 0.8.0-1
544- Update to 0.8.0
545
546* Fri Apr 02 2004 Colin Walters <walters@redhat.com> - 0.7.2-1
547- Update to 0.7.2
548
549* Mon Mar 29 2004 Colin Walters <walters@redhat.com> - 0.7.1-2
550- Remove BuildRequires on autoconf and libvorbis-devel
551
552* Mon Mar 29 2004 Colin Walters <walters@redhat.com> - 0.7.1-1
553- New major version - I know we are past major version slush, but
554  this should have been done two weeks ago along with the GNOME 2.6
555  upload.  As upstream author as well, I believe this version is
556  good enough for FC2.
557- Remove --disable-mp3
558- Remove id3, flac variables
559- Remove GStreamer major version patch
560- Fix typo in description
561
562* Tue Mar 16 2004 Jeremy Katz <katzj@redhat.com> - 0.6.8-2
563- rebuild for new gstreamer
564
565* Thu Mar 11 2004 Alex Larsson <alexl@redhat.com> 0.6.8-1
566- update to 0.6.8
567
568* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
569- rebuilt
570
571* Mon Mar  1 2004 Alexander Larsson <alexl@redhat.com> 0.6.7-1
572- update to 0.6.7
573
574* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
575- rebuilt
576
577* Mon Jan 12 2004 Colin Walters <walters@verbum.org> 0.6.4-1
578- New upstream version
579- Don't re-run the autotools; upstream incorporates newer versions.
580* Tue Oct 28 2003 Jonathan Blandford <jrb@redhat.com> 0.5.4-1
581- new version
582- remove smp_flags
583
584* Fri Oct 24 2003 Jonathan Blandford <jrb@redhat.com> 0.5.3-5
585- remove the initial iradio channels as they all are mp3 based.
586
587* Wed Oct  8 2003 Matthias Saou <matthias@rpmforge.net> 0.5.3-3
588- Fix category from Development/Libraries to Applications/Multimedia.
589- Use bz2 instead of gz as ftp.gnome.org has both, 300k saved in the src.rpm.
590- Fix SCHEMES vs. SCHEMAS in the post scriplet.
591- Added gstreamer-plugins-devel, libvorbis-devel, scrollkeeper and gettext deps.
592- Removed unnecessary date expansion define.
593- Updated description, including mp3 reference removal.
594- Added libid3tag and flac optional support for convenient rebuild.
595- Removed obsolete omf.make and xmldocs.make (included ones are the same now).
596
597* Mon Sep 22 2003 Jonathan Blandford <jrb@redhat.com> 0.5.3-1
598- new version
599- use %{_sysconfdir} instead of /etc
600
601* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
602- rebuilt
603
604* Wed Dec 18 2002 Jonathan Blandford <jrb@redhat.com>
605- gave up on other archs for the Beta
606- new version
607- remove werror and add missing files
608
609* Thu Nov  7 2002 Jeremy Katz <katzj@redhat.com>
610- update to newer cvs snap
611
612* Mon Sep 23 2002 Jeremy Katz <katzj@redhat.com>
613- update to cvs snap
614
615* Sun Sep 22 2002 Jeremy Katz <katzj@redhat.com>
616- use %%(lang)
617
618* Sun Aug 11 2002 Jeremy Katz <katzj@redhat.com>
619- fix post to actually install the schema
620
621* Sat Jun 22 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
622- Added gconf file
623- Added i18n directory
624
625* Sat Jun 15 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
626- Updated for new rewrite of rhythmbox, thanks to Jeroen
627
628* Mon Mar 18 2002 Jorn Baayen <jorn@nl.linux.org>
629- removed bonobo dependency
630* Sat Mar 02 2002 Christian Schaller <Uraeus@linuxrising.org>
631- created new spec file
Note: See TracBrowser for help on using the repository browser.