source: projects/specs/trunk/r/readline/readline-vl.spec @ 12131

Revision 12131, 11.6 KB checked in by tomop, 5 years ago (diff)

Merge branch 'tomop'

Line 
1Summary: A library for editing typed in command lines.
2Summary(ja): Readline ライブラリ
3
4Name: readline
5Version: 8.0
6Release: 1%{?_dist_release}
7License: GPLv3+
8Group: System Environment/Libraries
9URL: http://tiswww.tis.case.edu/~chet/readline/rltop.html
10Source: https://ftp.gnu.org/gnu/readline/readline-%{version}.tar.gz
11
12# upstream patches
13Patch1: https://ftp.gnu.org/gnu/readline/readline-%{version}-patches/readline80-001
14
15# fix file permissions, remove RPATH, use CFLAGS
16Patch10: readline-8.0-shlib.patch
17
18Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
19BuildRequires: sed
20BuildRequires: ncurses-devel
21Requires(post): /sbin/install-info, /sbin/ldconfig
22Requires(preun): /sbin/install-info
23Requires(postun): /sbin/ldconfig
24
25Vendor: Project Vine
26Distribution: Vine Linux
27
28%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
29
30%description
31The Readline library provides a set of functions that allow users to
32edit command lines. Both Emacs and vi editing modes are available. The
33Readline library includes additional functions for maintaining a list
34of previously-entered command lines for recalling or editing those
35lines, and for performing csh-like history expansion on previous
36commands.
37
38%description -l ja
39Readline ライブラリは、ユーザーがコマンドラインを編集する機能を提供します。
40Emacs と vi の編集モードが利用可能です。Readline ライブラリはさらに、
41これまで入力されたコマンドライン履歴を保持し、再利用する機能も備えています。
42
43%package devel
44Summary: Files needed to develop programs which use the readline library.
45Summary(ja): Readline ライブラリを使うプログラムための開発用ライブラリ
46Group: Development/Libraries
47Requires: readline = %{version}
48Requires: ncurses-devel
49
50%description devel
51The Readline library provides a set of functions that allow users to
52edit typed command lines. If you want to develop programs that will
53use the readline library, you need to have the readline-devel package
54installed. You also need to have the readline package installed.
55
56
57%package -n compat32-%{name}
58Summary: A library for editing typed in command lines.
59Summary(ja): Readline ライブラリ
60Group: System Environment/Libraries
61Requires: %{name} = %{version}-%{release}
62
63%description -n compat32-%{name}
64The Readline library provides a set of functions that allow users to
65edit command lines. Both Emacs and vi editing modes are available. The
66Readline library includes additional functions for maintaining a list
67of previously-entered command lines for recalling or editing those
68lines, and for performing csh-like history expansion on previous
69commands.
70
71%description -n compat32-%{name} -l ja
72Readline ライブラリは、ユーザーがコマンドラインを編集する機能を提供します。
73Emacs と vi の編集モードが利用可能です。Readline ライブラリはさらに、
74これまで入力されたコマンドライン履歴を保持し、再利用する機能も備えています。
75
76%package -n compat32-%{name}-devel
77Summary: Files needed to develop programs which use the readline library.
78Summary(ja): Readline ライブラリを使うプログラムための開発用ライブラリ
79Group: Development/Libraries
80Requires: %{name} = %{version}-%{release}
81Requires: %{name}-devel = %{version}-%{release}
82Requires: compat32-ncurses-devel
83
84%description -n compat32-%{name}-devel
85The Readline library provides a set of functions that allow users to
86edit typed command lines. If you want to develop programs that will
87use the readline library, you need to have the readline-devel package
88installed. You also need to have the readline package installed.
89
90%prep
91%setup -q
92
93# upstream patches
94%patch1 -p0 -b .001
95
96%patch10 -p1 -b .shlib
97
98%build
99%configure --with-curses --disable-install-examples
100make %{?_smp_mflags}
101
102
103%install
104[ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
105mkdir -p ${RPM_BUILD_ROOT}%{_libdir}
106
107make DESTDIR=$RPM_BUILD_ROOT install
108
109mkdir $RPM_BUILD_ROOT/%{_lib}
110mv $RPM_BUILD_ROOT%{_libdir}/libreadline.so.* $RPM_BUILD_ROOT/%{_lib}
111for l in $RPM_BUILD_ROOT%{_libdir}/libreadline.so; do
112    ln -sf $(echo %{_libdir} | \
113     sed 's,\(^/\|\)[^/][^/]*,..,g')/%{_lib}/$(readlink $l) $l
114done
115
116rm -rf $RPM_BUILD_ROOT%{_docdir}/readline
117rm -rf $RPM_BUILD_ROOT%{_datadir}/readline
118rm -f $RPM_BUILD_ROOT%{_infodir}/dir
119
120%clean
121[ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
122
123%post
124/sbin/ldconfig
125/sbin/install-info %{_infodir}/history.info.gz %{_infodir}/dir &> /dev/null
126/sbin/install-info %{_infodir}/rluserman.info.gz %{_infodir}/dir &> /dev/null
127:
128
129%postun -p /sbin/ldconfig
130
131%post -n compat32-%{name} -p /sbin/ldconfig
132
133%postun -n compat32-%{name} -p /sbin/ldconfig
134
135%preun
136if [ $1 = 0 ]; then
137   /sbin/install-info --delete %{_infodir}/history.info.gz %{_infodir}/dir &> /dev/null
138   /sbin/install-info --delete %{_infodir}/rluserman.info.gz %{_infodir}/dir &> /dev/null
139fi
140:
141
142%post devel
143/sbin/install-info %{_infodir}/readline.info.gz %{_infodir}/dir &> /dev/null
144:
145
146%preun devel
147if [ $1 = 0 ]; then
148   /sbin/install-info --delete %{_infodir}/readline.info.gz %{_infodir}/dir &> /dev/null
149fi
150:
151
152%files
153%defattr(-,root,root)
154%license COPYING
155%doc CHANGES NEWS README USAGE
156/%{_lib}/libreadline*.so.*
157%{_libdir}/libhistory*.so.*
158%{_infodir}/history.info*
159%{_infodir}/rluserman.info*
160
161%files devel
162%defattr(-,root,root)
163%doc examples/*.c examples/*.h examples/rlfe
164%{_includedir}/readline
165%{_libdir}/lib*.a
166%{_libdir}/lib*.so
167%{_libdir}/pkgconfig/*.pc
168%{_infodir}/readline.info*
169%{_mandir}/man*/*
170
171%if %{build_compat32}
172%files -n compat32-%{name}
173%defattr(-,root,root)
174/%{_lib}/libreadline*.so.*
175%{_libdir}/libhistory*.so.*
176
177%files -n compat32-%{name}-devel
178%defattr(-,root,root)
179%{_libdir}/lib*.a
180%{_libdir}/lib*.so
181%{_libdir}/pkgconfig/*.pc
182%endif
183
184%changelog
185* Fri Aug 30 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.0-1
186- new upstream release.
187- dropped all of official patches.
188- added Patch1.
189- dropped Patch9.
190- updated Patch10.
191
192* Sat Mar 21 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 6.3-1
193- new upstream release
194- update upstream patches (patch1-8)
195
196* Fri Dec 27 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.2-5
197- rebuild with VineSeed environment
198
199* Sun Apr 17 2011 IWAI, Masaharu <iwai@alib.jp> 5.2-4
200- add upstream patches 13,14 (Patch13,14)
201
202* Fri Mar  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.2-3
203- rebuilt with new toolchain
204- add Requires(post,pre): /sbin/ldconfig
205
206* Tue Aug 19 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 5.2-2vl5
207- build with ncurses-devel
208- spec in utf8
209- move libncurses.so.* to %%_lib from %%_libdir
210
211* Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.2-1vl5
212- added upstream patches (patch8-12)
213
214* Fri Oct 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.2-0vl1
215- new upstream release
216- update upstream patches (patch1-7)
217
218* Sun Mar 19 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 5.1-0vl1
219- new upstream release
220- update upstream patches (patch1-4)
221- add doc/*.{html,pdf} instead of doc/
222
223* Sun Mar 19 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 4.3-5vl3
224- s/Copyright/License/
225- add URL
226- update source URL
227- add PreReq: ldconfig
228- move outdated.patch (patch1) to patch10
229- add upstream patches (patch1-5)
230- add no_rpath.patch (patch11)
231
232* Fri Oct 28 2005 NAKAMURA Kenta <kenta@c.csce.kyushu-u.ac.jp> 4.3-5vl2
233- added compat32- packages for x86_64 architecture support
234- fixed %files section (TODO* has been removed)
235
236* Sat Mar  8 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3-5vl1
237- new upstream release 4.3
238- merged with rawhide package.
239  * Wed Nov 20 2002 Tim Powers <timp@redhat.com>
240  - rebuild in current collinst
241  - BuildRequires autoconf only
242  * Wed Aug 07 2002 Phil Knirsch <pknirsch@redhat.com> 4.3-3
243  - Fixed Esc-O-M stack overflow bug.
244  * Mon Jul 22 2002 Phil Knirsch <pknirsch@redhat.com> 4.3-1
245  - Updated to latest readline release 4.3
246  * Thu Jul 11 2002 Phil Knirsch <pknirsch@redhat.com> 4.2a-7
247  - Fixed problem with alpha build.
248  * Wed Jul 10 2002 Phil Knirsch <pknirsch@redhat.com>
249  - Fixed utf8 problem (originally observed in bash).
250  * Fri Jun 21 2002 Tim Powers <timp@redhat.com> 4.2a-6
251  - automated rebuild
252  * Thu May 23 2002 Tim Powers <timp@redhat.com> 4.2a-5
253  - automated rebuild
254  * Wed Mar 20 2002 Trond Eivind Glomsrod <teg@redhat.com> 4.2a-4
255  - Use autoconf 2.53, not 2.52
256  * Mon Mar  4 2002 Bernhard Rosenkraenzer <bero@redhat.com> 4.2a-3
257  - Rebuild
258  * Mon Nov 26 2001 Matt Wilson <msw@redhat.com> 4.2a-2
259  - removed the manual symlinking of .so, readline handles this by itself
260  - call only %%makeinstall, not %%makeinstall install install-shared as
261    this makes bogus .old files in the buildroot
262  * Tue Nov 20 2001 Bernhard Rosenkraenzer <bero@redhat.com> 4.2a-1
263  - 4.2a
264  * Tue Oct  2 2001 Bernhard Rosenkraenzer <bero@redhat.com> 4.2-4
265  - Work around autoconf bug
266  * Mon Oct  1 2001 Bernhard Rosenkraenzer <bero@redhat.com> 4.2-3
267  - Don't use readline's internal re-implementation of strpbrk on systems
268    that have strpbrk - the system implementation is faster and better maintained.
269  * Tue Aug  7 2001 Bernhard Rosenkraenzer <bero@redhat.com> 4.2-2
270  - Make sure headers can be included from C++ applications (#51131)
271    (Patch based on Debian's with the bugs removed ;) )
272  * Wed May 09 2001 Florian La Roche <Florian.LaRoche@redhat.de>
273  - update to 4.2 and adapt patches
274  * Fri Apr  6 2001 Nalin Dahyabhai <nalin@redhat.com>
275  - change the paths listed for the header files in the man page to reflect
276    the location changes from previous versions (#35073)
277  - note that "on" is acceptable instead of "On" in the man page (#21327)
278  * Thu Mar  8 2001 Preston Brown <pbrown@redhat.com>
279  - fix reading of end key termcap value (@7 is correct, was kH) (#30884)
280  * Tue Jan 30 2001 Nalin Dahyabhai <nalin@redhat.com>
281  - mark the man page as currently out-of-date (#25294)
282
283* Tue Sep  4 2001 Jun Nishii <jun@vinelinux.org> 4.1-6vl5
284- remove texi2dvi and texi2html from doc/
285
286* Fri Jun 29 2001 Jun Nishii <jun@vinelinux.org> 4.1-6vl4
287- added doc and examples
288
289* Mon Jun 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
290- 4.1-6vl3
291- rebuilt for VineSeed
292
293* Wed Dec 13 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
294- 4.1-6vl2
295- Oops, spec was written in SJIS...
296
297* Sat Dec  9 2000 Jun Nishii <jun@vinelinux.org>
298- 4.1-6vl1
299- got i18n patch from Kondara
300
301* Thu Sep  7 2000 Jeff Johnson <jbj@redhat.com>
302- FHS packaging (64bit systems need to use libdir).
303
304* Thu Aug 17 2000 Jeff Johnson <jbj@redhat.com>
305- summaries from specspo.
306
307* Wed Aug  2 2000 Florian La Roche <Florian.LaRoche@redhat.com>
308- use "rm -f" in specfile
309
310* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
311- automatic rebuild
312
313* Mon Jun  5 2000 Jeff Johnson <jbj@redhat.com>
314- FHS packaging.
315
316* Tue Mar 21 2000 Bernhard Rosenkraenzer <bero@redhat.com>
317- 4.1
318
319* Thu Feb 03 2000 Nalin Dahyabhai <nalin@redhat.com>
320- update to 4.0
321
322* Fri Apr 09 1999 Michael K. Johnson <johnsonm@redhat.com>
323- added guard patch from Taneli Huuskonen <huuskone@cc.helsinki.fi>
324
325* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
326- auto rebuild in the new build environment (release 4)
327
328* Sun Jul 26 1998 Jeff Johnson <jbj@redhat.com>
329- updated to 2.2.1
330
331* Wed May 06 1998 Prospector System <bugs@redhat.com>
332- translations modified for de, fr, tr
333
334* Wed May 06 1998 Cristian Gafton <gafton@redhat.com>
335- don't package /usr/info/dir
336
337* Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
338- devel package moved to Development/Libraries
339
340* Tue Apr 21 1998 Cristian Gafton <gafton@redhat.com>
341- updated to 2.2
342
343* Tue Oct 14 1997 Donnie Barnes <djb@redhat.com>
344- spec file cleanups
345
346* Fri Oct 10 1997 Erik Troan <ewt@redhat.com>
347- added proper sonames
348
349* Tue Jul 08 1997 Erik Troan <ewt@redhat.com>
350- updated to readline 2.1
351
352* Tue Jun 03 1997 Erik Troan <ewt@redhat.com>
353- built against glibc
Note: See TracBrowser for help on using the repository browser.