source: projects/specs/trunk/r/readline/readline-vl.spec @ 12548

Revision 12548, 11.9 KB checked in by tomop, 3 years ago (diff)

updated 4 packages

gjs-1.66.2-2

libgnomekbd-3.26.1-1

readline-8.1-1

sqlite3-3.34.1-1

Line 
1Summary: A library for editing typed in command lines.
2Summary(ja): Readline ライブラリ
3Name: readline
4Version: 8.1
5%global shortver %(echo %{version} | cut -d . -f 1-2)
6%global shortver_nodots %(echo %{shortver} | tr -d ".")
7Release: 1%{?_dist_release}
8Group: system
9Vendor: Project Vine
10Distribution: Vine Linux
11
12License: GPLv3+
13URL: http://tiswww.tis.case.edu/~chet/readline/rltop.html
14%global baseurl https://ftp.gnu.org/gnu/readline
15Source: %{baseurl}/readline-%{shortver}.tar.gz
16
17# upstream patches
18#Patch1: %{baseurl}/readline-%{shortver}-patches/readline%{shortver_nodots}-001
19
20# fix file permissions, remove RPATH, use CFLAGS
21Patch100: readline-8.0-shlib.patch
22
23Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
24BuildRequires: sed
25BuildRequires: ncurses-devel
26Requires(post): /sbin/install-info, /sbin/ldconfig
27Requires(preun): /sbin/install-info
28Requires(postun): /sbin/ldconfig
29
30%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
31
32%description
33The Readline library provides a set of functions that allow users to
34edit command lines. Both Emacs and vi editing modes are available. The
35Readline library includes additional functions for maintaining a list
36of previously-entered command lines for recalling or editing those
37lines, and for performing csh-like history expansion on previous
38commands.
39
40%description -l ja
41Readline ライブラリは、ユーザーがコマンドラインを編集する機能を提供します。
42Emacs と vi の編集モードが利用可能です。Readline ライブラリはさらに、
43これまで入力されたコマンドライン履歴を保持し、再利用する機能も備えています。
44
45
46%package devel
47Summary: Files needed to develop programs which use the readline library.
48Summary(ja): Readline ライブラリを使うプログラムための開発用ライブラリ
49Group: programming
50Requires: readline = %{version}
51Requires: ncurses-devel
52
53%description devel
54The Readline library provides a set of functions that allow users to
55edit typed command lines. If you want to develop programs that will
56use the readline library, you need to have the readline-devel package
57installed. You also need to have the readline package installed.
58
59
60%package -n compat32-%{name}
61Summary: A library for editing typed in command lines.
62Summary(ja): Readline ライブラリ
63Group: system
64Requires: %{name} = %{version}-%{release}
65
66%description -n compat32-%{name}
67The Readline library provides a set of functions that allow users to
68edit command lines. Both Emacs and vi editing modes are available. The
69Readline library includes additional functions for maintaining a list
70of previously-entered command lines for recalling or editing those
71lines, and for performing csh-like history expansion on previous
72commands.
73
74%description -n compat32-%{name} -l ja
75Readline ライブラリは、ユーザーがコマンドラインを編集する機能を提供します。
76Emacs と vi の編集モードが利用可能です。Readline ライブラリはさらに、
77これまで入力されたコマンドライン履歴を保持し、再利用する機能も備えています。
78
79
80%package -n compat32-%{name}-devel
81Summary: Files needed to develop programs which use the readline library.
82Summary(ja): Readline ライブラリを使うプログラムための開発用ライブラリ
83Group: programming
84Requires: %{name} = %{version}-%{release}
85Requires: %{name}-devel = %{version}-%{release}
86Requires: compat32-ncurses-devel
87
88%description -n compat32-%{name}-devel
89The Readline library provides a set of functions that allow users to
90edit typed command lines. If you want to develop programs that will
91use the readline library, you need to have the readline-devel package
92installed. You also need to have the readline package installed.
93
94
95%debug_package
96
97
98%prep
99%setup -q -n %{name}-%{shortver}
100
101# upstream patches
102#patch1 -p0 -b .001
103
104%patch100 -p1 -b .shlib
105
106%build
107%configure --with-curses --disable-install-examples
108make %{?_smp_mflags}
109
110
111%install
112[ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
113mkdir -p ${RPM_BUILD_ROOT}%{_libdir}
114
115make DESTDIR=$RPM_BUILD_ROOT install
116
117mkdir $RPM_BUILD_ROOT/%{_lib}
118mv $RPM_BUILD_ROOT%{_libdir}/libreadline.so.* $RPM_BUILD_ROOT/%{_lib}
119for l in $RPM_BUILD_ROOT%{_libdir}/libreadline.so; do
120    ln -sf $(echo %{_libdir} | \
121     sed 's,\(^/\|\)[^/][^/]*,..,g')/%{_lib}/$(readlink $l) $l
122done
123
124rm -rf $RPM_BUILD_ROOT%{_docdir}/readline
125rm -rf $RPM_BUILD_ROOT%{_datadir}/readline
126rm -f $RPM_BUILD_ROOT%{_infodir}/dir
127
128%clean
129[ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
130
131%post
132/sbin/ldconfig
133/sbin/install-info %{_infodir}/history.info.gz %{_infodir}/dir &> /dev/null
134/sbin/install-info %{_infodir}/rluserman.info.gz %{_infodir}/dir &> /dev/null
135:
136
137%postun -p /sbin/ldconfig
138
139%ldconfig_scriptlets -n compat32-%{name}
140
141%preun
142if [ $1 = 0 ]; then
143   /sbin/install-info --delete %{_infodir}/history.info.gz %{_infodir}/dir &> /dev/null
144   /sbin/install-info --delete %{_infodir}/rluserman.info.gz %{_infodir}/dir &> /dev/null
145fi
146:
147
148%post devel
149/sbin/install-info %{_infodir}/readline.info.gz %{_infodir}/dir &> /dev/null
150:
151
152%preun devel
153if [ $1 = 0 ]; then
154   /sbin/install-info --delete %{_infodir}/readline.info.gz %{_infodir}/dir &> /dev/null
155fi
156:
157
158
159%files
160%defattr(-,root,root)
161%license COPYING
162%doc CHANGES NEWS README USAGE
163/%{_lib}/libreadline*.so.*
164%{_libdir}/libhistory*.so.*
165%{_infodir}/history.info*
166%{_infodir}/rluserman.info*
167
168%files devel
169%defattr(-,root,root)
170%doc examples/*.c examples/*.h examples/rlfe
171%{_includedir}/readline
172%{_libdir}/lib*.a
173%{_libdir}/lib*.so
174%{_libdir}/pkgconfig/*.pc
175%{_infodir}/readline.info*
176%{_mandir}/man*/*
177
178%if %{build_compat32}
179%files -n compat32-%{name}
180%defattr(-,root,root)
181/%{_lib}/libreadline*.so.*
182%{_libdir}/libhistory*.so.*
183
184%files -n compat32-%{name}-devel
185%defattr(-,root,root)
186%{_libdir}/lib*.a
187%{_libdir}/lib*.so
188%{_libdir}/pkgconfig/*.pc
189%endif
190
191
192%changelog
193* Thu Feb 25 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.1-1
194- new upstream release.
195- dropped Patch1-4.
196
197* Sat Sep 12 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.0.4-1
198- updated to patchlevel 004.
199
200* Fri Aug 30 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.0-1
201- new upstream release.
202- dropped all of official patches.
203- added Patch1.
204- dropped Patch9.
205- updated Patch10.
206
207* Sat Mar 21 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 6.3-1
208- new upstream release
209- update upstream patches (patch1-8)
210
211* Fri Dec 27 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.2-5
212- rebuild with VineSeed environment
213
214* Sun Apr 17 2011 IWAI, Masaharu <iwai@alib.jp> 5.2-4
215- add upstream patches 13,14 (Patch13,14)
216
217* Fri Mar  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.2-3
218- rebuilt with new toolchain
219- add Requires(post,pre): /sbin/ldconfig
220
221* Tue Aug 19 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 5.2-2vl5
222- build with ncurses-devel
223- spec in utf8
224- move libncurses.so.* to %%_lib from %%_libdir
225
226* Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.2-1vl5
227- added upstream patches (patch8-12)
228
229* Fri Oct 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.2-0vl1
230- new upstream release
231- update upstream patches (patch1-7)
232
233* Sun Mar 19 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 5.1-0vl1
234- new upstream release
235- update upstream patches (patch1-4)
236- add doc/*.{html,pdf} instead of doc/
237
238* Sun Mar 19 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 4.3-5vl3
239- s/Copyright/License/
240- add URL
241- update source URL
242- add PreReq: ldconfig
243- move outdated.patch (patch1) to patch10
244- add upstream patches (patch1-5)
245- add no_rpath.patch (patch11)
246
247* Fri Oct 28 2005 NAKAMURA Kenta <kenta@c.csce.kyushu-u.ac.jp> 4.3-5vl2
248- added compat32- packages for x86_64 architecture support
249- fixed %files section (TODO* has been removed)
250
251* Sat Mar  8 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3-5vl1
252- new upstream release 4.3
253- merged with rawhide package.
254  * Wed Nov 20 2002 Tim Powers <timp@redhat.com>
255  - rebuild in current collinst
256  - BuildRequires autoconf only
257  * Wed Aug 07 2002 Phil Knirsch <pknirsch@redhat.com> 4.3-3
258  - Fixed Esc-O-M stack overflow bug.
259  * Mon Jul 22 2002 Phil Knirsch <pknirsch@redhat.com> 4.3-1
260  - Updated to latest readline release 4.3
261  * Thu Jul 11 2002 Phil Knirsch <pknirsch@redhat.com> 4.2a-7
262  - Fixed problem with alpha build.
263  * Wed Jul 10 2002 Phil Knirsch <pknirsch@redhat.com>
264  - Fixed utf8 problem (originally observed in bash).
265  * Fri Jun 21 2002 Tim Powers <timp@redhat.com> 4.2a-6
266  - automated rebuild
267  * Thu May 23 2002 Tim Powers <timp@redhat.com> 4.2a-5
268  - automated rebuild
269  * Wed Mar 20 2002 Trond Eivind Glomsrod <teg@redhat.com> 4.2a-4
270  - Use autoconf 2.53, not 2.52
271  * Mon Mar  4 2002 Bernhard Rosenkraenzer <bero@redhat.com> 4.2a-3
272  - Rebuild
273  * Mon Nov 26 2001 Matt Wilson <msw@redhat.com> 4.2a-2
274  - removed the manual symlinking of .so, readline handles this by itself
275  - call only %%makeinstall, not %%makeinstall install install-shared as
276    this makes bogus .old files in the buildroot
277  * Tue Nov 20 2001 Bernhard Rosenkraenzer <bero@redhat.com> 4.2a-1
278  - 4.2a
279  * Tue Oct  2 2001 Bernhard Rosenkraenzer <bero@redhat.com> 4.2-4
280  - Work around autoconf bug
281  * Mon Oct  1 2001 Bernhard Rosenkraenzer <bero@redhat.com> 4.2-3
282  - Don't use readline's internal re-implementation of strpbrk on systems
283    that have strpbrk - the system implementation is faster and better maintained.
284  * Tue Aug  7 2001 Bernhard Rosenkraenzer <bero@redhat.com> 4.2-2
285  - Make sure headers can be included from C++ applications (#51131)
286    (Patch based on Debian's with the bugs removed ;) )
287  * Wed May 09 2001 Florian La Roche <Florian.LaRoche@redhat.de>
288  - update to 4.2 and adapt patches
289  * Fri Apr  6 2001 Nalin Dahyabhai <nalin@redhat.com>
290  - change the paths listed for the header files in the man page to reflect
291    the location changes from previous versions (#35073)
292  - note that "on" is acceptable instead of "On" in the man page (#21327)
293  * Thu Mar  8 2001 Preston Brown <pbrown@redhat.com>
294  - fix reading of end key termcap value (@7 is correct, was kH) (#30884)
295  * Tue Jan 30 2001 Nalin Dahyabhai <nalin@redhat.com>
296  - mark the man page as currently out-of-date (#25294)
297
298* Tue Sep  4 2001 Jun Nishii <jun@vinelinux.org> 4.1-6vl5
299- remove texi2dvi and texi2html from doc/
300
301* Fri Jun 29 2001 Jun Nishii <jun@vinelinux.org> 4.1-6vl4
302- added doc and examples
303
304* Mon Jun 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
305- 4.1-6vl3
306- rebuilt for VineSeed
307
308* Wed Dec 13 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
309- 4.1-6vl2
310- Oops, spec was written in SJIS...
311
312* Sat Dec  9 2000 Jun Nishii <jun@vinelinux.org>
313- 4.1-6vl1
314- got i18n patch from Kondara
315
316* Thu Sep  7 2000 Jeff Johnson <jbj@redhat.com>
317- FHS packaging (64bit systems need to use libdir).
318
319* Thu Aug 17 2000 Jeff Johnson <jbj@redhat.com>
320- summaries from specspo.
321
322* Wed Aug  2 2000 Florian La Roche <Florian.LaRoche@redhat.com>
323- use "rm -f" in specfile
324
325* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
326- automatic rebuild
327
328* Mon Jun  5 2000 Jeff Johnson <jbj@redhat.com>
329- FHS packaging.
330
331* Tue Mar 21 2000 Bernhard Rosenkraenzer <bero@redhat.com>
332- 4.1
333
334* Thu Feb 03 2000 Nalin Dahyabhai <nalin@redhat.com>
335- update to 4.0
336
337* Fri Apr 09 1999 Michael K. Johnson <johnsonm@redhat.com>
338- added guard patch from Taneli Huuskonen <huuskone@cc.helsinki.fi>
339
340* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
341- auto rebuild in the new build environment (release 4)
342
343* Sun Jul 26 1998 Jeff Johnson <jbj@redhat.com>
344- updated to 2.2.1
345
346* Wed May 06 1998 Prospector System <bugs@redhat.com>
347- translations modified for de, fr, tr
348
349* Wed May 06 1998 Cristian Gafton <gafton@redhat.com>
350- don't package /usr/info/dir
351
352* Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
353- devel package moved to Development/Libraries
354
355* Tue Apr 21 1998 Cristian Gafton <gafton@redhat.com>
356- updated to 2.2
357
358* Tue Oct 14 1997 Donnie Barnes <djb@redhat.com>
359- spec file cleanups
360
361* Fri Oct 10 1997 Erik Troan <ewt@redhat.com>
362- added proper sonames
363
364* Tue Jul 08 1997 Erik Troan <ewt@redhat.com>
365- updated to readline 2.1
366
367* Tue Jun 03 1997 Erik Troan <ewt@redhat.com>
368- built against glibc
Note: See TracBrowser for help on using the repository browser.