source: projects/specs/trunk/r/readline/readline-vl.spec @ 12490

Revision 12490, 12.1 KB checked in by tomop, 4 years ago (diff)

updated 3 packages

bash-5.0.18-1

bison-3.7.2-1

readline-8.0.4-1

Line 
1Summary: A library for editing typed in command lines.
2Summary(ja): Readline ライブラリ
3Name: readline
4Version: 8.0.4
5%global shortver %(echo %{version} | cut -d . -f 1-2)
6%global shortver_nodots %(echo %{shortver} | tr -d ".")
7Release: 1%{?_dist_release}
8Group: system
9Vendor: Project Vine
10Distribution: Vine Linux
11
12License: GPLv3+
13URL: http://tiswww.tis.case.edu/~chet/readline/rltop.html
14%global baseurl https://ftp.gnu.org/gnu/readline
15Source: %{baseurl}/readline-%{shortver}.tar.gz
16
17# upstream patches
18Patch1: %{baseurl}/readline-%{shortver}-patches/readline%{shortver_nodots}-001
19Patch2: %{baseurl}/readline-%{shortver}-patches/readline%{shortver_nodots}-002
20Patch3: %{baseurl}/readline-%{shortver}-patches/readline%{shortver_nodots}-003
21Patch4: %{baseurl}/readline-%{shortver}-patches/readline%{shortver_nodots}-004
22
23# fix file permissions, remove RPATH, use CFLAGS
24Patch100: readline-8.0-shlib.patch
25
26Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
27BuildRequires: sed
28BuildRequires: ncurses-devel
29Requires(post): /sbin/install-info, /sbin/ldconfig
30Requires(preun): /sbin/install-info
31Requires(postun): /sbin/ldconfig
32
33%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
34
35%description
36The Readline library provides a set of functions that allow users to
37edit command lines. Both Emacs and vi editing modes are available. The
38Readline library includes additional functions for maintaining a list
39of previously-entered command lines for recalling or editing those
40lines, and for performing csh-like history expansion on previous
41commands.
42
43%description -l ja
44Readline ライブラリは、ユーザーがコマンドラインを編集する機能を提供します。
45Emacs と vi の編集モードが利用可能です。Readline ライブラリはさらに、
46これまで入力されたコマンドライン履歴を保持し、再利用する機能も備えています。
47
48
49%package devel
50Summary: Files needed to develop programs which use the readline library.
51Summary(ja): Readline ライブラリを使うプログラムための開発用ライブラリ
52Group: programming
53Requires: readline = %{version}
54Requires: ncurses-devel
55
56%description devel
57The Readline library provides a set of functions that allow users to
58edit typed command lines. If you want to develop programs that will
59use the readline library, you need to have the readline-devel package
60installed. You also need to have the readline package installed.
61
62
63%package -n compat32-%{name}
64Summary: A library for editing typed in command lines.
65Summary(ja): Readline ライブラリ
66Group: system
67Requires: %{name} = %{version}-%{release}
68
69%description -n compat32-%{name}
70The Readline library provides a set of functions that allow users to
71edit command lines. Both Emacs and vi editing modes are available. The
72Readline library includes additional functions for maintaining a list
73of previously-entered command lines for recalling or editing those
74lines, and for performing csh-like history expansion on previous
75commands.
76
77%description -n compat32-%{name} -l ja
78Readline ライブラリは、ユーザーがコマンドラインを編集する機能を提供します。
79Emacs と vi の編集モードが利用可能です。Readline ライブラリはさらに、
80これまで入力されたコマンドライン履歴を保持し、再利用する機能も備えています。
81
82
83%package -n compat32-%{name}-devel
84Summary: Files needed to develop programs which use the readline library.
85Summary(ja): Readline ライブラリを使うプログラムための開発用ライブラリ
86Group: programming
87Requires: %{name} = %{version}-%{release}
88Requires: %{name}-devel = %{version}-%{release}
89Requires: compat32-ncurses-devel
90
91%description -n compat32-%{name}-devel
92The Readline library provides a set of functions that allow users to
93edit typed command lines. If you want to develop programs that will
94use the readline library, you need to have the readline-devel package
95installed. You also need to have the readline package installed.
96
97
98%debug_package
99
100
101%prep
102%setup -q -n %{name}-%{shortver}
103
104# upstream patches
105%patch1 -p0 -b .001
106%patch2 -p0 -b .002
107%patch3 -p0 -b .003
108%patch4 -p0 -b .004
109
110%patch100 -p1 -b .shlib
111
112%build
113%configure --with-curses --disable-install-examples
114make %{?_smp_mflags}
115
116
117%install
118[ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
119mkdir -p ${RPM_BUILD_ROOT}%{_libdir}
120
121make DESTDIR=$RPM_BUILD_ROOT install
122
123mkdir $RPM_BUILD_ROOT/%{_lib}
124mv $RPM_BUILD_ROOT%{_libdir}/libreadline.so.* $RPM_BUILD_ROOT/%{_lib}
125for l in $RPM_BUILD_ROOT%{_libdir}/libreadline.so; do
126    ln -sf $(echo %{_libdir} | \
127     sed 's,\(^/\|\)[^/][^/]*,..,g')/%{_lib}/$(readlink $l) $l
128done
129
130rm -rf $RPM_BUILD_ROOT%{_docdir}/readline
131rm -rf $RPM_BUILD_ROOT%{_datadir}/readline
132rm -f $RPM_BUILD_ROOT%{_infodir}/dir
133
134%clean
135[ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
136
137%post
138/sbin/ldconfig
139/sbin/install-info %{_infodir}/history.info.gz %{_infodir}/dir &> /dev/null
140/sbin/install-info %{_infodir}/rluserman.info.gz %{_infodir}/dir &> /dev/null
141:
142
143%postun -p /sbin/ldconfig
144
145%post -n compat32-%{name} -p /sbin/ldconfig
146
147%postun -n compat32-%{name} -p /sbin/ldconfig
148
149%preun
150if [ $1 = 0 ]; then
151   /sbin/install-info --delete %{_infodir}/history.info.gz %{_infodir}/dir &> /dev/null
152   /sbin/install-info --delete %{_infodir}/rluserman.info.gz %{_infodir}/dir &> /dev/null
153fi
154:
155
156%post devel
157/sbin/install-info %{_infodir}/readline.info.gz %{_infodir}/dir &> /dev/null
158:
159
160%preun devel
161if [ $1 = 0 ]; then
162   /sbin/install-info --delete %{_infodir}/readline.info.gz %{_infodir}/dir &> /dev/null
163fi
164:
165
166%files
167%defattr(-,root,root)
168%license COPYING
169%doc CHANGES NEWS README USAGE
170/%{_lib}/libreadline*.so.*
171%{_libdir}/libhistory*.so.*
172%{_infodir}/history.info*
173%{_infodir}/rluserman.info*
174
175%files devel
176%defattr(-,root,root)
177%doc examples/*.c examples/*.h examples/rlfe
178%{_includedir}/readline
179%{_libdir}/lib*.a
180%{_libdir}/lib*.so
181%{_libdir}/pkgconfig/*.pc
182%{_infodir}/readline.info*
183%{_mandir}/man*/*
184
185%if %{build_compat32}
186%files -n compat32-%{name}
187%defattr(-,root,root)
188/%{_lib}/libreadline*.so.*
189%{_libdir}/libhistory*.so.*
190
191%files -n compat32-%{name}-devel
192%defattr(-,root,root)
193%{_libdir}/lib*.a
194%{_libdir}/lib*.so
195%{_libdir}/pkgconfig/*.pc
196%endif
197
198%changelog
199* Sat Sep 12 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.0.4-1
200- updated to patchlevel 004.
201
202* Fri Aug 30 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.0-1
203- new upstream release.
204- dropped all of official patches.
205- added Patch1.
206- dropped Patch9.
207- updated Patch10.
208
209* Sat Mar 21 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 6.3-1
210- new upstream release
211- update upstream patches (patch1-8)
212
213* Fri Dec 27 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.2-5
214- rebuild with VineSeed environment
215
216* Sun Apr 17 2011 IWAI, Masaharu <iwai@alib.jp> 5.2-4
217- add upstream patches 13,14 (Patch13,14)
218
219* Fri Mar  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.2-3
220- rebuilt with new toolchain
221- add Requires(post,pre): /sbin/ldconfig
222
223* Tue Aug 19 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 5.2-2vl5
224- build with ncurses-devel
225- spec in utf8
226- move libncurses.so.* to %%_lib from %%_libdir
227
228* Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.2-1vl5
229- added upstream patches (patch8-12)
230
231* Fri Oct 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.2-0vl1
232- new upstream release
233- update upstream patches (patch1-7)
234
235* Sun Mar 19 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 5.1-0vl1
236- new upstream release
237- update upstream patches (patch1-4)
238- add doc/*.{html,pdf} instead of doc/
239
240* Sun Mar 19 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 4.3-5vl3
241- s/Copyright/License/
242- add URL
243- update source URL
244- add PreReq: ldconfig
245- move outdated.patch (patch1) to patch10
246- add upstream patches (patch1-5)
247- add no_rpath.patch (patch11)
248
249* Fri Oct 28 2005 NAKAMURA Kenta <kenta@c.csce.kyushu-u.ac.jp> 4.3-5vl2
250- added compat32- packages for x86_64 architecture support
251- fixed %files section (TODO* has been removed)
252
253* Sat Mar  8 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3-5vl1
254- new upstream release 4.3
255- merged with rawhide package.
256  * Wed Nov 20 2002 Tim Powers <timp@redhat.com>
257  - rebuild in current collinst
258  - BuildRequires autoconf only
259  * Wed Aug 07 2002 Phil Knirsch <pknirsch@redhat.com> 4.3-3
260  - Fixed Esc-O-M stack overflow bug.
261  * Mon Jul 22 2002 Phil Knirsch <pknirsch@redhat.com> 4.3-1
262  - Updated to latest readline release 4.3
263  * Thu Jul 11 2002 Phil Knirsch <pknirsch@redhat.com> 4.2a-7
264  - Fixed problem with alpha build.
265  * Wed Jul 10 2002 Phil Knirsch <pknirsch@redhat.com>
266  - Fixed utf8 problem (originally observed in bash).
267  * Fri Jun 21 2002 Tim Powers <timp@redhat.com> 4.2a-6
268  - automated rebuild
269  * Thu May 23 2002 Tim Powers <timp@redhat.com> 4.2a-5
270  - automated rebuild
271  * Wed Mar 20 2002 Trond Eivind Glomsrod <teg@redhat.com> 4.2a-4
272  - Use autoconf 2.53, not 2.52
273  * Mon Mar  4 2002 Bernhard Rosenkraenzer <bero@redhat.com> 4.2a-3
274  - Rebuild
275  * Mon Nov 26 2001 Matt Wilson <msw@redhat.com> 4.2a-2
276  - removed the manual symlinking of .so, readline handles this by itself
277  - call only %%makeinstall, not %%makeinstall install install-shared as
278    this makes bogus .old files in the buildroot
279  * Tue Nov 20 2001 Bernhard Rosenkraenzer <bero@redhat.com> 4.2a-1
280  - 4.2a
281  * Tue Oct  2 2001 Bernhard Rosenkraenzer <bero@redhat.com> 4.2-4
282  - Work around autoconf bug
283  * Mon Oct  1 2001 Bernhard Rosenkraenzer <bero@redhat.com> 4.2-3
284  - Don't use readline's internal re-implementation of strpbrk on systems
285    that have strpbrk - the system implementation is faster and better maintained.
286  * Tue Aug  7 2001 Bernhard Rosenkraenzer <bero@redhat.com> 4.2-2
287  - Make sure headers can be included from C++ applications (#51131)
288    (Patch based on Debian's with the bugs removed ;) )
289  * Wed May 09 2001 Florian La Roche <Florian.LaRoche@redhat.de>
290  - update to 4.2 and adapt patches
291  * Fri Apr  6 2001 Nalin Dahyabhai <nalin@redhat.com>
292  - change the paths listed for the header files in the man page to reflect
293    the location changes from previous versions (#35073)
294  - note that "on" is acceptable instead of "On" in the man page (#21327)
295  * Thu Mar  8 2001 Preston Brown <pbrown@redhat.com>
296  - fix reading of end key termcap value (@7 is correct, was kH) (#30884)
297  * Tue Jan 30 2001 Nalin Dahyabhai <nalin@redhat.com>
298  - mark the man page as currently out-of-date (#25294)
299
300* Tue Sep  4 2001 Jun Nishii <jun@vinelinux.org> 4.1-6vl5
301- remove texi2dvi and texi2html from doc/
302
303* Fri Jun 29 2001 Jun Nishii <jun@vinelinux.org> 4.1-6vl4
304- added doc and examples
305
306* Mon Jun 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
307- 4.1-6vl3
308- rebuilt for VineSeed
309
310* Wed Dec 13 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
311- 4.1-6vl2
312- Oops, spec was written in SJIS...
313
314* Sat Dec  9 2000 Jun Nishii <jun@vinelinux.org>
315- 4.1-6vl1
316- got i18n patch from Kondara
317
318* Thu Sep  7 2000 Jeff Johnson <jbj@redhat.com>
319- FHS packaging (64bit systems need to use libdir).
320
321* Thu Aug 17 2000 Jeff Johnson <jbj@redhat.com>
322- summaries from specspo.
323
324* Wed Aug  2 2000 Florian La Roche <Florian.LaRoche@redhat.com>
325- use "rm -f" in specfile
326
327* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
328- automatic rebuild
329
330* Mon Jun  5 2000 Jeff Johnson <jbj@redhat.com>
331- FHS packaging.
332
333* Tue Mar 21 2000 Bernhard Rosenkraenzer <bero@redhat.com>
334- 4.1
335
336* Thu Feb 03 2000 Nalin Dahyabhai <nalin@redhat.com>
337- update to 4.0
338
339* Fri Apr 09 1999 Michael K. Johnson <johnsonm@redhat.com>
340- added guard patch from Taneli Huuskonen <huuskone@cc.helsinki.fi>
341
342* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
343- auto rebuild in the new build environment (release 4)
344
345* Sun Jul 26 1998 Jeff Johnson <jbj@redhat.com>
346- updated to 2.2.1
347
348* Wed May 06 1998 Prospector System <bugs@redhat.com>
349- translations modified for de, fr, tr
350
351* Wed May 06 1998 Cristian Gafton <gafton@redhat.com>
352- don't package /usr/info/dir
353
354* Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
355- devel package moved to Development/Libraries
356
357* Tue Apr 21 1998 Cristian Gafton <gafton@redhat.com>
358- updated to 2.2
359
360* Tue Oct 14 1997 Donnie Barnes <djb@redhat.com>
361- spec file cleanups
362
363* Fri Oct 10 1997 Erik Troan <ewt@redhat.com>
364- added proper sonames
365
366* Tue Jul 08 1997 Erik Troan <ewt@redhat.com>
367- updated to readline 2.1
368
369* Tue Jun 03 1997 Erik Troan <ewt@redhat.com>
370- built against glibc
Note: See TracBrowser for help on using the repository browser.