source: projects/specs/trunk/p/python25/python25-vl.spec @ 872

Revision 872, 30.3 KB checked in by owa, 14 years ago (diff)

included db46 headers

Line 
1# If you want to run test, add "--define '_run_test 1'" to rpm option
2%define run_test %{?_run_test:1}%{!?_run_test:0}
3%define with_doc %{?_without_doc:1}%{!?_without_doc:0}
4%define unicode  ucs4
5%define tcl_major 8.4
6%define tk_major 8.4
7%define tix_major 8.4
8%define pybasever 2.5
9%define python_lib %{_libdir}/python%{pybasever}
10## as python25
11Packager: owa
12
13Summary: An interpreted, interactive, object-oriented programming language.
14Summary(ja): オブジェクト指向言語 Python インタプリタ
15Name: python25
16Version: %{pybasever}.5
17Release: 2%{?_dist_release}
18License: PSF - see LICENSE
19Group: Development/Languages
20URL: http://www.python.org/%{pybasever}/
21Source0: http://www.python.org/ftp/python/%{version}/Python-%{version}.tar.bz2
22Source1: db46_headers.tar.gz
23Source6: shmmodule.c
24# For TEST
25Source7: http://people.freebsd.org/~perky/i18n/EUC-CN.TXT
26Source8: http://www.unicode.org/Public/MAPPINGS/VENDORS/MICSFT/WINDOWS/CP936.TXT
27Source9: http://people.freebsd.org/~perky/i18n/BIG5HKSCS.TXT
28Source10: http://www.unicode.org/Public/MAPPINGS/VENDORS/MICSFT/WINDOWS/CP932.TXT
29Source11: http://people.freebsd.org/~perky/i18n/EUC-JP.TXT
30Source12: http://www.unicode.org/Public/MAPPINGS/OBSOLETE/EASTASIA/JIS/SHIFTJIS.TXT
31Source13: http://people.freebsd.org/~perky/i18n/EUC-JISX0213.TXT
32Source14: http://people.freebsd.org/~perky/i18n/SHIFT_JISX0213.TXT
33Source15: http://www.unicode.org/Public/MAPPINGS/VENDORS/MICSFT/WINDOWS/CP949.TXT
34Source16: http://people.freebsd.org/~perky/i18n/EUC-KR.TXT
35Source17: http://www.unicode.org/Public/MAPPINGS/OBSOLETE/EASTASIA/KSC/JOHAB.TXT
36Source18: http://www.unicode.org/Public/MAPPINGS/OBSOLETE/EASTASIA/OTHER/BIG5.TXT
37Source19: http://www.unicode.org/Public/MAPPINGS/VENDORS/MICSFT/WINDOWS/CP950.TXT
38Source20: http://www.unicode.org/Public/3.2-Update/NormalizationTest-3.2.0.txt
39
40#Patch0: python-2.5.2-config.patch
41Patch3: Python-2.2.1-pydocnogui.patch
42Patch4: Python-2.3.3-nowhatsnew.patch
43Patch5: Python-2.3.3-distutilrpm.patch
44Patch8: python-2.5.2-lib64.patch
45#Patch9: python-2.5.2-config64.patch
46#Patch10: python-2.5.4-libcrypt.patch
47
48# new Setup patchs include patch-{0, 9, 10}
49Patch11: Python-2.5.4-Setup.patch
50Patch12: Python-2.5.4-Setup64.patch
51
52# Security fixes
53#Patch100: python-2.4.4_CVE-2007-4965.patch
54#Patch110: python-2.4.4_CVE-2008-1721.patch
55#Patch120: python-2.4.4-CVE-2008-1679.patch
56#Patch130: python-2.4.4_CVE-2008-1887.patch
57#Patch140: python-2.4.4_CVE-2007-2052.patch
58
59Conflicts: python = 2.5
60Obsoletes: python2
61Obsoletes: Distutils
62Obsoletes: python-base
63Provides: Distutils
64
65BuildRequires: db4-devel
66BuildRequires: readline-devel, libtermcap-devel, openssl-devel, gmp-devel
67BuildRequires: ncurses-devel, gdbm-devel, zlib-devel, expat-devel, tetex-latex
68BuildRequires: tk tix gcc-c++ glibc-devel
69BuildRequires: xorg-x11-devel mesa-libGL-devel
70BuildRequires: gzip tar /usr/bin/find pkgconfig bzip2-devel
71BuildRequires: nkf
72%if %{with_doc}
73BuildRequires: latex2html
74%endif
75BuildRoot: %{_tmppath}/%{name}-%{version}-root
76
77
78%description
79Python is an interpreted, interactive, object-oriented programming
80language often compared to Tcl, Perl, Scheme or Java. Python includes
81modules, classes, exceptions, very high level dynamic data types and
82dynamic typing. Python supports interfaces to many system calls and
83libraries, as well as to various windowing systems (X11, Motif, Tk,
84Mac and MFC).
85
86Programmers can write new built-in modules for Python in C or C++.
87Python can be used as an extension language for applications that need
88a programmable interface. This package contains most of the standard
89Python modules, as well as modules for interfacing to the Tix widget
90set for Tk and RPM.
91
92Note that documentation for Python is provided in the python-docs
93package.
94
95%package devel
96Summary: The libraries and header files needed for Python development.
97Summary(ja): Python での開発に必要なライブラリやヘッダファイル
98Group: Development/Libraries
99Obsoletes: python2-devel
100
101%description devel
102The Python programming language's interpreter can be extended with
103dynamically loaded extensions and can be embedded in other programs.
104This package contains the header files and libraries needed to do
105these types of tasks.
106
107Install python-devel if you want to develop Python extensions.  The
108python package will also need to be installed.  You'll probably also
109want to install the python-docs package, which contains Python
110documentation.
111
112%package tools
113Summary: A collection of development tools included with Python.
114Summary(ja): Python に含まれる開発ツール一式
115Group: Development/Tools
116Requires: %{name} = %{version}
117Requires: %{name}-tkinter = %{version}
118Obsoletes: python2-tools
119
120%description tools
121The Python package includes several development tools that are used
122to build python programs.
123
124%package docs
125Summary: Documentation for the Python programming language.
126Summary(ja): Python プログラミング言語のドキュメント
127Group: Applications/Documentation
128Obsoletes: python2-docs
129
130%description docs
131The python-docs package contains documentation on the Python
132programming language and interpreter.  The documentation is provided
133in ASCII text files and in LaTeX source files.
134
135Install the python-docs package if you'd like to use the documentation
136for the Python language.
137
138%package tkinter
139Summary: A graphical user interface for the Python scripting language.
140Summary(ja): Python スクリプト言語のグラフィカルインターフェイス
141Group: Development/Languages
142Obsoletes: tkinter2
143BuildRequires: tcl, tk
144Requires: %{name} = %{version}
145Requires: tix
146
147%description tkinter
148The Tkinter (Tk interface) program is an graphical user interface for
149the Python scripting language.
150
151You should install the tkinter package if you'd like to use a graphical
152user interface for Python programming.
153
154%prep
155%setup -q -n Python-%{version} -a 1
156%patch3 -p1 -b .no_gui
157%patch4 -p1 -b .nowhatsnew
158%patch5 -p1
159
160%if %{_lib} == lib64
161%patch8 -p2 -b .lib64
162#%patch9 -p1 -b .config64
163%patch12 -p1 -b .Setup64
164%else
165#%patch0 -p1 -b .config
166%patch11 -p1 -b .Setup
167%endif
168
169#%patch10 -p1 -b .libcrypt
170
171# security fixes
172#%patch100 -p1 -b .CVE-2007-4965
173#%patch110 -p1 -b .CVE-2008-1721
174#%patch120 -p1 -b .CVE-2008-1679
175#%patch130 -p0 -b .CVE-2008-1887
176#%patch140 -p0 -b .CVE-2007-2052
177
178# remove unneeded files
179rm -vf Lib/test/test_*.py.CVE*
180rm -vf Lib/test/test_*.py.orig
181rm -vf Lib/test/test_*.py.org
182
183# Temporary workaround to avoid confusing find-requires: don't ship the tests
184# as executable files
185chmod 0644 Lib/test/test_*.py
186
187# shm module
188cp %{SOURCE6} Modules
189cat >> Modules/Setup.dist << EOF
190
191# Shared memory module
192shm shmmodule.c
193EOF
194
195# Fix library flags
196pushd Modules
197mv Setup.dist Setup.dist.in
198sed "s|-ltcl|-ltcl%{tcl_major}|" < Setup.dist.in |\
199sed "s|-ltk|-ltk%{tk_major}|" |\
200sed "s|-ltix|-ltix%{tix_major}|"  > Setup.dist
201rm -f Setup.dist.in
202popd
203
204
205%build
206topdir=`pwd`
207export CFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE -fPIC"
208export CXXFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE -fPIC"
209export OPT="$RPM_OPT_FLAGS -D_GNU_SOURCE -fPIC"
210export LINKCC="gcc"
211if pkg-config openssl ; then
212        export CFLAGS="$CFLAGS `pkg-config --cflags openssl`"
213        export LDFLAGS="$LDFLAGS `pkg-config --libs-only-L openssl`"
214fi
215%configure --enable-ipv6 --enable-unicode=%{unicode} --enable-shared
216make OPT="$CFLAGS" %{?_smp_mflags}
217
218export LD_LIBRARY_PATH=$topdir
219export PATH="$topdir:$PATH"
220cp $topdir/python $topdir/python%{pybasever}
221$topdir/python Tools/scripts/pathfix.py -i "/usr/bin/env python%{pybasever}" .
222make OPT="$CFLAGS" %{?_smp_mflags}
223
224# Doc
225%if %{with_doc}
226make %{?_smp_mflags} -C Doc
227rm Doc/html/index.html.in
228%endif
229
230# Test
231%if %{run_test}
232cp %{SOURCE7} ./
233cp %{SOURCE8} ./
234cp %{SOURCE9} ./
235cp %{SOURCE10} ./
236cp %{SOURCE11} ./
237cp %{SOURCE12} ./
238cp %{SOURCE13} ./
239cp %{SOURCE14} ./
240cp %{SOURCE15} ./
241cp %{SOURCE16} ./
242cp %{SOURCE17} ./
243cp %{SOURCE18} ./
244cp %{SOURCE19} ./
245cp %{SOURCE20} ./
246# This runs the test set twice (once with no compiled files, once with
247# the compiled files left by the previous test run).
248export LD_LIBRARY_PATH=$topdir
249export PYTHONHOME=$topdir
250export PYTHONPATH=$topdir/Lib:$topdir/Lib/test:$topdir/Lib/lib-tk:$topdir/Lib/site-packages:$topdir/Modules:$topdir/build/lib.linux-%{_host_cpu}-%{pybasever}
251
252find ./Lib -name '*.py[co]' -print | xargs rm -f
253./python -tt ./Lib/test/regrtest.py -l
254./python -tt ./Lib/test/regrtest.py -l
255#./python -tt ./Lib/test/test_bsddb.py -l
256#./python -tt ./Lib/test/test_bsddb.py -l
257%endif
258
259
260%install
261rm -fr $RPM_BUILD_ROOT
262mkdir -p $RPM_BUILD_ROOT/usr $RPM_BUILD_ROOT%{_mandir}
263
264# Clean up patched .py files that are saved as .lib64
265for f in distutils/command/install distutils/sysconfig; do
266    rm -f Lib/$f.py.lib64
267done
268
269make DESTDIR=$RPM_BUILD_ROOT install
270
271# Fix the interpreter path in binaries installed by distutils
272# (which changes them by itself)
273# Make sure we preserve the file permissions
274for fixed in $RPM_BUILD_ROOT/usr/bin/pydoc; do
275    sed 's,#!.*/python$,#!/usr/bin/env python%{pybasever},' $fixed > $fixed- \
276        && cat $fixed- > $fixed && rm -f $fixed-
277done
278
279# tools
280mkdir -p $RPM_BUILD_ROOT%{python_lib}/site-packages
281
282echo "#!/bin/bash
283exec %{python_lib}/site-packages/pynche/pynche" \
284        > $RPM_BUILD_ROOT/usr/bin/pynche%{pybasever}
285chmod 755 $RPM_BUILD_ROOT/usr/bin/pynche%{pybasever}
286
287echo "#!/bin/bash
288exec %{python_lib}/site-packages/modulator/modulator.py" \
289        > $RPM_BUILD_ROOT/usr/bin/modulator%{pybasever}
290chmod 755 $RPM_BUILD_ROOT/usr/bin/modulator%{pybasever}
291
292# idle
293mkdir -p $RPM_BUILD_ROOT%{python_lib}/site-packages/idle
294install -m 755 ./Lib/idlelib/idle.py $RPM_BUILD_ROOT%{python_lib}/site-packages/idle
295
296sed "s/python/&%{pybasever}/" $RPM_BUILD_ROOT/usr/bin/idle > $RPM_BUILD_ROOT/usr/bin/idle%{pybasever}
297chmod 755 $RPM_BUILD_ROOT/usr/bin/idle%{pybasever}
298
299install -m755 $RPM_BUILD_ROOT%{_bindir}/pydoc $RPM_BUILD_ROOT%{_bindir}/pydoc%{pybasever}
300install -m755 $RPM_BUILD_ROOT%{_bindir}/smtpd.py $RPM_BUILD_ROOT%{_bindir}/smtpd%{pybasever}.py
301
302#modulator
303cp -r Tools/modulator ${RPM_BUILD_ROOT}%{python_lib}/site-packages/
304
305#pynche
306rm -f Tools/pynche/*.pyw
307cp -r Tools/pynche $RPM_BUILD_ROOT%{python_lib}/site-packages/
308
309(mv Tools/modulator/README Tools/modulator/README.modulator)
310(mv Tools/pynche/README Tools/pynche/README.pynche)
311
312#gettext
313install -m755  Tools/i18n/pygettext.py $RPM_BUILD_ROOT/usr/bin/pygettext%{pybasever}.py
314install -m755  Tools/i18n/msgfmt.py $RPM_BUILD_ROOT/usr/bin/msgfmt%{pybasever}.py
315
316# Get rid of crap
317find $RPM_BUILD_ROOT/ -name "*~"|xargs rm -f
318find $RPM_BUILD_ROOT/ -name ".cvsignore"|xargs rm -f
319find . -name "*~"|xargs rm -f
320find . -name ".cvsignore"|xargs rm -f
321#zero length
322rm -f $RPM_BUILD_ROOT%{python_lib}/site-packages/modulator/Templates/copyright
323
324# Clean up the testsuite - we don't need compiled files for it
325find $RPM_BUILD_ROOT%{python_lib}/test \
326    -name "*.pyc" -o -name "*.pyo" | xargs rm -f
327rm -f $RPM_BUILD_ROOT%{python_lib}/LICENSE.txt
328
329find $RPM_BUILD_ROOT%{python_lib}/lib-dynload -type f | grep -v _tkinter.so | sed "s|$RPM_BUILD_ROOT||" > dynfiles
330
331# Fix the file permissions
332chmod 755 $RPM_BUILD_ROOT%{python_lib}/lib-dynload/*.so
333chmod 755 $RPM_BUILD_ROOT%{_libdir}/libpython*.so.*
334find $RPM_BUILD_ROOT%{python_lib} -type f -name '*.py' | xargs chmod -x
335
336## remove unuse files
337rm -f $RPM_BUILD_ROOT%{_mandir}/man1/python*
338rm -f $RPM_BUILD_ROOT%{_bindir}/idle
339rm -f $RPM_BUILD_ROOT%{_bindir}/pydoc
340rm -f $RPM_BUILD_ROOT%{_bindir}/python
341rm -f $RPM_BUILD_ROOT%{_bindir}/python-config
342rm -f $RPM_BUILD_ROOT%{_bindir}/smtpd.py
343
344%clean
345rm -fr $RPM_BUILD_ROOT
346
347%files -f dynfiles
348%defattr(-, root, root)
349%doc LICENSE README
350%{_bindir}/python%{pybasever}
351%{_bindir}/python%{pybasever}-config
352%{_libdir}/libpython%{pybasever}.so*
353%dir %{python_lib}
354%dir %{python_lib}/lib-dynload
355%dir %{python_lib}/site-packages
356%{python_lib}/*.py*
357%{python_lib}/*.doc
358%{python_lib}/bsddb
359%{python_lib}/compiler
360%{python_lib}/ctypes
361%{python_lib}/curses
362%{python_lib}/distutils
363%{python_lib}/email
364%{python_lib}/encodings
365%{python_lib}/hotshot
366%{python_lib}/idlelib
367%{python_lib}/logging
368%{python_lib}/plat-linux2
369%{python_lib}/sqlite3
370%{python_lib}/wsgiref
371%{python_lib}/wsgiref.egg-info
372%{python_lib}/xml
373
374%files devel
375%defattr(-,root,root)
376%{_includedir}/*
377%{python_lib}/config
378%{python_lib}/test
379
380%files tools
381%defattr(-,root,root,755)
382%doc Tools/modulator/README.modulator
383%doc Tools/pynche/README.pynche
384%{python_lib}/site-packages
385%{_bindir}/idle%{pybasever}
386%{_bindir}/modulator%{pybasever}
387%{_bindir}/msgfmt%{pybasever}.py
388%{_bindir}/pydoc%{pybasever}
389%{_bindir}/pygettext%{pybasever}.py
390%{_bindir}/pynche%{pybasever}
391%{_bindir}/smtpd%{pybasever}.py
392
393%if %{with_doc}
394%files docs
395%defattr(-,root,root,755)
396%doc Misc/NEWS  Misc/README Misc/cheatsheet
397%doc Misc/HISTORY Doc/html
398%endif
399
400%files tkinter
401%defattr(-,root,root,755)
402%{python_lib}/lib-tk
403%{python_lib}/lib-dynload/_tkinter.so
404
405%changelog
406* Tue Apr 20 2010 Shu KONNO <owa@bg.wakwak.com> 2.5.5-2
407- added db46_headers.tar.gz
408- update Setup.dist{32,64}.patch
409- s/BuildPreReq/BuildRequires/
410
411* Mon Feb 01 2010 Shu KONNO <owa@bg.wakwak.com> 2.5.5-1
412- forked python to python25
413- renamed tkinter to python25-tkinter
414
415* Mon Feb 01 2010 Shu KONNO <owa@bg.wakwak.com> 2.5.5-1
416- updated python to 2.5.5
417
418* Wed May 06 2009 Shu KONNO <owa@bg.wakwak.com> 2.5.4-4vl5
419- added Python-2.5.4-{Setup,Setup64}.patch
420  - added _bsddb module
421  - dropt patch{0,9,10}
422
423* Sun May  3 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.4-3vl5
424- updated Patch0 for building with db-4.6.21
425
426* Thu Feb 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.4-2vl5
427- add patch10
428  - add -lcrypt for cryptmodule
429
430* Wed Dec 24 2008 Shu KONNO <owa@bg.wakwak.com> 2.5.4-1vl5
431- new upstream release
432- changed typo of summary(ja)
433
434* Sat Dec 20 2008 Shu KONNO <owa@bg.wakwak.com> 2.5.3-1vl5
435- new upstream release
436- dropt python-2.4.4_CVE-2007-4965.patch
437- dropt python-2.4.4_CVE-2008-1721.patch
438- dropt python-2.4.4-CVE-2008-1679.patch
439
440* Fri Jul 18 2008 Shu KONNO <owa@bg.wakwak.com> 2.5.2-1vl5
441- updated python to 2.5.2
442- added python-2.5.2-config.patch instead of python-2.5c1-config.patch
443- added python-2.5.2-config64.patch instead of python-2.4.3-config.lib64.patch
444- added python-2.5.2-lib64.patch instead of python-2.4.2-lib64.patch
445- added modules ctypes, sqlite3, and wsgiref
446- dropt modules lib-old
447- dropt python-2.4.4_CVE-2008-1887.patch
448- dropt python-2.4.4_CVE-2007-2052.patch
449- fixed the file permissions
450
451* Sun Jun 08 2008 Shu KONNO <owa@bg.wakwak.com> 2.4.5-1vl5
452- applied new versioning policy and spec in utf-8
453- added BuildPrereq: xorg-x11-devel
454- imported updates from Vine4.2
455        * Fri Apr 25 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.4-1.4vl4
456        - add patch120 for fix CVE-2008-1679 (added fix of CVE-2007-4965)
457        - add patch130 for fix CVE-2008-1887 (PyString_FromStringAndSize)
458        - add patch140 for fix CVE-2007-2052 (_localemodule.c off-by-one err)
459        * Mon Apr 21 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.4-1.3vl4
460        - add patch110 CVE-2008-1721 (zlib module)
461        - add remove unneeded files in Lib/test/
462        #- new versioning policy
463
464* Wed Mar 12 2008 Shu KONNO <owa@bg.wakwak.com> 2.4.5-0vl1
465- updated python to 2.4.5
466
467* Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.4-0vl7
468- rebuild with expat-2.0.1
469
470* Mon Feb 18 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.4-0vl6
471- fix typo on Patch0 (s/db-4.2/db-4.3/)
472
473* Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 2.4.4-0vl5
474- rebuild with tcl/tk-8.4.18
475
476* Sat Dec 01 2007 Shu KONNO <owa@bg.wakwak.com> 2.4.4-0vl4
477- imported updates from Vine4.2 Plus
478        * Thu Nov 01 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.4-0vl1.2
479        - add BuildPrereq: nkf
480        * Wed Oct 31 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.4-0vl1.1
481        - add patch100 for fix CVE-2007-4965 (imageop Module integer OF)
482
483* Sat Jun 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.4-0vl3
484- rebuilt with openssl-0.9.8e and tix-8.4.2
485- fixed spec file encoding
486
487* Wed May 09 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.4-0vl2
488- rebuilt with new toolchain and db4-4.3.x
489- modified Patch0 (s/db-4.2/db-4.3/)
490
491* Thu Oct 19 2006 Shu KONNO <owa@bg.wakwak.com> 2.4.4-0vl1
492- updated python to 2.4.4 (included security fix PSF-2006-001)
493- added japanese summary
494- updated patch8 (python-2.4.2-lib64.patch)
495- added patch9 (python-2.4.4c1-setup.lib64.patch)
496
497* Wed Sep 13 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.4.3-0vl4
498- change docs Group to Applications/Documentation. <BTS:VineLinux:163>
499
500* Fri Aug 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.4.3-0vl3
501- rebuild with readline-5.1 (x86_64)
502
503* Fri Apr 14 2006 Shu KONNO <owa@bg.wakwak.com> 2.4.3-0vl2
504- fixed python-2.4.3-config.patch cause undefined symbol: crypt
505
506* Thu Mar 30 2006 Shu KONNO <owa@bg.wakwak.com> 2.4.3-0vl1
507- updated python to 2.4.3
508- added python-2.4.3-config.patch instead of python-2.4.1c1-config.patch
509
510* Wed Feb 15 2006 Shu KONNO <owa@bg.wakwak.com> 2.4.2-0vl5
511- set permition of lib-dynload/*.so to 755
512- added without_doc option
513- rebuilt with x86_64
514
515* Thu Nov 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.2-0vl4
516- add run_test option
517
518* Fri Nov  4 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.2-0vl3.2
519- add BuildPrereq: bzip2-devel
520- arrange testing script
521
522* Wed Nov 02 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.2-0vl3.1
523- back to %%configure macro
524- change testing script
525
526* Mon Oct 31 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.2-0vl3
527- update Patch8 (VineSeed:10306)
528- use ./configure instead of %%configure script
529- add forgotten popd
530
531* Fri Oct 28 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.2-0vl2
532- add --enable-shared to confiugre option
533- add %%{_libdir}/libpython2.4.so* to python package
534- add LD_LIBRARY_PATH=$topdir to use pathfix.py
535- change build method of Doc
536- add files for make test
537- change install method
538
539* Wed Sep 28 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.2-0vl1
540- update python to 2.4.2 (final)
541
542* Wed Mar 30 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.1-0vl1
543- update python to 2.4.1 (final)
544
545* Sat Mar 19 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.1-0vl0.c2
546- update python to 2.4.1c2
547- moved all site-packages files to python-tools package
548
549* Sat Mar 12 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.1-0vl0.c1
550- update python to 2.4.1c1
551- droped aspython2 macros
552- droped japanese-codecs module
553- droped Source2 idle, now it's provided from original source
554- droped Source3 modulator, now it's generated in a spec file
555- droped Source4 pynche, now it's generated in a spec file
556- droped Python-2.3.3-buildroot-bytecode.patch
557- changed python-2.3.3-config2.patch to python-2.4.1c1-config.patch
558
559* Wed Feb 09 2005 Shu KONNO <owa@bg.wakwak.com> 2.3.5-0vl1
560- update python to 2.3.5
561
562* Fri Feb 04 2005 Shu KONNO <owa@bg.wakwak.com> 2.3.4-0vl6
563- add PSF-2005-001.patch
564
565* Wed Nov 17 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.4-0vl4
566- rebuilt
567
568* Wed Oct 13 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.3.4-0vl3
569- modified Patch0 and Patch8 (-ldb-4.0 -> -ldb-4.2)
570
571* Wed Oct 13 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.3.4-0vl2
572- rebuilt with db4-4.2.25
573
574* Thu May 27 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.4-0vl1
575- updated python to 2.3.4
576- fixed patch10, patch11
577
578* Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.3-0vl1
579- rebuild
580
581* Thu Apr 08 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.3-0vl0.3
582- updated python-2.3.3-config2.patch
583
584* Thu Apr 08 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.3-0vl0.2
585- added librarys 'logging, bsddb, idlelib' to /usr/lib/python2.3
586
587* Wed Apr 07 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.3-0vl0.1
588- updated python to 2.3.3
589- changed version code 2.2.3 to 2.3.3 in source{2,3,4}
590- updated config2.patch for 2.3.3
591- updated nowhatsnew.patch for 2.3.3
592- updated distutilrpm.patch in which tabstops have made indent error
593- updated buildroot-bytecode.patch for 2.3.3
594- deleted buildroot.patch which fixed in 2.3.3
595- changed Tools/idle with Lib/idlelib
596
597* Wed Mar 31 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.3-3vl3
598- rebuild with openssl-0.9.7d
599
600* Wed Mar 03 2004 Shu KONNO <owa@bg.wakwak.com> 2.2.3-3vl2
601- updated JapaneseCodecs to 1.4.10
602
603* Wed Jul 09 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.2.3-3vl1
604- synced with RawHide 2.2.3-3 (substantially source ver up)
605
606* Mon Mar 31 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.2.2-26vl1
607- rebuild with tcltk-8.4.2
608- synced with RawHide 2.2.2-26
609  * Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com>
610  - rebuilt
611
612  * Mon Feb 24 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-25
613  - Fixed bug #84886: pydoc dies when run w/o arguments
614  - Fixed bug #84205: add python shm module back (used to be shipped with 1.5.2)
615  - Fixed bug #84966: path in byte-compiled code still wrong
616
617  * Thu Feb 20 2003 Jeremy Katz <katzj@redhat.com> 2.2.2-23
618  - ftp uri's should be able to specify being rooted at the root instead of
619    where you login via ftp (#84692)
620
621  * Mon Feb 10 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-22
622  - Using newer Japanese codecs (1.4.9). Thanks to
623    Peter Bowen <pzb@datastacks.com> for pointing this out.
624
625  * Thu Feb  6 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-21
626  - Rebuild
627
628  * Wed Feb  5 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-20
629  - Release number bumped really high: turning on UCS4 (ABI compatibility
630    breakage)
631
632  * Fri Jan 31 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-13
633  - Attempt to look both in /usr/lib64 and /usr/lib/python2.2/site-packages/:
634    some work on python-2.2.2-lib64.patch
635
636  * Thu Jan 30 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-12
637  - Rebuild to incorporate the removal of .lib64 and - files.
638
639  * Thu Jan 30 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-11.7.3
640  - Fixed bug #82544: Errata removes most tools
641  - Fixed bug #82435: Python 2.2.2 errata breaks redhat-config-users
642  - Removed .lib64 and - files that get installed after we fix the multilib
643    .py files.
644
645  * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
646  - rebuilt
647
648  * Wed Jan 15 2003 Jens Petersen <petersen@redhat.com> 2.2.2-10
649  - rebuild to update tkinter's tcltk deps
650  - convert changelog to utf-8
651
652
653* Wed Jan 15 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.2-9vl0
654- rebuilt for Vine Linux against db4
655- obsolete python-base (which comes with python-2.2.1 of TestPkg)
656
657* Tue Jan  7 2003 Nalin Dahyabhai <nalin@redhat.com> 2.2.2-9
658- rebuild
659
660* Fri Jan  3 2003 Nalin Dahyabhai <nalin@redhat.com>
661- pick up OpenSSL cflags and ldflags from pkgconfig if available
662
663* Thu Jan  2 2003 Jeremy Katz <katzj@redhat.com> 2.2.2-8
664- urllib2 didn't support non-anonymous ftp.  add support based on how
665  urllib did it (#80676, #78168)
666
667* Mon Dec 16 2002 Mihai Ibanescu <misa@redhat.com> 2.2.2-7
668- Fix bug #79647 (Rebuild of SRPM fails if python isn't installed)
669- Added a bunch of missing BuildRequires found while fixing the
670  above-mentioned bug
671
672* Tue Dec 10 2002 Tim Powers <timp@redhat.com> 2.2.2-6
673- rebuild to fix broken tcltk deps for tkinter
674
675* Fri Nov 22 2002 Mihai Ibanescu <misa@redhat.com>
6762.2.2-3.7.3
677- Recompiled for 7.3 (to fix the -lcrypt bug)
678- Fix for the spurious error message at the end of the build (build-requires
679  gets confused by executable files starting with """"): make the tests
680  non-executable.
681
682* Wed Nov 20 2002 Mihai Ibanescu <misa@redhat.com>
6832.2.2-5
684- Fixed configuration patch to add -lcrypt when compiling cryptmodule.c
685
6862.2.2-4
687- Spec file change from Matt Wilson <msw@redhat.com> to disable linking
688  with the C++ compiler.
689
690* Mon Nov 11 2002 Mihai Ibanescu <misa@redhat.com>
6912.2.2-3.*
692- Merged patch from Karsten Hopp <karsten@redhat.de> from 2.2.1-17hammer to
693  use %%{_libdir}
694- Added XFree86-libs as BuildRequires (because of tkinter)
695- Fixed duplicate listing of plat-linux2
696- Fixed exclusion of lib-dynload/japanese
697- Added lib64 patch for the japanese codecs
698- Use setup magic instead of using tar directly on JapaneseCodecs
699
700* Tue Nov  5 2002 Mihai Ibanescu <misa@redhat.com>
7012.2.2-2
702- Fix #76912 (python-tools contains idle, which uses tkinter, but there is no
703  requirement of tkinter from python-tools).
704- Fix #74013 (rpm is missing the /usr/lib/python2.2/test directory)
705
706* Mon Nov  4 2002 Mihai Ibanescu <misa@redhat.com>
707- builds as python2 require a different libdb
708- changed the buildroot name of python to match python2 builds
709
710* Fri Nov  1 2002 Mihai Ibanescu <misa@redhat.com>
711- updated python to 2.2.2 and adjusted the patches accordingly
712
713* Mon Oct 21 2002 Mihai Ibanescu <misa@redhat.com>
714- Fix #53930 (Python-2.2.1-buildroot-bytecode.patch)
715- Added BuildPrereq dependency on gcc-c++
716
717* Fri Aug 30 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-17
718- security fix for _execvpe
719
720* Tue Aug 13 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-16
721- Fix  #71011,#71134, #58157
722
723* Wed Aug  7 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-15
724- Resurrect tkinter
725- Fix for distutils (#67671)
726- Fix #69962
727
728* Thu Jul 25 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-14
729- Obsolete tkinter/tkinter2 (#69838)
730
731* Tue Jul 23 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-13
732- Doc fixes (#53951) - not on alpha at the momemt
733
734* Mon Jul  8 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-12
735- fix pydoc (#68082)
736
737* Mon Jul  8 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-11
738- Add db4-devel as a BuildPrereq
739
740* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 2.2.1-10
741- automated rebuild
742
743* Mon Jun 17 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-9
744- Add Japanese codecs (#66352)
745
746* Tue Jun 11 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-8
747- No more tkinter...
748
749* Wed May 29 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-7
750- Rebuild
751
752* Tue May 21 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-6
753- Add the email subcomponent (#65301)
754
755* Fri May 10 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-5
756- Rebuild
757
758* Thu May 02 2002 Than Ngo <than@redhat.com> 2.2.1-4
759- rebuild i new enviroment
760
761* Tue Apr 23 2002 Trond Eivind Glomsroed <teg@redhat.com>
762- Use ucs2, not ucs4, to avoid breaking tkinter (#63965)
763
764* Mon Apr 22 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-2
765- Make it use db4
766
767* Fri Apr 12 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-1
768- 2.2.1 - a bugfix-only release
769
770* Fri Apr 12 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-16
771- the same, but in builddirs - this will remove them from the
772  docs package, which doesn't look in the buildroot for files.
773
774* Fri Apr 12 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-15
775- Get rid of temporary files and .cvsignores included
776  in the tarball and make install
777
778* Fri Apr  5 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-14
779- Don't own lib-tk in main package, only in tkinter (#62753)
780
781* Mon Mar 25 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-13
782- rebuild
783
784* Mon Mar 25 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-12
785- rebuild
786
787* Fri Mar  1 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-11
788- Add a not to the Distutils obsoletes test (doh!)
789
790* Fri Mar  1 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-10
791- Rebuild
792
793* Mon Feb 25 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-9
794- Only obsolete Distutils when built as python
795
796* Thu Feb 21 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-8
797- Make files in /usr/bin install side by side with python 1.5 when
798- Drop explicit requirement of db4
799  built as python2
800
801* Thu Jan 31 2002 Elliot Lee <sopwith@redhat.com> 2.2-7
802- Use version and pybasever macros to make updating easy
803- Use _smp_mflags macro
804
805* Tue Jan 29 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-6
806- Add db4-devel to BuildPrereq
807
808* Fri Jan 25 2002 Nalin Dahyabhai <nalin@redhat.com> 2.2-5
809- disable ndbm support, which is db2 in disguise (really interesting things
810  can happen when you mix db2 and db4 in a single application)
811
812* Thu Jan 24 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-4
813- Obsolete subpackages if necesarry
814- provide versioned python2
815- build with db4
816
817* Wed Jan 16 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-3
818- Alpha toolchain broken. Disable build on alpha.
819- New openssl
820
821* Wed Dec 26 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-1
822- 2.2 final
823
824* Fri Dec 14 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.11c1
825- 2.2 RC 1
826- Don't include the _tkinter module in the main package - it's
827  already in the tkiter packace
828- Turn off the mpzmodule, something broke in the buildroot
829
830* Wed Nov 28 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.10b2
831- Use -fPIC for OPT as well, in lack of a proper libpython.so
832
833* Mon Nov 26 2001 Matt Wilson <msw@redhat.com> 2.2-0.9b2
834- changed DESTDIR to point to / so that distutils will install dynload
835  modules properly in the installroot
836
837* Fri Nov 16 2001 Matt Wilson <msw@redhat.com> 2.2-0.8b2
838- 2.2b2
839
840* Fri Oct 26 2001 Matt Wilson <msw@redhat.com> 2.2-0.7b1
841- python2ify
842
843* Fri Oct 19 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.5b1
844- 2.2b1
845
846* Sun Sep 30 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.4a4
847- 2.2a4
848- Enable UCS4 support
849- Enable IPv6
850- Provide distutils
851- Include msgfmt.py and pygettext.py
852
853* Fri Sep 14 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.3a3
854- Obsolete Distutils, which is now part of the main package
855- Obsolete python2
856
857* Thu Sep 13 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.2a3
858- Add docs, tools and tkinter subpackages, to match the 1.5 layout
859
860* Wed Sep 12 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.1a3
861- 2.2a3
862- don't build tix and blt extensions
863
864* Mon Aug 13 2001 Trond Eivind Glomsroed <teg@redhat.com>
865- Add tk and tix to build dependencies
866
867* Sat Jul 21 2001 Trond Eivind Glomsroed <teg@redhat.com>
868- 2.1.1 bugfix release - with a GPL compatible license
869
870* Fri Jul 20 2001 Trond Eivind Glomsroed <teg@redhat.com>
871- Add new build dependencies (#49753)
872
873* Tue Jun 26 2001 Nalin Dahyabhai <nalin@redhat.com>
874- build with -fPIC
875
876* Fri Jun  1 2001 Trond Eivind Glomsroed <teg@redhat.com>
877- 2.1
878- reorganization of file includes
879
880* Wed Dec 20 2000 Trond Eivind Glomsroed <teg@redhat.com>
881- fix the "requires" clause, it lacked a space causing problems
882- use %%{_tmppath}
883- don't define name, version etc
884- add the available patches from the Python home page
885
886* Fri Dec 15 2000 Matt Wilson <msw@redhat.com>
887- added devel subpackage
888
889* Fri Dec 15 2000 Matt Wilson <msw@redhat.com>
890- modify all files to use "python2.0" as the intrepter
891- don't build the Expat bindings
892- build against db1
893
894* Mon Oct 16 2000 Jeremy Hylton <jeremy@beopen.com>
895- updated for 2.0 final
896
897* Mon Oct  9 2000 Jeremy Hylton <jeremy@beopen.com>
898- updated for 2.0c1
899- build audioop, imageop, and rgbimg extension modules
900- include xml.parsers subpackage
901- add test.xml.out to files list
902
903* Thu Oct  5 2000 Jeremy Hylton <jeremy@beopen.com>
904- added bin/python2.0 to files list (suggested by Martin v. Loewis)
905
906* Tue Sep 26 2000 Jeremy Hylton <jeremy@beopen.com>
907- updated for release 1 of 2.0b2
908- use .bz2 version of Python source
909
910* Tue Sep 12 2000 Jeremy Hylton <jeremy@beopen.com>
911- Version 2 of 2.0b1
912- Make the package relocatable.  Thanks to Suchandra Thapa.
913- Exclude Tkinter from main RPM.  If it is in a separate RPM, it is
914  easier to track Tk releases.
Note: See TracBrowser for help on using the repository browser.