source: projects/specs/trunk/p/python25/python25-vl.spec @ 521

Revision 521, 30.1 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1# If you want to run test, add "--define '_run_test 1'" to rpm option
2%define run_test %{?_run_test:1}%{!?_run_test:0}
3%define with_doc %{?_without_doc:1}%{!?_without_doc:0}
4%define unicode  ucs4
5%define tcl_major 8.4
6%define tk_major 8.4
7%define tix_major 8.4
8%define pybasever 2.5
9%define python_lib %{_libdir}/python%{pybasever}
10
11Summary: An interpreted, interactive, object-oriented programming language.
12Summary(ja): オブジェクト指向言語 Python インタプリタ
13Name: python25
14Version: %{pybasever}.5
15Release: 1%{?_dist_release}
16License: PSF - see LICENSE
17Group: Development/Languages
18URL: http://www.python.org/%{pybasever}/
19Source0: http://www.python.org/ftp/python/%{version}/Python-%{version}.tar.bz2
20Source6: shmmodule.c
21# For TEST
22Source7: http://people.freebsd.org/~perky/i18n/EUC-CN.TXT
23Source8: http://www.unicode.org/Public/MAPPINGS/VENDORS/MICSFT/WINDOWS/CP936.TXT
24Source9: http://people.freebsd.org/~perky/i18n/BIG5HKSCS.TXT
25Source10: http://www.unicode.org/Public/MAPPINGS/VENDORS/MICSFT/WINDOWS/CP932.TXT
26Source11: http://people.freebsd.org/~perky/i18n/EUC-JP.TXT
27Source12: http://www.unicode.org/Public/MAPPINGS/OBSOLETE/EASTASIA/JIS/SHIFTJIS.TXT
28Source13: http://people.freebsd.org/~perky/i18n/EUC-JISX0213.TXT
29Source14: http://people.freebsd.org/~perky/i18n/SHIFT_JISX0213.TXT
30Source15: http://www.unicode.org/Public/MAPPINGS/VENDORS/MICSFT/WINDOWS/CP949.TXT
31Source16: http://people.freebsd.org/~perky/i18n/EUC-KR.TXT
32Source17: http://www.unicode.org/Public/MAPPINGS/OBSOLETE/EASTASIA/KSC/JOHAB.TXT
33Source18: http://www.unicode.org/Public/MAPPINGS/OBSOLETE/EASTASIA/OTHER/BIG5.TXT
34Source19: http://www.unicode.org/Public/MAPPINGS/VENDORS/MICSFT/WINDOWS/CP950.TXT
35Source20: http://www.unicode.org/Public/3.2-Update/NormalizationTest-3.2.0.txt
36
37#Patch0: python-2.5.2-config.patch
38Patch3: Python-2.2.1-pydocnogui.patch
39Patch4: Python-2.3.3-nowhatsnew.patch
40Patch5: Python-2.3.3-distutilrpm.patch
41Patch8: python-2.5.2-lib64.patch
42#Patch9: python-2.5.2-config64.patch
43#Patch10: python-2.5.4-libcrypt.patch
44
45# new Setup patchs include patch-{0, 9, 10}
46Patch11: Python-2.5.4-Setup.patch
47Patch12: Python-2.5.4-Setup64.patch
48
49# Security fixes
50#Patch100: python-2.4.4_CVE-2007-4965.patch
51#Patch110: python-2.4.4_CVE-2008-1721.patch
52#Patch120: python-2.4.4-CVE-2008-1679.patch
53#Patch130: python-2.4.4_CVE-2008-1887.patch
54#Patch140: python-2.4.4_CVE-2007-2052.patch
55
56Conflicts: python = 2.5
57Obsoletes: python2
58Obsoletes: Distutils
59Obsoletes: python-base
60Provides: Distutils
61
62BuildPrereq: db4-devel
63BuildPrereq: readline-devel, libtermcap-devel, openssl-devel, gmp-devel
64BuildPrereq: ncurses-devel, gdbm-devel, zlib-devel, expat-devel, tetex-latex
65BuildPrereq: tk tix gcc-c++ glibc-devel
66BuildPrereq: xorg-x11-devel mesa-libGL-devel
67BuildPrereq: gzip tar /usr/bin/find pkgconfig bzip2-devel
68BuildPrereq: nkf
69%if %{with_doc}
70BuildPrereq: latex2html
71%endif
72BuildRoot: %{_tmppath}/%{name}-%{version}-root
73
74
75%description
76Python is an interpreted, interactive, object-oriented programming
77language often compared to Tcl, Perl, Scheme or Java. Python includes
78modules, classes, exceptions, very high level dynamic data types and
79dynamic typing. Python supports interfaces to many system calls and
80libraries, as well as to various windowing systems (X11, Motif, Tk,
81Mac and MFC).
82
83Programmers can write new built-in modules for Python in C or C++.
84Python can be used as an extension language for applications that need
85a programmable interface. This package contains most of the standard
86Python modules, as well as modules for interfacing to the Tix widget
87set for Tk and RPM.
88
89Note that documentation for Python is provided in the python-docs
90package.
91
92%package devel
93Summary: The libraries and header files needed for Python development.
94Summary(ja): Python での開発に必要なライブラリやヘッダファイル
95Group: Development/Libraries
96Obsoletes: python2-devel
97
98%description devel
99The Python programming language's interpreter can be extended with
100dynamically loaded extensions and can be embedded in other programs.
101This package contains the header files and libraries needed to do
102these types of tasks.
103
104Install python-devel if you want to develop Python extensions.  The
105python package will also need to be installed.  You'll probably also
106want to install the python-docs package, which contains Python
107documentation.
108
109%package tools
110Summary: A collection of development tools included with Python.
111Summary(ja): Python に含まれる開発ツール一式
112Group: Development/Tools
113Requires: %{name} = %{version}
114Requires: %{name}-tkinter = %{version}
115Obsoletes: python2-tools
116
117%description tools
118The Python package includes several development tools that are used
119to build python programs.
120
121%package docs
122Summary: Documentation for the Python programming language.
123Summary(ja): Python プログラミング言語のドキュメント
124Group: Applications/Documentation
125Obsoletes: python2-docs
126
127%description docs
128The python-docs package contains documentation on the Python
129programming language and interpreter.  The documentation is provided
130in ASCII text files and in LaTeX source files.
131
132Install the python-docs package if you'd like to use the documentation
133for the Python language.
134
135%package tkinter
136Summary: A graphical user interface for the Python scripting language.
137Summary(ja): Python スクリプト言語のグラフィカルインターフェイス
138Group: Development/Languages
139Obsoletes: tkinter2
140BuildRequires: tcl, tk
141Requires: %{name} = %{version}
142Requires: tix
143
144%description tkinter
145The Tkinter (Tk interface) program is an graphical user interface for
146the Python scripting language.
147
148You should install the tkinter package if you'd like to use a graphical
149user interface for Python programming.
150
151%prep
152%setup -q -n Python-%{version}
153%patch3 -p1 -b .no_gui
154%patch4 -p1 -b .nowhatsnew
155%patch5 -p1
156
157%if %{_lib} == lib64
158%patch8 -p2 -b .lib64
159#%patch9 -p1 -b .config64
160%patch12 -p1 -b .Setup64
161%else
162#%patch0 -p1 -b .config
163%patch11 -p1 -b .Setup
164%endif
165
166#%patch10 -p1 -b .libcrypt
167
168# security fixes
169#%patch100 -p1 -b .CVE-2007-4965
170#%patch110 -p1 -b .CVE-2008-1721
171#%patch120 -p1 -b .CVE-2008-1679
172#%patch130 -p0 -b .CVE-2008-1887
173#%patch140 -p0 -b .CVE-2007-2052
174
175# remove unneeded files
176rm -vf Lib/test/test_*.py.CVE*
177rm -vf Lib/test/test_*.py.orig
178rm -vf Lib/test/test_*.py.org
179
180# Temporary workaround to avoid confusing find-requires: don't ship the tests
181# as executable files
182chmod 0644 Lib/test/test_*.py
183
184# shm module
185cp %{SOURCE6} Modules
186cat >> Modules/Setup.dist << EOF
187
188# Shared memory module
189shm shmmodule.c
190EOF
191
192# Fix library flags
193pushd Modules
194mv Setup.dist Setup.dist.in
195sed "s|-ltcl|-ltcl%{tcl_major}|" < Setup.dist.in |\
196sed "s|-ltk|-ltk%{tk_major}|" |\
197sed "s|-ltix|-ltix%{tix_major}|"  > Setup.dist
198rm -f Setup.dist.in
199popd
200
201
202%build
203topdir=`pwd`
204export CFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE -fPIC"
205export CXXFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE -fPIC"
206export OPT="$RPM_OPT_FLAGS -D_GNU_SOURCE -fPIC"
207export LINKCC="gcc"
208if pkg-config openssl ; then
209        export CFLAGS="$CFLAGS `pkg-config --cflags openssl`"
210        export LDFLAGS="$LDFLAGS `pkg-config --libs-only-L openssl`"
211fi
212%configure --enable-ipv6 --enable-unicode=%{unicode} --enable-shared
213make OPT="$CFLAGS" %{?_smp_mflags}
214
215export LD_LIBRARY_PATH=$topdir
216export PATH="$topdir:$PATH"
217cp $topdir/python $topdir/python%{pybasever}
218$topdir/python Tools/scripts/pathfix.py -i "/usr/bin/env python%{pybasever}" .
219make OPT="$CFLAGS" %{?_smp_mflags}
220
221# Doc
222%if %{with_doc}
223make %{?_smp_mflags} -C Doc
224rm Doc/html/index.html.in
225%endif
226
227# Test
228%if %{run_test}
229cp %{SOURCE7} ./
230cp %{SOURCE8} ./
231cp %{SOURCE9} ./
232cp %{SOURCE10} ./
233cp %{SOURCE11} ./
234cp %{SOURCE12} ./
235cp %{SOURCE13} ./
236cp %{SOURCE14} ./
237cp %{SOURCE15} ./
238cp %{SOURCE16} ./
239cp %{SOURCE17} ./
240cp %{SOURCE18} ./
241cp %{SOURCE19} ./
242cp %{SOURCE20} ./
243# This runs the test set twice (once with no compiled files, once with
244# the compiled files left by the previous test run).
245export LD_LIBRARY_PATH=$topdir
246export PYTHONHOME=$topdir
247export PYTHONPATH=$topdir/Lib:$topdir/Lib/test:$topdir/Lib/lib-tk:$topdir/Lib/site-packages:$topdir/Modules:$topdir/build/lib.linux-%{_host_cpu}-%{pybasever}
248
249find ./Lib -name '*.py[co]' -print | xargs rm -f
250./python -tt ./Lib/test/regrtest.py -l
251./python -tt ./Lib/test/regrtest.py -l
252#./python -tt ./Lib/test/test_bsddb.py -l
253#./python -tt ./Lib/test/test_bsddb.py -l
254%endif
255
256
257%install
258rm -fr $RPM_BUILD_ROOT
259mkdir -p $RPM_BUILD_ROOT/usr $RPM_BUILD_ROOT%{_mandir}
260
261# Clean up patched .py files that are saved as .lib64
262for f in distutils/command/install distutils/sysconfig; do
263    rm -f Lib/$f.py.lib64
264done
265
266make DESTDIR=$RPM_BUILD_ROOT install
267
268# Fix the interpreter path in binaries installed by distutils
269# (which changes them by itself)
270# Make sure we preserve the file permissions
271for fixed in $RPM_BUILD_ROOT/usr/bin/pydoc; do
272    sed 's,#!.*/python$,#!/usr/bin/env python%{pybasever},' $fixed > $fixed- \
273        && cat $fixed- > $fixed && rm -f $fixed-
274done
275
276# tools
277mkdir -p $RPM_BUILD_ROOT%{python_lib}/site-packages
278
279echo "#!/bin/bash
280exec %{python_lib}/site-packages/pynche/pynche" \
281        > $RPM_BUILD_ROOT/usr/bin/pynche%{pybasever}
282chmod 755 $RPM_BUILD_ROOT/usr/bin/pynche%{pybasever}
283
284echo "#!/bin/bash
285exec %{python_lib}/site-packages/modulator/modulator.py" \
286        > $RPM_BUILD_ROOT/usr/bin/modulator%{pybasever}
287chmod 755 $RPM_BUILD_ROOT/usr/bin/modulator%{pybasever}
288
289# idle
290mkdir -p $RPM_BUILD_ROOT%{python_lib}/site-packages/idle
291install -m 755 ./Lib/idlelib/idle.py $RPM_BUILD_ROOT%{python_lib}/site-packages/idle
292
293sed "s/python/&%{pybasever}/" $RPM_BUILD_ROOT/usr/bin/idle > $RPM_BUILD_ROOT/usr/bin/idle%{pybasever}
294chmod 755 $RPM_BUILD_ROOT/usr/bin/idle%{pybasever}
295
296install -m755 $RPM_BUILD_ROOT%{_bindir}/pydoc $RPM_BUILD_ROOT%{_bindir}/pydoc%{pybasever}
297install -m755 $RPM_BUILD_ROOT%{_bindir}/smtpd.py $RPM_BUILD_ROOT%{_bindir}/smtpd%{pybasever}.py
298
299#modulator
300cp -r Tools/modulator ${RPM_BUILD_ROOT}%{python_lib}/site-packages/
301
302#pynche
303rm -f Tools/pynche/*.pyw
304cp -r Tools/pynche $RPM_BUILD_ROOT%{python_lib}/site-packages/
305
306(mv Tools/modulator/README Tools/modulator/README.modulator)
307(mv Tools/pynche/README Tools/pynche/README.pynche)
308
309#gettext
310install -m755  Tools/i18n/pygettext.py $RPM_BUILD_ROOT/usr/bin/pygettext%{pybasever}.py
311install -m755  Tools/i18n/msgfmt.py $RPM_BUILD_ROOT/usr/bin/msgfmt%{pybasever}.py
312
313# Get rid of crap
314find $RPM_BUILD_ROOT/ -name "*~"|xargs rm -f
315find $RPM_BUILD_ROOT/ -name ".cvsignore"|xargs rm -f
316find . -name "*~"|xargs rm -f
317find . -name ".cvsignore"|xargs rm -f
318#zero length
319rm -f $RPM_BUILD_ROOT%{python_lib}/site-packages/modulator/Templates/copyright
320
321# Clean up the testsuite - we don't need compiled files for it
322find $RPM_BUILD_ROOT%{python_lib}/test \
323    -name "*.pyc" -o -name "*.pyo" | xargs rm -f
324rm -f $RPM_BUILD_ROOT%{python_lib}/LICENSE.txt
325
326find $RPM_BUILD_ROOT%{python_lib}/lib-dynload -type f | grep -v _tkinter.so | sed "s|$RPM_BUILD_ROOT||" > dynfiles
327
328# Fix the file permissions
329chmod 755 $RPM_BUILD_ROOT%{python_lib}/lib-dynload/*.so
330chmod 755 $RPM_BUILD_ROOT%{_libdir}/libpython*.so.*
331find $RPM_BUILD_ROOT%{python_lib} -type f -name '*.py' | xargs chmod -x
332
333## remove unuse files
334rm -f $RPM_BUILD_ROOT%{_mandir}/man1/python*
335rm -f $RPM_BUILD_ROOT%{_bindir}/idle
336rm -f $RPM_BUILD_ROOT%{_bindir}/pydoc
337rm -f $RPM_BUILD_ROOT%{_bindir}/python
338rm -f $RPM_BUILD_ROOT%{_bindir}/python-config
339rm -f $RPM_BUILD_ROOT%{_bindir}/smtpd.py
340
341%clean
342rm -fr $RPM_BUILD_ROOT
343
344%files -f dynfiles
345%defattr(-, root, root)
346%doc LICENSE README
347%{_bindir}/python%{pybasever}
348%{_bindir}/python%{pybasever}-config
349%{_libdir}/libpython%{pybasever}.so*
350%dir %{python_lib}
351%dir %{python_lib}/lib-dynload
352%dir %{python_lib}/site-packages
353%{python_lib}/*.py*
354%{python_lib}/*.doc
355%{python_lib}/bsddb
356%{python_lib}/compiler
357%{python_lib}/ctypes
358%{python_lib}/curses
359%{python_lib}/distutils
360%{python_lib}/email
361%{python_lib}/encodings
362%{python_lib}/hotshot
363%{python_lib}/idlelib
364%{python_lib}/logging
365%{python_lib}/plat-linux2
366%{python_lib}/sqlite3
367%{python_lib}/wsgiref
368%{python_lib}/wsgiref.egg-info
369%{python_lib}/xml
370
371%files devel
372%defattr(-,root,root)
373%{_includedir}/*
374%{python_lib}/config
375%{python_lib}/test
376
377%files tools
378%defattr(-,root,root,755)
379%doc Tools/modulator/README.modulator
380%doc Tools/pynche/README.pynche
381%{python_lib}/site-packages
382%{_bindir}/idle%{pybasever}
383%{_bindir}/modulator%{pybasever}
384%{_bindir}/msgfmt%{pybasever}.py
385%{_bindir}/pydoc%{pybasever}
386%{_bindir}/pygettext%{pybasever}.py
387%{_bindir}/pynche%{pybasever}
388%{_bindir}/smtpd%{pybasever}.py
389
390%if %{with_doc}
391%files docs
392%defattr(-,root,root,755)
393%doc Misc/NEWS  Misc/README Misc/cheatsheet
394%doc Misc/HISTORY Doc/html
395%endif
396
397%files tkinter
398%defattr(-,root,root,755)
399%{python_lib}/lib-tk
400%{python_lib}/lib-dynload/_tkinter.so
401
402%changelog
403* Mon Feb 01 2010 Shu KONNO <owa@bg.wakwak.com> 2.5.5-1
404- forked python to python25
405- renamed tkinter to python25-tkinter
406
407* Mon Feb 01 2010 Shu KONNO <owa@bg.wakwak.com> 2.5.5-1
408- updated python to 2.5.5
409
410* Wed May 06 2009 Shu KONNO <owa@bg.wakwak.com> 2.5.4-4vl5
411- added Python-2.5.4-{Setup,Setup64}.patch
412  - added _bsddb module
413  - dropt patch{0,9,10}
414
415* Sun May  3 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.4-3vl5
416- updated Patch0 for building with db-4.6.21
417
418* Thu Feb 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.4-2vl5
419- add patch10
420  - add -lcrypt for cryptmodule
421
422* Wed Dec 24 2008 Shu KONNO <owa@bg.wakwak.com> 2.5.4-1vl5
423- new upstream release
424- changed typo of summary(ja)
425
426* Sat Dec 20 2008 Shu KONNO <owa@bg.wakwak.com> 2.5.3-1vl5
427- new upstream release
428- dropt python-2.4.4_CVE-2007-4965.patch
429- dropt python-2.4.4_CVE-2008-1721.patch
430- dropt python-2.4.4-CVE-2008-1679.patch
431
432* Fri Jul 18 2008 Shu KONNO <owa@bg.wakwak.com> 2.5.2-1vl5
433- updated python to 2.5.2
434- added python-2.5.2-config.patch instead of python-2.5c1-config.patch
435- added python-2.5.2-config64.patch instead of python-2.4.3-config.lib64.patch
436- added python-2.5.2-lib64.patch instead of python-2.4.2-lib64.patch
437- added modules ctypes, sqlite3, and wsgiref
438- dropt modules lib-old
439- dropt python-2.4.4_CVE-2008-1887.patch
440- dropt python-2.4.4_CVE-2007-2052.patch
441- fixed the file permissions
442
443* Sun Jun 08 2008 Shu KONNO <owa@bg.wakwak.com> 2.4.5-1vl5
444- applied new versioning policy and spec in utf-8
445- added BuildPrereq: xorg-x11-devel
446- imported updates from Vine4.2
447        * Fri Apr 25 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.4-1.4vl4
448        - add patch120 for fix CVE-2008-1679 (added fix of CVE-2007-4965)
449        - add patch130 for fix CVE-2008-1887 (PyString_FromStringAndSize)
450        - add patch140 for fix CVE-2007-2052 (_localemodule.c off-by-one err)
451        * Mon Apr 21 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.4-1.3vl4
452        - add patch110 CVE-2008-1721 (zlib module)
453        - add remove unneeded files in Lib/test/
454        #- new versioning policy
455
456* Wed Mar 12 2008 Shu KONNO <owa@bg.wakwak.com> 2.4.5-0vl1
457- updated python to 2.4.5
458
459* Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.4-0vl7
460- rebuild with expat-2.0.1
461
462* Mon Feb 18 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.4-0vl6
463- fix typo on Patch0 (s/db-4.2/db-4.3/)
464
465* Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 2.4.4-0vl5
466- rebuild with tcl/tk-8.4.18
467
468* Sat Dec 01 2007 Shu KONNO <owa@bg.wakwak.com> 2.4.4-0vl4
469- imported updates from Vine4.2 Plus
470        * Thu Nov 01 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.4-0vl1.2
471        - add BuildPrereq: nkf
472        * Wed Oct 31 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.4-0vl1.1
473        - add patch100 for fix CVE-2007-4965 (imageop Module integer OF)
474
475* Sat Jun 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.4-0vl3
476- rebuilt with openssl-0.9.8e and tix-8.4.2
477- fixed spec file encoding
478
479* Wed May 09 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.4-0vl2
480- rebuilt with new toolchain and db4-4.3.x
481- modified Patch0 (s/db-4.2/db-4.3/)
482
483* Thu Oct 19 2006 Shu KONNO <owa@bg.wakwak.com> 2.4.4-0vl1
484- updated python to 2.4.4 (included security fix PSF-2006-001)
485- added japanese summary
486- updated patch8 (python-2.4.2-lib64.patch)
487- added patch9 (python-2.4.4c1-setup.lib64.patch)
488
489* Wed Sep 13 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.4.3-0vl4
490- change docs Group to Applications/Documentation. <BTS:VineLinux:163>
491
492* Fri Aug 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.4.3-0vl3
493- rebuild with readline-5.1 (x86_64)
494
495* Fri Apr 14 2006 Shu KONNO <owa@bg.wakwak.com> 2.4.3-0vl2
496- fixed python-2.4.3-config.patch cause undefined symbol: crypt
497
498* Thu Mar 30 2006 Shu KONNO <owa@bg.wakwak.com> 2.4.3-0vl1
499- updated python to 2.4.3
500- added python-2.4.3-config.patch instead of python-2.4.1c1-config.patch
501
502* Wed Feb 15 2006 Shu KONNO <owa@bg.wakwak.com> 2.4.2-0vl5
503- set permition of lib-dynload/*.so to 755
504- added without_doc option
505- rebuilt with x86_64
506
507* Thu Nov 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.2-0vl4
508- add run_test option
509
510* Fri Nov  4 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.2-0vl3.2
511- add BuildPrereq: bzip2-devel
512- arrange testing script
513
514* Wed Nov 02 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.2-0vl3.1
515- back to %%configure macro
516- change testing script
517
518* Mon Oct 31 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.2-0vl3
519- update Patch8 (VineSeed:10306)
520- use ./configure instead of %%configure script
521- add forgotten popd
522
523* Fri Oct 28 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.2-0vl2
524- add --enable-shared to confiugre option
525- add %%{_libdir}/libpython2.4.so* to python package
526- add LD_LIBRARY_PATH=$topdir to use pathfix.py
527- change build method of Doc
528- add files for make test
529- change install method
530
531* Wed Sep 28 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.2-0vl1
532- update python to 2.4.2 (final)
533
534* Wed Mar 30 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.1-0vl1
535- update python to 2.4.1 (final)
536
537* Sat Mar 19 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.1-0vl0.c2
538- update python to 2.4.1c2
539- moved all site-packages files to python-tools package
540
541* Sat Mar 12 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.1-0vl0.c1
542- update python to 2.4.1c1
543- droped aspython2 macros
544- droped japanese-codecs module
545- droped Source2 idle, now it's provided from original source
546- droped Source3 modulator, now it's generated in a spec file
547- droped Source4 pynche, now it's generated in a spec file
548- droped Python-2.3.3-buildroot-bytecode.patch
549- changed python-2.3.3-config2.patch to python-2.4.1c1-config.patch
550
551* Wed Feb 09 2005 Shu KONNO <owa@bg.wakwak.com> 2.3.5-0vl1
552- update python to 2.3.5
553
554* Fri Feb 04 2005 Shu KONNO <owa@bg.wakwak.com> 2.3.4-0vl6
555- add PSF-2005-001.patch
556
557* Wed Nov 17 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.4-0vl4
558- rebuilt
559
560* Wed Oct 13 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.3.4-0vl3
561- modified Patch0 and Patch8 (-ldb-4.0 -> -ldb-4.2)
562
563* Wed Oct 13 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.3.4-0vl2
564- rebuilt with db4-4.2.25
565
566* Thu May 27 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.4-0vl1
567- updated python to 2.3.4
568- fixed patch10, patch11
569
570* Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.3-0vl1
571- rebuild
572
573* Thu Apr 08 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.3-0vl0.3
574- updated python-2.3.3-config2.patch
575
576* Thu Apr 08 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.3-0vl0.2
577- added librarys 'logging, bsddb, idlelib' to /usr/lib/python2.3
578
579* Wed Apr 07 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.3-0vl0.1
580- updated python to 2.3.3
581- changed version code 2.2.3 to 2.3.3 in source{2,3,4}
582- updated config2.patch for 2.3.3
583- updated nowhatsnew.patch for 2.3.3
584- updated distutilrpm.patch in which tabstops have made indent error
585- updated buildroot-bytecode.patch for 2.3.3
586- deleted buildroot.patch which fixed in 2.3.3
587- changed Tools/idle with Lib/idlelib
588
589* Wed Mar 31 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.3-3vl3
590- rebuild with openssl-0.9.7d
591
592* Wed Mar 03 2004 Shu KONNO <owa@bg.wakwak.com> 2.2.3-3vl2
593- updated JapaneseCodecs to 1.4.10
594
595* Wed Jul 09 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.2.3-3vl1
596- synced with RawHide 2.2.3-3 (substantially source ver up)
597
598* Mon Mar 31 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.2.2-26vl1
599- rebuild with tcltk-8.4.2
600- synced with RawHide 2.2.2-26
601  * Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com>
602  - rebuilt
603
604  * Mon Feb 24 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-25
605  - Fixed bug #84886: pydoc dies when run w/o arguments
606  - Fixed bug #84205: add python shm module back (used to be shipped with 1.5.2)
607  - Fixed bug #84966: path in byte-compiled code still wrong
608
609  * Thu Feb 20 2003 Jeremy Katz <katzj@redhat.com> 2.2.2-23
610  - ftp uri's should be able to specify being rooted at the root instead of
611    where you login via ftp (#84692)
612
613  * Mon Feb 10 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-22
614  - Using newer Japanese codecs (1.4.9). Thanks to
615    Peter Bowen <pzb@datastacks.com> for pointing this out.
616
617  * Thu Feb  6 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-21
618  - Rebuild
619
620  * Wed Feb  5 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-20
621  - Release number bumped really high: turning on UCS4 (ABI compatibility
622    breakage)
623
624  * Fri Jan 31 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-13
625  - Attempt to look both in /usr/lib64 and /usr/lib/python2.2/site-packages/:
626    some work on python-2.2.2-lib64.patch
627
628  * Thu Jan 30 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-12
629  - Rebuild to incorporate the removal of .lib64 and - files.
630
631  * Thu Jan 30 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-11.7.3
632  - Fixed bug #82544: Errata removes most tools
633  - Fixed bug #82435: Python 2.2.2 errata breaks redhat-config-users
634  - Removed .lib64 and - files that get installed after we fix the multilib
635    .py files.
636
637  * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
638  - rebuilt
639
640  * Wed Jan 15 2003 Jens Petersen <petersen@redhat.com> 2.2.2-10
641  - rebuild to update tkinter's tcltk deps
642  - convert changelog to utf-8
643
644
645* Wed Jan 15 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.2-9vl0
646- rebuilt for Vine Linux against db4
647- obsolete python-base (which comes with python-2.2.1 of TestPkg)
648
649* Tue Jan  7 2003 Nalin Dahyabhai <nalin@redhat.com> 2.2.2-9
650- rebuild
651
652* Fri Jan  3 2003 Nalin Dahyabhai <nalin@redhat.com>
653- pick up OpenSSL cflags and ldflags from pkgconfig if available
654
655* Thu Jan  2 2003 Jeremy Katz <katzj@redhat.com> 2.2.2-8
656- urllib2 didn't support non-anonymous ftp.  add support based on how
657  urllib did it (#80676, #78168)
658
659* Mon Dec 16 2002 Mihai Ibanescu <misa@redhat.com> 2.2.2-7
660- Fix bug #79647 (Rebuild of SRPM fails if python isn't installed)
661- Added a bunch of missing BuildRequires found while fixing the
662  above-mentioned bug
663
664* Tue Dec 10 2002 Tim Powers <timp@redhat.com> 2.2.2-6
665- rebuild to fix broken tcltk deps for tkinter
666
667* Fri Nov 22 2002 Mihai Ibanescu <misa@redhat.com>
6682.2.2-3.7.3
669- Recompiled for 7.3 (to fix the -lcrypt bug)
670- Fix for the spurious error message at the end of the build (build-requires
671  gets confused by executable files starting with """"): make the tests
672  non-executable.
673
674* Wed Nov 20 2002 Mihai Ibanescu <misa@redhat.com>
6752.2.2-5
676- Fixed configuration patch to add -lcrypt when compiling cryptmodule.c
677
6782.2.2-4
679- Spec file change from Matt Wilson <msw@redhat.com> to disable linking
680  with the C++ compiler.
681
682* Mon Nov 11 2002 Mihai Ibanescu <misa@redhat.com>
6832.2.2-3.*
684- Merged patch from Karsten Hopp <karsten@redhat.de> from 2.2.1-17hammer to
685  use %%{_libdir}
686- Added XFree86-libs as BuildRequires (because of tkinter)
687- Fixed duplicate listing of plat-linux2
688- Fixed exclusion of lib-dynload/japanese
689- Added lib64 patch for the japanese codecs
690- Use setup magic instead of using tar directly on JapaneseCodecs
691
692* Tue Nov  5 2002 Mihai Ibanescu <misa@redhat.com>
6932.2.2-2
694- Fix #76912 (python-tools contains idle, which uses tkinter, but there is no
695  requirement of tkinter from python-tools).
696- Fix #74013 (rpm is missing the /usr/lib/python2.2/test directory)
697
698* Mon Nov  4 2002 Mihai Ibanescu <misa@redhat.com>
699- builds as python2 require a different libdb
700- changed the buildroot name of python to match python2 builds
701
702* Fri Nov  1 2002 Mihai Ibanescu <misa@redhat.com>
703- updated python to 2.2.2 and adjusted the patches accordingly
704
705* Mon Oct 21 2002 Mihai Ibanescu <misa@redhat.com>
706- Fix #53930 (Python-2.2.1-buildroot-bytecode.patch)
707- Added BuildPrereq dependency on gcc-c++
708
709* Fri Aug 30 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-17
710- security fix for _execvpe
711
712* Tue Aug 13 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-16
713- Fix  #71011,#71134, #58157
714
715* Wed Aug  7 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-15
716- Resurrect tkinter
717- Fix for distutils (#67671)
718- Fix #69962
719
720* Thu Jul 25 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-14
721- Obsolete tkinter/tkinter2 (#69838)
722
723* Tue Jul 23 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-13
724- Doc fixes (#53951) - not on alpha at the momemt
725
726* Mon Jul  8 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-12
727- fix pydoc (#68082)
728
729* Mon Jul  8 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-11
730- Add db4-devel as a BuildPrereq
731
732* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 2.2.1-10
733- automated rebuild
734
735* Mon Jun 17 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-9
736- Add Japanese codecs (#66352)
737
738* Tue Jun 11 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-8
739- No more tkinter...
740
741* Wed May 29 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-7
742- Rebuild
743
744* Tue May 21 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-6
745- Add the email subcomponent (#65301)
746
747* Fri May 10 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-5
748- Rebuild
749
750* Thu May 02 2002 Than Ngo <than@redhat.com> 2.2.1-4
751- rebuild i new enviroment
752
753* Tue Apr 23 2002 Trond Eivind Glomsroed <teg@redhat.com>
754- Use ucs2, not ucs4, to avoid breaking tkinter (#63965)
755
756* Mon Apr 22 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-2
757- Make it use db4
758
759* Fri Apr 12 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-1
760- 2.2.1 - a bugfix-only release
761
762* Fri Apr 12 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-16
763- the same, but in builddirs - this will remove them from the
764  docs package, which doesn't look in the buildroot for files.
765
766* Fri Apr 12 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-15
767- Get rid of temporary files and .cvsignores included
768  in the tarball and make install
769
770* Fri Apr  5 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-14
771- Don't own lib-tk in main package, only in tkinter (#62753)
772
773* Mon Mar 25 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-13
774- rebuild
775
776* Mon Mar 25 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-12
777- rebuild
778
779* Fri Mar  1 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-11
780- Add a not to the Distutils obsoletes test (doh!)
781
782* Fri Mar  1 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-10
783- Rebuild
784
785* Mon Feb 25 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-9
786- Only obsolete Distutils when built as python
787
788* Thu Feb 21 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-8
789- Make files in /usr/bin install side by side with python 1.5 when
790- Drop explicit requirement of db4
791  built as python2
792
793* Thu Jan 31 2002 Elliot Lee <sopwith@redhat.com> 2.2-7
794- Use version and pybasever macros to make updating easy
795- Use _smp_mflags macro
796
797* Tue Jan 29 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-6
798- Add db4-devel to BuildPrereq
799
800* Fri Jan 25 2002 Nalin Dahyabhai <nalin@redhat.com> 2.2-5
801- disable ndbm support, which is db2 in disguise (really interesting things
802  can happen when you mix db2 and db4 in a single application)
803
804* Thu Jan 24 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-4
805- Obsolete subpackages if necesarry
806- provide versioned python2
807- build with db4
808
809* Wed Jan 16 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-3
810- Alpha toolchain broken. Disable build on alpha.
811- New openssl
812
813* Wed Dec 26 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-1
814- 2.2 final
815
816* Fri Dec 14 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.11c1
817- 2.2 RC 1
818- Don't include the _tkinter module in the main package - it's
819  already in the tkiter packace
820- Turn off the mpzmodule, something broke in the buildroot
821
822* Wed Nov 28 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.10b2
823- Use -fPIC for OPT as well, in lack of a proper libpython.so
824
825* Mon Nov 26 2001 Matt Wilson <msw@redhat.com> 2.2-0.9b2
826- changed DESTDIR to point to / so that distutils will install dynload
827  modules properly in the installroot
828
829* Fri Nov 16 2001 Matt Wilson <msw@redhat.com> 2.2-0.8b2
830- 2.2b2
831
832* Fri Oct 26 2001 Matt Wilson <msw@redhat.com> 2.2-0.7b1
833- python2ify
834
835* Fri Oct 19 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.5b1
836- 2.2b1
837
838* Sun Sep 30 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.4a4
839- 2.2a4
840- Enable UCS4 support
841- Enable IPv6
842- Provide distutils
843- Include msgfmt.py and pygettext.py
844
845* Fri Sep 14 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.3a3
846- Obsolete Distutils, which is now part of the main package
847- Obsolete python2
848
849* Thu Sep 13 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.2a3
850- Add docs, tools and tkinter subpackages, to match the 1.5 layout
851
852* Wed Sep 12 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.1a3
853- 2.2a3
854- don't build tix and blt extensions
855
856* Mon Aug 13 2001 Trond Eivind Glomsroed <teg@redhat.com>
857- Add tk and tix to build dependencies
858
859* Sat Jul 21 2001 Trond Eivind Glomsroed <teg@redhat.com>
860- 2.1.1 bugfix release - with a GPL compatible license
861
862* Fri Jul 20 2001 Trond Eivind Glomsroed <teg@redhat.com>
863- Add new build dependencies (#49753)
864
865* Tue Jun 26 2001 Nalin Dahyabhai <nalin@redhat.com>
866- build with -fPIC
867
868* Fri Jun  1 2001 Trond Eivind Glomsroed <teg@redhat.com>
869- 2.1
870- reorganization of file includes
871
872* Wed Dec 20 2000 Trond Eivind Glomsroed <teg@redhat.com>
873- fix the "requires" clause, it lacked a space causing problems
874- use %%{_tmppath}
875- don't define name, version etc
876- add the available patches from the Python home page
877
878* Fri Dec 15 2000 Matt Wilson <msw@redhat.com>
879- added devel subpackage
880
881* Fri Dec 15 2000 Matt Wilson <msw@redhat.com>
882- modify all files to use "python2.0" as the intrepter
883- don't build the Expat bindings
884- build against db1
885
886* Mon Oct 16 2000 Jeremy Hylton <jeremy@beopen.com>
887- updated for 2.0 final
888
889* Mon Oct  9 2000 Jeremy Hylton <jeremy@beopen.com>
890- updated for 2.0c1
891- build audioop, imageop, and rgbimg extension modules
892- include xml.parsers subpackage
893- add test.xml.out to files list
894
895* Thu Oct  5 2000 Jeremy Hylton <jeremy@beopen.com>
896- added bin/python2.0 to files list (suggested by Martin v. Loewis)
897
898* Tue Sep 26 2000 Jeremy Hylton <jeremy@beopen.com>
899- updated for release 1 of 2.0b2
900- use .bz2 version of Python source
901
902* Tue Sep 12 2000 Jeremy Hylton <jeremy@beopen.com>
903- Version 2 of 2.0b1
904- Make the package relocatable.  Thanks to Suchandra Thapa.
905- Exclude Tkinter from main RPM.  If it is in a separate RPM, it is
906  easier to track Tk releases.
Note: See TracBrowser for help on using the repository browser.