source: projects/specs/trunk/p/python25/python25-vl.spec @ 1909

Revision 1909, 30.4 KB checked in by owa, 14 years ago (diff)

rebuilt with rpm-4.8.1

Line 
1# If you want to run test, add "--define '_run_test 1'" to rpm option
2%define run_test %{?_run_test:1}%{!?_run_test:0}
3%define with_doc %{?_without_doc:1}%{!?_without_doc:0}
4%define unicode  ucs4
5%define tcl_major 8.4
6%define tk_major 8.4
7%define tix_major 8.4
8%define pybasever 2.5
9%define python_lib %{_libdir}/python%{pybasever}
10Packager: owa
11
12Summary: An interpreted, interactive, object-oriented programming language.
13Summary(ja): オブジェクト指向言語 Python インタプリタ
14Name: python25
15Version: %{pybasever}.5
16Release: 3%{?_dist_release}
17License: PSF - see LICENSE
18Group: Development/Languages
19URL: http://www.python.org/%{pybasever}/
20Source0: http://www.python.org/ftp/python/%{version}/Python-%{version}.tar.bz2
21Source1: db46_headers.tar.gz
22Source6: shmmodule.c
23# For TEST
24Source7: http://people.freebsd.org/~perky/i18n/EUC-CN.TXT
25Source8: http://www.unicode.org/Public/MAPPINGS/VENDORS/MICSFT/WINDOWS/CP936.TXT
26Source9: http://people.freebsd.org/~perky/i18n/BIG5HKSCS.TXT
27Source10: http://www.unicode.org/Public/MAPPINGS/VENDORS/MICSFT/WINDOWS/CP932.TXT
28Source11: http://people.freebsd.org/~perky/i18n/EUC-JP.TXT
29Source12: http://www.unicode.org/Public/MAPPINGS/OBSOLETE/EASTASIA/JIS/SHIFTJIS.TXT
30Source13: http://people.freebsd.org/~perky/i18n/EUC-JISX0213.TXT
31Source14: http://people.freebsd.org/~perky/i18n/SHIFT_JISX0213.TXT
32Source15: http://www.unicode.org/Public/MAPPINGS/VENDORS/MICSFT/WINDOWS/CP949.TXT
33Source16: http://people.freebsd.org/~perky/i18n/EUC-KR.TXT
34Source17: http://www.unicode.org/Public/MAPPINGS/OBSOLETE/EASTASIA/KSC/JOHAB.TXT
35Source18: http://www.unicode.org/Public/MAPPINGS/OBSOLETE/EASTASIA/OTHER/BIG5.TXT
36Source19: http://www.unicode.org/Public/MAPPINGS/VENDORS/MICSFT/WINDOWS/CP950.TXT
37Source20: http://www.unicode.org/Public/3.2-Update/NormalizationTest-3.2.0.txt
38
39#Patch0: python-2.5.2-config.patch
40Patch3: Python-2.2.1-pydocnogui.patch
41Patch4: Python-2.3.3-nowhatsnew.patch
42Patch5: Python-2.3.3-distutilrpm.patch
43Patch8: python-2.5.2-lib64.patch
44#Patch9: python-2.5.2-config64.patch
45#Patch10: python-2.5.4-libcrypt.patch
46
47# new Setup patchs include patch-{0, 9, 10}
48Patch11: Python-2.5.4-Setup.patch
49Patch12: Python-2.5.4-Setup64.patch
50
51# Security fixes
52#Patch100: python-2.4.4_CVE-2007-4965.patch
53#Patch110: python-2.4.4_CVE-2008-1721.patch
54#Patch120: python-2.4.4-CVE-2008-1679.patch
55#Patch130: python-2.4.4_CVE-2008-1887.patch
56#Patch140: python-2.4.4_CVE-2007-2052.patch
57
58Conflicts: python = 2.5
59Obsoletes: python2
60Obsoletes: Distutils
61Obsoletes: python-base
62Provides: Distutils
63
64BuildRequires: db4-devel
65BuildRequires: readline-devel, libtermcap-devel, openssl-devel, gmp-devel
66#BuildRequires: ncurses-devel, gdbm-devel, zlib-devel, expat-devel, tetex-latex
67BuildRequires: ncurses-devel, gdbm-devel, zlib-devel, expat-devel
68BuildRequires: tk tix gcc-c++ glibc-devel
69BuildRequires: xorg-x11-devel mesa-libGL-devel
70BuildRequires: gzip tar /usr/bin/find pkgconfig bzip2-devel
71BuildRequires: nkf
72%if %{with_doc}
73BuildRequires: latex2html
74%endif
75BuildRoot: %{_tmppath}/%{name}-%{version}-root
76
77
78%description
79Python is an interpreted, interactive, object-oriented programming
80language often compared to Tcl, Perl, Scheme or Java. Python includes
81modules, classes, exceptions, very high level dynamic data types and
82dynamic typing. Python supports interfaces to many system calls and
83libraries, as well as to various windowing systems (X11, Motif, Tk,
84Mac and MFC).
85
86Programmers can write new built-in modules for Python in C or C++.
87Python can be used as an extension language for applications that need
88a programmable interface. This package contains most of the standard
89Python modules, as well as modules for interfacing to the Tix widget
90set for Tk and RPM.
91
92Note that documentation for Python is provided in the python-docs
93package.
94
95%package devel
96Summary: The libraries and header files needed for Python development.
97Summary(ja): Python での開発に必要なライブラリやヘッダファイル
98Group: Development/Libraries
99Obsoletes: python2-devel
100
101%description devel
102The Python programming language's interpreter can be extended with
103dynamically loaded extensions and can be embedded in other programs.
104This package contains the header files and libraries needed to do
105these types of tasks.
106
107Install python-devel if you want to develop Python extensions.  The
108python package will also need to be installed.  You'll probably also
109want to install the python-docs package, which contains Python
110documentation.
111
112%package tools
113Summary: A collection of development tools included with Python.
114Summary(ja): Python に含まれる開発ツール一式
115Group: Development/Tools
116Requires: %{name} = %{version}
117Requires: %{name}-tkinter = %{version}
118Obsoletes: python2-tools
119
120%description tools
121The Python package includes several development tools that are used
122to build python programs.
123
124%package docs
125Summary: Documentation for the Python programming language.
126Summary(ja): Python プログラミング言語のドキュメント
127Group: Applications/Documentation
128Obsoletes: python2-docs
129
130%description docs
131The python-docs package contains documentation on the Python
132programming language and interpreter.  The documentation is provided
133in ASCII text files and in LaTeX source files.
134
135Install the python-docs package if you'd like to use the documentation
136for the Python language.
137
138%package tkinter
139Summary: A graphical user interface for the Python scripting language.
140Summary(ja): Python スクリプト言語のグラフィカルインターフェイス
141Group: Development/Languages
142Obsoletes: tkinter2
143BuildRequires: tcl, tk
144Requires: %{name} = %{version}
145Requires: tix
146
147%description tkinter
148The Tkinter (Tk interface) program is an graphical user interface for
149the Python scripting language.
150
151You should install the tkinter package if you'd like to use a graphical
152user interface for Python programming.
153
154%prep
155%setup -q -n Python-%{version} -a 1
156%patch3 -p1 -b .no_gui
157%patch4 -p1 -b .nowhatsnew
158%patch5 -p1
159
160%if %{_lib} == lib64
161%patch8 -p2 -b .lib64
162#%patch9 -p1 -b .config64
163%patch12 -p1 -b .Setup64
164%else
165#%patch0 -p1 -b .config
166%patch11 -p1 -b .Setup
167%endif
168
169#%patch10 -p1 -b .libcrypt
170
171# security fixes
172#%patch100 -p1 -b .CVE-2007-4965
173#%patch110 -p1 -b .CVE-2008-1721
174#%patch120 -p1 -b .CVE-2008-1679
175#%patch130 -p0 -b .CVE-2008-1887
176#%patch140 -p0 -b .CVE-2007-2052
177
178# remove unneeded files
179rm -vf Lib/test/test_*.py.CVE*
180rm -vf Lib/test/test_*.py.orig
181rm -vf Lib/test/test_*.py.org
182
183# Temporary workaround to avoid confusing find-requires: don't ship the tests
184# as executable files
185chmod 0644 Lib/test/test_*.py
186
187# shm module
188cp %{SOURCE6} Modules
189cat >> Modules/Setup.dist << EOF
190
191# Shared memory module
192shm shmmodule.c
193EOF
194
195# Fix library flags
196pushd Modules
197mv Setup.dist Setup.dist.in
198sed "s|-ltcl|-ltcl%{tcl_major}|" < Setup.dist.in |\
199sed "s|-ltk|-ltk%{tk_major}|" |\
200sed "s|-ltix|-ltix%{tix_major}|"  > Setup.dist
201rm -f Setup.dist.in
202popd
203
204
205%build
206topdir=`pwd`
207export CFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE -fPIC"
208export CXXFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE -fPIC"
209export OPT="$RPM_OPT_FLAGS -D_GNU_SOURCE -fPIC"
210export LINKCC="gcc"
211if pkg-config openssl ; then
212        export CFLAGS="$CFLAGS `pkg-config --cflags openssl`"
213        export LDFLAGS="$LDFLAGS `pkg-config --libs-only-L openssl`"
214fi
215%configure --enable-ipv6 --enable-unicode=%{unicode} --enable-shared
216make OPT="$CFLAGS" %{?_smp_mflags}
217
218export LD_LIBRARY_PATH=$topdir
219export PATH="$topdir:$PATH"
220cp $topdir/python $topdir/python%{pybasever}
221$topdir/python Tools/scripts/pathfix.py -i "/usr/bin/env python%{pybasever}" .
222make OPT="$CFLAGS" %{?_smp_mflags}
223
224# Doc
225%if %{with_doc}
226make %{?_smp_mflags} -C Doc
227rm Doc/html/index.html.in
228%endif
229
230# Test
231%if %{run_test}
232cp %{SOURCE7} ./
233cp %{SOURCE8} ./
234cp %{SOURCE9} ./
235cp %{SOURCE10} ./
236cp %{SOURCE11} ./
237cp %{SOURCE12} ./
238cp %{SOURCE13} ./
239cp %{SOURCE14} ./
240cp %{SOURCE15} ./
241cp %{SOURCE16} ./
242cp %{SOURCE17} ./
243cp %{SOURCE18} ./
244cp %{SOURCE19} ./
245cp %{SOURCE20} ./
246# This runs the test set twice (once with no compiled files, once with
247# the compiled files left by the previous test run).
248export LD_LIBRARY_PATH=$topdir
249export PYTHONHOME=$topdir
250export PYTHONPATH=$topdir/Lib:$topdir/Lib/test:$topdir/Lib/lib-tk:$topdir/Lib/site-packages:$topdir/Modules:$topdir/build/lib.linux-%{_host_cpu}-%{pybasever}
251
252find ./Lib -name '*.py[co]' -print | xargs rm -f
253./python -tt ./Lib/test/regrtest.py -l
254./python -tt ./Lib/test/regrtest.py -l
255#./python -tt ./Lib/test/test_bsddb.py -l
256#./python -tt ./Lib/test/test_bsddb.py -l
257%endif
258
259
260%install
261rm -fr $RPM_BUILD_ROOT
262mkdir -p $RPM_BUILD_ROOT/usr $RPM_BUILD_ROOT%{_mandir}
263
264# Clean up patched .py files that are saved as .lib64
265for f in distutils/command/install distutils/sysconfig; do
266    rm -f Lib/$f.py.lib64
267done
268
269make DESTDIR=$RPM_BUILD_ROOT install
270
271# Fix the interpreter path in binaries installed by distutils
272# (which changes them by itself)
273# Make sure we preserve the file permissions
274for fixed in $RPM_BUILD_ROOT/usr/bin/pydoc; do
275    sed 's,#!.*/python$,#!/usr/bin/env python%{pybasever},' $fixed > $fixed- \
276        && cat $fixed- > $fixed && rm -f $fixed-
277done
278
279# tools
280mkdir -p $RPM_BUILD_ROOT%{python_lib}/site-packages
281
282echo "#!/bin/bash
283exec %{python_lib}/site-packages/pynche/pynche" \
284        > $RPM_BUILD_ROOT/usr/bin/pynche%{pybasever}
285chmod 755 $RPM_BUILD_ROOT/usr/bin/pynche%{pybasever}
286
287echo "#!/bin/bash
288exec %{python_lib}/site-packages/modulator/modulator.py" \
289        > $RPM_BUILD_ROOT/usr/bin/modulator%{pybasever}
290chmod 755 $RPM_BUILD_ROOT/usr/bin/modulator%{pybasever}
291
292# idle
293mkdir -p $RPM_BUILD_ROOT%{python_lib}/site-packages/idle
294install -m 755 ./Lib/idlelib/idle.py $RPM_BUILD_ROOT%{python_lib}/site-packages/idle
295
296sed "s/python/&%{pybasever}/" $RPM_BUILD_ROOT/usr/bin/idle > $RPM_BUILD_ROOT/usr/bin/idle%{pybasever}
297chmod 755 $RPM_BUILD_ROOT/usr/bin/idle%{pybasever}
298
299install -m755 $RPM_BUILD_ROOT%{_bindir}/pydoc $RPM_BUILD_ROOT%{_bindir}/pydoc%{pybasever}
300install -m755 $RPM_BUILD_ROOT%{_bindir}/smtpd.py $RPM_BUILD_ROOT%{_bindir}/smtpd%{pybasever}.py
301
302#modulator
303cp -r Tools/modulator ${RPM_BUILD_ROOT}%{python_lib}/site-packages/
304
305#pynche
306rm -f Tools/pynche/*.pyw
307cp -r Tools/pynche $RPM_BUILD_ROOT%{python_lib}/site-packages/
308
309(mv Tools/modulator/README Tools/modulator/README.modulator)
310(mv Tools/pynche/README Tools/pynche/README.pynche)
311
312#gettext
313install -m755  Tools/i18n/pygettext.py $RPM_BUILD_ROOT/usr/bin/pygettext%{pybasever}.py
314install -m755  Tools/i18n/msgfmt.py $RPM_BUILD_ROOT/usr/bin/msgfmt%{pybasever}.py
315
316# Get rid of crap
317find $RPM_BUILD_ROOT/ -name "*~"|xargs rm -f
318find $RPM_BUILD_ROOT/ -name ".cvsignore"|xargs rm -f
319find . -name "*~"|xargs rm -f
320find . -name ".cvsignore"|xargs rm -f
321#zero length
322rm -f $RPM_BUILD_ROOT%{python_lib}/site-packages/modulator/Templates/copyright
323
324# Clean up the testsuite - we don't need compiled files for it
325find $RPM_BUILD_ROOT%{python_lib}/test \
326    -name "*.pyc" -o -name "*.pyo" | xargs rm -f
327rm -f $RPM_BUILD_ROOT%{python_lib}/LICENSE.txt
328
329find $RPM_BUILD_ROOT%{python_lib}/lib-dynload -type f | grep -v _tkinter.so | sed "s|$RPM_BUILD_ROOT||" > dynfiles
330
331# Fix the file permissions
332chmod 755 $RPM_BUILD_ROOT%{python_lib}/lib-dynload/*.so
333chmod 755 $RPM_BUILD_ROOT%{_libdir}/libpython*.so.*
334find $RPM_BUILD_ROOT%{python_lib} -type f -name '*.py' | xargs chmod -x
335
336## remove unuse files
337rm -f $RPM_BUILD_ROOT%{_mandir}/man1/python*
338rm -f $RPM_BUILD_ROOT%{_bindir}/idle
339rm -f $RPM_BUILD_ROOT%{_bindir}/pydoc
340rm -f $RPM_BUILD_ROOT%{_bindir}/python
341rm -f $RPM_BUILD_ROOT%{_bindir}/python-config
342rm -f $RPM_BUILD_ROOT%{_bindir}/smtpd.py
343
344%clean
345rm -fr $RPM_BUILD_ROOT
346
347%files -f dynfiles
348%defattr(-, root, root)
349%doc LICENSE README
350%{_bindir}/python%{pybasever}
351%{_bindir}/python%{pybasever}-config
352%{_libdir}/libpython%{pybasever}.so*
353%dir %{python_lib}
354%dir %{python_lib}/lib-dynload
355%dir %{python_lib}/site-packages
356%{python_lib}/*.py*
357%{python_lib}/*.doc
358%{python_lib}/bsddb
359%{python_lib}/compiler
360%{python_lib}/ctypes
361%{python_lib}/curses
362%{python_lib}/distutils
363%{python_lib}/email
364%{python_lib}/encodings
365%{python_lib}/hotshot
366%{python_lib}/idlelib
367%{python_lib}/logging
368%{python_lib}/plat-linux2
369%{python_lib}/sqlite3
370%{python_lib}/wsgiref
371%{python_lib}/wsgiref.egg-info
372%{python_lib}/xml
373
374%files devel
375%defattr(-,root,root)
376%{_includedir}/*
377%{python_lib}/config
378%{python_lib}/test
379
380%files tools
381%defattr(-,root,root,755)
382%doc Tools/modulator/README.modulator
383%doc Tools/pynche/README.pynche
384%{python_lib}/site-packages
385%{_bindir}/idle%{pybasever}
386%{_bindir}/modulator%{pybasever}
387%{_bindir}/msgfmt%{pybasever}.py
388%{_bindir}/pydoc%{pybasever}
389%{_bindir}/pygettext%{pybasever}.py
390%{_bindir}/pynche%{pybasever}
391%{_bindir}/smtpd%{pybasever}.py
392
393%if %{with_doc}
394%files docs
395%defattr(-,root,root,755)
396%doc Misc/NEWS  Misc/README Misc/cheatsheet
397%doc Misc/HISTORY Doc/html
398%endif
399
400%files tkinter
401%defattr(-,root,root,755)
402%{python_lib}/lib-tk
403%{python_lib}/lib-dynload/_tkinter.so
404
405%changelog
406* Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 2.5.5-3
407- rebuilt with rpm-4.8.1 for pkg-config
408
409* Tue Apr 20 2010 Shu KONNO <owa@bg.wakwak.com> 2.5.5-2
410- added db46_headers.tar.gz
411- update Setup.dist{32,64}.patch
412- s/BuildPreReq/BuildRequires/
413
414* Mon Feb 01 2010 Shu KONNO <owa@bg.wakwak.com> 2.5.5-1
415- forked python to python25
416- renamed tkinter to python25-tkinter
417
418* Mon Feb 01 2010 Shu KONNO <owa@bg.wakwak.com> 2.5.5-1
419- updated python to 2.5.5
420
421* Wed May 06 2009 Shu KONNO <owa@bg.wakwak.com> 2.5.4-4vl5
422- added Python-2.5.4-{Setup,Setup64}.patch
423  - added _bsddb module
424  - dropt patch{0,9,10}
425
426* Sun May  3 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.4-3vl5
427- updated Patch0 for building with db-4.6.21
428
429* Thu Feb 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.4-2vl5
430- add patch10
431  - add -lcrypt for cryptmodule
432
433* Wed Dec 24 2008 Shu KONNO <owa@bg.wakwak.com> 2.5.4-1vl5
434- new upstream release
435- changed typo of summary(ja)
436
437* Sat Dec 20 2008 Shu KONNO <owa@bg.wakwak.com> 2.5.3-1vl5
438- new upstream release
439- dropt python-2.4.4_CVE-2007-4965.patch
440- dropt python-2.4.4_CVE-2008-1721.patch
441- dropt python-2.4.4-CVE-2008-1679.patch
442
443* Fri Jul 18 2008 Shu KONNO <owa@bg.wakwak.com> 2.5.2-1vl5
444- updated python to 2.5.2
445- added python-2.5.2-config.patch instead of python-2.5c1-config.patch
446- added python-2.5.2-config64.patch instead of python-2.4.3-config.lib64.patch
447- added python-2.5.2-lib64.patch instead of python-2.4.2-lib64.patch
448- added modules ctypes, sqlite3, and wsgiref
449- dropt modules lib-old
450- dropt python-2.4.4_CVE-2008-1887.patch
451- dropt python-2.4.4_CVE-2007-2052.patch
452- fixed the file permissions
453
454* Sun Jun 08 2008 Shu KONNO <owa@bg.wakwak.com> 2.4.5-1vl5
455- applied new versioning policy and spec in utf-8
456- added BuildPrereq: xorg-x11-devel
457- imported updates from Vine4.2
458        * Fri Apr 25 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.4-1.4vl4
459        - add patch120 for fix CVE-2008-1679 (added fix of CVE-2007-4965)
460        - add patch130 for fix CVE-2008-1887 (PyString_FromStringAndSize)
461        - add patch140 for fix CVE-2007-2052 (_localemodule.c off-by-one err)
462        * Mon Apr 21 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.4-1.3vl4
463        - add patch110 CVE-2008-1721 (zlib module)
464        - add remove unneeded files in Lib/test/
465        #- new versioning policy
466
467* Wed Mar 12 2008 Shu KONNO <owa@bg.wakwak.com> 2.4.5-0vl1
468- updated python to 2.4.5
469
470* Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.4-0vl7
471- rebuild with expat-2.0.1
472
473* Mon Feb 18 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.4-0vl6
474- fix typo on Patch0 (s/db-4.2/db-4.3/)
475
476* Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 2.4.4-0vl5
477- rebuild with tcl/tk-8.4.18
478
479* Sat Dec 01 2007 Shu KONNO <owa@bg.wakwak.com> 2.4.4-0vl4
480- imported updates from Vine4.2 Plus
481        * Thu Nov 01 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.4-0vl1.2
482        - add BuildPrereq: nkf
483        * Wed Oct 31 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.4-0vl1.1
484        - add patch100 for fix CVE-2007-4965 (imageop Module integer OF)
485
486* Sat Jun 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.4-0vl3
487- rebuilt with openssl-0.9.8e and tix-8.4.2
488- fixed spec file encoding
489
490* Wed May 09 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.4-0vl2
491- rebuilt with new toolchain and db4-4.3.x
492- modified Patch0 (s/db-4.2/db-4.3/)
493
494* Thu Oct 19 2006 Shu KONNO <owa@bg.wakwak.com> 2.4.4-0vl1
495- updated python to 2.4.4 (included security fix PSF-2006-001)
496- added japanese summary
497- updated patch8 (python-2.4.2-lib64.patch)
498- added patch9 (python-2.4.4c1-setup.lib64.patch)
499
500* Wed Sep 13 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.4.3-0vl4
501- change docs Group to Applications/Documentation. <BTS:VineLinux:163>
502
503* Fri Aug 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.4.3-0vl3
504- rebuild with readline-5.1 (x86_64)
505
506* Fri Apr 14 2006 Shu KONNO <owa@bg.wakwak.com> 2.4.3-0vl2
507- fixed python-2.4.3-config.patch cause undefined symbol: crypt
508
509* Thu Mar 30 2006 Shu KONNO <owa@bg.wakwak.com> 2.4.3-0vl1
510- updated python to 2.4.3
511- added python-2.4.3-config.patch instead of python-2.4.1c1-config.patch
512
513* Wed Feb 15 2006 Shu KONNO <owa@bg.wakwak.com> 2.4.2-0vl5
514- set permition of lib-dynload/*.so to 755
515- added without_doc option
516- rebuilt with x86_64
517
518* Thu Nov 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.2-0vl4
519- add run_test option
520
521* Fri Nov  4 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.2-0vl3.2
522- add BuildPrereq: bzip2-devel
523- arrange testing script
524
525* Wed Nov 02 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.2-0vl3.1
526- back to %%configure macro
527- change testing script
528
529* Mon Oct 31 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.2-0vl3
530- update Patch8 (VineSeed:10306)
531- use ./configure instead of %%configure script
532- add forgotten popd
533
534* Fri Oct 28 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.2-0vl2
535- add --enable-shared to confiugre option
536- add %%{_libdir}/libpython2.4.so* to python package
537- add LD_LIBRARY_PATH=$topdir to use pathfix.py
538- change build method of Doc
539- add files for make test
540- change install method
541
542* Wed Sep 28 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.2-0vl1
543- update python to 2.4.2 (final)
544
545* Wed Mar 30 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.1-0vl1
546- update python to 2.4.1 (final)
547
548* Sat Mar 19 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.1-0vl0.c2
549- update python to 2.4.1c2
550- moved all site-packages files to python-tools package
551
552* Sat Mar 12 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.1-0vl0.c1
553- update python to 2.4.1c1
554- droped aspython2 macros
555- droped japanese-codecs module
556- droped Source2 idle, now it's provided from original source
557- droped Source3 modulator, now it's generated in a spec file
558- droped Source4 pynche, now it's generated in a spec file
559- droped Python-2.3.3-buildroot-bytecode.patch
560- changed python-2.3.3-config2.patch to python-2.4.1c1-config.patch
561
562* Wed Feb 09 2005 Shu KONNO <owa@bg.wakwak.com> 2.3.5-0vl1
563- update python to 2.3.5
564
565* Fri Feb 04 2005 Shu KONNO <owa@bg.wakwak.com> 2.3.4-0vl6
566- add PSF-2005-001.patch
567
568* Wed Nov 17 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.4-0vl4
569- rebuilt
570
571* Wed Oct 13 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.3.4-0vl3
572- modified Patch0 and Patch8 (-ldb-4.0 -> -ldb-4.2)
573
574* Wed Oct 13 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.3.4-0vl2
575- rebuilt with db4-4.2.25
576
577* Thu May 27 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.4-0vl1
578- updated python to 2.3.4
579- fixed patch10, patch11
580
581* Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.3-0vl1
582- rebuild
583
584* Thu Apr 08 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.3-0vl0.3
585- updated python-2.3.3-config2.patch
586
587* Thu Apr 08 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.3-0vl0.2
588- added librarys 'logging, bsddb, idlelib' to /usr/lib/python2.3
589
590* Wed Apr 07 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.3-0vl0.1
591- updated python to 2.3.3
592- changed version code 2.2.3 to 2.3.3 in source{2,3,4}
593- updated config2.patch for 2.3.3
594- updated nowhatsnew.patch for 2.3.3
595- updated distutilrpm.patch in which tabstops have made indent error
596- updated buildroot-bytecode.patch for 2.3.3
597- deleted buildroot.patch which fixed in 2.3.3
598- changed Tools/idle with Lib/idlelib
599
600* Wed Mar 31 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.3-3vl3
601- rebuild with openssl-0.9.7d
602
603* Wed Mar 03 2004 Shu KONNO <owa@bg.wakwak.com> 2.2.3-3vl2
604- updated JapaneseCodecs to 1.4.10
605
606* Wed Jul 09 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.2.3-3vl1
607- synced with RawHide 2.2.3-3 (substantially source ver up)
608
609* Mon Mar 31 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.2.2-26vl1
610- rebuild with tcltk-8.4.2
611- synced with RawHide 2.2.2-26
612  * Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com>
613  - rebuilt
614
615  * Mon Feb 24 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-25
616  - Fixed bug #84886: pydoc dies when run w/o arguments
617  - Fixed bug #84205: add python shm module back (used to be shipped with 1.5.2)
618  - Fixed bug #84966: path in byte-compiled code still wrong
619
620  * Thu Feb 20 2003 Jeremy Katz <katzj@redhat.com> 2.2.2-23
621  - ftp uri's should be able to specify being rooted at the root instead of
622    where you login via ftp (#84692)
623
624  * Mon Feb 10 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-22
625  - Using newer Japanese codecs (1.4.9). Thanks to
626    Peter Bowen <pzb@datastacks.com> for pointing this out.
627
628  * Thu Feb  6 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-21
629  - Rebuild
630
631  * Wed Feb  5 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-20
632  - Release number bumped really high: turning on UCS4 (ABI compatibility
633    breakage)
634
635  * Fri Jan 31 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-13
636  - Attempt to look both in /usr/lib64 and /usr/lib/python2.2/site-packages/:
637    some work on python-2.2.2-lib64.patch
638
639  * Thu Jan 30 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-12
640  - Rebuild to incorporate the removal of .lib64 and - files.
641
642  * Thu Jan 30 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-11.7.3
643  - Fixed bug #82544: Errata removes most tools
644  - Fixed bug #82435: Python 2.2.2 errata breaks redhat-config-users
645  - Removed .lib64 and - files that get installed after we fix the multilib
646    .py files.
647
648  * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
649  - rebuilt
650
651  * Wed Jan 15 2003 Jens Petersen <petersen@redhat.com> 2.2.2-10
652  - rebuild to update tkinter's tcltk deps
653  - convert changelog to utf-8
654
655
656* Wed Jan 15 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.2-9vl0
657- rebuilt for Vine Linux against db4
658- obsolete python-base (which comes with python-2.2.1 of TestPkg)
659
660* Tue Jan  7 2003 Nalin Dahyabhai <nalin@redhat.com> 2.2.2-9
661- rebuild
662
663* Fri Jan  3 2003 Nalin Dahyabhai <nalin@redhat.com>
664- pick up OpenSSL cflags and ldflags from pkgconfig if available
665
666* Thu Jan  2 2003 Jeremy Katz <katzj@redhat.com> 2.2.2-8
667- urllib2 didn't support non-anonymous ftp.  add support based on how
668  urllib did it (#80676, #78168)
669
670* Mon Dec 16 2002 Mihai Ibanescu <misa@redhat.com> 2.2.2-7
671- Fix bug #79647 (Rebuild of SRPM fails if python isn't installed)
672- Added a bunch of missing BuildRequires found while fixing the
673  above-mentioned bug
674
675* Tue Dec 10 2002 Tim Powers <timp@redhat.com> 2.2.2-6
676- rebuild to fix broken tcltk deps for tkinter
677
678* Fri Nov 22 2002 Mihai Ibanescu <misa@redhat.com>
6792.2.2-3.7.3
680- Recompiled for 7.3 (to fix the -lcrypt bug)
681- Fix for the spurious error message at the end of the build (build-requires
682  gets confused by executable files starting with """"): make the tests
683  non-executable.
684
685* Wed Nov 20 2002 Mihai Ibanescu <misa@redhat.com>
6862.2.2-5
687- Fixed configuration patch to add -lcrypt when compiling cryptmodule.c
688
6892.2.2-4
690- Spec file change from Matt Wilson <msw@redhat.com> to disable linking
691  with the C++ compiler.
692
693* Mon Nov 11 2002 Mihai Ibanescu <misa@redhat.com>
6942.2.2-3.*
695- Merged patch from Karsten Hopp <karsten@redhat.de> from 2.2.1-17hammer to
696  use %%{_libdir}
697- Added XFree86-libs as BuildRequires (because of tkinter)
698- Fixed duplicate listing of plat-linux2
699- Fixed exclusion of lib-dynload/japanese
700- Added lib64 patch for the japanese codecs
701- Use setup magic instead of using tar directly on JapaneseCodecs
702
703* Tue Nov  5 2002 Mihai Ibanescu <misa@redhat.com>
7042.2.2-2
705- Fix #76912 (python-tools contains idle, which uses tkinter, but there is no
706  requirement of tkinter from python-tools).
707- Fix #74013 (rpm is missing the /usr/lib/python2.2/test directory)
708
709* Mon Nov  4 2002 Mihai Ibanescu <misa@redhat.com>
710- builds as python2 require a different libdb
711- changed the buildroot name of python to match python2 builds
712
713* Fri Nov  1 2002 Mihai Ibanescu <misa@redhat.com>
714- updated python to 2.2.2 and adjusted the patches accordingly
715
716* Mon Oct 21 2002 Mihai Ibanescu <misa@redhat.com>
717- Fix #53930 (Python-2.2.1-buildroot-bytecode.patch)
718- Added BuildPrereq dependency on gcc-c++
719
720* Fri Aug 30 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-17
721- security fix for _execvpe
722
723* Tue Aug 13 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-16
724- Fix  #71011,#71134, #58157
725
726* Wed Aug  7 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-15
727- Resurrect tkinter
728- Fix for distutils (#67671)
729- Fix #69962
730
731* Thu Jul 25 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-14
732- Obsolete tkinter/tkinter2 (#69838)
733
734* Tue Jul 23 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-13
735- Doc fixes (#53951) - not on alpha at the momemt
736
737* Mon Jul  8 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-12
738- fix pydoc (#68082)
739
740* Mon Jul  8 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-11
741- Add db4-devel as a BuildPrereq
742
743* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 2.2.1-10
744- automated rebuild
745
746* Mon Jun 17 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-9
747- Add Japanese codecs (#66352)
748
749* Tue Jun 11 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-8
750- No more tkinter...
751
752* Wed May 29 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-7
753- Rebuild
754
755* Tue May 21 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-6
756- Add the email subcomponent (#65301)
757
758* Fri May 10 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-5
759- Rebuild
760
761* Thu May 02 2002 Than Ngo <than@redhat.com> 2.2.1-4
762- rebuild i new enviroment
763
764* Tue Apr 23 2002 Trond Eivind Glomsroed <teg@redhat.com>
765- Use ucs2, not ucs4, to avoid breaking tkinter (#63965)
766
767* Mon Apr 22 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-2
768- Make it use db4
769
770* Fri Apr 12 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-1
771- 2.2.1 - a bugfix-only release
772
773* Fri Apr 12 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-16
774- the same, but in builddirs - this will remove them from the
775  docs package, which doesn't look in the buildroot for files.
776
777* Fri Apr 12 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-15
778- Get rid of temporary files and .cvsignores included
779  in the tarball and make install
780
781* Fri Apr  5 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-14
782- Don't own lib-tk in main package, only in tkinter (#62753)
783
784* Mon Mar 25 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-13
785- rebuild
786
787* Mon Mar 25 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-12
788- rebuild
789
790* Fri Mar  1 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-11
791- Add a not to the Distutils obsoletes test (doh!)
792
793* Fri Mar  1 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-10
794- Rebuild
795
796* Mon Feb 25 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-9
797- Only obsolete Distutils when built as python
798
799* Thu Feb 21 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-8
800- Make files in /usr/bin install side by side with python 1.5 when
801- Drop explicit requirement of db4
802  built as python2
803
804* Thu Jan 31 2002 Elliot Lee <sopwith@redhat.com> 2.2-7
805- Use version and pybasever macros to make updating easy
806- Use _smp_mflags macro
807
808* Tue Jan 29 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-6
809- Add db4-devel to BuildPrereq
810
811* Fri Jan 25 2002 Nalin Dahyabhai <nalin@redhat.com> 2.2-5
812- disable ndbm support, which is db2 in disguise (really interesting things
813  can happen when you mix db2 and db4 in a single application)
814
815* Thu Jan 24 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-4
816- Obsolete subpackages if necesarry
817- provide versioned python2
818- build with db4
819
820* Wed Jan 16 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-3
821- Alpha toolchain broken. Disable build on alpha.
822- New openssl
823
824* Wed Dec 26 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-1
825- 2.2 final
826
827* Fri Dec 14 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.11c1
828- 2.2 RC 1
829- Don't include the _tkinter module in the main package - it's
830  already in the tkiter packace
831- Turn off the mpzmodule, something broke in the buildroot
832
833* Wed Nov 28 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.10b2
834- Use -fPIC for OPT as well, in lack of a proper libpython.so
835
836* Mon Nov 26 2001 Matt Wilson <msw@redhat.com> 2.2-0.9b2
837- changed DESTDIR to point to / so that distutils will install dynload
838  modules properly in the installroot
839
840* Fri Nov 16 2001 Matt Wilson <msw@redhat.com> 2.2-0.8b2
841- 2.2b2
842
843* Fri Oct 26 2001 Matt Wilson <msw@redhat.com> 2.2-0.7b1
844- python2ify
845
846* Fri Oct 19 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.5b1
847- 2.2b1
848
849* Sun Sep 30 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.4a4
850- 2.2a4
851- Enable UCS4 support
852- Enable IPv6
853- Provide distutils
854- Include msgfmt.py and pygettext.py
855
856* Fri Sep 14 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.3a3
857- Obsolete Distutils, which is now part of the main package
858- Obsolete python2
859
860* Thu Sep 13 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.2a3
861- Add docs, tools and tkinter subpackages, to match the 1.5 layout
862
863* Wed Sep 12 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.1a3
864- 2.2a3
865- don't build tix and blt extensions
866
867* Mon Aug 13 2001 Trond Eivind Glomsroed <teg@redhat.com>
868- Add tk and tix to build dependencies
869
870* Sat Jul 21 2001 Trond Eivind Glomsroed <teg@redhat.com>
871- 2.1.1 bugfix release - with a GPL compatible license
872
873* Fri Jul 20 2001 Trond Eivind Glomsroed <teg@redhat.com>
874- Add new build dependencies (#49753)
875
876* Tue Jun 26 2001 Nalin Dahyabhai <nalin@redhat.com>
877- build with -fPIC
878
879* Fri Jun  1 2001 Trond Eivind Glomsroed <teg@redhat.com>
880- 2.1
881- reorganization of file includes
882
883* Wed Dec 20 2000 Trond Eivind Glomsroed <teg@redhat.com>
884- fix the "requires" clause, it lacked a space causing problems
885- use %%{_tmppath}
886- don't define name, version etc
887- add the available patches from the Python home page
888
889* Fri Dec 15 2000 Matt Wilson <msw@redhat.com>
890- added devel subpackage
891
892* Fri Dec 15 2000 Matt Wilson <msw@redhat.com>
893- modify all files to use "python2.0" as the intrepter
894- don't build the Expat bindings
895- build against db1
896
897* Mon Oct 16 2000 Jeremy Hylton <jeremy@beopen.com>
898- updated for 2.0 final
899
900* Mon Oct  9 2000 Jeremy Hylton <jeremy@beopen.com>
901- updated for 2.0c1
902- build audioop, imageop, and rgbimg extension modules
903- include xml.parsers subpackage
904- add test.xml.out to files list
905
906* Thu Oct  5 2000 Jeremy Hylton <jeremy@beopen.com>
907- added bin/python2.0 to files list (suggested by Martin v. Loewis)
908
909* Tue Sep 26 2000 Jeremy Hylton <jeremy@beopen.com>
910- updated for release 1 of 2.0b2
911- use .bz2 version of Python source
912
913* Tue Sep 12 2000 Jeremy Hylton <jeremy@beopen.com>
914- Version 2 of 2.0b1
915- Make the package relocatable.  Thanks to Suchandra Thapa.
916- Exclude Tkinter from main RPM.  If it is in a separate RPM, it is
917  easier to track Tk releases.
Note: See TracBrowser for help on using the repository browser.