source: projects/specs/trunk/p/python24/python24-vl.spec @ 872

Revision 872, 28.9 KB checked in by owa, 14 years ago (diff)

included db46 headers

Line 
1# If you want to run test, add "--define '_run_test 1'" to rpm option
2%define run_test %{?_run_test:1}%{!?_run_test:0}
3%define with_doc %{?_without_doc:1}%{!?_without_doc:0}
4%define unicode  ucs4
5%define tcl_major 8.4
6%define tk_major 8.4
7%define tix_major 8.4
8%define pybasever 2.4
9%define python_lib %{_libdir}/python%{pybasever}
10## as python24
11Packager: owa
12
13Summary: An interpreted, interactive, object-oriented programming language.
14Summary(ja): オブジェクト指向言語 Python2.4 インタプリタ
15Name: python24
16Version: 2.4.6
17Release: 3%{?_dist_release}
18License: PSF - see LICENSE
19Group: Development/Languages
20URL: http://www.python.org/2.4/
21Source0: Python-%{version}.tar.bz2
22Source1: db46_headers.tar.gz
23#Source6: http://gigue.peabody.jhu.edu/~mdboom/omi/source/shm_source/shmmodule.c
24Source6: shmmodule.c
25# For TEST
26Source7: http://people.freebsd.org/~perky/i18n/EUC-CN.TXT
27Source8: http://www.unicode.org/Public/MAPPINGS/VENDORS/MICSFT/WINDOWS/CP936.TXT
28Source9: http://people.freebsd.org/~perky/i18n/BIG5HKSCS.TXT
29Source10: http://www.unicode.org/Public/MAPPINGS/VENDORS/MICSFT/WINDOWS/CP932.TXT
30Source11: http://people.freebsd.org/~perky/i18n/EUC-JP.TXT
31Source12: http://www.unicode.org/Public/MAPPINGS/OBSOLETE/EASTASIA/JIS/SHIFTJIS.TXT
32Source13: http://people.freebsd.org/~perky/i18n/EUC-JISX0213.TXT
33Source14: http://people.freebsd.org/~perky/i18n/SHIFT_JISX0213.TXT
34Source15: http://www.unicode.org/Public/MAPPINGS/VENDORS/MICSFT/WINDOWS/CP949.TXT
35Source16: http://people.freebsd.org/~perky/i18n/EUC-KR.TXT
36Source17: http://www.unicode.org/Public/MAPPINGS/OBSOLETE/EASTASIA/KSC/JOHAB.TXT
37Source18: http://www.unicode.org/Public/MAPPINGS/OBSOLETE/EASTASIA/OTHER/BIG5.TXT
38Source19: http://www.unicode.org/Public/MAPPINGS/VENDORS/MICSFT/WINDOWS/CP950.TXT
39Source20: http://www.unicode.org/Public/3.2-Update/NormalizationTest-3.2.0.txt
40
41
42#Patch0: python-2.4.6-config.patch
43Patch3: Python-2.2.1-pydocnogui.patch
44Patch4: Python-2.3.3-nowhatsnew.patch
45Patch5: Python-2.3.3-distutilrpm.patch
46
47#Patch8: python-2.4.2-lib64.patch
48#Patch9: python-2.4.4c1-setup.lib64.patch
49Patch10: python-2.4.6-Setup.patch
50Patch11: python-2.4.6-Setup64.patch
51Patch12: python-2.4.6-lib64.patch
52Patch13: python-2.4.6-bsddb.patch
53
54# Security fixes
55Patch100: python-2.4.4_CVE-2007-4965.patch
56Patch110: python-2.4.4_CVE-2008-1721.patch
57Patch120: python-2.4.4-CVE-2008-1679.patch
58Patch130: python-2.4.4_CVE-2008-1887.patch
59Patch140: python-2.4.4_CVE-2007-2052.patch
60
61Obsoletes: python2
62Obsoletes: Distutils
63Obsoletes: python-base
64Provides: Distutils
65Provides: python2.4
66
67BuildRequires: db4-devel
68BuildRequires: readline-devel, libtermcap-devel, openssl-devel, gmp-devel
69BuildRequires: ncurses-devel, gdbm-devel, zlib-devel, expat-devel, tetex-latex
70BuildRequires: tk tix gcc-c++ glibc-devel
71BuildRequires: xorg-x11-devel mesa-libGL-devel
72BuildRequires: gzip tar /usr/bin/find pkgconfig bzip2-devel
73BuildRequires: nkf
74%if %{with_doc}
75BuildRequires: latex2html
76%endif
77BuildRoot: %{_tmppath}/%{name}-%{version}-root
78
79%description
80Python is an interpreted, interactive, object-oriented programming
81language often compared to Tcl, Perl, Scheme or Java. Python includes
82modules, classes, exceptions, very high level dynamic data types and
83dynamic typing. Python supports interfaces to many system calls and
84libraries, as well as to various windowing systems (X11, Motif, Tk,
85Mac and MFC).
86
87Programmers can write new built-in modules for Python in C or C++.
88Python can be used as an extension language for applications that need
89a programmable interface. This package contains most of the standard
90Python modules, as well as modules for interfacing to the Tix widget
91set for Tk and RPM.
92
93Note that documentation for Python is provided in the python-docs
94package.
95
96%package devel
97Summary: The libraries and header files needed for Python development.
98Summary(ja): Python での開発に必要なライブラリやヘッダファイル
99Group: Development/Libraries
100Obsoletes: python2-devel
101
102%description devel
103The Python programming language's interpreter can be extended with
104dynamically loaded extensions and can be embedded in other programs.
105This package contains the header files and libraries needed to do
106these types of tasks.
107
108Install python-devel if you want to develop Python extensions.  The
109python package will also need to be installed.  You'll probably also
110want to install the python-docs package, which contains Python
111documentation.
112
113%package tools
114Summary: A collection of development tools included with Python.
115Summary(ja): Python に含まれる開発ツール一式
116Group: Development/Tools
117Requires: %{name} = %{version}
118Requires: %{name}-tkinter = %{version}
119Obsoletes: python2-tools
120
121%description tools
122The Python package includes several development tools that are used
123to build python programs.
124
125%package docs
126Summary: Documentation for the Python programming language.
127Summary(ja): Python プログラミング言語のドキュメント
128Group: Applications/Documentation
129Obsoletes: python2-docs
130
131%description docs
132The python-docs package contains documentation on the Python
133programming language and interpreter.  The documentation is provided
134in ASCII text files and in LaTeX source files.
135
136Install the python-docs package if you'd like to use the documentation
137for the Python language.
138
139%package tkinter
140Summary: A graphical user interface for the Python scripting language.
141Summary(ja): Python スクリプト言語のグラフィカルインターフェイス
142Group: Development/Languages
143Obsoletes: tkinter2
144BuildRequires:  tcl, tk
145Requires: %{name} = %{version}
146Requires: tix
147
148%description tkinter
149The Tkinter (Tk interface) program is an graphical user interface for
150the Python scripting language.
151
152You should install the tkinter package if you'd like to use a graphical
153user interface for Python programming.
154
155%prep
156%setup -q -n Python-%{version} -a 1
157
158#%patch0 -p1 -b .Setup
159%patch3 -p1 -b .no_gui
160%patch4 -p1 -b .nowhatsnew
161%patch5 -p1
162
163%if %{_lib} == lib64
164%patch11 -p1 -b .Setup64
165%patch12 -p1 -b .lib64
166%else
167%patch10 -p1 -b .Setup
168%endif
169%patch13 -p1 -b .bsddb
170
171
172# security fixes
173#%patch100 -p1 -b .CVE-2007-4965
174#%patch110 -p1 -b .CVE-2008-1721
175#%patch120 -p1 -b .CVE-2008-1679
176#%patch130 -p0 -b .CVE-2008-1887
177%patch140 -p0 -b .CVE-2007-2052
178
179# remove unneeded files
180rm -vf Lib/test/test_*.py.CVE*
181rm -vf Lib/test/test_*.py.orig
182rm -vf Lib/test/test_*.py.org
183
184# Temporary workaround to avoid confusing find-requires: don't ship the tests
185# as executable files
186chmod 0644 Lib/test/test_*.py
187
188# shm module
189cp %{SOURCE6} Modules
190cat >> Modules/Setup.dist << EOF
191
192# Shared memory module
193shm shmmodule.c
194EOF
195
196# Fix library flags
197pushd Modules
198mv Setup.dist Setup.dist.in
199sed "s|-ltcl|-ltcl%{tcl_major}|" < Setup.dist.in |\
200sed "s|-ltk|-ltk%{tk_major}|" |\
201sed "s|-ltix|-ltix%{tix_major}|"  > Setup.dist
202rm -f Setup.dist.in
203popd
204
205
206%build
207topdir=`pwd`
208export CFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE -fPIC"
209export CXXFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE -fPIC"
210export OPT="$RPM_OPT_FLAGS -D_GNU_SOURCE -fPIC"
211export LINKCC="gcc"
212if pkg-config openssl ; then
213        export CFLAGS="$CFLAGS `pkg-config --cflags openssl`"
214        export LDFLAGS="$LDFLAGS `pkg-config --libs-only-L openssl`"
215fi
216%configure --enable-ipv6 --enable-unicode=%{unicode} --enable-shared
217
218make OPT="$CFLAGS" %{?_smp_mflags}
219LD_LIBRARY_PATH=$topdir $topdir/python Tools/scripts/pathfix.py -i "/usr/bin/env python%{pybasever}" .
220make OPT="$CFLAGS" %{?_smp_mflags}
221
222# Doc
223%if %{with_doc}
224make %{?_smp_mflags} -C Doc
225rm Doc/html/index.html.in
226%endif
227
228# Test
229%if %{run_test}
230cp %{SOURCE7} ./
231cp %{SOURCE8} ./
232cp %{SOURCE9} ./
233cp %{SOURCE10} ./
234cp %{SOURCE11} ./
235cp %{SOURCE12} ./
236cp %{SOURCE13} ./
237cp %{SOURCE14} ./
238cp %{SOURCE15} ./
239cp %{SOURCE16} ./
240cp %{SOURCE17} ./
241cp %{SOURCE18} ./
242cp %{SOURCE19} ./
243cp %{SOURCE20} ./
244# This runs the test set twice (once with no compiled files, once with
245# the compiled files left by the previous test run).
246export LD_LIBRARY_PATH=$topdir
247export PYTHONHOME=$topdir
248export PYTHONPATH=$topdir/Lib:$topdir/Lib/test:$topdir/Lib/lib-tk:$topdir/Lib/site-packages:$topdir/Modules:$topdir/build/lib.linux-%{_host_cpu}-%{pybasever}
249
250find ./Lib -name '*.py[co]' -print | xargs rm -f
251./python -tt ./Lib/test/regrtest.py -l
252./python -tt ./Lib/test/regrtest.py -l
253#./python -tt ./Lib/test/test_bsddb.py -l
254#./python -tt ./Lib/test/test_bsddb.py -l
255%endif
256
257
258%install
259rm -fr $RPM_BUILD_ROOT
260mkdir -p $RPM_BUILD_ROOT/usr $RPM_BUILD_ROOT%{_mandir}
261
262# Clean up patched .py files that are saved as .lib64
263for f in distutils/command/install distutils/sysconfig; do
264    rm -f Lib/$f.py.lib64
265done
266
267make DESTDIR=$RPM_BUILD_ROOT install
268
269# Fix the interpreter path in binaries installed by distutils
270# (which changes them by itself)
271# Make sure we preserve the file permissions
272for fixed in $RPM_BUILD_ROOT/usr/bin/pydoc; do
273    sed 's,#!.*/python$,#!/usr/bin/env python%{pybasever},' $fixed > $fixed- \
274        && cat $fixed- > $fixed && rm -f $fixed-
275done
276
277# tools
278mkdir -p $RPM_BUILD_ROOT%{python_lib}/site-packages
279
280echo "#!/bin/bash
281exec %{python_lib}/site-packages/pynche/pynche" \
282        > $RPM_BUILD_ROOT/usr/bin/pynche
283chmod 755 $RPM_BUILD_ROOT/usr/bin/pynche
284
285echo "#!/bin/bash
286exec %{python_lib}/site-packages/modulator/modulator.py" \
287        > $RPM_BUILD_ROOT/usr/bin/modulator
288chmod 755 $RPM_BUILD_ROOT/usr/bin/modulator
289
290# idle
291mkdir -p $RPM_BUILD_ROOT%{python_lib}/site-packages/idle
292install -m 755 ./Lib/idlelib/idle.py $RPM_BUILD_ROOT%{python_lib}/site-packages/idle
293mv $RPM_BUILD_ROOT/usr/bin/idle $RPM_BUILD_ROOT/idle
294sed "s/python/&%{pybasever}/" $RPM_BUILD_ROOT/idle > $RPM_BUILD_ROOT/usr/bin/idle
295chmod 755 $RPM_BUILD_ROOT/usr/bin/idle
296rm $RPM_BUILD_ROOT/idle
297
298#modulator
299cp -r Tools/modulator ${RPM_BUILD_ROOT}%{python_lib}/site-packages/
300
301#pynche
302rm -f Tools/pynche/*.pyw
303cp -r Tools/pynche $RPM_BUILD_ROOT%{python_lib}/site-packages/
304
305(mv Tools/modulator/README Tools/modulator/README.modulator)
306(mv Tools/pynche/README Tools/pynche/README.pynche)
307
308#gettext
309install -m755  Tools/i18n/pygettext.py $RPM_BUILD_ROOT/usr/bin/
310install -m755  Tools/i18n/msgfmt.py $RPM_BUILD_ROOT/usr/bin/
311
312# Get rid of crap
313find $RPM_BUILD_ROOT/ -name "*~"|xargs rm -f
314find $RPM_BUILD_ROOT/ -name ".cvsignore"|xargs rm -f
315find . -name "*~"|xargs rm -f
316find . -name ".cvsignore"|xargs rm -f
317#zero length
318rm -f $RPM_BUILD_ROOT%{python_lib}/site-packages/modulator/Templates/copyright
319
320# Clean up the testsuite - we don't need compiled files for it
321find $RPM_BUILD_ROOT%{python_lib}/test \
322    -name "*.pyc" -o -name "*.pyo" | xargs rm -f
323rm -f $RPM_BUILD_ROOT%{python_lib}/LICENSE.txt
324
325find $RPM_BUILD_ROOT%{python_lib}/lib-dynload -type f | grep -v _tkinter.so | sed "s|$RPM_BUILD_ROOT||" > dynfiles
326
327chmod 755 $RPM_BUILD_ROOT%{python_lib}/lib-dynload/*.so
328chmod 755 $RPM_BUILD_ROOT%{_libdir}/libpython*.so.*
329
330## move conflict files
331mkdir -p $RPM_BUILD_ROOT%{python_lib}/bin
332mv $RPM_BUILD_ROOT%{_bindir}/* $RPM_BUILD_ROOT%{python_lib}/bin
333mv $RPM_BUILD_ROOT%{python_lib}/bin/python%{pybasever} $RPM_BUILD_ROOT%{_bindir}/
334rm -rf $RPM_BUILD_ROOT%{_mandir}
335
336%clean
337rm -fr $RPM_BUILD_ROOT
338
339
340%files -f dynfiles
341%defattr(-, root, root)
342%doc LICENSE README
343%{_bindir}/python%{pybasever}
344%{_libdir}/libpython%{pybasever}.so*
345%dir %{python_lib}
346%dir %{python_lib}/bin
347%dir %{python_lib}/lib-dynload
348%dir %{python_lib}/site-packages
349%{python_lib}/bin/python
350%{python_lib}/*.py*
351%{python_lib}/*.doc
352%{python_lib}/bsddb
353%{python_lib}/compiler
354%{python_lib}/curses
355%{python_lib}/distutils
356%{python_lib}/email
357%{python_lib}/encodings
358%{python_lib}/hotshot
359%{python_lib}/idlelib
360%{python_lib}/lib-old
361%{python_lib}/logging
362%{python_lib}/plat-linux2
363%{python_lib}/xml
364#%{_mandir}/*/*
365
366%files devel
367%defattr(-,root,root)
368%{_includedir}/*
369%{python_lib}/config
370%{python_lib}/test
371
372%files tools
373%defattr(-,root,root,755)
374%doc Tools/modulator/README.modulator
375%doc Tools/pynche/README.pynche
376%exclude %{python_lib}/bin/python
377%{python_lib}/bin/*
378%{python_lib}/site-packages
379
380%if %{with_doc}
381%files docs
382%defattr(-,root,root,755)
383%doc Misc/NEWS  Misc/README Misc/cheatsheet
384%doc Misc/HISTORY Doc/html
385%endif
386
387%files tkinter
388%defattr(-,root,root,755)
389%{python_lib}/lib-tk
390%{python_lib}/lib-dynload/_tkinter.so
391
392%changelog
393* Tue Apr 20 2010 Shu KONNO <owa@bg.wakwak.com> python2.4-2.4.6-3
394- added db46_headers.tar.gz
395- update Setup.dist{32,64}.patch
396- changed default to '--without doc'
397- s/BuildPreReq/BuildRequires/
398
399* Thu May 07 2009 Shu KONNO <owa@bg.wakwak.com> python2.4-2.4.6-2vl5
400- added python-2.4.6-{Setup,Setup64,lib64}.patch
401  - added _bsddb module
402  - dropt Patch{0,8,9}
403- added python-2.4.6-bsddb.patch
404
405* Sat Dec 20 2008 Shu KONNO <owa@bg.wakwak.com> python2.4-2.4.6-1vl5
406- new upstream release
407- dropt python-2.4.4_CVE-2007-4965.patch
408- dropt python-2.4.4_CVE-2008-1721.patch
409- dropt python-2.4.4-CVE-2008-1679.patch
410- dropt python-2.4.4_CVE-2008-1887.patch
411
412* Wed Oct 22 2008 Shu KONNO <owa@bg.wakwak.com> python2.4-2.4.5-1vl5
413- new package name is %{name}
414- new sub-package name is %{name}-*
415
416* Sun Jun 08 2008 Shu KONNO <owa@bg.wakwak.com> 2.4.5-1vl5
417- applied new versioning policy and spec in utf-8
418- added BuildPrereq: xorg-x11-devel
419- imported updates from Vine4.2
420        * Fri Apr 25 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.4-1.4vl4
421        - add patch120 for fix CVE-2008-1679 (added fix of CVE-2007-4965)
422        - add patch130 for fix CVE-2008-1887 (PyString_FromStringAndSize)
423        - add patch140 for fix CVE-2007-2052 (_localemodule.c off-by-one err)
424        * Mon Apr 21 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.4-1.3vl4
425        - add patch110 CVE-2008-1721 (zlib module)
426        - add remove unneeded files in Lib/test/
427        #- new versioning policy
428
429* Wed Mar 12 2008 Shu KONNO <owa@bg.wakwak.com> 2.4.5-0vl1
430- updated python to 2.4.5
431
432* Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.4-0vl7
433- rebuild with expat-2.0.1
434
435* Mon Feb 18 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.4-0vl6
436- fix typo on Patch0 (s/db-4.2/db-4.3/)
437
438* Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 2.4.4-0vl5
439- rebuild with tcl/tk-8.4.18
440
441* Sat Dec 01 2007 Shu KONNO <owa@bg.wakwak.com> 2.4.4-0vl4
442- imported updates from Vine4.2 Plus
443        * Thu Nov 01 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.4-0vl1.2
444        - add BuildPrereq: nkf
445        * Wed Oct 31 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.4-0vl1.1
446        - add patch100 for fix CVE-2007-4965 (imageop Module integer OF)
447
448* Sat Jun 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.4-0vl3
449- rebuilt with openssl-0.9.8e and tix-8.4.2
450- fixed spec file encoding
451
452* Wed May 09 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.4-0vl2
453- rebuilt with new toolchain and db4-4.3.x
454- modified Patch0 (s/db-4.2/db-4.3/)
455
456* Thu Oct 19 2006 Shu KONNO <owa@bg.wakwak.com> 2.4.4-0vl1
457- updated python to 2.4.4 (included security fix PSF-2006-001)
458- added japanese summary
459- updated patch8 (python-2.4.2-lib64.patch)
460- added patch9 (python-2.4.4c1-setup.lib64.patch)
461
462* Wed Sep 13 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.4.3-0vl4
463- change docs Group to Applications/Documentation. <BTS:VineLinux:163>
464
465* Fri Aug 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.4.3-0vl3
466- rebuild with readline-5.1 (x86_64)
467
468* Fri Apr 14 2006 Shu KONNO <owa@bg.wakwak.com> 2.4.3-0vl2
469- fixed python-2.4.3-config.patch cause undefined symbol: crypt
470
471* Thu Mar 30 2006 Shu KONNO <owa@bg.wakwak.com> 2.4.3-0vl1
472- updated python to 2.4.3
473- added python-2.4.3-config.patch instead of python-2.4.1c1-config.patch
474
475* Wed Feb 15 2006 Shu KONNO <owa@bg.wakwak.com> 2.4.2-0vl5
476- set permition of lib-dynload/*.so to 755
477- added without_doc option
478- rebuilt with x86_64
479
480* Thu Nov 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.2-0vl4
481- add run_test option
482
483* Fri Nov  4 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.2-0vl3.2
484- add BuildPrereq: bzip2-devel
485- arrange testing script
486
487* Wed Nov 02 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.2-0vl3.1
488- back to %%configure macro
489- change testing script
490
491* Mon Oct 31 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.2-0vl3
492- update Patch8 (VineSeed:10306)
493- use ./configure instead of %%configure script
494- add forgotten popd
495
496* Fri Oct 28 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.2-0vl2
497- add --enable-shared to confiugre option
498- add %%{_libdir}/libpython2.4.so* to python package
499- add LD_LIBRARY_PATH=$topdir to use pathfix.py
500- change build method of Doc
501- add files for make test
502- change install method
503
504* Wed Sep 28 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.2-0vl1
505- update python to 2.4.2 (final)
506
507* Wed Mar 30 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.1-0vl1
508- update python to 2.4.1 (final)
509
510* Sat Mar 19 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.1-0vl0.c2
511- update python to 2.4.1c2
512- moved all site-packages files to python-tools package
513
514* Sat Mar 12 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.1-0vl0.c1
515- update python to 2.4.1c1
516- droped aspython2 macros
517- droped japanese-codecs module
518- droped Source2 idle, now it's provided from original source
519- droped Source3 modulator, now it's generated in a spec file
520- droped Source4 pynche, now it's generated in a spec file
521- droped Python-2.3.3-buildroot-bytecode.patch
522- changed python-2.3.3-config2.patch to python-2.4.1c1-config.patch
523
524* Wed Feb 09 2005 Shu KONNO <owa@bg.wakwak.com> 2.3.5-0vl1
525- update python to 2.3.5
526
527* Fri Feb 04 2005 Shu KONNO <owa@bg.wakwak.com> 2.3.4-0vl6
528- add PSF-2005-001.patch
529
530* Wed Nov 17 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.4-0vl4
531- rebuilt
532
533* Wed Oct 13 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.3.4-0vl3
534- modified Patch0 and Patch8 (-ldb-4.0 -> -ldb-4.2)
535
536* Wed Oct 13 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.3.4-0vl2
537- rebuilt with db4-4.2.25
538
539* Thu May 27 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.4-0vl1
540- updated python to 2.3.4
541- fixed patch10, patch11
542
543* Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.3-0vl1
544- rebuild
545
546* Thu Apr 08 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.3-0vl0.3
547- updated python-2.3.3-config2.patch
548
549* Thu Apr 08 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.3-0vl0.2
550- added librarys 'logging, bsddb, idlelib' to /usr/lib/python2.3
551
552* Wed Apr 07 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.3-0vl0.1
553- updated python to 2.3.3
554- changed version code 2.2.3 to 2.3.3 in source{2,3,4}
555- updated config2.patch for 2.3.3
556- updated nowhatsnew.patch for 2.3.3
557- updated distutilrpm.patch in which tabstops have made indent error
558- updated buildroot-bytecode.patch for 2.3.3
559- deleted buildroot.patch which fixed in 2.3.3
560- changed Tools/idle with Lib/idlelib
561
562* Wed Mar 31 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.3-3vl3
563- rebuild with openssl-0.9.7d
564
565* Wed Mar 03 2004 Shu KONNO <owa@bg.wakwak.com> 2.2.3-3vl2
566- updated JapaneseCodecs to 1.4.10
567
568* Wed Jul 09 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.2.3-3vl1
569- synced with RawHide 2.2.3-3 (substantially source ver up)
570
571* Mon Mar 31 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.2.2-26vl1
572- rebuild with tcltk-8.4.2
573- synced with RawHide 2.2.2-26
574  * Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com>
575  - rebuilt
576
577  * Mon Feb 24 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-25
578  - Fixed bug #84886: pydoc dies when run w/o arguments
579  - Fixed bug #84205: add python shm module back (used to be shipped with 1.5.2)
580  - Fixed bug #84966: path in byte-compiled code still wrong
581
582  * Thu Feb 20 2003 Jeremy Katz <katzj@redhat.com> 2.2.2-23
583  - ftp uri's should be able to specify being rooted at the root instead of
584    where you login via ftp (#84692)
585
586  * Mon Feb 10 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-22
587  - Using newer Japanese codecs (1.4.9). Thanks to
588    Peter Bowen <pzb@datastacks.com> for pointing this out.
589
590  * Thu Feb  6 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-21
591  - Rebuild
592
593  * Wed Feb  5 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-20
594  - Release number bumped really high: turning on UCS4 (ABI compatibility
595    breakage)
596
597  * Fri Jan 31 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-13
598  - Attempt to look both in /usr/lib64 and /usr/lib/python2.2/site-packages/:
599    some work on python-2.2.2-lib64.patch
600
601  * Thu Jan 30 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-12
602  - Rebuild to incorporate the removal of .lib64 and - files.
603
604  * Thu Jan 30 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-11.7.3
605  - Fixed bug #82544: Errata removes most tools
606  - Fixed bug #82435: Python 2.2.2 errata breaks redhat-config-users
607  - Removed .lib64 and - files that get installed after we fix the multilib
608    .py files.
609
610  * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
611  - rebuilt
612
613  * Wed Jan 15 2003 Jens Petersen <petersen@redhat.com> 2.2.2-10
614  - rebuild to update tkinter's tcltk deps
615  - convert changelog to utf-8
616
617
618* Wed Jan 15 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.2-9vl0
619- rebuilt for Vine Linux against db4
620- obsolete python-base (which comes with python-2.2.1 of TestPkg)
621
622* Tue Jan  7 2003 Nalin Dahyabhai <nalin@redhat.com> 2.2.2-9
623- rebuild
624
625* Fri Jan  3 2003 Nalin Dahyabhai <nalin@redhat.com>
626- pick up OpenSSL cflags and ldflags from pkgconfig if available
627
628* Thu Jan  2 2003 Jeremy Katz <katzj@redhat.com> 2.2.2-8
629- urllib2 didn't support non-anonymous ftp.  add support based on how
630  urllib did it (#80676, #78168)
631
632* Mon Dec 16 2002 Mihai Ibanescu <misa@redhat.com> 2.2.2-7
633- Fix bug #79647 (Rebuild of SRPM fails if python isn't installed)
634- Added a bunch of missing BuildRequires found while fixing the
635  above-mentioned bug
636
637* Tue Dec 10 2002 Tim Powers <timp@redhat.com> 2.2.2-6
638- rebuild to fix broken tcltk deps for tkinter
639
640* Fri Nov 22 2002 Mihai Ibanescu <misa@redhat.com>
6412.2.2-3.7.3
642- Recompiled for 7.3 (to fix the -lcrypt bug)
643- Fix for the spurious error message at the end of the build (build-requires
644  gets confused by executable files starting with """"): make the tests
645  non-executable.
646
647* Wed Nov 20 2002 Mihai Ibanescu <misa@redhat.com>
6482.2.2-5
649- Fixed configuration patch to add -lcrypt when compiling cryptmodule.c
650
6512.2.2-4
652- Spec file change from Matt Wilson <msw@redhat.com> to disable linking
653  with the C++ compiler.
654
655* Mon Nov 11 2002 Mihai Ibanescu <misa@redhat.com>
6562.2.2-3.*
657- Merged patch from Karsten Hopp <karsten@redhat.de> from 2.2.1-17hammer to
658  use %%{_libdir}
659- Added XFree86-libs as BuildRequires (because of tkinter)
660- Fixed duplicate listing of plat-linux2
661- Fixed exclusion of lib-dynload/japanese
662- Added lib64 patch for the japanese codecs
663- Use setup magic instead of using tar directly on JapaneseCodecs
664
665* Tue Nov  5 2002 Mihai Ibanescu <misa@redhat.com>
6662.2.2-2
667- Fix #76912 (python-tools contains idle, which uses tkinter, but there is no
668  requirement of tkinter from python-tools).
669- Fix #74013 (rpm is missing the /usr/lib/python2.2/test directory)
670
671* Mon Nov  4 2002 Mihai Ibanescu <misa@redhat.com>
672- builds as python2 require a different libdb
673- changed the buildroot name of python to match python2 builds
674
675* Fri Nov  1 2002 Mihai Ibanescu <misa@redhat.com>
676- updated python to 2.2.2 and adjusted the patches accordingly
677
678* Mon Oct 21 2002 Mihai Ibanescu <misa@redhat.com>
679- Fix #53930 (Python-2.2.1-buildroot-bytecode.patch)
680- Added BuildPrereq dependency on gcc-c++
681
682* Fri Aug 30 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-17
683- security fix for _execvpe
684
685* Tue Aug 13 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-16
686- Fix  #71011,#71134, #58157
687
688* Wed Aug  7 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-15
689- Resurrect tkinter
690- Fix for distutils (#67671)
691- Fix #69962
692
693* Thu Jul 25 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-14
694- Obsolete tkinter/tkinter2 (#69838)
695
696* Tue Jul 23 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-13
697- Doc fixes (#53951) - not on alpha at the momemt
698
699* Mon Jul  8 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-12
700- fix pydoc (#68082)
701
702* Mon Jul  8 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-11
703- Add db4-devel as a BuildPrereq
704
705* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 2.2.1-10
706- automated rebuild
707
708* Mon Jun 17 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-9
709- Add Japanese codecs (#66352)
710
711* Tue Jun 11 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-8
712- No more tkinter...
713
714* Wed May 29 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-7
715- Rebuild
716
717* Tue May 21 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-6
718- Add the email subcomponent (#65301)
719
720* Fri May 10 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-5
721- Rebuild
722
723* Thu May 02 2002 Than Ngo <than@redhat.com> 2.2.1-4
724- rebuild i new enviroment
725
726* Tue Apr 23 2002 Trond Eivind Glomsroed <teg@redhat.com>
727- Use ucs2, not ucs4, to avoid breaking tkinter (#63965)
728
729* Mon Apr 22 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-2
730- Make it use db4
731
732* Fri Apr 12 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-1
733- 2.2.1 - a bugfix-only release
734
735* Fri Apr 12 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-16
736- the same, but in builddirs - this will remove them from the
737  docs package, which doesn't look in the buildroot for files.
738
739* Fri Apr 12 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-15
740- Get rid of temporary files and .cvsignores included
741  in the tarball and make install
742
743* Fri Apr  5 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-14
744- Don't own lib-tk in main package, only in tkinter (#62753)
745
746* Mon Mar 25 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-13
747- rebuild
748
749* Mon Mar 25 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-12
750- rebuild
751
752* Fri Mar  1 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-11
753- Add a not to the Distutils obsoletes test (doh!)
754
755* Fri Mar  1 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-10
756- Rebuild
757
758* Mon Feb 25 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-9
759- Only obsolete Distutils when built as python
760
761* Thu Feb 21 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-8
762- Make files in /usr/bin install side by side with python 1.5 when
763- Drop explicit requirement of db4
764  built as python2
765
766* Thu Jan 31 2002 Elliot Lee <sopwith@redhat.com> 2.2-7
767- Use version and pybasever macros to make updating easy
768- Use _smp_mflags macro
769
770* Tue Jan 29 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-6
771- Add db4-devel to BuildPrereq
772
773* Fri Jan 25 2002 Nalin Dahyabhai <nalin@redhat.com> 2.2-5
774- disable ndbm support, which is db2 in disguise (really interesting things
775  can happen when you mix db2 and db4 in a single application)
776
777* Thu Jan 24 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-4
778- Obsolete subpackages if necesarry
779- provide versioned python2
780- build with db4
781
782* Wed Jan 16 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-3
783- Alpha toolchain broken. Disable build on alpha.
784- New openssl
785
786* Wed Dec 26 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-1
787- 2.2 final
788
789* Fri Dec 14 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.11c1
790- 2.2 RC 1
791- Don't include the _tkinter module in the main package - it's
792  already in the tkiter packace
793- Turn off the mpzmodule, something broke in the buildroot
794
795* Wed Nov 28 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.10b2
796- Use -fPIC for OPT as well, in lack of a proper libpython.so
797
798* Mon Nov 26 2001 Matt Wilson <msw@redhat.com> 2.2-0.9b2
799- changed DESTDIR to point to / so that distutils will install dynload
800  modules properly in the installroot
801
802* Fri Nov 16 2001 Matt Wilson <msw@redhat.com> 2.2-0.8b2
803- 2.2b2
804
805* Fri Oct 26 2001 Matt Wilson <msw@redhat.com> 2.2-0.7b1
806- python2ify
807
808* Fri Oct 19 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.5b1
809- 2.2b1
810
811* Sun Sep 30 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.4a4
812- 2.2a4
813- Enable UCS4 support
814- Enable IPv6
815- Provide distutils
816- Include msgfmt.py and pygettext.py
817
818* Fri Sep 14 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.3a3
819- Obsolete Distutils, which is now part of the main package
820- Obsolete python2
821
822* Thu Sep 13 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.2a3
823- Add docs, tools and tkinter subpackages, to match the 1.5 layout
824
825* Wed Sep 12 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.1a3
826- 2.2a3
827- don't build tix and blt extensions
828
829* Mon Aug 13 2001 Trond Eivind Glomsroed <teg@redhat.com>
830- Add tk and tix to build dependencies
831
832* Sat Jul 21 2001 Trond Eivind Glomsroed <teg@redhat.com>
833- 2.1.1 bugfix release - with a GPL compatible license
834
835* Fri Jul 20 2001 Trond Eivind Glomsroed <teg@redhat.com>
836- Add new build dependencies (#49753)
837
838* Tue Jun 26 2001 Nalin Dahyabhai <nalin@redhat.com>
839- build with -fPIC
840
841* Fri Jun  1 2001 Trond Eivind Glomsroed <teg@redhat.com>
842- 2.1
843- reorganization of file includes
844
845* Wed Dec 20 2000 Trond Eivind Glomsroed <teg@redhat.com>
846- fix the "requires" clause, it lacked a space causing problems
847- use %%{_tmppath}
848- don't define name, version etc
849- add the available patches from the Python home page
850
851* Fri Dec 15 2000 Matt Wilson <msw@redhat.com>
852- added devel subpackage
853
854* Fri Dec 15 2000 Matt Wilson <msw@redhat.com>
855- modify all files to use "python2.0" as the intrepter
856- don't build the Expat bindings
857- build against db1
858
859* Mon Oct 16 2000 Jeremy Hylton <jeremy@beopen.com>
860- updated for 2.0 final
861
862* Mon Oct  9 2000 Jeremy Hylton <jeremy@beopen.com>
863- updated for 2.0c1
864- build audioop, imageop, and rgbimg extension modules
865- include xml.parsers subpackage
866- add test.xml.out to files list
867
868* Thu Oct  5 2000 Jeremy Hylton <jeremy@beopen.com>
869- added bin/python2.0 to files list (suggested by Martin v. Loewis)
870
871* Tue Sep 26 2000 Jeremy Hylton <jeremy@beopen.com>
872- updated for release 1 of 2.0b2
873- use .bz2 version of Python source
874
875* Tue Sep 12 2000 Jeremy Hylton <jeremy@beopen.com>
876- Version 2 of 2.0b1
877- Make the package relocatable.  Thanks to Suchandra Thapa.
878- Exclude Tkinter from main RPM.  If it is in a separate RPM, it is
879  easier to track Tk releases.
Note: See TracBrowser for help on using the repository browser.