source: projects/specs/trunk/p/python24/python24-vl.spec @ 521

Revision 521, 28.6 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1# If you want to run test, add "--define '_run_test 1'" to rpm option
2%define run_test %{?_run_test:1}%{!?_run_test:0}
3%define with_doc %{?_without_doc:0}%{!?_without_doc:1}
4%define unicode  ucs4
5%define tcl_major 8.4
6%define tk_major 8.4
7%define tix_major 8.4
8%define pybasever 2.4
9%define python_lib %{_libdir}/python%{pybasever}
10
11Summary: An interpreted, interactive, object-oriented programming language.
12Summary(ja): オブジェクト指向言語 Python2.4 インタプリタ
13Name: python24
14Version: 2.4.6
15Release: 2%{?_dist_release}
16License: PSF - see LICENSE
17Group: Development/Languages
18URL: http://www.python.org/2.4/
19Source0: Python-%{version}.tar.bz2
20#Source6: http://gigue.peabody.jhu.edu/~mdboom/omi/source/shm_source/shmmodule.c
21Source6: shmmodule.c
22# For TEST
23Source7: http://people.freebsd.org/~perky/i18n/EUC-CN.TXT
24Source8: http://www.unicode.org/Public/MAPPINGS/VENDORS/MICSFT/WINDOWS/CP936.TXT
25Source9: http://people.freebsd.org/~perky/i18n/BIG5HKSCS.TXT
26Source10: http://www.unicode.org/Public/MAPPINGS/VENDORS/MICSFT/WINDOWS/CP932.TXT
27Source11: http://people.freebsd.org/~perky/i18n/EUC-JP.TXT
28Source12: http://www.unicode.org/Public/MAPPINGS/OBSOLETE/EASTASIA/JIS/SHIFTJIS.TXT
29Source13: http://people.freebsd.org/~perky/i18n/EUC-JISX0213.TXT
30Source14: http://people.freebsd.org/~perky/i18n/SHIFT_JISX0213.TXT
31Source15: http://www.unicode.org/Public/MAPPINGS/VENDORS/MICSFT/WINDOWS/CP949.TXT
32Source16: http://people.freebsd.org/~perky/i18n/EUC-KR.TXT
33Source17: http://www.unicode.org/Public/MAPPINGS/OBSOLETE/EASTASIA/KSC/JOHAB.TXT
34Source18: http://www.unicode.org/Public/MAPPINGS/OBSOLETE/EASTASIA/OTHER/BIG5.TXT
35Source19: http://www.unicode.org/Public/MAPPINGS/VENDORS/MICSFT/WINDOWS/CP950.TXT
36Source20: http://www.unicode.org/Public/3.2-Update/NormalizationTest-3.2.0.txt
37
38#Patch0: python-2.4.6-config.patch
39Patch3: Python-2.2.1-pydocnogui.patch
40Patch4: Python-2.3.3-nowhatsnew.patch
41Patch5: Python-2.3.3-distutilrpm.patch
42
43#Patch8: python-2.4.2-lib64.patch
44#Patch9: python-2.4.4c1-setup.lib64.patch
45Patch10: python-2.4.6-Setup.patch
46Patch11: python-2.4.6-Setup64.patch
47Patch12: python-2.4.6-lib64.patch
48Patch13: python-2.4.6-bsddb.patch
49
50# Security fixes
51Patch100: python-2.4.4_CVE-2007-4965.patch
52Patch110: python-2.4.4_CVE-2008-1721.patch
53Patch120: python-2.4.4-CVE-2008-1679.patch
54Patch130: python-2.4.4_CVE-2008-1887.patch
55Patch140: python-2.4.4_CVE-2007-2052.patch
56
57Obsoletes: python2
58Obsoletes: Distutils
59Obsoletes: python-base
60Provides: Distutils
61Provides: python2.4
62
63BuildPrereq: db4-devel
64BuildPrereq: readline-devel, libtermcap-devel, openssl-devel, gmp-devel
65BuildPrereq: ncurses-devel, gdbm-devel, zlib-devel, expat-devel, tetex-latex
66BuildPrereq: tk tix gcc-c++ glibc-devel
67BuildPrereq: xorg-x11-devel mesa-libGL-devel
68BuildPrereq: gzip tar /usr/bin/find pkgconfig bzip2-devel
69BuildPrereq: nkf
70%if %{with_doc}
71BuildPrereq: latex2html
72%endif
73BuildRoot: %{_tmppath}/%{name}-%{version}-root
74
75%description
76Python is an interpreted, interactive, object-oriented programming
77language often compared to Tcl, Perl, Scheme or Java. Python includes
78modules, classes, exceptions, very high level dynamic data types and
79dynamic typing. Python supports interfaces to many system calls and
80libraries, as well as to various windowing systems (X11, Motif, Tk,
81Mac and MFC).
82
83Programmers can write new built-in modules for Python in C or C++.
84Python can be used as an extension language for applications that need
85a programmable interface. This package contains most of the standard
86Python modules, as well as modules for interfacing to the Tix widget
87set for Tk and RPM.
88
89Note that documentation for Python is provided in the python-docs
90package.
91
92%package devel
93Summary: The libraries and header files needed for Python development.
94Summary(ja): Python での開発に必要なライブラリやヘッダファイル
95Group: Development/Libraries
96Obsoletes: python2-devel
97
98%description devel
99The Python programming language's interpreter can be extended with
100dynamically loaded extensions and can be embedded in other programs.
101This package contains the header files and libraries needed to do
102these types of tasks.
103
104Install python-devel if you want to develop Python extensions.  The
105python package will also need to be installed.  You'll probably also
106want to install the python-docs package, which contains Python
107documentation.
108
109%package tools
110Summary: A collection of development tools included with Python.
111Summary(ja): Python に含まれる開発ツール一式
112Group: Development/Tools
113Requires: %{name} = %{version}
114Requires: %{name}-tkinter = %{version}
115Obsoletes: python2-tools
116
117%description tools
118The Python package includes several development tools that are used
119to build python programs.
120
121%package docs
122Summary: Documentation for the Python programming language.
123Summary(ja): Python プログラミング言語のドキュメント
124Group: Applications/Documentation
125Obsoletes: python2-docs
126
127%description docs
128The python-docs package contains documentation on the Python
129programming language and interpreter.  The documentation is provided
130in ASCII text files and in LaTeX source files.
131
132Install the python-docs package if you'd like to use the documentation
133for the Python language.
134
135%package tkinter
136Summary: A graphical user interface for the Python scripting language.
137Summary(ja): Python スクリプト言語のグラフィカルインターフェイス
138Group: Development/Languages
139Obsoletes: tkinter2
140BuildPrereq:  tcl, tk
141Requires: %{name} = %{version}
142Requires: tix
143
144%description tkinter
145The Tkinter (Tk interface) program is an graphical user interface for
146the Python scripting language.
147
148You should install the tkinter package if you'd like to use a graphical
149user interface for Python programming.
150
151%prep
152%setup -q -n Python-%{version}
153#%patch0 -p1 -b .Setup
154%patch3 -p1 -b .no_gui
155%patch4 -p1 -b .nowhatsnew
156%patch5 -p1
157
158%if %{_lib} == lib64
159%patch11 -p1 -b .Setup64
160%patch12 -p1 -b .lib64
161%else
162%patch10 -p1 -b .Setup
163%endif
164%patch13 -p1 -b .bsddb
165
166
167# security fixes
168#%patch100 -p1 -b .CVE-2007-4965
169#%patch110 -p1 -b .CVE-2008-1721
170#%patch120 -p1 -b .CVE-2008-1679
171#%patch130 -p0 -b .CVE-2008-1887
172%patch140 -p0 -b .CVE-2007-2052
173
174# remove unneeded files
175rm -vf Lib/test/test_*.py.CVE*
176rm -vf Lib/test/test_*.py.orig
177rm -vf Lib/test/test_*.py.org
178
179# Temporary workaround to avoid confusing find-requires: don't ship the tests
180# as executable files
181chmod 0644 Lib/test/test_*.py
182
183# shm module
184cp %{SOURCE6} Modules
185cat >> Modules/Setup.dist << EOF
186
187# Shared memory module
188shm shmmodule.c
189EOF
190
191# Fix library flags
192pushd Modules
193mv Setup.dist Setup.dist.in
194sed "s|-ltcl|-ltcl%{tcl_major}|" < Setup.dist.in |\
195sed "s|-ltk|-ltk%{tk_major}|" |\
196sed "s|-ltix|-ltix%{tix_major}|"  > Setup.dist
197rm -f Setup.dist.in
198popd
199
200
201%build
202topdir=`pwd`
203export CFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE -fPIC"
204export CXXFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE -fPIC"
205export OPT="$RPM_OPT_FLAGS -D_GNU_SOURCE -fPIC"
206export LINKCC="gcc"
207if pkg-config openssl ; then
208        export CFLAGS="$CFLAGS `pkg-config --cflags openssl`"
209        export LDFLAGS="$LDFLAGS `pkg-config --libs-only-L openssl`"
210fi
211%configure --enable-ipv6 --enable-unicode=%{unicode} --enable-shared
212
213make OPT="$CFLAGS" %{?_smp_mflags}
214LD_LIBRARY_PATH=$topdir $topdir/python Tools/scripts/pathfix.py -i "/usr/bin/env python%{pybasever}" .
215make OPT="$CFLAGS" %{?_smp_mflags}
216
217# Doc
218%if %{with_doc}
219make %{?_smp_mflags} -C Doc
220rm Doc/html/index.html.in
221%endif
222
223# Test
224%if %{run_test}
225cp %{SOURCE7} ./
226cp %{SOURCE8} ./
227cp %{SOURCE9} ./
228cp %{SOURCE10} ./
229cp %{SOURCE11} ./
230cp %{SOURCE12} ./
231cp %{SOURCE13} ./
232cp %{SOURCE14} ./
233cp %{SOURCE15} ./
234cp %{SOURCE16} ./
235cp %{SOURCE17} ./
236cp %{SOURCE18} ./
237cp %{SOURCE19} ./
238cp %{SOURCE20} ./
239# This runs the test set twice (once with no compiled files, once with
240# the compiled files left by the previous test run).
241export LD_LIBRARY_PATH=$topdir
242export PYTHONHOME=$topdir
243export PYTHONPATH=$topdir/Lib:$topdir/Lib/test:$topdir/Lib/lib-tk:$topdir/Lib/site-packages:$topdir/Modules:$topdir/build/lib.linux-%{_host_cpu}-%{pybasever}
244
245find ./Lib -name '*.py[co]' -print | xargs rm -f
246./python -tt ./Lib/test/regrtest.py -l
247./python -tt ./Lib/test/regrtest.py -l
248#./python -tt ./Lib/test/test_bsddb.py -l
249#./python -tt ./Lib/test/test_bsddb.py -l
250%endif
251
252
253%install
254rm -fr $RPM_BUILD_ROOT
255mkdir -p $RPM_BUILD_ROOT/usr $RPM_BUILD_ROOT%{_mandir}
256
257# Clean up patched .py files that are saved as .lib64
258for f in distutils/command/install distutils/sysconfig; do
259    rm -f Lib/$f.py.lib64
260done
261
262make DESTDIR=$RPM_BUILD_ROOT install
263
264# Fix the interpreter path in binaries installed by distutils
265# (which changes them by itself)
266# Make sure we preserve the file permissions
267for fixed in $RPM_BUILD_ROOT/usr/bin/pydoc; do
268    sed 's,#!.*/python$,#!/usr/bin/env python%{pybasever},' $fixed > $fixed- \
269        && cat $fixed- > $fixed && rm -f $fixed-
270done
271
272# tools
273mkdir -p $RPM_BUILD_ROOT%{python_lib}/site-packages
274
275echo "#!/bin/bash
276exec %{python_lib}/site-packages/pynche/pynche" \
277        > $RPM_BUILD_ROOT/usr/bin/pynche
278chmod 755 $RPM_BUILD_ROOT/usr/bin/pynche
279
280echo "#!/bin/bash
281exec %{python_lib}/site-packages/modulator/modulator.py" \
282        > $RPM_BUILD_ROOT/usr/bin/modulator
283chmod 755 $RPM_BUILD_ROOT/usr/bin/modulator
284
285# idle
286mkdir -p $RPM_BUILD_ROOT%{python_lib}/site-packages/idle
287install -m 755 ./Lib/idlelib/idle.py $RPM_BUILD_ROOT%{python_lib}/site-packages/idle
288mv $RPM_BUILD_ROOT/usr/bin/idle $RPM_BUILD_ROOT/idle
289sed "s/python/&%{pybasever}/" $RPM_BUILD_ROOT/idle > $RPM_BUILD_ROOT/usr/bin/idle
290chmod 755 $RPM_BUILD_ROOT/usr/bin/idle
291rm $RPM_BUILD_ROOT/idle
292
293#modulator
294cp -r Tools/modulator ${RPM_BUILD_ROOT}%{python_lib}/site-packages/
295
296#pynche
297rm -f Tools/pynche/*.pyw
298cp -r Tools/pynche $RPM_BUILD_ROOT%{python_lib}/site-packages/
299
300(mv Tools/modulator/README Tools/modulator/README.modulator)
301(mv Tools/pynche/README Tools/pynche/README.pynche)
302
303#gettext
304install -m755  Tools/i18n/pygettext.py $RPM_BUILD_ROOT/usr/bin/
305install -m755  Tools/i18n/msgfmt.py $RPM_BUILD_ROOT/usr/bin/
306
307# Get rid of crap
308find $RPM_BUILD_ROOT/ -name "*~"|xargs rm -f
309find $RPM_BUILD_ROOT/ -name ".cvsignore"|xargs rm -f
310find . -name "*~"|xargs rm -f
311find . -name ".cvsignore"|xargs rm -f
312#zero length
313rm -f $RPM_BUILD_ROOT%{python_lib}/site-packages/modulator/Templates/copyright
314
315# Clean up the testsuite - we don't need compiled files for it
316find $RPM_BUILD_ROOT%{python_lib}/test \
317    -name "*.pyc" -o -name "*.pyo" | xargs rm -f
318rm -f $RPM_BUILD_ROOT%{python_lib}/LICENSE.txt
319
320find $RPM_BUILD_ROOT%{python_lib}/lib-dynload -type f | grep -v _tkinter.so | sed "s|$RPM_BUILD_ROOT||" > dynfiles
321
322chmod 755 $RPM_BUILD_ROOT%{python_lib}/lib-dynload/*.so
323chmod 755 $RPM_BUILD_ROOT%{_libdir}/libpython*.so.*
324
325## move conflict files
326mkdir -p $RPM_BUILD_ROOT%{python_lib}/bin
327mv $RPM_BUILD_ROOT%{_bindir}/* $RPM_BUILD_ROOT%{python_lib}/bin
328mv $RPM_BUILD_ROOT%{python_lib}/bin/python%{pybasever} $RPM_BUILD_ROOT%{_bindir}/
329rm -rf $RPM_BUILD_ROOT%{_mandir}
330
331%clean
332rm -fr $RPM_BUILD_ROOT
333
334
335%files -f dynfiles
336%defattr(-, root, root)
337%doc LICENSE README
338%{_bindir}/python%{pybasever}
339%{_libdir}/libpython%{pybasever}.so*
340%dir %{python_lib}
341%dir %{python_lib}/bin
342%dir %{python_lib}/lib-dynload
343%dir %{python_lib}/site-packages
344%{python_lib}/bin/python
345%{python_lib}/*.py*
346%{python_lib}/*.doc
347%{python_lib}/bsddb
348%{python_lib}/compiler
349%{python_lib}/curses
350%{python_lib}/distutils
351%{python_lib}/email
352%{python_lib}/encodings
353%{python_lib}/hotshot
354%{python_lib}/idlelib
355%{python_lib}/lib-old
356%{python_lib}/logging
357%{python_lib}/plat-linux2
358%{python_lib}/xml
359#%{_mandir}/*/*
360
361%files devel
362%defattr(-,root,root)
363%{_includedir}/*
364%{python_lib}/config
365%{python_lib}/test
366
367%files tools
368%defattr(-,root,root,755)
369%doc Tools/modulator/README.modulator
370%doc Tools/pynche/README.pynche
371%exclude %{python_lib}/bin/python
372%{python_lib}/bin/*
373%{python_lib}/site-packages
374
375%if %{with_doc}
376%files docs
377%defattr(-,root,root,755)
378%doc Misc/NEWS  Misc/README Misc/cheatsheet
379%doc Misc/HISTORY Doc/html
380%endif
381
382%files tkinter
383%defattr(-,root,root,755)
384%{python_lib}/lib-tk
385%{python_lib}/lib-dynload/_tkinter.so
386
387%changelog
388* Thu May 07 2009 Shu KONNO <owa@bg.wakwak.com> python2.4-2.4.6-2vl5
389- added python-2.4.6-{Setup,Setup64,lib64}.patch
390  - added _bsddb module
391  - dropt Patch{0,8,9}
392- added python-2.4.6-bsddb.patch
393
394* Sat Dec 20 2008 Shu KONNO <owa@bg.wakwak.com> python2.4-2.4.6-1vl5
395- new upstream release
396- dropt python-2.4.4_CVE-2007-4965.patch
397- dropt python-2.4.4_CVE-2008-1721.patch
398- dropt python-2.4.4-CVE-2008-1679.patch
399- dropt python-2.4.4_CVE-2008-1887.patch
400
401* Wed Oct 22 2008 Shu KONNO <owa@bg.wakwak.com> python2.4-2.4.5-1vl5
402- new package name is %{name}
403- new sub-package name is %{name}-*
404
405* Sun Jun 08 2008 Shu KONNO <owa@bg.wakwak.com> 2.4.5-1vl5
406- applied new versioning policy and spec in utf-8
407- added BuildPrereq: xorg-x11-devel
408- imported updates from Vine4.2
409        * Fri Apr 25 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.4-1.4vl4
410        - add patch120 for fix CVE-2008-1679 (added fix of CVE-2007-4965)
411        - add patch130 for fix CVE-2008-1887 (PyString_FromStringAndSize)
412        - add patch140 for fix CVE-2007-2052 (_localemodule.c off-by-one err)
413        * Mon Apr 21 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.4-1.3vl4
414        - add patch110 CVE-2008-1721 (zlib module)
415        - add remove unneeded files in Lib/test/
416        #- new versioning policy
417
418* Wed Mar 12 2008 Shu KONNO <owa@bg.wakwak.com> 2.4.5-0vl1
419- updated python to 2.4.5
420
421* Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.4-0vl7
422- rebuild with expat-2.0.1
423
424* Mon Feb 18 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.4-0vl6
425- fix typo on Patch0 (s/db-4.2/db-4.3/)
426
427* Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 2.4.4-0vl5
428- rebuild with tcl/tk-8.4.18
429
430* Sat Dec 01 2007 Shu KONNO <owa@bg.wakwak.com> 2.4.4-0vl4
431- imported updates from Vine4.2 Plus
432        * Thu Nov 01 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.4-0vl1.2
433        - add BuildPrereq: nkf
434        * Wed Oct 31 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.4-0vl1.1
435        - add patch100 for fix CVE-2007-4965 (imageop Module integer OF)
436
437* Sat Jun 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.4-0vl3
438- rebuilt with openssl-0.9.8e and tix-8.4.2
439- fixed spec file encoding
440
441* Wed May 09 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.4-0vl2
442- rebuilt with new toolchain and db4-4.3.x
443- modified Patch0 (s/db-4.2/db-4.3/)
444
445* Thu Oct 19 2006 Shu KONNO <owa@bg.wakwak.com> 2.4.4-0vl1
446- updated python to 2.4.4 (included security fix PSF-2006-001)
447- added japanese summary
448- updated patch8 (python-2.4.2-lib64.patch)
449- added patch9 (python-2.4.4c1-setup.lib64.patch)
450
451* Wed Sep 13 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.4.3-0vl4
452- change docs Group to Applications/Documentation. <BTS:VineLinux:163>
453
454* Fri Aug 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.4.3-0vl3
455- rebuild with readline-5.1 (x86_64)
456
457* Fri Apr 14 2006 Shu KONNO <owa@bg.wakwak.com> 2.4.3-0vl2
458- fixed python-2.4.3-config.patch cause undefined symbol: crypt
459
460* Thu Mar 30 2006 Shu KONNO <owa@bg.wakwak.com> 2.4.3-0vl1
461- updated python to 2.4.3
462- added python-2.4.3-config.patch instead of python-2.4.1c1-config.patch
463
464* Wed Feb 15 2006 Shu KONNO <owa@bg.wakwak.com> 2.4.2-0vl5
465- set permition of lib-dynload/*.so to 755
466- added without_doc option
467- rebuilt with x86_64
468
469* Thu Nov 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.2-0vl4
470- add run_test option
471
472* Fri Nov  4 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.2-0vl3.2
473- add BuildPrereq: bzip2-devel
474- arrange testing script
475
476* Wed Nov 02 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.2-0vl3.1
477- back to %%configure macro
478- change testing script
479
480* Mon Oct 31 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.2-0vl3
481- update Patch8 (VineSeed:10306)
482- use ./configure instead of %%configure script
483- add forgotten popd
484
485* Fri Oct 28 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.2-0vl2
486- add --enable-shared to confiugre option
487- add %%{_libdir}/libpython2.4.so* to python package
488- add LD_LIBRARY_PATH=$topdir to use pathfix.py
489- change build method of Doc
490- add files for make test
491- change install method
492
493* Wed Sep 28 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.2-0vl1
494- update python to 2.4.2 (final)
495
496* Wed Mar 30 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.1-0vl1
497- update python to 2.4.1 (final)
498
499* Sat Mar 19 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.1-0vl0.c2
500- update python to 2.4.1c2
501- moved all site-packages files to python-tools package
502
503* Sat Mar 12 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.1-0vl0.c1
504- update python to 2.4.1c1
505- droped aspython2 macros
506- droped japanese-codecs module
507- droped Source2 idle, now it's provided from original source
508- droped Source3 modulator, now it's generated in a spec file
509- droped Source4 pynche, now it's generated in a spec file
510- droped Python-2.3.3-buildroot-bytecode.patch
511- changed python-2.3.3-config2.patch to python-2.4.1c1-config.patch
512
513* Wed Feb 09 2005 Shu KONNO <owa@bg.wakwak.com> 2.3.5-0vl1
514- update python to 2.3.5
515
516* Fri Feb 04 2005 Shu KONNO <owa@bg.wakwak.com> 2.3.4-0vl6
517- add PSF-2005-001.patch
518
519* Wed Nov 17 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.4-0vl4
520- rebuilt
521
522* Wed Oct 13 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.3.4-0vl3
523- modified Patch0 and Patch8 (-ldb-4.0 -> -ldb-4.2)
524
525* Wed Oct 13 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.3.4-0vl2
526- rebuilt with db4-4.2.25
527
528* Thu May 27 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.4-0vl1
529- updated python to 2.3.4
530- fixed patch10, patch11
531
532* Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.3-0vl1
533- rebuild
534
535* Thu Apr 08 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.3-0vl0.3
536- updated python-2.3.3-config2.patch
537
538* Thu Apr 08 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.3-0vl0.2
539- added librarys 'logging, bsddb, idlelib' to /usr/lib/python2.3
540
541* Wed Apr 07 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.3-0vl0.1
542- updated python to 2.3.3
543- changed version code 2.2.3 to 2.3.3 in source{2,3,4}
544- updated config2.patch for 2.3.3
545- updated nowhatsnew.patch for 2.3.3
546- updated distutilrpm.patch in which tabstops have made indent error
547- updated buildroot-bytecode.patch for 2.3.3
548- deleted buildroot.patch which fixed in 2.3.3
549- changed Tools/idle with Lib/idlelib
550
551* Wed Mar 31 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.3-3vl3
552- rebuild with openssl-0.9.7d
553
554* Wed Mar 03 2004 Shu KONNO <owa@bg.wakwak.com> 2.2.3-3vl2
555- updated JapaneseCodecs to 1.4.10
556
557* Wed Jul 09 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.2.3-3vl1
558- synced with RawHide 2.2.3-3 (substantially source ver up)
559
560* Mon Mar 31 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.2.2-26vl1
561- rebuild with tcltk-8.4.2
562- synced with RawHide 2.2.2-26
563  * Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com>
564  - rebuilt
565
566  * Mon Feb 24 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-25
567  - Fixed bug #84886: pydoc dies when run w/o arguments
568  - Fixed bug #84205: add python shm module back (used to be shipped with 1.5.2)
569  - Fixed bug #84966: path in byte-compiled code still wrong
570
571  * Thu Feb 20 2003 Jeremy Katz <katzj@redhat.com> 2.2.2-23
572  - ftp uri's should be able to specify being rooted at the root instead of
573    where you login via ftp (#84692)
574
575  * Mon Feb 10 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-22
576  - Using newer Japanese codecs (1.4.9). Thanks to
577    Peter Bowen <pzb@datastacks.com> for pointing this out.
578
579  * Thu Feb  6 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-21
580  - Rebuild
581
582  * Wed Feb  5 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-20
583  - Release number bumped really high: turning on UCS4 (ABI compatibility
584    breakage)
585
586  * Fri Jan 31 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-13
587  - Attempt to look both in /usr/lib64 and /usr/lib/python2.2/site-packages/:
588    some work on python-2.2.2-lib64.patch
589
590  * Thu Jan 30 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-12
591  - Rebuild to incorporate the removal of .lib64 and - files.
592
593  * Thu Jan 30 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-11.7.3
594  - Fixed bug #82544: Errata removes most tools
595  - Fixed bug #82435: Python 2.2.2 errata breaks redhat-config-users
596  - Removed .lib64 and - files that get installed after we fix the multilib
597    .py files.
598
599  * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
600  - rebuilt
601
602  * Wed Jan 15 2003 Jens Petersen <petersen@redhat.com> 2.2.2-10
603  - rebuild to update tkinter's tcltk deps
604  - convert changelog to utf-8
605
606
607* Wed Jan 15 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.2-9vl0
608- rebuilt for Vine Linux against db4
609- obsolete python-base (which comes with python-2.2.1 of TestPkg)
610
611* Tue Jan  7 2003 Nalin Dahyabhai <nalin@redhat.com> 2.2.2-9
612- rebuild
613
614* Fri Jan  3 2003 Nalin Dahyabhai <nalin@redhat.com>
615- pick up OpenSSL cflags and ldflags from pkgconfig if available
616
617* Thu Jan  2 2003 Jeremy Katz <katzj@redhat.com> 2.2.2-8
618- urllib2 didn't support non-anonymous ftp.  add support based on how
619  urllib did it (#80676, #78168)
620
621* Mon Dec 16 2002 Mihai Ibanescu <misa@redhat.com> 2.2.2-7
622- Fix bug #79647 (Rebuild of SRPM fails if python isn't installed)
623- Added a bunch of missing BuildRequires found while fixing the
624  above-mentioned bug
625
626* Tue Dec 10 2002 Tim Powers <timp@redhat.com> 2.2.2-6
627- rebuild to fix broken tcltk deps for tkinter
628
629* Fri Nov 22 2002 Mihai Ibanescu <misa@redhat.com>
6302.2.2-3.7.3
631- Recompiled for 7.3 (to fix the -lcrypt bug)
632- Fix for the spurious error message at the end of the build (build-requires
633  gets confused by executable files starting with """"): make the tests
634  non-executable.
635
636* Wed Nov 20 2002 Mihai Ibanescu <misa@redhat.com>
6372.2.2-5
638- Fixed configuration patch to add -lcrypt when compiling cryptmodule.c
639
6402.2.2-4
641- Spec file change from Matt Wilson <msw@redhat.com> to disable linking
642  with the C++ compiler.
643
644* Mon Nov 11 2002 Mihai Ibanescu <misa@redhat.com>
6452.2.2-3.*
646- Merged patch from Karsten Hopp <karsten@redhat.de> from 2.2.1-17hammer to
647  use %%{_libdir}
648- Added XFree86-libs as BuildRequires (because of tkinter)
649- Fixed duplicate listing of plat-linux2
650- Fixed exclusion of lib-dynload/japanese
651- Added lib64 patch for the japanese codecs
652- Use setup magic instead of using tar directly on JapaneseCodecs
653
654* Tue Nov  5 2002 Mihai Ibanescu <misa@redhat.com>
6552.2.2-2
656- Fix #76912 (python-tools contains idle, which uses tkinter, but there is no
657  requirement of tkinter from python-tools).
658- Fix #74013 (rpm is missing the /usr/lib/python2.2/test directory)
659
660* Mon Nov  4 2002 Mihai Ibanescu <misa@redhat.com>
661- builds as python2 require a different libdb
662- changed the buildroot name of python to match python2 builds
663
664* Fri Nov  1 2002 Mihai Ibanescu <misa@redhat.com>
665- updated python to 2.2.2 and adjusted the patches accordingly
666
667* Mon Oct 21 2002 Mihai Ibanescu <misa@redhat.com>
668- Fix #53930 (Python-2.2.1-buildroot-bytecode.patch)
669- Added BuildPrereq dependency on gcc-c++
670
671* Fri Aug 30 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-17
672- security fix for _execvpe
673
674* Tue Aug 13 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-16
675- Fix  #71011,#71134, #58157
676
677* Wed Aug  7 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-15
678- Resurrect tkinter
679- Fix for distutils (#67671)
680- Fix #69962
681
682* Thu Jul 25 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-14
683- Obsolete tkinter/tkinter2 (#69838)
684
685* Tue Jul 23 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-13
686- Doc fixes (#53951) - not on alpha at the momemt
687
688* Mon Jul  8 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-12
689- fix pydoc (#68082)
690
691* Mon Jul  8 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-11
692- Add db4-devel as a BuildPrereq
693
694* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 2.2.1-10
695- automated rebuild
696
697* Mon Jun 17 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-9
698- Add Japanese codecs (#66352)
699
700* Tue Jun 11 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-8
701- No more tkinter...
702
703* Wed May 29 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-7
704- Rebuild
705
706* Tue May 21 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-6
707- Add the email subcomponent (#65301)
708
709* Fri May 10 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-5
710- Rebuild
711
712* Thu May 02 2002 Than Ngo <than@redhat.com> 2.2.1-4
713- rebuild i new enviroment
714
715* Tue Apr 23 2002 Trond Eivind Glomsroed <teg@redhat.com>
716- Use ucs2, not ucs4, to avoid breaking tkinter (#63965)
717
718* Mon Apr 22 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-2
719- Make it use db4
720
721* Fri Apr 12 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-1
722- 2.2.1 - a bugfix-only release
723
724* Fri Apr 12 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-16
725- the same, but in builddirs - this will remove them from the
726  docs package, which doesn't look in the buildroot for files.
727
728* Fri Apr 12 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-15
729- Get rid of temporary files and .cvsignores included
730  in the tarball and make install
731
732* Fri Apr  5 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-14
733- Don't own lib-tk in main package, only in tkinter (#62753)
734
735* Mon Mar 25 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-13
736- rebuild
737
738* Mon Mar 25 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-12
739- rebuild
740
741* Fri Mar  1 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-11
742- Add a not to the Distutils obsoletes test (doh!)
743
744* Fri Mar  1 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-10
745- Rebuild
746
747* Mon Feb 25 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-9
748- Only obsolete Distutils when built as python
749
750* Thu Feb 21 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-8
751- Make files in /usr/bin install side by side with python 1.5 when
752- Drop explicit requirement of db4
753  built as python2
754
755* Thu Jan 31 2002 Elliot Lee <sopwith@redhat.com> 2.2-7
756- Use version and pybasever macros to make updating easy
757- Use _smp_mflags macro
758
759* Tue Jan 29 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-6
760- Add db4-devel to BuildPrereq
761
762* Fri Jan 25 2002 Nalin Dahyabhai <nalin@redhat.com> 2.2-5
763- disable ndbm support, which is db2 in disguise (really interesting things
764  can happen when you mix db2 and db4 in a single application)
765
766* Thu Jan 24 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-4
767- Obsolete subpackages if necesarry
768- provide versioned python2
769- build with db4
770
771* Wed Jan 16 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-3
772- Alpha toolchain broken. Disable build on alpha.
773- New openssl
774
775* Wed Dec 26 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-1
776- 2.2 final
777
778* Fri Dec 14 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.11c1
779- 2.2 RC 1
780- Don't include the _tkinter module in the main package - it's
781  already in the tkiter packace
782- Turn off the mpzmodule, something broke in the buildroot
783
784* Wed Nov 28 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.10b2
785- Use -fPIC for OPT as well, in lack of a proper libpython.so
786
787* Mon Nov 26 2001 Matt Wilson <msw@redhat.com> 2.2-0.9b2
788- changed DESTDIR to point to / so that distutils will install dynload
789  modules properly in the installroot
790
791* Fri Nov 16 2001 Matt Wilson <msw@redhat.com> 2.2-0.8b2
792- 2.2b2
793
794* Fri Oct 26 2001 Matt Wilson <msw@redhat.com> 2.2-0.7b1
795- python2ify
796
797* Fri Oct 19 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.5b1
798- 2.2b1
799
800* Sun Sep 30 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.4a4
801- 2.2a4
802- Enable UCS4 support
803- Enable IPv6
804- Provide distutils
805- Include msgfmt.py and pygettext.py
806
807* Fri Sep 14 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.3a3
808- Obsolete Distutils, which is now part of the main package
809- Obsolete python2
810
811* Thu Sep 13 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.2a3
812- Add docs, tools and tkinter subpackages, to match the 1.5 layout
813
814* Wed Sep 12 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.1a3
815- 2.2a3
816- don't build tix and blt extensions
817
818* Mon Aug 13 2001 Trond Eivind Glomsroed <teg@redhat.com>
819- Add tk and tix to build dependencies
820
821* Sat Jul 21 2001 Trond Eivind Glomsroed <teg@redhat.com>
822- 2.1.1 bugfix release - with a GPL compatible license
823
824* Fri Jul 20 2001 Trond Eivind Glomsroed <teg@redhat.com>
825- Add new build dependencies (#49753)
826
827* Tue Jun 26 2001 Nalin Dahyabhai <nalin@redhat.com>
828- build with -fPIC
829
830* Fri Jun  1 2001 Trond Eivind Glomsroed <teg@redhat.com>
831- 2.1
832- reorganization of file includes
833
834* Wed Dec 20 2000 Trond Eivind Glomsroed <teg@redhat.com>
835- fix the "requires" clause, it lacked a space causing problems
836- use %%{_tmppath}
837- don't define name, version etc
838- add the available patches from the Python home page
839
840* Fri Dec 15 2000 Matt Wilson <msw@redhat.com>
841- added devel subpackage
842
843* Fri Dec 15 2000 Matt Wilson <msw@redhat.com>
844- modify all files to use "python2.0" as the intrepter
845- don't build the Expat bindings
846- build against db1
847
848* Mon Oct 16 2000 Jeremy Hylton <jeremy@beopen.com>
849- updated for 2.0 final
850
851* Mon Oct  9 2000 Jeremy Hylton <jeremy@beopen.com>
852- updated for 2.0c1
853- build audioop, imageop, and rgbimg extension modules
854- include xml.parsers subpackage
855- add test.xml.out to files list
856
857* Thu Oct  5 2000 Jeremy Hylton <jeremy@beopen.com>
858- added bin/python2.0 to files list (suggested by Martin v. Loewis)
859
860* Tue Sep 26 2000 Jeremy Hylton <jeremy@beopen.com>
861- updated for release 1 of 2.0b2
862- use .bz2 version of Python source
863
864* Tue Sep 12 2000 Jeremy Hylton <jeremy@beopen.com>
865- Version 2 of 2.0b1
866- Make the package relocatable.  Thanks to Suchandra Thapa.
867- Exclude Tkinter from main RPM.  If it is in a separate RPM, it is
868  easier to track Tk releases.
Note: See TracBrowser for help on using the repository browser.