source: projects/specs/trunk/p/python24/python24-vl.spec @ 1909

Revision 1909, 29.0 KB checked in by owa, 14 years ago (diff)

rebuilt with rpm-4.8.1

Line 
1# If you want to run test, add "--define '_run_test 1'" to rpm option
2%define run_test %{?_run_test:1}%{!?_run_test:0}
3%define with_doc %{?_without_doc:1}%{!?_without_doc:0}
4%define unicode  ucs4
5%define tcl_major 8.4
6%define tk_major 8.4
7%define tix_major 8.4
8%define pybasever 2.4
9%define python_lib %{_libdir}/python%{pybasever}
10Packager: owa
11
12Summary: An interpreted, interactive, object-oriented programming language.
13Summary(ja): オブジェクト指向言語 Python2.4 インタプリタ
14Name: python24
15Version: 2.4.6
16Release: 4%{?_dist_release}
17License: PSF - see LICENSE
18Group: Development/Languages
19URL: http://www.python.org/2.4/
20Source0: Python-%{version}.tar.bz2
21Source1: db46_headers.tar.gz
22#Source6: http://gigue.peabody.jhu.edu/~mdboom/omi/source/shm_source/shmmodule.c
23Source6: shmmodule.c
24# For TEST
25Source7: http://people.freebsd.org/~perky/i18n/EUC-CN.TXT
26Source8: http://www.unicode.org/Public/MAPPINGS/VENDORS/MICSFT/WINDOWS/CP936.TXT
27Source9: http://people.freebsd.org/~perky/i18n/BIG5HKSCS.TXT
28Source10: http://www.unicode.org/Public/MAPPINGS/VENDORS/MICSFT/WINDOWS/CP932.TXT
29Source11: http://people.freebsd.org/~perky/i18n/EUC-JP.TXT
30Source12: http://www.unicode.org/Public/MAPPINGS/OBSOLETE/EASTASIA/JIS/SHIFTJIS.TXT
31Source13: http://people.freebsd.org/~perky/i18n/EUC-JISX0213.TXT
32Source14: http://people.freebsd.org/~perky/i18n/SHIFT_JISX0213.TXT
33Source15: http://www.unicode.org/Public/MAPPINGS/VENDORS/MICSFT/WINDOWS/CP949.TXT
34Source16: http://people.freebsd.org/~perky/i18n/EUC-KR.TXT
35Source17: http://www.unicode.org/Public/MAPPINGS/OBSOLETE/EASTASIA/KSC/JOHAB.TXT
36Source18: http://www.unicode.org/Public/MAPPINGS/OBSOLETE/EASTASIA/OTHER/BIG5.TXT
37Source19: http://www.unicode.org/Public/MAPPINGS/VENDORS/MICSFT/WINDOWS/CP950.TXT
38Source20: http://www.unicode.org/Public/3.2-Update/NormalizationTest-3.2.0.txt
39
40
41#Patch0: python-2.4.6-config.patch
42Patch3: Python-2.2.1-pydocnogui.patch
43Patch4: Python-2.3.3-nowhatsnew.patch
44Patch5: Python-2.3.3-distutilrpm.patch
45
46#Patch8: python-2.4.2-lib64.patch
47#Patch9: python-2.4.4c1-setup.lib64.patch
48Patch10: python-2.4.6-Setup.patch
49Patch11: python-2.4.6-Setup64.patch
50Patch12: python-2.4.6-lib64.patch
51Patch13: python-2.4.6-bsddb.patch
52
53# Security fixes
54Patch100: python-2.4.4_CVE-2007-4965.patch
55Patch110: python-2.4.4_CVE-2008-1721.patch
56Patch120: python-2.4.4-CVE-2008-1679.patch
57Patch130: python-2.4.4_CVE-2008-1887.patch
58Patch140: python-2.4.4_CVE-2007-2052.patch
59
60Obsoletes: python2
61Obsoletes: Distutils
62Obsoletes: python-base
63Provides: Distutils
64Provides: python2.4
65
66BuildRequires: db4-devel
67BuildRequires: readline-devel, libtermcap-devel, openssl-devel, gmp-devel
68#BuildRequires: ncurses-devel, gdbm-devel, zlib-devel, expat-devel, tetex-latex
69BuildRequires: ncurses-devel, gdbm-devel, zlib-devel, expat-devel
70BuildRequires: tk tix gcc-c++ glibc-devel
71BuildRequires: xorg-x11-devel mesa-libGL-devel
72BuildRequires: gzip tar /usr/bin/find pkgconfig bzip2-devel
73BuildRequires: nkf
74%if %{with_doc}
75BuildRequires: latex2html
76%endif
77BuildRoot: %{_tmppath}/%{name}-%{version}-root
78
79%description
80Python is an interpreted, interactive, object-oriented programming
81language often compared to Tcl, Perl, Scheme or Java. Python includes
82modules, classes, exceptions, very high level dynamic data types and
83dynamic typing. Python supports interfaces to many system calls and
84libraries, as well as to various windowing systems (X11, Motif, Tk,
85Mac and MFC).
86
87Programmers can write new built-in modules for Python in C or C++.
88Python can be used as an extension language for applications that need
89a programmable interface. This package contains most of the standard
90Python modules, as well as modules for interfacing to the Tix widget
91set for Tk and RPM.
92
93Note that documentation for Python is provided in the python-docs
94package.
95
96%package devel
97Summary: The libraries and header files needed for Python development.
98Summary(ja): Python での開発に必要なライブラリやヘッダファイル
99Group: Development/Libraries
100Obsoletes: python2-devel
101
102%description devel
103The Python programming language's interpreter can be extended with
104dynamically loaded extensions and can be embedded in other programs.
105This package contains the header files and libraries needed to do
106these types of tasks.
107
108Install python-devel if you want to develop Python extensions.  The
109python package will also need to be installed.  You'll probably also
110want to install the python-docs package, which contains Python
111documentation.
112
113%package tools
114Summary: A collection of development tools included with Python.
115Summary(ja): Python に含まれる開発ツール一式
116Group: Development/Tools
117Requires: %{name} = %{version}
118Requires: %{name}-tkinter = %{version}
119Obsoletes: python2-tools
120
121%description tools
122The Python package includes several development tools that are used
123to build python programs.
124
125%package docs
126Summary: Documentation for the Python programming language.
127Summary(ja): Python プログラミング言語のドキュメント
128Group: Applications/Documentation
129Obsoletes: python2-docs
130
131%description docs
132The python-docs package contains documentation on the Python
133programming language and interpreter.  The documentation is provided
134in ASCII text files and in LaTeX source files.
135
136Install the python-docs package if you'd like to use the documentation
137for the Python language.
138
139%package tkinter
140Summary: A graphical user interface for the Python scripting language.
141Summary(ja): Python スクリプト言語のグラフィカルインターフェイス
142Group: Development/Languages
143Obsoletes: tkinter2
144BuildRequires:  tcl, tk
145Requires: %{name} = %{version}
146Requires: tix
147
148%description tkinter
149The Tkinter (Tk interface) program is an graphical user interface for
150the Python scripting language.
151
152You should install the tkinter package if you'd like to use a graphical
153user interface for Python programming.
154
155%prep
156%setup -q -n Python-%{version} -a 1
157
158#%patch0 -p1 -b .Setup
159%patch3 -p1 -b .no_gui
160%patch4 -p1 -b .nowhatsnew
161%patch5 -p1
162
163%if %{_lib} == lib64
164%patch11 -p1 -b .Setup64
165%patch12 -p1 -b .lib64
166%else
167%patch10 -p1 -b .Setup
168%endif
169%patch13 -p1 -b .bsddb
170
171
172# security fixes
173#%patch100 -p1 -b .CVE-2007-4965
174#%patch110 -p1 -b .CVE-2008-1721
175#%patch120 -p1 -b .CVE-2008-1679
176#%patch130 -p0 -b .CVE-2008-1887
177%patch140 -p0 -b .CVE-2007-2052
178
179# remove unneeded files
180rm -vf Lib/test/test_*.py.CVE*
181rm -vf Lib/test/test_*.py.orig
182rm -vf Lib/test/test_*.py.org
183
184# Temporary workaround to avoid confusing find-requires: don't ship the tests
185# as executable files
186chmod 0644 Lib/test/test_*.py
187
188# shm module
189cp %{SOURCE6} Modules
190cat >> Modules/Setup.dist << EOF
191
192# Shared memory module
193shm shmmodule.c
194EOF
195
196# Fix library flags
197pushd Modules
198mv Setup.dist Setup.dist.in
199sed "s|-ltcl|-ltcl%{tcl_major}|" < Setup.dist.in |\
200sed "s|-ltk|-ltk%{tk_major}|" |\
201sed "s|-ltix|-ltix%{tix_major}|"  > Setup.dist
202rm -f Setup.dist.in
203popd
204
205
206%build
207topdir=`pwd`
208export CFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE -fPIC"
209export CXXFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE -fPIC"
210export OPT="$RPM_OPT_FLAGS -D_GNU_SOURCE -fPIC"
211export LINKCC="gcc"
212if pkg-config openssl ; then
213        export CFLAGS="$CFLAGS `pkg-config --cflags openssl`"
214        export LDFLAGS="$LDFLAGS `pkg-config --libs-only-L openssl`"
215fi
216%configure --enable-ipv6 --enable-unicode=%{unicode} --enable-shared
217
218make OPT="$CFLAGS" %{?_smp_mflags}
219LD_LIBRARY_PATH=$topdir $topdir/python Tools/scripts/pathfix.py -i "/usr/bin/env python%{pybasever}" .
220make OPT="$CFLAGS" %{?_smp_mflags}
221
222# Doc
223%if %{with_doc}
224make %{?_smp_mflags} -C Doc
225rm Doc/html/index.html.in
226%endif
227
228# Test
229%if %{run_test}
230cp %{SOURCE7} ./
231cp %{SOURCE8} ./
232cp %{SOURCE9} ./
233cp %{SOURCE10} ./
234cp %{SOURCE11} ./
235cp %{SOURCE12} ./
236cp %{SOURCE13} ./
237cp %{SOURCE14} ./
238cp %{SOURCE15} ./
239cp %{SOURCE16} ./
240cp %{SOURCE17} ./
241cp %{SOURCE18} ./
242cp %{SOURCE19} ./
243cp %{SOURCE20} ./
244# This runs the test set twice (once with no compiled files, once with
245# the compiled files left by the previous test run).
246export LD_LIBRARY_PATH=$topdir
247export PYTHONHOME=$topdir
248export PYTHONPATH=$topdir/Lib:$topdir/Lib/test:$topdir/Lib/lib-tk:$topdir/Lib/site-packages:$topdir/Modules:$topdir/build/lib.linux-%{_host_cpu}-%{pybasever}
249
250find ./Lib -name '*.py[co]' -print | xargs rm -f
251./python -tt ./Lib/test/regrtest.py -l
252./python -tt ./Lib/test/regrtest.py -l
253#./python -tt ./Lib/test/test_bsddb.py -l
254#./python -tt ./Lib/test/test_bsddb.py -l
255%endif
256
257
258%install
259rm -fr $RPM_BUILD_ROOT
260mkdir -p $RPM_BUILD_ROOT/usr $RPM_BUILD_ROOT%{_mandir}
261
262# Clean up patched .py files that are saved as .lib64
263for f in distutils/command/install distutils/sysconfig; do
264    rm -f Lib/$f.py.lib64
265done
266
267make DESTDIR=$RPM_BUILD_ROOT install
268
269# Fix the interpreter path in binaries installed by distutils
270# (which changes them by itself)
271# Make sure we preserve the file permissions
272for fixed in $RPM_BUILD_ROOT/usr/bin/pydoc; do
273    sed 's,#!.*/python$,#!/usr/bin/env python%{pybasever},' $fixed > $fixed- \
274        && cat $fixed- > $fixed && rm -f $fixed-
275done
276
277# tools
278mkdir -p $RPM_BUILD_ROOT%{python_lib}/site-packages
279
280echo "#!/bin/bash
281exec %{python_lib}/site-packages/pynche/pynche" \
282        > $RPM_BUILD_ROOT/usr/bin/pynche
283chmod 755 $RPM_BUILD_ROOT/usr/bin/pynche
284
285echo "#!/bin/bash
286exec %{python_lib}/site-packages/modulator/modulator.py" \
287        > $RPM_BUILD_ROOT/usr/bin/modulator
288chmod 755 $RPM_BUILD_ROOT/usr/bin/modulator
289
290# idle
291mkdir -p $RPM_BUILD_ROOT%{python_lib}/site-packages/idle
292install -m 755 ./Lib/idlelib/idle.py $RPM_BUILD_ROOT%{python_lib}/site-packages/idle
293mv $RPM_BUILD_ROOT/usr/bin/idle $RPM_BUILD_ROOT/idle
294sed "s/python/&%{pybasever}/" $RPM_BUILD_ROOT/idle > $RPM_BUILD_ROOT/usr/bin/idle
295chmod 755 $RPM_BUILD_ROOT/usr/bin/idle
296rm $RPM_BUILD_ROOT/idle
297
298#modulator
299cp -r Tools/modulator ${RPM_BUILD_ROOT}%{python_lib}/site-packages/
300
301#pynche
302rm -f Tools/pynche/*.pyw
303cp -r Tools/pynche $RPM_BUILD_ROOT%{python_lib}/site-packages/
304
305(mv Tools/modulator/README Tools/modulator/README.modulator)
306(mv Tools/pynche/README Tools/pynche/README.pynche)
307
308#gettext
309install -m755  Tools/i18n/pygettext.py $RPM_BUILD_ROOT/usr/bin/
310install -m755  Tools/i18n/msgfmt.py $RPM_BUILD_ROOT/usr/bin/
311
312# Get rid of crap
313find $RPM_BUILD_ROOT/ -name "*~"|xargs rm -f
314find $RPM_BUILD_ROOT/ -name ".cvsignore"|xargs rm -f
315find . -name "*~"|xargs rm -f
316find . -name ".cvsignore"|xargs rm -f
317#zero length
318rm -f $RPM_BUILD_ROOT%{python_lib}/site-packages/modulator/Templates/copyright
319
320# Clean up the testsuite - we don't need compiled files for it
321find $RPM_BUILD_ROOT%{python_lib}/test \
322    -name "*.pyc" -o -name "*.pyo" | xargs rm -f
323rm -f $RPM_BUILD_ROOT%{python_lib}/LICENSE.txt
324
325find $RPM_BUILD_ROOT%{python_lib}/lib-dynload -type f | grep -v _tkinter.so | sed "s|$RPM_BUILD_ROOT||" > dynfiles
326
327chmod 755 $RPM_BUILD_ROOT%{python_lib}/lib-dynload/*.so
328chmod 755 $RPM_BUILD_ROOT%{_libdir}/libpython*.so.*
329
330## move conflict files
331mkdir -p $RPM_BUILD_ROOT%{python_lib}/bin
332mv $RPM_BUILD_ROOT%{_bindir}/* $RPM_BUILD_ROOT%{python_lib}/bin
333mv $RPM_BUILD_ROOT%{python_lib}/bin/python%{pybasever} $RPM_BUILD_ROOT%{_bindir}/
334rm -rf $RPM_BUILD_ROOT%{_mandir}
335
336%clean
337rm -fr $RPM_BUILD_ROOT
338
339
340%files -f dynfiles
341%defattr(-, root, root)
342%doc LICENSE README
343%{_bindir}/python%{pybasever}
344%{_libdir}/libpython%{pybasever}.so*
345%dir %{python_lib}
346%dir %{python_lib}/bin
347%dir %{python_lib}/lib-dynload
348%dir %{python_lib}/site-packages
349%{python_lib}/bin/python
350%{python_lib}/*.py*
351%{python_lib}/*.doc
352%{python_lib}/bsddb
353%{python_lib}/compiler
354%{python_lib}/curses
355%{python_lib}/distutils
356%{python_lib}/email
357%{python_lib}/encodings
358%{python_lib}/hotshot
359%{python_lib}/idlelib
360%{python_lib}/lib-old
361%{python_lib}/logging
362%{python_lib}/plat-linux2
363%{python_lib}/xml
364#%{_mandir}/*/*
365
366%files devel
367%defattr(-,root,root)
368%{_includedir}/*
369%{python_lib}/config
370%{python_lib}/test
371
372%files tools
373%defattr(-,root,root,755)
374%doc Tools/modulator/README.modulator
375%doc Tools/pynche/README.pynche
376%exclude %{python_lib}/bin/python
377%{python_lib}/bin/*
378%{python_lib}/site-packages
379
380%if %{with_doc}
381%files docs
382%defattr(-,root,root,755)
383%doc Misc/NEWS  Misc/README Misc/cheatsheet
384%doc Misc/HISTORY Doc/html
385%endif
386
387%files tkinter
388%defattr(-,root,root,755)
389%{python_lib}/lib-tk
390%{python_lib}/lib-dynload/_tkinter.so
391
392%changelog
393* Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> python2.4-2.4.6-4
394- rebuilt with rpm-4.8.1 for pkg-config
395
396* Tue Apr 20 2010 Shu KONNO <owa@bg.wakwak.com> python2.4-2.4.6-3
397- added db46_headers.tar.gz
398- update Setup.dist{32,64}.patch
399- changed default to '--without doc'
400- s/BuildPreReq/BuildRequires/
401
402* Thu May 07 2009 Shu KONNO <owa@bg.wakwak.com> python2.4-2.4.6-2vl5
403- added python-2.4.6-{Setup,Setup64,lib64}.patch
404  - added _bsddb module
405  - dropt Patch{0,8,9}
406- added python-2.4.6-bsddb.patch
407
408* Sat Dec 20 2008 Shu KONNO <owa@bg.wakwak.com> python2.4-2.4.6-1vl5
409- new upstream release
410- dropt python-2.4.4_CVE-2007-4965.patch
411- dropt python-2.4.4_CVE-2008-1721.patch
412- dropt python-2.4.4-CVE-2008-1679.patch
413- dropt python-2.4.4_CVE-2008-1887.patch
414
415* Wed Oct 22 2008 Shu KONNO <owa@bg.wakwak.com> python2.4-2.4.5-1vl5
416- new package name is %{name}
417- new sub-package name is %{name}-*
418
419* Sun Jun 08 2008 Shu KONNO <owa@bg.wakwak.com> 2.4.5-1vl5
420- applied new versioning policy and spec in utf-8
421- added BuildPrereq: xorg-x11-devel
422- imported updates from Vine4.2
423        * Fri Apr 25 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.4-1.4vl4
424        - add patch120 for fix CVE-2008-1679 (added fix of CVE-2007-4965)
425        - add patch130 for fix CVE-2008-1887 (PyString_FromStringAndSize)
426        - add patch140 for fix CVE-2007-2052 (_localemodule.c off-by-one err)
427        * Mon Apr 21 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.4-1.3vl4
428        - add patch110 CVE-2008-1721 (zlib module)
429        - add remove unneeded files in Lib/test/
430        #- new versioning policy
431
432* Wed Mar 12 2008 Shu KONNO <owa@bg.wakwak.com> 2.4.5-0vl1
433- updated python to 2.4.5
434
435* Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.4-0vl7
436- rebuild with expat-2.0.1
437
438* Mon Feb 18 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.4-0vl6
439- fix typo on Patch0 (s/db-4.2/db-4.3/)
440
441* Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 2.4.4-0vl5
442- rebuild with tcl/tk-8.4.18
443
444* Sat Dec 01 2007 Shu KONNO <owa@bg.wakwak.com> 2.4.4-0vl4
445- imported updates from Vine4.2 Plus
446        * Thu Nov 01 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.4-0vl1.2
447        - add BuildPrereq: nkf
448        * Wed Oct 31 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.4-0vl1.1
449        - add patch100 for fix CVE-2007-4965 (imageop Module integer OF)
450
451* Sat Jun 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.4-0vl3
452- rebuilt with openssl-0.9.8e and tix-8.4.2
453- fixed spec file encoding
454
455* Wed May 09 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.4-0vl2
456- rebuilt with new toolchain and db4-4.3.x
457- modified Patch0 (s/db-4.2/db-4.3/)
458
459* Thu Oct 19 2006 Shu KONNO <owa@bg.wakwak.com> 2.4.4-0vl1
460- updated python to 2.4.4 (included security fix PSF-2006-001)
461- added japanese summary
462- updated patch8 (python-2.4.2-lib64.patch)
463- added patch9 (python-2.4.4c1-setup.lib64.patch)
464
465* Wed Sep 13 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.4.3-0vl4
466- change docs Group to Applications/Documentation. <BTS:VineLinux:163>
467
468* Fri Aug 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.4.3-0vl3
469- rebuild with readline-5.1 (x86_64)
470
471* Fri Apr 14 2006 Shu KONNO <owa@bg.wakwak.com> 2.4.3-0vl2
472- fixed python-2.4.3-config.patch cause undefined symbol: crypt
473
474* Thu Mar 30 2006 Shu KONNO <owa@bg.wakwak.com> 2.4.3-0vl1
475- updated python to 2.4.3
476- added python-2.4.3-config.patch instead of python-2.4.1c1-config.patch
477
478* Wed Feb 15 2006 Shu KONNO <owa@bg.wakwak.com> 2.4.2-0vl5
479- set permition of lib-dynload/*.so to 755
480- added without_doc option
481- rebuilt with x86_64
482
483* Thu Nov 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.2-0vl4
484- add run_test option
485
486* Fri Nov  4 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.2-0vl3.2
487- add BuildPrereq: bzip2-devel
488- arrange testing script
489
490* Wed Nov 02 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.2-0vl3.1
491- back to %%configure macro
492- change testing script
493
494* Mon Oct 31 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.2-0vl3
495- update Patch8 (VineSeed:10306)
496- use ./configure instead of %%configure script
497- add forgotten popd
498
499* Fri Oct 28 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.2-0vl2
500- add --enable-shared to confiugre option
501- add %%{_libdir}/libpython2.4.so* to python package
502- add LD_LIBRARY_PATH=$topdir to use pathfix.py
503- change build method of Doc
504- add files for make test
505- change install method
506
507* Wed Sep 28 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.2-0vl1
508- update python to 2.4.2 (final)
509
510* Wed Mar 30 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.1-0vl1
511- update python to 2.4.1 (final)
512
513* Sat Mar 19 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.1-0vl0.c2
514- update python to 2.4.1c2
515- moved all site-packages files to python-tools package
516
517* Sat Mar 12 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.1-0vl0.c1
518- update python to 2.4.1c1
519- droped aspython2 macros
520- droped japanese-codecs module
521- droped Source2 idle, now it's provided from original source
522- droped Source3 modulator, now it's generated in a spec file
523- droped Source4 pynche, now it's generated in a spec file
524- droped Python-2.3.3-buildroot-bytecode.patch
525- changed python-2.3.3-config2.patch to python-2.4.1c1-config.patch
526
527* Wed Feb 09 2005 Shu KONNO <owa@bg.wakwak.com> 2.3.5-0vl1
528- update python to 2.3.5
529
530* Fri Feb 04 2005 Shu KONNO <owa@bg.wakwak.com> 2.3.4-0vl6
531- add PSF-2005-001.patch
532
533* Wed Nov 17 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.4-0vl4
534- rebuilt
535
536* Wed Oct 13 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.3.4-0vl3
537- modified Patch0 and Patch8 (-ldb-4.0 -> -ldb-4.2)
538
539* Wed Oct 13 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.3.4-0vl2
540- rebuilt with db4-4.2.25
541
542* Thu May 27 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.4-0vl1
543- updated python to 2.3.4
544- fixed patch10, patch11
545
546* Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.3-0vl1
547- rebuild
548
549* Thu Apr 08 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.3-0vl0.3
550- updated python-2.3.3-config2.patch
551
552* Thu Apr 08 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.3-0vl0.2
553- added librarys 'logging, bsddb, idlelib' to /usr/lib/python2.3
554
555* Wed Apr 07 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.3-0vl0.1
556- updated python to 2.3.3
557- changed version code 2.2.3 to 2.3.3 in source{2,3,4}
558- updated config2.patch for 2.3.3
559- updated nowhatsnew.patch for 2.3.3
560- updated distutilrpm.patch in which tabstops have made indent error
561- updated buildroot-bytecode.patch for 2.3.3
562- deleted buildroot.patch which fixed in 2.3.3
563- changed Tools/idle with Lib/idlelib
564
565* Wed Mar 31 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.3-3vl3
566- rebuild with openssl-0.9.7d
567
568* Wed Mar 03 2004 Shu KONNO <owa@bg.wakwak.com> 2.2.3-3vl2
569- updated JapaneseCodecs to 1.4.10
570
571* Wed Jul 09 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.2.3-3vl1
572- synced with RawHide 2.2.3-3 (substantially source ver up)
573
574* Mon Mar 31 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.2.2-26vl1
575- rebuild with tcltk-8.4.2
576- synced with RawHide 2.2.2-26
577  * Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com>
578  - rebuilt
579
580  * Mon Feb 24 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-25
581  - Fixed bug #84886: pydoc dies when run w/o arguments
582  - Fixed bug #84205: add python shm module back (used to be shipped with 1.5.2)
583  - Fixed bug #84966: path in byte-compiled code still wrong
584
585  * Thu Feb 20 2003 Jeremy Katz <katzj@redhat.com> 2.2.2-23
586  - ftp uri's should be able to specify being rooted at the root instead of
587    where you login via ftp (#84692)
588
589  * Mon Feb 10 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-22
590  - Using newer Japanese codecs (1.4.9). Thanks to
591    Peter Bowen <pzb@datastacks.com> for pointing this out.
592
593  * Thu Feb  6 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-21
594  - Rebuild
595
596  * Wed Feb  5 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-20
597  - Release number bumped really high: turning on UCS4 (ABI compatibility
598    breakage)
599
600  * Fri Jan 31 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-13
601  - Attempt to look both in /usr/lib64 and /usr/lib/python2.2/site-packages/:
602    some work on python-2.2.2-lib64.patch
603
604  * Thu Jan 30 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-12
605  - Rebuild to incorporate the removal of .lib64 and - files.
606
607  * Thu Jan 30 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-11.7.3
608  - Fixed bug #82544: Errata removes most tools
609  - Fixed bug #82435: Python 2.2.2 errata breaks redhat-config-users
610  - Removed .lib64 and - files that get installed after we fix the multilib
611    .py files.
612
613  * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
614  - rebuilt
615
616  * Wed Jan 15 2003 Jens Petersen <petersen@redhat.com> 2.2.2-10
617  - rebuild to update tkinter's tcltk deps
618  - convert changelog to utf-8
619
620
621* Wed Jan 15 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.2-9vl0
622- rebuilt for Vine Linux against db4
623- obsolete python-base (which comes with python-2.2.1 of TestPkg)
624
625* Tue Jan  7 2003 Nalin Dahyabhai <nalin@redhat.com> 2.2.2-9
626- rebuild
627
628* Fri Jan  3 2003 Nalin Dahyabhai <nalin@redhat.com>
629- pick up OpenSSL cflags and ldflags from pkgconfig if available
630
631* Thu Jan  2 2003 Jeremy Katz <katzj@redhat.com> 2.2.2-8
632- urllib2 didn't support non-anonymous ftp.  add support based on how
633  urllib did it (#80676, #78168)
634
635* Mon Dec 16 2002 Mihai Ibanescu <misa@redhat.com> 2.2.2-7
636- Fix bug #79647 (Rebuild of SRPM fails if python isn't installed)
637- Added a bunch of missing BuildRequires found while fixing the
638  above-mentioned bug
639
640* Tue Dec 10 2002 Tim Powers <timp@redhat.com> 2.2.2-6
641- rebuild to fix broken tcltk deps for tkinter
642
643* Fri Nov 22 2002 Mihai Ibanescu <misa@redhat.com>
6442.2.2-3.7.3
645- Recompiled for 7.3 (to fix the -lcrypt bug)
646- Fix for the spurious error message at the end of the build (build-requires
647  gets confused by executable files starting with """"): make the tests
648  non-executable.
649
650* Wed Nov 20 2002 Mihai Ibanescu <misa@redhat.com>
6512.2.2-5
652- Fixed configuration patch to add -lcrypt when compiling cryptmodule.c
653
6542.2.2-4
655- Spec file change from Matt Wilson <msw@redhat.com> to disable linking
656  with the C++ compiler.
657
658* Mon Nov 11 2002 Mihai Ibanescu <misa@redhat.com>
6592.2.2-3.*
660- Merged patch from Karsten Hopp <karsten@redhat.de> from 2.2.1-17hammer to
661  use %%{_libdir}
662- Added XFree86-libs as BuildRequires (because of tkinter)
663- Fixed duplicate listing of plat-linux2
664- Fixed exclusion of lib-dynload/japanese
665- Added lib64 patch for the japanese codecs
666- Use setup magic instead of using tar directly on JapaneseCodecs
667
668* Tue Nov  5 2002 Mihai Ibanescu <misa@redhat.com>
6692.2.2-2
670- Fix #76912 (python-tools contains idle, which uses tkinter, but there is no
671  requirement of tkinter from python-tools).
672- Fix #74013 (rpm is missing the /usr/lib/python2.2/test directory)
673
674* Mon Nov  4 2002 Mihai Ibanescu <misa@redhat.com>
675- builds as python2 require a different libdb
676- changed the buildroot name of python to match python2 builds
677
678* Fri Nov  1 2002 Mihai Ibanescu <misa@redhat.com>
679- updated python to 2.2.2 and adjusted the patches accordingly
680
681* Mon Oct 21 2002 Mihai Ibanescu <misa@redhat.com>
682- Fix #53930 (Python-2.2.1-buildroot-bytecode.patch)
683- Added BuildPrereq dependency on gcc-c++
684
685* Fri Aug 30 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-17
686- security fix for _execvpe
687
688* Tue Aug 13 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-16
689- Fix  #71011,#71134, #58157
690
691* Wed Aug  7 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-15
692- Resurrect tkinter
693- Fix for distutils (#67671)
694- Fix #69962
695
696* Thu Jul 25 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-14
697- Obsolete tkinter/tkinter2 (#69838)
698
699* Tue Jul 23 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-13
700- Doc fixes (#53951) - not on alpha at the momemt
701
702* Mon Jul  8 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-12
703- fix pydoc (#68082)
704
705* Mon Jul  8 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-11
706- Add db4-devel as a BuildPrereq
707
708* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 2.2.1-10
709- automated rebuild
710
711* Mon Jun 17 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-9
712- Add Japanese codecs (#66352)
713
714* Tue Jun 11 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-8
715- No more tkinter...
716
717* Wed May 29 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-7
718- Rebuild
719
720* Tue May 21 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-6
721- Add the email subcomponent (#65301)
722
723* Fri May 10 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-5
724- Rebuild
725
726* Thu May 02 2002 Than Ngo <than@redhat.com> 2.2.1-4
727- rebuild i new enviroment
728
729* Tue Apr 23 2002 Trond Eivind Glomsroed <teg@redhat.com>
730- Use ucs2, not ucs4, to avoid breaking tkinter (#63965)
731
732* Mon Apr 22 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-2
733- Make it use db4
734
735* Fri Apr 12 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-1
736- 2.2.1 - a bugfix-only release
737
738* Fri Apr 12 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-16
739- the same, but in builddirs - this will remove them from the
740  docs package, which doesn't look in the buildroot for files.
741
742* Fri Apr 12 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-15
743- Get rid of temporary files and .cvsignores included
744  in the tarball and make install
745
746* Fri Apr  5 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-14
747- Don't own lib-tk in main package, only in tkinter (#62753)
748
749* Mon Mar 25 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-13
750- rebuild
751
752* Mon Mar 25 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-12
753- rebuild
754
755* Fri Mar  1 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-11
756- Add a not to the Distutils obsoletes test (doh!)
757
758* Fri Mar  1 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-10
759- Rebuild
760
761* Mon Feb 25 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-9
762- Only obsolete Distutils when built as python
763
764* Thu Feb 21 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-8
765- Make files in /usr/bin install side by side with python 1.5 when
766- Drop explicit requirement of db4
767  built as python2
768
769* Thu Jan 31 2002 Elliot Lee <sopwith@redhat.com> 2.2-7
770- Use version and pybasever macros to make updating easy
771- Use _smp_mflags macro
772
773* Tue Jan 29 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-6
774- Add db4-devel to BuildPrereq
775
776* Fri Jan 25 2002 Nalin Dahyabhai <nalin@redhat.com> 2.2-5
777- disable ndbm support, which is db2 in disguise (really interesting things
778  can happen when you mix db2 and db4 in a single application)
779
780* Thu Jan 24 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-4
781- Obsolete subpackages if necesarry
782- provide versioned python2
783- build with db4
784
785* Wed Jan 16 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-3
786- Alpha toolchain broken. Disable build on alpha.
787- New openssl
788
789* Wed Dec 26 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-1
790- 2.2 final
791
792* Fri Dec 14 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.11c1
793- 2.2 RC 1
794- Don't include the _tkinter module in the main package - it's
795  already in the tkiter packace
796- Turn off the mpzmodule, something broke in the buildroot
797
798* Wed Nov 28 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.10b2
799- Use -fPIC for OPT as well, in lack of a proper libpython.so
800
801* Mon Nov 26 2001 Matt Wilson <msw@redhat.com> 2.2-0.9b2
802- changed DESTDIR to point to / so that distutils will install dynload
803  modules properly in the installroot
804
805* Fri Nov 16 2001 Matt Wilson <msw@redhat.com> 2.2-0.8b2
806- 2.2b2
807
808* Fri Oct 26 2001 Matt Wilson <msw@redhat.com> 2.2-0.7b1
809- python2ify
810
811* Fri Oct 19 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.5b1
812- 2.2b1
813
814* Sun Sep 30 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.4a4
815- 2.2a4
816- Enable UCS4 support
817- Enable IPv6
818- Provide distutils
819- Include msgfmt.py and pygettext.py
820
821* Fri Sep 14 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.3a3
822- Obsolete Distutils, which is now part of the main package
823- Obsolete python2
824
825* Thu Sep 13 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.2a3
826- Add docs, tools and tkinter subpackages, to match the 1.5 layout
827
828* Wed Sep 12 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.1a3
829- 2.2a3
830- don't build tix and blt extensions
831
832* Mon Aug 13 2001 Trond Eivind Glomsroed <teg@redhat.com>
833- Add tk and tix to build dependencies
834
835* Sat Jul 21 2001 Trond Eivind Glomsroed <teg@redhat.com>
836- 2.1.1 bugfix release - with a GPL compatible license
837
838* Fri Jul 20 2001 Trond Eivind Glomsroed <teg@redhat.com>
839- Add new build dependencies (#49753)
840
841* Tue Jun 26 2001 Nalin Dahyabhai <nalin@redhat.com>
842- build with -fPIC
843
844* Fri Jun  1 2001 Trond Eivind Glomsroed <teg@redhat.com>
845- 2.1
846- reorganization of file includes
847
848* Wed Dec 20 2000 Trond Eivind Glomsroed <teg@redhat.com>
849- fix the "requires" clause, it lacked a space causing problems
850- use %%{_tmppath}
851- don't define name, version etc
852- add the available patches from the Python home page
853
854* Fri Dec 15 2000 Matt Wilson <msw@redhat.com>
855- added devel subpackage
856
857* Fri Dec 15 2000 Matt Wilson <msw@redhat.com>
858- modify all files to use "python2.0" as the intrepter
859- don't build the Expat bindings
860- build against db1
861
862* Mon Oct 16 2000 Jeremy Hylton <jeremy@beopen.com>
863- updated for 2.0 final
864
865* Mon Oct  9 2000 Jeremy Hylton <jeremy@beopen.com>
866- updated for 2.0c1
867- build audioop, imageop, and rgbimg extension modules
868- include xml.parsers subpackage
869- add test.xml.out to files list
870
871* Thu Oct  5 2000 Jeremy Hylton <jeremy@beopen.com>
872- added bin/python2.0 to files list (suggested by Martin v. Loewis)
873
874* Tue Sep 26 2000 Jeremy Hylton <jeremy@beopen.com>
875- updated for release 1 of 2.0b2
876- use .bz2 version of Python source
877
878* Tue Sep 12 2000 Jeremy Hylton <jeremy@beopen.com>
879- Version 2 of 2.0b1
880- Make the package relocatable.  Thanks to Suchandra Thapa.
881- Exclude Tkinter from main RPM.  If it is in a separate RPM, it is
882  easier to track Tk releases.
Note: See TracBrowser for help on using the repository browser.