source: projects/specs/trunk/p/python-pyxml/python-pyxml-vl.spec @ 889

Revision 889, 3.7 KB checked in by inagaki, 14 years ago (diff)

updated: cyrus-imapd, python-pyxml

Line 
1%define module PyXML
2#%define pyver %(python -c 'import sys;print(sys.version[0:3])')
3#%define pysite %{_libdir}/python%{pyver}/site-packages
4%define pyinc %{_includedir}/python%{pyver}
5Summary:        XML libraries for python
6Summary(ja):    Python XML ライブラリ
7Name:           python-pyxml
8Version:        0.8.4
9Release:        5%{?_dist_release}
10URL:            http://pyxml.sourceforge.net/
11Source0:        http://prdownloads.sourceforge.net/pyxml/PyXML-%{version}.tar.gz
12Patch0:         PyXML-0.7.1-intern.patch
13Patch1:         PyXML-0.8.4-cvs20041111-python2.4-backport.patch
14Patch2:         PyXML-memmove.patch
15Patch3:         PyXML-0.8.4-python2.6.patch
16
17License:        Apacheish
18Group:          Development/Libraries
19
20BuildRoot:      %{_tmppath}/%{name}-%{version}-root
21BuildRequires:  python-devel, expat-devel
22BuildRequires:  python-setuptools
23Requires:       python, libexpat
24Obsoletes:      %{module}
25Provides:       %{module}
26
27%description
28An XML package for Python. The distribution contains a validating XML
29parser, an implementation of the SAX and DOM programming interfaces
30and an interface to the Expat parser.
31
32%prep
33%setup -q -n %{module}-%{version}
34%patch0 -p1 -b .intern
35%patch1 -p1 -b .python2.4-backport
36%patch2 -p1
37%patch3 -p1
38
39# iconv to use utf8
40for file in CREDITS ANNOUNCE doc/xml-howto.txt doc/xml-ref.txt README; do
41  iconv -f iso8859-1 -t utf-8 -o tmp $file
42  mv tmp $file
43done
44
45%build
46CFLAGS="%{optflags}" \
47        %{_bindir}/python -c 'import setuptools; execfile("setup.py")' build --with-libexpat=%{_prefix}
48
49%install
50%__rm -rf %{buildroot}
51%{_bindir}/python -c 'import setuptools; execfile("setup.py")' install --skip-build install --root=%{buildroot}
52
53%{_bindir}/python -O %{_libdir}/python%{pyver}/compileall.py \
54        %{buildroot}%{python_sitearch}
55
56%clean
57%__rm -rf %{buildroot}
58
59%files
60%defattr(-,root,root)
61%doc LICENCE ANNOUNCE CREDITS README README.* TODO doc/*
62%{_bindir}/*
63%{python_sitearch}/*
64
65%changelog
66* Sat Jun 06 2009 Shu KONNO <owa@bg.wakwak.com> 0.8.4-5
67- rebuilt with python-2.6
68- added Patch0-4 from Fedora
69  * Wed Dec 24 2008 Johan Cwiklinski <johan AT x-tnd DOT be> - 0.8.4-12
70  - Patch for 'as' reserved keyword (bug #477783)
71  * Thu Jul 27 2006 Florian La Roche <laroche@redhat.com> - 0.8.4-4
72  - don't check memmove
73  * Thu Nov 11 2004 Miloslav Trmac <mitr@redhat.com> - 0.8.4-0.cvs20041111.1
74  - Backport xml.sax.saxutils fix from Python 2.4b2
75  * Fri Jun 28 2002 Trond Eivind Glomsrød <teg@redhat.com>
76  - A fix for the expatreader
77
78* Sat Jun 06 2009 Shu KONNO <owa@bg.wakwak.com> 0.8.4-4
79- spec in utf-8 properly
80- use rpm macros: pyver, python_sitearch
81
82* Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> 0.8.4-3vl5
83- rebuilt with python-2.5.2
84- applied new versioning policy and spec in utf-8
85
86* Wed Feb 27 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.8.4-2vl3
87- rebuild with expat-2.0.1
88
89* Mon May  8 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.4-2vl2
90- fixed Japanese summary
91- changed Group:
92
93* Wed Sep 21 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.4-2vl1
94- initial build for Vine Linux
95
96* Wed May  4 2005 Gotz Waschk <waschk@mandriva.org> 0.8.4-2mdk
97- use external libexpat
98- enable xpath and xslt
99
100* Thu Dec 16 2004 Guillaume Rousse <guillomovitch@mandrake.org> 0.8.4-1mdk
101- new version
102- changed name
103
104* Sun Dec 05 2004 Michael Scherer <misc@mandrake.org> 0.8.3-4mdk
105- Rebuild for new python
106
107* Mon Nov 01 2004 Michael Scherer <misc@mandrake.org> 0.8.3-3mdk
108- [DIRM]
109
110* Sat Apr 10 2004 Michael Scherer <misc@mandrake.org> 0.8.3-2mdk
111- [DIRM]
112
113* Wed Aug 20 2003 Austin Acton <aacton@yorku.ca> 0.8.3-1mdk
114- 0.8.3
115
116* Tue Aug 12 2003 Per Oyvind Karlsen <peroyvind@linux-mandrake.com> 0.8.2-4mdk
117- rebuild for new python
118
119* Sat Mar 29 2003 David Walluck <walluck@linux-mandrake.com> 0.8.2-3mdk
120- release
121
122* Tue Mar 25 2003 David Walluck <david@anti-microsoft.org> 0.8.2-2plf
123- spec file cleanups
124
125* Sun Jan 26 2003 David Walluck <david@anti-microsoft.org> 0.8.2-1plf
126- release
Note: See TracBrowser for help on using the repository browser.