source: projects/specs/trunk/p/python-pyxml/python-pyxml-vl.spec @ 521

Revision 521, 2.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define module PyXML
2#%define pyver %(python -c 'import sys;print(sys.version[0:3])')
3#%define pysite %{_libdir}/python%{pyver}/site-packages
4%define pyinc %{_includedir}/python%{pyver}
5Summary:        XML libraries for python
6Summary(ja):    Python XML ライブラリ
7Name:           python-pyxml
8Version:        0.8.4
9Release:        4%{?_dist_release}
10URL:            http://pyxml.sourceforge.net/
11Source0:        http://prdownloads.sourceforge.net/pyxml/PyXML-%{version}.tar.gz
12License:        Apacheish
13Group:          Development/Languages
14Requires:       python, libexpat
15BuildRequires:  python-devel, expat-devel
16BuildRoot:      %{_tmppath}/%{name}-%{version}-root
17Obsoletes:      %{module}
18Provides:       %{module}
19
20%description
21An XML package for Python. The distribution contains a validating XML
22parser, an implementation of the SAX and DOM programming interfaces
23and an interface to the Expat parser.
24
25%prep
26%setup -q -n %{module}-%{version}
27
28%build
29CFLAGS="%{optflags}" \
30        %{_bindir}/python setup.py build --with-libexpat=%{_prefix}
31
32%install
33%__rm -rf %{buildroot}
34%{_bindir}/python setup.py install --root=%{buildroot}
35
36%{_bindir}/python -O %{_libdir}/python%{pyver}/compileall.py \
37        %{buildroot}%{python_sitearch}
38
39%clean
40%__rm -rf %{buildroot}
41
42%files
43%defattr(-,root,root)
44%doc LICENCE ANNOUNCE CREDITS README README.* TODO doc/*
45%{_bindir}/*
46%{python_sitearch}/*
47
48%changelog
49* Sat Jun 06 2009 Shu KONNO <owa@bg.wakwak.com> 0.8.4-4
50- spec in utf-8 properly
51- use rpm macros: pyver, python_sitearch
52
53* Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> 0.8.4-3vl5
54- rebuilt with python-2.5.2
55- applied new versioning policy and spec in utf-8
56
57* Wed Feb 27 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.8.4-2vl3
58- rebuild with expat-2.0.1
59
60* Mon May  8 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.4-2vl2
61- fixed Japanese summary
62- changed Group:
63
64* Wed Sep 21 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.4-2vl1
65- initial build for Vine Linux
66
67* Wed May  4 2005 Gotz Waschk <waschk@mandriva.org> 0.8.4-2mdk
68- use external libexpat
69- enable xpath and xslt
70
71* Thu Dec 16 2004 Guillaume Rousse <guillomovitch@mandrake.org> 0.8.4-1mdk
72- new version
73- changed name
74
75* Sun Dec 05 2004 Michael Scherer <misc@mandrake.org> 0.8.3-4mdk
76- Rebuild for new python
77
78* Mon Nov 01 2004 Michael Scherer <misc@mandrake.org> 0.8.3-3mdk
79- [DIRM]
80
81* Sat Apr 10 2004 Michael Scherer <misc@mandrake.org> 0.8.3-2mdk
82- [DIRM]
83
84* Wed Aug 20 2003 Austin Acton <aacton@yorku.ca> 0.8.3-1mdk
85- 0.8.3
86
87* Tue Aug 12 2003 Per Oyvind Karlsen <peroyvind@linux-mandrake.com> 0.8.2-4mdk
88- rebuild for new python
89
90* Sat Mar 29 2003 David Walluck <walluck@linux-mandrake.com> 0.8.2-3mdk
91- release
92
93* Tue Mar 25 2003 David Walluck <david@anti-microsoft.org> 0.8.2-2plf
94- spec file cleanups
95
96* Sun Jan 26 2003 David Walluck <david@anti-microsoft.org> 0.8.2-1plf
97- release
Note: See TracBrowser for help on using the repository browser.