source: projects/specs/trunk/p/python-pyxml/python-pyxml-vl.spec @ 8158

Revision 8158, 4.0 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release or rebuild

Line 
1%define module PyXML
2#%define pyver %(python -c 'import sys;print(sys.version[0:3])')
3#%define pysite %{_libdir}/python%{pyver}/site-packages
4%define pyinc %{_includedir}/python%{pyver}
5Summary:        XML libraries for python
6Summary(ja):    Python XML ライブラリ
7Name:           python-pyxml
8Version:        0.8.4
9Release:        7%{?_dist_release}
10URL:            http://pyxml.sourceforge.net/
11Source0:        http://prdownloads.sourceforge.net/pyxml/PyXML-%{version}.tar.gz
12Patch0:         PyXML-0.7.1-intern.patch
13Patch1:         PyXML-0.8.4-cvs20041111-python2.4-backport.patch
14Patch2:         PyXML-memmove.patch
15Patch3:         PyXML-0.8.4-python2.6.patch
16
17License:        Apacheish
18Group:          Development/Libraries
19
20BuildRoot:      %{_tmppath}/%{name}-%{version}-root
21BuildRequires:  python-devel, expat-devel
22BuildRequires:  python-setuptools
23Requires:       python, libexpat
24Obsoletes:      %{module}
25Provides:       %{module}
26
27Vendor: Project Vine
28Distribution: Vine Linux
29
30%description
31An XML package for Python. The distribution contains a validating XML
32parser, an implementation of the SAX and DOM programming interfaces
33and an interface to the Expat parser.
34
35%prep
36%setup -q -n %{module}-%{version}
37%patch0 -p1 -b .intern
38%patch1 -p1 -b .python2.4-backport
39%patch2 -p1
40%patch3 -p1
41
42# iconv to use utf8
43for file in CREDITS ANNOUNCE doc/xml-howto.txt doc/xml-ref.txt README; do
44  iconv -f iso8859-1 -t utf-8 -o tmp $file
45  mv tmp $file
46done
47
48%build
49CFLAGS="%{optflags}" \
50        %{_bindir}/python -c 'import setuptools; execfile("setup.py")' build --with-libexpat=%{_prefix}
51
52%install
53%__rm -rf %{buildroot}
54%{_bindir}/python -c 'import setuptools; execfile("setup.py")' install --skip-build install --root=%{buildroot}
55
56%{_bindir}/python -O %{_libdir}/python%{pyver}/compileall.py \
57        %{buildroot}%{python_sitearch}
58
59%clean
60%__rm -rf %{buildroot}
61
62%files
63%defattr(-,root,root)
64%doc LICENCE ANNOUNCE CREDITS README README.* TODO doc/*
65%{_bindir}/*
66%{python_sitearch}/*
67
68%changelog
69* Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.4-7
70- rebuild with VineSeed environment
71
72* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.4-6
73- rebuild with python-2.7.2
74
75* Sat Jun 06 2009 Shu KONNO <owa@bg.wakwak.com> 0.8.4-5
76- rebuilt with python-2.6
77- added Patch0-4 from Fedora
78  * Wed Dec 24 2008 Johan Cwiklinski <johan AT x-tnd DOT be> - 0.8.4-12
79  - Patch for 'as' reserved keyword (bug #477783)
80  * Thu Jul 27 2006 Florian La Roche <laroche@redhat.com> - 0.8.4-4
81  - don't check memmove
82  * Thu Nov 11 2004 Miloslav Trmac <mitr@redhat.com> - 0.8.4-0.cvs20041111.1
83  - Backport xml.sax.saxutils fix from Python 2.4b2
84  * Fri Jun 28 2002 Trond Eivind Glomsrød <teg@redhat.com>
85  - A fix for the expatreader
86
87* Sat Jun 06 2009 Shu KONNO <owa@bg.wakwak.com> 0.8.4-4
88- spec in utf-8 properly
89- use rpm macros: pyver, python_sitearch
90
91* Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> 0.8.4-3vl5
92- rebuilt with python-2.5.2
93- applied new versioning policy and spec in utf-8
94
95* Wed Feb 27 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.8.4-2vl3
96- rebuild with expat-2.0.1
97
98* Mon May  8 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.4-2vl2
99- fixed Japanese summary
100- changed Group:
101
102* Wed Sep 21 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.4-2vl1
103- initial build for Vine Linux
104
105* Wed May  4 2005 Gotz Waschk <waschk@mandriva.org> 0.8.4-2mdk
106- use external libexpat
107- enable xpath and xslt
108
109* Thu Dec 16 2004 Guillaume Rousse <guillomovitch@mandrake.org> 0.8.4-1mdk
110- new version
111- changed name
112
113* Sun Dec 05 2004 Michael Scherer <misc@mandrake.org> 0.8.3-4mdk
114- Rebuild for new python
115
116* Mon Nov 01 2004 Michael Scherer <misc@mandrake.org> 0.8.3-3mdk
117- [DIRM]
118
119* Sat Apr 10 2004 Michael Scherer <misc@mandrake.org> 0.8.3-2mdk
120- [DIRM]
121
122* Wed Aug 20 2003 Austin Acton <aacton@yorku.ca> 0.8.3-1mdk
123- 0.8.3
124
125* Tue Aug 12 2003 Per Oyvind Karlsen <peroyvind@linux-mandrake.com> 0.8.2-4mdk
126- rebuild for new python
127
128* Sat Mar 29 2003 David Walluck <walluck@linux-mandrake.com> 0.8.2-3mdk
129- release
130
131* Tue Mar 25 2003 David Walluck <david@anti-microsoft.org> 0.8.2-2plf
132- spec file cleanups
133
134* Sun Jan 26 2003 David Walluck <david@anti-microsoft.org> 0.8.2-1plf
135- release
Note: See TracBrowser for help on using the repository browser.