source: projects/specs/trunk/p/python-dns/python-dns-vl.spec @ 6890

Revision 6890, 9.2 KB checked in by Takemikaduchi, 12 years ago (diff)

GNOME-3.6.0 & Cinnamon-1.6.1

Line 
1Name:           python-dns
2Version:        1.10.0
3Release:        1%{?_dist_release}
4Summary:        DNS toolkit for Python
5Summary(ja):    Python 用 DNS ツールキット
6
7Group:          Development/Languages
8License:        MIT
9URL:            http://www.dnspython.org/
10Source0:        http://www.dnspython.org/kits/%{version}/dnspython-%{version}.tar.gz
11Source1:        http://www.dnspython.org/kits/%{version}/dnspython-%{version}.tar.gz.asc
12BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
13
14BuildArch:      noarch
15BuildRequires: python-setuptools
16
17%description
18dnspython is a DNS toolkit for Python. It supports almost all record
19types. It can be used for queries, zone transfers, and dynamic
20updates. It supports TSIG authenticated messages and EDNS0.
21
22dnspython provides both high and low level access to DNS. The high
23level classes perform queries for data of a given name, type, and
24class, and return an answer set. The low level classes allow direct
25manipulation of DNS zones, messages, names, and records.
26
27%prep
28%setup0 -q -n dnspython-%{version}
29
30# strip executable permissions so that we don't pick up dependencies
31# from documentation
32find examples -type f | xargs chmod a-x
33
34%build
35CFLAGS="%{optflags}" %{__python} -c 'import setuptools; execfile("setup.py")' build
36
37%install
38rm -rf %{buildroot}
39%{__python} -c 'import setuptools; execfile("setup.py")' install --skip-build --root %{buildroot}
40
41%check
42pushd tests
43# skip one test because it queries the network
44for py in *.py
45do
46        if [ $py != resolver.py ]
47        then
48                PYTHONPATH=%{buildroot}%{python_sitelib} %{__python} $py
49        fi
50done
51
52%clean
53rm -rf %{buildroot}
54
55%files
56%defattr(-,root,root,-)
57%doc ChangeLog LICENSE README examples
58
59%{python_sitelib}/*egg-info
60%{python_sitelib}/dns
61
62%changelog
63* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.0-1
64- new upstream release
65
66* Thu Apr 05 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.4-1
67- initial build for Vine Linux
68
69* Mon Mar 28 2011 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.9.4-1
70-
71- dnspython 1.9.4 has been released and is available at
72- http://www.dnspython.org/kits/1.9.4/
73-
74- There is no new functionality in this release; just a few bug fixes
75- in RRSIG and SIG code.
76-
77- I will be eliminating legacy code for earlier versions of DNSSEC in a
78- future release of dnspython.
79
80* Fri Mar 25 2011 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.9.3-1
81-
82- New since 1.9.2:
83-
84-     A boolean parameter, 'raise_on_no_answer', has been added to
85- the query() methods.  In no-error, no-data situations, this
86- parameter determines whether NoAnswer should be raised or not.
87- If True, NoAnswer is raised.  If False, then an Answer()
88- object with a None rrset will be returned.
89-
90- Resolver Answer() objects now have a canonical_name field.
91-
92- Rdata now have a __hash__ method.
93-
94- Bugs fixed since 1.9.2:
95-
96-        Dnspython was erroneously doing case-insensitive comparisons
97- of the names in NSEC and RRSIG RRs.
98-
99- We now use "is" and not "==" when testing what section an RR
100- is in.
101-
102- The resolver now disallows metaqueries.
103
104* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.9.2-2
105- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
106
107* Tue Nov 23 2010 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.9.2-1
108- It's brown paper bag time :) The fix for the import problems was
109- actually bad, but didn't show up in testing because the test suite's
110- conditional importing code hid the problem.
111-
112- Any, 1.9.2 is out.
113-
114- Sorry for the churn!
115
116* Mon Nov 22 2010 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.9.1-1
117- New since 1.9.0:
118-
119-        Nothing.
120-
121- Bugs fixed since 1.9.0
122-
123-        The dns.dnssec module didn't work with DSA due to namespace
124-        contamination from a "from"-style import.
125-
126- New since 1.8.0:
127-
128-        dnspython now uses poll() instead of select() when available.
129-
130-        Basic DNSSEC validation can be done using dns.dnsec.validate()
131-        and dns.dnssec.validate_rrsig() if you have PyCrypto 2.3 or
132-        later installed.  Complete secure resolution is not yet
133-        available.
134-
135-        Added key_id() to the DNSSEC module, which computes the DNSSEC
136-        key id of a DNSKEY rdata.
137-
138-        Added make_ds() to the DNSSEC module, which returns the DS RR
139-        for a given DNSKEY rdata.
140-
141-        dnspython now raises an exception if HMAC-SHA284 or
142-        HMAC-SHA512 are used with a Python older than 2.5.2.  (Older
143-        Pythons do not compute the correct value.)
144-
145-        Symbolic constants are now available for TSIG algorithm names.
146-
147- Bugs fixed since 1.8.0
148-
149-        dns.resolver.zone_for_name() didn't handle a query response
150-        with a CNAME or DNAME correctly in some cases.
151-
152-        When specifying rdata types and classes as text, Unicode
153-        strings may now be used.
154-
155-        Hashlib compatibility issues have been fixed.
156-
157-        dns.message now imports dns.edns.
158-
159-        The TSIG algorithm value was passed incorrectly to use_tsig()
160-        in some cases.
161
162* Fri Aug 13 2010 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.8.0-3
163- Add a patch from upstream to fix a Python 2.7 issue.
164
165* Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 1.8.0-2.1
166- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
167
168* Wed Jan 27 2010 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.8.0-1.1
169- Fix error
170
171* Wed Jan 27 2010 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.8.0-1
172- New since 1.7.1:
173-
174-  Support for hmac-sha1, hmac-sha224, hmac-sha256, hmac-sha384 and
175-  hmac-sha512 has been contributed by Kevin Chen.
176-
177-  The tokenizer's tokens are now Token objects instead of (type,
178-  value) tuples.
179-
180- Bugs fixed since 1.7.1:
181-
182-  Escapes in masterfiles now work correctly.  Previously they were
183-  only working correctly when the text involved was part of a domain
184-  name.
185-
186-  When constructing a DDNS update, if the present() method was used
187-  with a single rdata, a zero TTL was not added.
188-
189-  The entropy pool needed locking to be thread safe.
190-
191-  The entropy pool's reading of /dev/random could cause dnspython to
192-  block.
193-
194-  The entropy pool did buffered reads, potentially consuming more
195-  randomness than we needed.
196-
197-  The entropy pool did not seed with high quality randomness on
198-  Windows.
199-
200-  SRV records were compared incorrectly.
201-
202-  In the e164 query function, the resolver parameter was not used.
203
204* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.7.1-2
205- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
206
207* Fri Jun 19 2009 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.7.1-1
208- New since 1.7.0:
209-
210-        Nothing
211-
212- Bugs fixed since 1.7.0:
213-
214-        The 1.7.0 kitting process inadventently omitted the code for the
215-        DLV RR.
216-
217-        Negative DDNS prerequisites are now handled correctly.
218
219* Fri Jun 19 2009 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.7.0-1
220- New since 1.6.0:
221-
222-        Rdatas now have a to_digestable() method, which returns the
223-        DNSSEC canonical form of the rdata, suitable for use in
224-        signature computations.
225-
226-        The NSEC3, NSEC3PARAM, DLV, and HIP RR types are now supported.
227-
228-        An entropy module has been added and is used to randomize query ids.
229-
230-        EDNS0 options are now supported.
231-
232-        UDP IXFR is now supported.
233-
234-        The wire format parser now has a 'one_rr_per_rrset' mode, which
235-        suppresses the usual coalescing of all RRs of a given type into a
236-        single RRset.
237-
238-        Various helpful DNSSEC-related constants are now defined.
239-
240-        The resolver's query() method now has an optional 'source' parameter,
241-        allowing the source IP address to be specified.
242-
243- Bugs fixed since 1.6.0:
244-
245-        On Windows, the resolver set the domain incorrectly.
246-
247-        DS RR parsing only allowed one Base64 chunk.
248-
249-        TSIG validation didn't always use absolute names.
250-
251-        NSEC.to_text() only printed the last window.
252-
253-        We did not canonicalize IPv6 addresses before comparing them; we
254-        would thus treat equivalent but different textual forms, e.g.
255-        "1:00::1" and "1::1" as being non-equivalent.
256-
257-        If the peer set a TSIG error, we didn't raise an exception.
258-
259-        Some EDNS bugs in the message code have been fixed (see the ChangeLog
260-        for details).
261
262* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.0-4
263- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
264
265* Sat Nov 29 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.6.0-3
266- Rebuild for Python 2.6
267
268* Fri Aug 29 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.6.0-2
269- fix license tag
270
271* Sat Dec  4 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.6.0-1
272- Update to 1.6.0
273
274* Tue Oct  9 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.5.0-2
275- Follow new Python egg packaging specs
276
277* Thu Jan 11 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.5.0-1
278- Update to 1.5.0
279
280* Fri Dec  8 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.4.0-3
281- Bump release for rebuild with Python 2.5
282
283* Mon Aug 14 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.4.0-2
284- No longer ghost *.pyo files, thus further simplifying the files section.
285
286* Sat Aug  5 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.4.0-1
287- Update to 1.4.0
288- Remove unneeded python-abi requires
289- Remove unneeded python_sitearch macro
290
291* Fri May 26 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.3.5-1
292- First version for Fedora Extras
293
Note: See TracBrowser for help on using the repository browser.