source: projects/specs/trunk/p/python-dns/python-dns-vl.spec @ 7618

Revision 7618, 9.3 KB checked in by daisuke, 11 years ago (diff)

python-dns: add BR* python,python-devel

Line 
1Name:           python-dns
2Version:        1.10.0
3Release:        2%{?_dist_release}
4Summary:        DNS toolkit for Python
5Summary(ja):    Python 用 DNS ツールキット
6
7Group:          Development/Languages
8License:        MIT
9URL:            http://www.dnspython.org/
10Source0:        http://www.dnspython.org/kits/%{version}/dnspython-%{version}.tar.gz
11Source1:        http://www.dnspython.org/kits/%{version}/dnspython-%{version}.tar.gz.asc
12BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
13
14BuildArch:      noarch
15BuildRequires: python-setuptools
16BuildRequires: python-devel
17
18%description
19dnspython is a DNS toolkit for Python. It supports almost all record
20types. It can be used for queries, zone transfers, and dynamic
21updates. It supports TSIG authenticated messages and EDNS0.
22
23dnspython provides both high and low level access to DNS. The high
24level classes perform queries for data of a given name, type, and
25class, and return an answer set. The low level classes allow direct
26manipulation of DNS zones, messages, names, and records.
27
28%prep
29%setup0 -q -n dnspython-%{version}
30
31# strip executable permissions so that we don't pick up dependencies
32# from documentation
33find examples -type f | xargs chmod a-x
34
35%build
36CFLAGS="%{optflags}" %{__python} -c 'import setuptools; execfile("setup.py")' build
37
38%install
39rm -rf %{buildroot}
40%{__python} -c 'import setuptools; execfile("setup.py")' install --skip-build --root %{buildroot}
41
42%check
43pushd tests
44# skip one test because it queries the network
45for py in *.py
46do
47        if [ $py != resolver.py ]
48        then
49                PYTHONPATH=%{buildroot}%{python_sitelib} %{__python} $py
50        fi
51done
52
53%clean
54rm -rf %{buildroot}
55
56%files
57%defattr(-,root,root,-)
58%doc ChangeLog LICENSE README examples
59
60%{python_sitelib}/*egg-info
61%{python_sitelib}/dns
62
63%changelog
64* Mon Apr 08 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.0-2
65- add BR: python-devel, python
66
67* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.0-1
68- new upstream release
69
70* Thu Apr 05 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.4-1
71- initial build for Vine Linux
72
73* Mon Mar 28 2011 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.9.4-1
74-
75- dnspython 1.9.4 has been released and is available at
76- http://www.dnspython.org/kits/1.9.4/
77-
78- There is no new functionality in this release; just a few bug fixes
79- in RRSIG and SIG code.
80-
81- I will be eliminating legacy code for earlier versions of DNSSEC in a
82- future release of dnspython.
83
84* Fri Mar 25 2011 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.9.3-1
85-
86- New since 1.9.2:
87-
88-     A boolean parameter, 'raise_on_no_answer', has been added to
89- the query() methods.  In no-error, no-data situations, this
90- parameter determines whether NoAnswer should be raised or not.
91- If True, NoAnswer is raised.  If False, then an Answer()
92- object with a None rrset will be returned.
93-
94- Resolver Answer() objects now have a canonical_name field.
95-
96- Rdata now have a __hash__ method.
97-
98- Bugs fixed since 1.9.2:
99-
100-        Dnspython was erroneously doing case-insensitive comparisons
101- of the names in NSEC and RRSIG RRs.
102-
103- We now use "is" and not "==" when testing what section an RR
104- is in.
105-
106- The resolver now disallows metaqueries.
107
108* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.9.2-2
109- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
110
111* Tue Nov 23 2010 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.9.2-1
112- It's brown paper bag time :) The fix for the import problems was
113- actually bad, but didn't show up in testing because the test suite's
114- conditional importing code hid the problem.
115-
116- Any, 1.9.2 is out.
117-
118- Sorry for the churn!
119
120* Mon Nov 22 2010 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.9.1-1
121- New since 1.9.0:
122-
123-        Nothing.
124-
125- Bugs fixed since 1.9.0
126-
127-        The dns.dnssec module didn't work with DSA due to namespace
128-        contamination from a "from"-style import.
129-
130- New since 1.8.0:
131-
132-        dnspython now uses poll() instead of select() when available.
133-
134-        Basic DNSSEC validation can be done using dns.dnsec.validate()
135-        and dns.dnssec.validate_rrsig() if you have PyCrypto 2.3 or
136-        later installed.  Complete secure resolution is not yet
137-        available.
138-
139-        Added key_id() to the DNSSEC module, which computes the DNSSEC
140-        key id of a DNSKEY rdata.
141-
142-        Added make_ds() to the DNSSEC module, which returns the DS RR
143-        for a given DNSKEY rdata.
144-
145-        dnspython now raises an exception if HMAC-SHA284 or
146-        HMAC-SHA512 are used with a Python older than 2.5.2.  (Older
147-        Pythons do not compute the correct value.)
148-
149-        Symbolic constants are now available for TSIG algorithm names.
150-
151- Bugs fixed since 1.8.0
152-
153-        dns.resolver.zone_for_name() didn't handle a query response
154-        with a CNAME or DNAME correctly in some cases.
155-
156-        When specifying rdata types and classes as text, Unicode
157-        strings may now be used.
158-
159-        Hashlib compatibility issues have been fixed.
160-
161-        dns.message now imports dns.edns.
162-
163-        The TSIG algorithm value was passed incorrectly to use_tsig()
164-        in some cases.
165
166* Fri Aug 13 2010 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.8.0-3
167- Add a patch from upstream to fix a Python 2.7 issue.
168
169* Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 1.8.0-2.1
170- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
171
172* Wed Jan 27 2010 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.8.0-1.1
173- Fix error
174
175* Wed Jan 27 2010 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.8.0-1
176- New since 1.7.1:
177-
178-  Support for hmac-sha1, hmac-sha224, hmac-sha256, hmac-sha384 and
179-  hmac-sha512 has been contributed by Kevin Chen.
180-
181-  The tokenizer's tokens are now Token objects instead of (type,
182-  value) tuples.
183-
184- Bugs fixed since 1.7.1:
185-
186-  Escapes in masterfiles now work correctly.  Previously they were
187-  only working correctly when the text involved was part of a domain
188-  name.
189-
190-  When constructing a DDNS update, if the present() method was used
191-  with a single rdata, a zero TTL was not added.
192-
193-  The entropy pool needed locking to be thread safe.
194-
195-  The entropy pool's reading of /dev/random could cause dnspython to
196-  block.
197-
198-  The entropy pool did buffered reads, potentially consuming more
199-  randomness than we needed.
200-
201-  The entropy pool did not seed with high quality randomness on
202-  Windows.
203-
204-  SRV records were compared incorrectly.
205-
206-  In the e164 query function, the resolver parameter was not used.
207
208* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.7.1-2
209- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
210
211* Fri Jun 19 2009 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.7.1-1
212- New since 1.7.0:
213-
214-        Nothing
215-
216- Bugs fixed since 1.7.0:
217-
218-        The 1.7.0 kitting process inadventently omitted the code for the
219-        DLV RR.
220-
221-        Negative DDNS prerequisites are now handled correctly.
222
223* Fri Jun 19 2009 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.7.0-1
224- New since 1.6.0:
225-
226-        Rdatas now have a to_digestable() method, which returns the
227-        DNSSEC canonical form of the rdata, suitable for use in
228-        signature computations.
229-
230-        The NSEC3, NSEC3PARAM, DLV, and HIP RR types are now supported.
231-
232-        An entropy module has been added and is used to randomize query ids.
233-
234-        EDNS0 options are now supported.
235-
236-        UDP IXFR is now supported.
237-
238-        The wire format parser now has a 'one_rr_per_rrset' mode, which
239-        suppresses the usual coalescing of all RRs of a given type into a
240-        single RRset.
241-
242-        Various helpful DNSSEC-related constants are now defined.
243-
244-        The resolver's query() method now has an optional 'source' parameter,
245-        allowing the source IP address to be specified.
246-
247- Bugs fixed since 1.6.0:
248-
249-        On Windows, the resolver set the domain incorrectly.
250-
251-        DS RR parsing only allowed one Base64 chunk.
252-
253-        TSIG validation didn't always use absolute names.
254-
255-        NSEC.to_text() only printed the last window.
256-
257-        We did not canonicalize IPv6 addresses before comparing them; we
258-        would thus treat equivalent but different textual forms, e.g.
259-        "1:00::1" and "1::1" as being non-equivalent.
260-
261-        If the peer set a TSIG error, we didn't raise an exception.
262-
263-        Some EDNS bugs in the message code have been fixed (see the ChangeLog
264-        for details).
265
266* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.0-4
267- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
268
269* Sat Nov 29 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.6.0-3
270- Rebuild for Python 2.6
271
272* Fri Aug 29 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.6.0-2
273- fix license tag
274
275* Tue Dec  4 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.6.0-1
276- Update to 1.6.0
277
278* Tue Oct  9 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.5.0-2
279- Follow new Python egg packaging specs
280
281* Thu Jan 11 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.5.0-1
282- Update to 1.5.0
283
284* Fri Dec  8 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.4.0-3
285- Bump release for rebuild with Python 2.5
286
287* Mon Aug 14 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.4.0-2
288- No longer ghost *.pyo files, thus further simplifying the files section.
289
290* Sat Aug  5 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.4.0-1
291- Update to 1.4.0
292- Remove unneeded python-abi requires
293- Remove unneeded python_sitearch macro
294
295* Fri May 26 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.3.5-1
296- First version for Fedora Extras
297
Note: See TracBrowser for help on using the repository browser.