source: projects/specs/trunk/p/python-dns/python-dns-vl.spec @ 12469

Revision 12469, 10.1 KB checked in by tomop, 4 years ago (diff)

python-3.8.5 and related packages.

Line 
1Name:           python-dns
2Version:        2.0.0
3Release:        1%{?_dist_release}
4Summary:        DNS toolkit for Python
5Summary(ja):    Python 用 DNS ツールキット
6Group:          programming
7Vendor:         Project Vine
8Distribution:   Vine Linux
9
10License:        MIT
11URL:            http://www.dnspython.org/
12Source0:        https://github.com/rthalley/dnspython/archive/v%{version}.tar.gz#/dnspython-%{version}.tar.gz
13
14BuildArch:      noarch
15BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
16BuildRequires: python-rpm-macros
17BuildRequires: python3-rpm-macros
18BuildRequires: python3-setuptools
19BuildRequires: python3-devel
20
21%description
22dnspython is a DNS toolkit for Python. It supports almost all record
23types. It can be used for queries, zone transfers, and dynamic
24updates. It supports TSIG authenticated messages and EDNS0.
25
26dnspython provides both high and low level access to DNS. The high
27level classes perform queries for data of a given name, type, and
28class, and return an answer set. The low level classes allow direct
29manipulation of DNS zones, messages, names, and records.
30
31%package -n python3-dns
32Summary:        DNS toolkit for Python 3
33Group:          programming
34%{?python_provide:%python_provide python3-dns}
35Requires:       python3-idna
36Requires:       python3-cryptography
37
38%description -n python3-dns
39dnspython3 is a DNS toolkit for Python 3. It supports almost all
40record types. It can be used for queries, zone transfers, and dynamic
41updates. It supports TSIG authenticated messages and EDNS0.
42
43dnspython3 provides both high and low level access to DNS. The high
44level classes perform queries for data of a given name, type, and
45class, and return an answer set. The low level classes allow direct
46manipulation of DNS zones, messages, names, and records.
47
48
49%prep
50%setup0 -q -n dnspython-%{version}
51
52# strip executable permissions so that we don't pick up dependencies
53# from documentation
54find examples -type f | xargs chmod a-x
55
56
57%build
58%py3_build
59
60
61%install
62rm -rf %{buildroot}
63%py3_install
64
65
66#%check
67#%{__python3} setup.py test
68
69
70%clean
71rm -rf %{buildroot}
72
73
74%files -n python3-dns
75%defattr(-,root,root,-)
76%license LICENSE
77%doc README* examples
78%{python3_sitelib}/*egg-info
79%{python3_sitelib}/dns
80
81
82%changelog
83* Sat Aug 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.0-1
84- new upstream release.
85- built with python3 only.
86
87* Tue May 14 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.16.0-1
88- new upstream release.
89- added python3 support.
90
91* Sun Jan 12 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.0-3
92- rebuild with VineSeed environment
93
94* Mon Apr 08 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.0-2
95- add BR: python-devel, python
96
97* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.0-1
98- new upstream release
99
100* Thu Apr 05 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.4-1
101- initial build for Vine Linux
102
103* Mon Mar 28 2011 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.9.4-1
104-
105- dnspython 1.9.4 has been released and is available at
106- http://www.dnspython.org/kits/1.9.4/
107-
108- There is no new functionality in this release; just a few bug fixes
109- in RRSIG and SIG code.
110-
111- I will be eliminating legacy code for earlier versions of DNSSEC in a
112- future release of dnspython.
113
114* Fri Mar 25 2011 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.9.3-1
115-
116- New since 1.9.2:
117-
118-     A boolean parameter, 'raise_on_no_answer', has been added to
119- the query() methods.  In no-error, no-data situations, this
120- parameter determines whether NoAnswer should be raised or not.
121- If True, NoAnswer is raised.  If False, then an Answer()
122- object with a None rrset will be returned.
123-
124- Resolver Answer() objects now have a canonical_name field.
125-
126- Rdata now have a __hash__ method.
127-
128- Bugs fixed since 1.9.2:
129-
130-        Dnspython was erroneously doing case-insensitive comparisons
131- of the names in NSEC and RRSIG RRs.
132-
133- We now use "is" and not "==" when testing what section an RR
134- is in.
135-
136- The resolver now disallows metaqueries.
137
138* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.9.2-2
139- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
140
141* Tue Nov 23 2010 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.9.2-1
142- It's brown paper bag time :) The fix for the import problems was
143- actually bad, but didn't show up in testing because the test suite's
144- conditional importing code hid the problem.
145-
146- Any, 1.9.2 is out.
147-
148- Sorry for the churn!
149
150* Mon Nov 22 2010 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.9.1-1
151- New since 1.9.0:
152-
153-        Nothing.
154-
155- Bugs fixed since 1.9.0
156-
157-        The dns.dnssec module didn't work with DSA due to namespace
158-        contamination from a "from"-style import.
159-
160- New since 1.8.0:
161-
162-        dnspython now uses poll() instead of select() when available.
163-
164-        Basic DNSSEC validation can be done using dns.dnsec.validate()
165-        and dns.dnssec.validate_rrsig() if you have PyCrypto 2.3 or
166-        later installed.  Complete secure resolution is not yet
167-        available.
168-
169-        Added key_id() to the DNSSEC module, which computes the DNSSEC
170-        key id of a DNSKEY rdata.
171-
172-        Added make_ds() to the DNSSEC module, which returns the DS RR
173-        for a given DNSKEY rdata.
174-
175-        dnspython now raises an exception if HMAC-SHA284 or
176-        HMAC-SHA512 are used with a Python older than 2.5.2.  (Older
177-        Pythons do not compute the correct value.)
178-
179-        Symbolic constants are now available for TSIG algorithm names.
180-
181- Bugs fixed since 1.8.0
182-
183-        dns.resolver.zone_for_name() didn't handle a query response
184-        with a CNAME or DNAME correctly in some cases.
185-
186-        When specifying rdata types and classes as text, Unicode
187-        strings may now be used.
188-
189-        Hashlib compatibility issues have been fixed.
190-
191-        dns.message now imports dns.edns.
192-
193-        The TSIG algorithm value was passed incorrectly to use_tsig()
194-        in some cases.
195
196* Fri Aug 13 2010 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.8.0-3
197- Add a patch from upstream to fix a Python 2.7 issue.
198
199* Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 1.8.0-2.1
200- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
201
202* Wed Jan 27 2010 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.8.0-1.1
203- Fix error
204
205* Wed Jan 27 2010 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.8.0-1
206- New since 1.7.1:
207-
208-  Support for hmac-sha1, hmac-sha224, hmac-sha256, hmac-sha384 and
209-  hmac-sha512 has been contributed by Kevin Chen.
210-
211-  The tokenizer's tokens are now Token objects instead of (type,
212-  value) tuples.
213-
214- Bugs fixed since 1.7.1:
215-
216-  Escapes in masterfiles now work correctly.  Previously they were
217-  only working correctly when the text involved was part of a domain
218-  name.
219-
220-  When constructing a DDNS update, if the present() method was used
221-  with a single rdata, a zero TTL was not added.
222-
223-  The entropy pool needed locking to be thread safe.
224-
225-  The entropy pool's reading of /dev/random could cause dnspython to
226-  block.
227-
228-  The entropy pool did buffered reads, potentially consuming more
229-  randomness than we needed.
230-
231-  The entropy pool did not seed with high quality randomness on
232-  Windows.
233-
234-  SRV records were compared incorrectly.
235-
236-  In the e164 query function, the resolver parameter was not used.
237
238* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.7.1-2
239- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
240
241* Fri Jun 19 2009 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.7.1-1
242- New since 1.7.0:
243-
244-        Nothing
245-
246- Bugs fixed since 1.7.0:
247-
248-        The 1.7.0 kitting process inadventently omitted the code for the
249-        DLV RR.
250-
251-        Negative DDNS prerequisites are now handled correctly.
252
253* Fri Jun 19 2009 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.7.0-1
254- New since 1.6.0:
255-
256-        Rdatas now have a to_digestable() method, which returns the
257-        DNSSEC canonical form of the rdata, suitable for use in
258-        signature computations.
259-
260-        The NSEC3, NSEC3PARAM, DLV, and HIP RR types are now supported.
261-
262-        An entropy module has been added and is used to randomize query ids.
263-
264-        EDNS0 options are now supported.
265-
266-        UDP IXFR is now supported.
267-
268-        The wire format parser now has a 'one_rr_per_rrset' mode, which
269-        suppresses the usual coalescing of all RRs of a given type into a
270-        single RRset.
271-
272-        Various helpful DNSSEC-related constants are now defined.
273-
274-        The resolver's query() method now has an optional 'source' parameter,
275-        allowing the source IP address to be specified.
276-
277- Bugs fixed since 1.6.0:
278-
279-        On Windows, the resolver set the domain incorrectly.
280-
281-        DS RR parsing only allowed one Base64 chunk.
282-
283-        TSIG validation didn't always use absolute names.
284-
285-        NSEC.to_text() only printed the last window.
286-
287-        We did not canonicalize IPv6 addresses before comparing them; we
288-        would thus treat equivalent but different textual forms, e.g.
289-        "1:00::1" and "1::1" as being non-equivalent.
290-
291-        If the peer set a TSIG error, we didn't raise an exception.
292-
293-        Some EDNS bugs in the message code have been fixed (see the ChangeLog
294-        for details).
295
296* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.0-4
297- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
298
299* Sat Nov 29 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.6.0-3
300- Rebuild for Python 2.6
301
302* Fri Aug 29 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.6.0-2
303- fix license tag
304
305* Tue Dec  4 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.6.0-1
306- Update to 1.6.0
307
308* Tue Oct  9 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.5.0-2
309- Follow new Python egg packaging specs
310
311* Thu Jan 11 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.5.0-1
312- Update to 1.5.0
313
314* Fri Dec  8 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.4.0-3
315- Bump release for rebuild with Python 2.5
316
317* Mon Aug 14 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.4.0-2
318- No longer ghost *.pyo files, thus further simplifying the files section.
319
320* Sat Aug  5 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.4.0-1
321- Update to 1.4.0
322- Remove unneeded python-abi requires
323- Remove unneeded python_sitearch macro
324
325* Fri May 26 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.3.5-1
326- First version for Fedora Extras
327
Note: See TracBrowser for help on using the repository browser.