source: projects/specs/trunk/p/python-babel/python-babel-vl.spec @ 11947

Revision 11947, 2.7 KB checked in by tomop, 5 years ago (diff)

python-babel-2.6.0-2

Line 
1%global srcname Babel
2%define ver 2.6.0
3%define rel 2
4
5Summary: A collection of tools for internationalizing Python applications
6Name: python-babel
7Version: %{ver}
8Release: %{rel}%{?_dist_release}
9
10License: modified BSD-style License
11Group: Development/Libraries
12URL: http://babel.pocoo.org/
13
14Vendor: Project Vine
15Distribution: Vine Linux
16
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
18BuildArch: noarch
19
20Source0: https://files.pythonhosted.org/packages/source/B/%{srcname}/%{srcname}-%{version}.tar.gz
21Patch0: babel-2.3.4-remove-pytz-version.patch
22
23BuildRequires: python-setuptools, python-rpm-macros, python-pytz
24Requires: python-setuptools
25Requires: python-pytz
26
27%{?python_provide:%python_provide python2-babel}
28
29%description
30Babel is composed of two major parts:
31
32 * tools to build and work with gettext message catalogs
33 * a Python interface to the CLDR (Common Locale Data Repository),
34   providing access to various locale display names, localized number
35   and date formatting, etc.
36
37%package -n python3-babel
38Summary: A collection of tools for internationalizing Python applications
39BuildRequires: python3-setuptools, python3-rpm-macros, python3-pytz
40Requires: python3-setuptools
41Requires: python3-pytz
42
43%{?python_provide:%python_provide python3-babel}
44
45%description -n python3-babel
46Babel is composed of two major parts:
47
48* tools to build and work with gettext message catalogs
49
50* a Python interface to the CLDR (Common Locale Data Repository),
51  providing access to various locale display names, localized number
52  and date formatting, etc.
53
54%prep
55%autosetup -n %{srcname}-%{version}
56
57%build
58%py3_build
59%py_build
60
61%install
62%{__rm} -rf ${RPM_BUILD_ROOT}
63%py3_install
64%py_install
65
66
67%clean
68%{__rm} -rf ${RPM_BUILD_ROOT}
69
70
71%files
72%defattr(-,root,root)
73%doc CHANGES AUTHORS
74%license LICENSE
75%{_bindir}/pybabel
76%{python_sitelib}/Babel-*.egg-info
77%{python_sitelib}/babel
78
79%files -n python3-babel
80%doc CHANGES AUTHORS
81%license LICENSE
82%{python3_sitelib}/Babel-%{version}-py*.egg-info
83%{python3_sitelib}/babel
84
85%changelog
86* Thu Nov 29 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.6.0-2
87- fixed R:.
88
89* Tue Nov 27 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.6.0-1
90- new upstream release.
91- added python3 support.
92
93* Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.6-3
94- rebuild with VineSeed environment
95
96* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.6-2
97- rebuild with python-2.7.2
98- add BuildRequires: python-setuptools
99
100* Sun Oct 30 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.9.6-1
101- new upstream release
102
103* Wed Feb  3 2010 Shu KONNO <owa@bg.wakwak.com> 0.9.4-2
104- rebuilt with python-2.6.4
105
106* Sun Apr  5 2009 IWAI, Masaharu <iwai@alib.jp> 0.9.4-1
107- initial release
108
Note: See TracBrowser for help on using the repository browser.