source: projects/specs/trunk/p/python-babel/python-babel-vl.spec @ 11926

Revision 11926, 2.5 KB checked in by tomop, 5 years ago (diff)

python-babel-2.6.0-1

Line 
1%global srcname Babel
2%define ver 2.6.0
3%define rel 1
4
5Summary: A collection of tools for internationalizing Python applications
6Name: python-babel
7Version: %{ver}
8Release: %{rel}%{?_dist_release}
9
10License: modified BSD-style License
11Group: Development/Libraries
12URL: http://babel.pocoo.org/
13
14Vendor: Project Vine
15Distribution: Vine Linux
16
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
18BuildArch: noarch
19
20Source0: https://files.pythonhosted.org/packages/source/B/%{srcname}/%{srcname}-%{version}.tar.gz
21Patch0: babel-2.3.4-remove-pytz-version.patch
22
23BuildRequires: python-setuptools, python-rpm-macros
24BuildRequires: python3-setuptools, python3-rpm-macros
25BuildRequires: python-pytz, python3-pytz
26
27%{?python_provide:%python_provide python2-babel}
28
29%description
30Babel is composed of two major parts:
31
32 * tools to build and work with gettext message catalogs
33 * a Python interface to the CLDR (Common Locale Data Repository),
34   providing access to various locale display names, localized number
35   and date formatting, etc.
36
37%package -n python3-babel
38Summary: A collection of tools for internationalizing Python applications
39Requires: python3-setuptools
40Requires: python3-pytz
41
42%{?python_provide:%python_provide python3-babel}
43
44%description -n python3-babel
45Babel is composed of two major parts:
46
47* tools to build and work with gettext message catalogs
48
49* a Python interface to the CLDR (Common Locale Data Repository),
50  providing access to various locale display names, localized number
51  and date formatting, etc.
52
53%prep
54%autosetup -n %{srcname}-%{version}
55
56%build
57%py3_build
58%py_build
59
60%install
61%{__rm} -rf ${RPM_BUILD_ROOT}
62%py3_install
63%py_install
64
65
66%clean
67%{__rm} -rf ${RPM_BUILD_ROOT}
68
69
70%files
71%defattr(-,root,root)
72%doc CHANGES AUTHORS
73%license LICENSE
74%{_bindir}/pybabel
75%{python_sitelib}/Babel-*.egg-info
76%{python_sitelib}/babel
77
78%files -n python3-babel
79%doc CHANGES AUTHORS
80%license LICENSE
81%{python3_sitelib}/Babel-%{version}-py*.egg-info
82%{python3_sitelib}/babel
83
84%changelog
85* Tue Nov 27 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.6.0-1
86- new upstream release.
87- added python3 support.
88
89* Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.6-3
90- rebuild with VineSeed environment
91
92* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.6-2
93- rebuild with python-2.7.2
94- add BuildRequires: python-setuptools
95
96* Sun Oct 30 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.9.6-1
97- new upstream release
98
99* Wed Feb  3 2010 Shu KONNO <owa@bg.wakwak.com> 0.9.4-2
100- rebuilt with python-2.6.4
101
102* Sun Apr  5 2009 IWAI, Masaharu <iwai@alib.jp> 0.9.4-1
103- initial release
104
Note: See TracBrowser for help on using the repository browser.