source: projects/specs/trunk/p/python-babel/python-babel-vl.spec @ 12469

Revision 12469, 2.7 KB checked in by tomop, 4 years ago (diff)

python-3.8.5 and related packages.

Line 
1%global srcname Babel
2
3Summary: A collection of tools for internationalizing Python applications
4Name: python-babel
5Version: 2.8.0
6Release: 1%{?_dist_release}
7Group: programming
8Vendor: Project Vine
9Distribution: Vine Linux
10
11License: modified BSD-style License
12URL: https://babel.pocoo.org/
13Source0: https://files.pythonhosted.org/packages/source/B/%{srcname}/%{srcname}-%{version}.tar.gz
14
15BuildArch: noarch
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17
18BuildRequires: python-rpm-macros
19BuildRequires: python-setuptools, python2-rpm-macros, python-pytz
20Requires: python-setuptools
21Requires: python-pytz
22
23%{?python_provide:%python_provide python2-babel}
24
25%description
26Babel is composed of two major parts:
27
28 * tools to build and work with gettext message catalogs
29 * a Python interface to the CLDR (Common Locale Data Repository),
30   providing access to various locale display names, localized number
31   and date formatting, etc.
32
33
34%package -n python3-babel
35Summary: A collection of tools for internationalizing Python applications
36Group: programming
37BuildRequires: python3-setuptools, python3-rpm-macros, python3-pytz
38Requires: python3-setuptools
39Requires: python3-pytz
40
41%{?python_provide:%python_provide python3-babel}
42
43%description -n python3-babel
44Babel is composed of two major parts:
45
46* tools to build and work with gettext message catalogs
47
48* a Python interface to the CLDR (Common Locale Data Repository),
49  providing access to various locale display names, localized number
50  and date formatting, etc.
51
52
53%prep
54%autosetup -n %{srcname}-%{version}
55
56
57%build
58%py3_build
59%py2_build
60
61
62%install
63%{__rm} -rf ${RPM_BUILD_ROOT}
64%py3_install
65%py2_install
66
67
68%clean
69%{__rm} -rf ${RPM_BUILD_ROOT}
70
71
72%files
73%defattr(-,root,root)
74%doc CHANGES AUTHORS
75%license LICENSE
76%{_bindir}/pybabel
77%{python_sitelib}/Babel-*.egg-info
78%{python_sitelib}/babel
79
80%files -n python3-babel
81%doc CHANGES AUTHORS
82%license LICENSE
83%{python3_sitelib}/Babel-%{version}-py*.egg-info
84%{python3_sitelib}/babel
85
86
87%changelog
88* Sun Aug 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.8.0-1
89- new upstream release.
90
91* Thu Nov 29 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.6.0-2
92- fixed R:.
93
94* Tue Nov 27 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.6.0-1
95- new upstream release.
96- added python3 support.
97
98* Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.6-3
99- rebuild with VineSeed environment
100
101* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.6-2
102- rebuild with python-2.7.2
103- add BuildRequires: python-setuptools
104
105* Sun Oct 30 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.9.6-1
106- new upstream release
107
108* Wed Feb  3 2010 Shu KONNO <owa@bg.wakwak.com> 0.9.4-2
109- rebuilt with python-2.6.4
110
111* Sun Apr  5 2009 IWAI, Masaharu <iwai@alib.jp> 0.9.4-1
112- initial release
113
Note: See TracBrowser for help on using the repository browser.