source: projects/specs/trunk/p/pygobject/pygobject-vl.spec @ 860

Revision 860, 5.6 KB checked in by daisuke, 14 years ago (diff)

pygtk2: update to 2.17.0
pygobject: update to 2.21.1

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
3Summary: Python bindings for GObject
4Summary(ja): GObject の Python バインディング
5Name: pygobject
6Version: 2.21.1
7Release: 1%{?_dist_release}
8License: LGPL
9Group: Development/Languages
10URL: http://www.pygtk.org/
11
12Source: pygobject-%{version}.tar.bz2
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15BuildRequires: glib2-devel >= 2.14.0
16BuildRequires: python-devel >= 2.6
17BuildRequires: libffi-devel
18BuildRequires: libtool, automake
19
20Vendor: Project Vine
21Distribution: Vine Linux
22Packager: daisuke
23
24%description
25pygobject provides a convenient wrapper for the GObject library
26for use in Python programs.
27
28%package devel
29Summary: Development files for building add-on libraries
30Group: Development/Libraries
31Requires: pygobject = %{version}-%{release}
32#Requires: pygobject-doc = %{version}-%{release}
33Requires: glib2-devel
34Requires: libffi-devel
35Requires: pkgconfig
36
37%description devel
38This package contains files required to build wrappers for
39pygobject-based libraries such as pygtk2.
40
41%package doc
42Summary: Documentation files for pygobject
43Group: Development/Documentation
44
45%description doc
46This package contains documentation files for pygobject.
47
48%prep
49%setup -q
50
51%build
52# --disable-docs doesn't work; it builds the docs anyway.
53%configure --enable-thread --disable-docs
54export tagname=CC
55make LIBTOOL=/usr/bin/libtool
56
57%install
58rm -rf $RPM_BUILD_ROOT
59export tagname=CC
60make LIBTOOL=/usr/bin/libtool DESTDIR=$RPM_BUILD_ROOT install
61find $RPM_BUILD_ROOT -name '*.la' -or -name '*.a' | xargs rm -f
62
63rm -f examples/Makefile*
64
65%clean
66rm -fr $RPM_BUILD_ROOT
67
68%files
69%defattr(644, root, root, 755)
70%doc AUTHORS NEWS README ChangeLog
71%doc examples
72
73%{_libdir}/libpyglib-2.0-python.so.*
74%dir %{python_sitearch}/gtk-2.0
75%{python_sitearch}/gtk-2.0/dsextras.*
76%{python_sitearch}/pygtk.*
77
78%defattr(755, root, root, 755)
79%{python_sitearch}/gtk-2.0/gio
80%{python_sitearch}/gtk-2.0/glib
81%{python_sitearch}/gtk-2.0/gobject
82
83%files devel
84%defattr(755, root, root, 755)
85%{_bindir}/pygobject-codegen-2.0
86%defattr(644, root, root, 755)
87%dir %{_datadir}/pygobject
88%dir %{_datadir}/pygobject/2.0
89%dir %{_includedir}/pygtk-2.0
90%{_datadir}/pygobject/2.0/codegen
91%{_datadir}/pygobject/2.0/defs
92%{_includedir}/pygtk-2.0/pyglib.h
93%{_includedir}/pygtk-2.0/pygobject.h
94%{_libdir}/libpyglib-2.0-python.so
95%{_libdir}/pkgconfig/pygobject-2.0.pc
96
97%files doc
98%defattr(644, root, root, 755)
99%{_datadir}/gtk-doc/html/pygobject
100%{_datadir}/pygobject/xsl
101
102%changelog
103* Sat Apr 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.21.1-1
104- new upstream release
105
106* Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.0-3
107- build for python-2.6
108
109* Wed Dec  2 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.0-2
110- added Requires: libffi-devel to devel package <BTS:830>
111
112* Sun Nov  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.0-1
113- new upstream release
114
115* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.1-1
116- new upstream release
117
118* Sat Jan 17 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.0-1
119- new upstream release
120
121* Sat Oct 04 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.4-1
122- new upstream release
123
124* Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> 2.14.2-2
125- rebuilt with python-2.5.2
126
127* Tue May 27 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.2-1
128- new upstream release
129- spec in UTF-8
130
131* Sat Mar 22 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.1-1vl5
132- rebuilt with python-2.4.5 and glib2-2.16.1
133- used %%{?_dist_release} macro
134
135* Sun Feb 24 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.1-0vl1
136- new upstream release
137
138* Sat Nov 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.0-0vl1
139- new upstream release
140- dropped Patch1 (merged into upstream)
141
142* Thu Apr 26 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.3-0vl1
143- initial build for Vine Linux
144
145* Thu Apr 19 2007 Matthew Barnes <mbarnes@redhat.com> - 2.12.3-3.fc7
146- Add patch for RH bug #237179 (memory leak).
147
148* Thu Dec  7 2006 Jeremy Katz <katzj@redhat.com> - 2.12.3-2
149- rebuild against python 2.5
150
151* Sat Nov 18 2006 Matthew Barnes <mbarnes@redhat.com> - 2.12.3-1.fc7
152- Update to 2.12.3
153
154* Thu Oct 26 2006 Matthew Barnes <mbarnes@redhat.com> - 2.12.2-3.fc7
155- Add subpackage pygobject2-doc (bug #205231).
156
157* Tue Oct 24 2006 Matthew Barnes <mbarnes@redhat.com> - 2.12.2-2.fc7
158- Use python_sitearch instead of python_sitelib.
159
160* Sun Oct 15 2006 Matthew Barnes <mbarnes@redhat.com> - 2.12.2-1.fc7
161- Update to 2.12.2
162
163* Sun Sep 24 2006 Matthew Barnes <mbarnes@redhat.com> - 2.12.1-3.fc6
164- Require glib2-devel for the -devel package.
165
166* Fri Sep 22 2006 Matthew Barnes <mbarnes@redhat.com> - 2.12.1-2.fc6
167- Define a python_sitelib macro for files under site_packages.
168- Spec file cleanups.
169
170* Tue Sep  5 2006 Matthias Clasen <mclasen@redhat.com> - 2.12.1-1.fc6
171- Update to 2.12.1
172- Require pkgconfig for the -devel package
173
174* Sun Aug 27 2006 Matthias Clasen <mclasen@redhat.com> - 2.11.4-1.fc6
175- Update to 2.11.4
176- Use pre-built docs
177
178* Mon Aug 21 2006 Matthias Clasen <mclasen@redhat.com> - 2.11.3-1.fc6
179- Update to 2.11.3
180
181* Sun Aug 13 2006 Matthias Clasen <mclasen@redhat.com> - 2.11.2-2.fc6
182- BR libxslt
183
184* Sun Aug 13 2006 Matthias Clasen <mclasen@redhat.com> - 2.11.2-1.fc6
185- Update to 2.11.2
186
187* Wed Jul 19 2006 Jesse Keating <jkeating@redhat.com> - 2.11.0-2
188- rebuild
189
190* Wed Jul 12 2006 Matthias Clasen <mclasen@redhat.com> - 2.11.0-1
191- Update to 2.11.0
192
193* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.10.1-3
194- rebuild
195- Add missing br libtool
196
197* Fri May 19 2006 John (J5) Palmieri <johnp@redhat.com> - 2.10.1-2
198- Cleanup
199
200* Fri May 12 2006 John (J5) Palmieri <johnp@redhat.com> - 2.10.1-1
201- Initial package
Note: See TracBrowser for help on using the repository browser.