source: projects/specs/trunk/p/pygobject/pygobject-vl.spec @ 521

Revision 521, 5.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
3Summary: Python bindings for GObject
4Summary(ja): GObject の Python バインディング
5Name: pygobject
6Version: 2.20.0
7Release: 5%{?_dist_release}
8License: LGPL
9Group: Development/Languages
10URL: http://www.pygtk.org/
11
12Source: pygobject-%{version}.tar.bz2
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15BuildRequires: glib2-devel >= 2.14.0
16BuildRequires: python-devel >= 2.6
17BuildRequires: libffi-devel
18BuildRequires: libtool, automake
19
20%description
21pygobject provides a convenient wrapper for the GObject library
22for use in Python programs.
23
24%package devel
25Summary: Development files for building add-on libraries
26Group: Development/Libraries
27Requires: pygobject = %{version}-%{release}
28#Requires: pygobject-doc = %{version}-%{release}
29Requires: glib2-devel
30Requires: libffi-devel
31Requires: pkgconfig
32
33%description devel
34This package contains files required to build wrappers for
35pygobject-based libraries such as pygtk2.
36
37%package doc
38Summary: Documentation files for pygobject
39Group: Development/Documentation
40
41%description doc
42This package contains documentation files for pygobject.
43
44%prep
45%setup -q
46
47%build
48# --disable-docs doesn't work; it builds the docs anyway.
49%configure --enable-thread --disable-docs
50export tagname=CC
51make LIBTOOL=/usr/bin/libtool
52
53%install
54rm -rf $RPM_BUILD_ROOT
55export tagname=CC
56make LIBTOOL=/usr/bin/libtool DESTDIR=$RPM_BUILD_ROOT install
57find $RPM_BUILD_ROOT -name '*.la' -or -name '*.a' | xargs rm -f
58
59rm -f examples/Makefile*
60
61%clean
62rm -fr $RPM_BUILD_ROOT
63
64%files
65%defattr(644, root, root, 755)
66%doc AUTHORS NEWS README ChangeLog
67%doc examples
68
69%{_libdir}/libpyglib-2.0-python.so.*
70%dir %{python_sitearch}/gtk-2.0
71%{python_sitearch}/gtk-2.0/dsextras.*
72%{python_sitearch}/pygtk.*
73
74%defattr(755, root, root, 755)
75%{python_sitearch}/gtk-2.0/gio
76%{python_sitearch}/gtk-2.0/glib
77%{python_sitearch}/gtk-2.0/gobject
78%{python_sitearch}/gtk-2.0/girepository
79
80%files devel
81%defattr(755, root, root, 755)
82%{_bindir}/pygobject-codegen-2.0
83%defattr(644, root, root, 755)
84%dir %{_datadir}/pygobject
85%dir %{_datadir}/pygobject/2.0
86%dir %{_includedir}/pygobject
87%dir %{_includedir}/pygtk-2.0
88%{_datadir}/pygobject/2.0/codegen
89%{_datadir}/pygobject/2.0/defs
90%{_includedir}/pygobject/bank.h
91%{_includedir}/pygtk-2.0/pyglib.h
92%{_includedir}/pygtk-2.0/pygobject.h
93%{_libdir}/libpyglib-2.0-python.so
94%{_libdir}/pkgconfig/pygobject-2.0.pc
95
96%files doc
97%defattr(644, root, root, 755)
98%{_datadir}/gtk-doc/html/pygobject
99%{_datadir}/pygobject/xsl
100
101%changelog
102* Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.0-3
103- build for python-2.6
104
105* Wed Dec  2 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.0-2
106- added Requires: libffi-devel to devel package <BTS:830>
107
108* Sun Nov  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.0-1
109- new upstream release
110
111* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.1-1
112- new upstream release
113
114* Sat Jan 17 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.0-1
115- new upstream release
116
117* Sat Oct 04 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.4-1
118- new upstream release
119
120* Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> 2.14.2-2
121- rebuilt with python-2.5.2
122
123* Tue May 27 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.2-1
124- new upstream release
125- spec in UTF-8
126
127* Sat Mar 22 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.1-1vl5
128- rebuilt with python-2.4.5 and glib2-2.16.1
129- used %%{?_dist_release} macro
130
131* Sun Feb 24 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.1-0vl1
132- new upstream release
133
134* Sat Nov 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.0-0vl1
135- new upstream release
136- dropped Patch1 (merged into upstream)
137
138* Thu Apr 26 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.3-0vl1
139- initial build for Vine Linux
140
141* Thu Apr 19 2007 Matthew Barnes <mbarnes@redhat.com> - 2.12.3-3.fc7
142- Add patch for RH bug #237179 (memory leak).
143
144* Thu Dec  7 2006 Jeremy Katz <katzj@redhat.com> - 2.12.3-2
145- rebuild against python 2.5
146
147* Sat Nov 18 2006 Matthew Barnes <mbarnes@redhat.com> - 2.12.3-1.fc7
148- Update to 2.12.3
149
150* Thu Oct 26 2006 Matthew Barnes <mbarnes@redhat.com> - 2.12.2-3.fc7
151- Add subpackage pygobject2-doc (bug #205231).
152
153* Tue Oct 24 2006 Matthew Barnes <mbarnes@redhat.com> - 2.12.2-2.fc7
154- Use python_sitearch instead of python_sitelib.
155
156* Sun Oct 15 2006 Matthew Barnes <mbarnes@redhat.com> - 2.12.2-1.fc7
157- Update to 2.12.2
158
159* Sun Sep 24 2006 Matthew Barnes <mbarnes@redhat.com> - 2.12.1-3.fc6
160- Require glib2-devel for the -devel package.
161
162* Fri Sep 22 2006 Matthew Barnes <mbarnes@redhat.com> - 2.12.1-2.fc6
163- Define a python_sitelib macro for files under site_packages.
164- Spec file cleanups.
165
166* Tue Sep  5 2006 Matthias Clasen <mclasen@redhat.com> - 2.12.1-1.fc6
167- Update to 2.12.1
168- Require pkgconfig for the -devel package
169
170* Sun Aug 27 2006 Matthias Clasen <mclasen@redhat.com> - 2.11.4-1.fc6
171- Update to 2.11.4
172- Use pre-built docs
173
174* Mon Aug 21 2006 Matthias Clasen <mclasen@redhat.com> - 2.11.3-1.fc6
175- Update to 2.11.3
176
177* Sun Aug 13 2006 Matthias Clasen <mclasen@redhat.com> - 2.11.2-2.fc6
178- BR libxslt
179
180* Sun Aug 13 2006 Matthias Clasen <mclasen@redhat.com> - 2.11.2-1.fc6
181- Update to 2.11.2
182
183* Wed Jul 19 2006 Jesse Keating <jkeating@redhat.com> - 2.11.0-2
184- rebuild
185
186* Wed Jul 12 2006 Matthias Clasen <mclasen@redhat.com> - 2.11.0-1
187- Update to 2.11.0
188
189* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.10.1-3
190- rebuild
191- Add missing br libtool
192
193* Fri May 19 2006 John (J5) Palmieri <johnp@redhat.com> - 2.10.1-2
194- Cleanup
195
196* Fri May 12 2006 John (J5) Palmieri <johnp@redhat.com> - 2.10.1-1
197- Initial package
Note: See TracBrowser for help on using the repository browser.