source: projects/specs/trunk/p/pygobject/pygobject-vl.spec @ 1881

Revision 1881, 5.9 KB checked in by inagaki, 14 years ago (diff)

update: pygobject, pycairo, pygtk2

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
3Name: pygobject
4Summary: Python bindings for GObject
5Summary(ja): GObject の Python バインディング
6Version: 2.21.5
7Release: 1%{?_dist_release}
8
9Group: Development/Languages
10License: LGPL
11URL: http://www.pygtk.org/
12
13Source: pygobject-%{version}.tar.bz2
14
15BuildRoot: %{_tmppath}/%{name}-%{version}-root
16BuildRequires: glib2-devel >= 2.14.0
17BuildRequires: python-devel >= 2.6
18BuildRequires: libffi-devel
19BuildRequires: libtool, automake
20
21Vendor: Project Vine
22Distribution: Vine Linux
23Packager: daisuke
24
25%description
26pygobject provides a convenient wrapper for the GObject library
27for use in Python programs.
28
29%package devel
30Summary: Development files for building add-on libraries
31Group: Development/Libraries
32Requires: pygobject = %{version}-%{release}
33#Requires: pygobject-doc = %{version}-%{release}
34Requires: glib2-devel
35Requires: libffi-devel
36Requires: pkgconfig
37
38%description devel
39This package contains files required to build wrappers for
40pygobject-based libraries such as pygtk2.
41
42%package doc
43Summary: Documentation files for pygobject
44Group: Documentation
45
46%description doc
47This package contains documentation files for pygobject.
48
49%prep
50%setup -q
51
52%build
53# --disable-docs doesn't work; it builds the docs anyway.
54%configure \
55    --enable-silent-rules \
56    --disable-static \
57    --enable-thread \
58    --disable-introspection \
59    --disable-docs
60export tagname=CC
61make LIBTOOL=/usr/bin/libtool
62
63%install
64rm -rf $RPM_BUILD_ROOT
65export tagname=CC
66make LIBTOOL=/usr/bin/libtool DESTDIR=$RPM_BUILD_ROOT install
67find $RPM_BUILD_ROOT -name '*.la' -or -name '*.a' | xargs rm -f
68
69rm -f examples/Makefile*
70
71%clean
72rm -fr $RPM_BUILD_ROOT
73
74%files
75%defattr(644, root, root, 755)
76%doc AUTHORS NEWS README ChangeLog
77%doc examples
78
79%{_libdir}/libpyglib-2.0-python.so.*
80%dir %{python_sitearch}/gtk-2.0
81%{python_sitearch}/gtk-2.0/dsextras.*
82%{python_sitearch}/pygtk.*
83
84%defattr(755, root, root, 755)
85%{python_sitearch}/gtk-2.0/gio
86%{python_sitearch}/gtk-2.0/glib
87%{python_sitearch}/gtk-2.0/gobject
88
89%files devel
90%defattr(755, root, root, 755)
91%{_bindir}/pygobject-codegen-2.0
92%defattr(644, root, root, 755)
93%dir %{_datadir}/pygobject
94%dir %{_datadir}/pygobject/2.0
95%dir %{_includedir}/pygtk-2.0
96%{_datadir}/pygobject/2.0/codegen
97%{_datadir}/pygobject/2.0/defs
98%{_datadir}/pygobject/xsl
99%{_includedir}/pygtk-2.0/pyglib.h
100%{_includedir}/pygtk-2.0/pygobject.h
101%{_libdir}/libpyglib-2.0-python.so
102%{_libdir}/pkgconfig/pygobject-2.0.pc
103
104%files doc
105%defattr(644, root, root, 755)
106%{_datadir}/gtk-doc/html/pygobject
107
108%changelog
109* Thu Sep 23 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.21.5-1
110- new upstream release
111- added --disable-intropection option (it needs gobject-introspection >= 0.9)
112- moved xsl files to devel package
113- built with rpm-4.8.1
114
115* Sat Apr 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.21.1-1
116- new upstream release
117
118* Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.0-3
119- build for python-2.6
120
121* Wed Dec  2 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.0-2
122- added Requires: libffi-devel to devel package <BTS:830>
123
124* Sun Nov  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.0-1
125- new upstream release
126
127* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.1-1
128- new upstream release
129
130* Sat Jan 17 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.0-1
131- new upstream release
132
133* Sat Oct 04 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.4-1
134- new upstream release
135
136* Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> 2.14.2-2
137- rebuilt with python-2.5.2
138
139* Tue May 27 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.2-1
140- new upstream release
141- spec in UTF-8
142
143* Sat Mar 22 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.1-1vl5
144- rebuilt with python-2.4.5 and glib2-2.16.1
145- used %%{?_dist_release} macro
146
147* Sun Feb 24 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.1-0vl1
148- new upstream release
149
150* Sat Nov 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.0-0vl1
151- new upstream release
152- dropped Patch1 (merged into upstream)
153
154* Thu Apr 26 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.3-0vl1
155- initial build for Vine Linux
156
157* Thu Apr 19 2007 Matthew Barnes <mbarnes@redhat.com> - 2.12.3-3.fc7
158- Add patch for RH bug #237179 (memory leak).
159
160* Thu Dec  7 2006 Jeremy Katz <katzj@redhat.com> - 2.12.3-2
161- rebuild against python 2.5
162
163* Sat Nov 18 2006 Matthew Barnes <mbarnes@redhat.com> - 2.12.3-1.fc7
164- Update to 2.12.3
165
166* Thu Oct 26 2006 Matthew Barnes <mbarnes@redhat.com> - 2.12.2-3.fc7
167- Add subpackage pygobject2-doc (bug #205231).
168
169* Tue Oct 24 2006 Matthew Barnes <mbarnes@redhat.com> - 2.12.2-2.fc7
170- Use python_sitearch instead of python_sitelib.
171
172* Sun Oct 15 2006 Matthew Barnes <mbarnes@redhat.com> - 2.12.2-1.fc7
173- Update to 2.12.2
174
175* Sun Sep 24 2006 Matthew Barnes <mbarnes@redhat.com> - 2.12.1-3.fc6
176- Require glib2-devel for the -devel package.
177
178* Fri Sep 22 2006 Matthew Barnes <mbarnes@redhat.com> - 2.12.1-2.fc6
179- Define a python_sitelib macro for files under site_packages.
180- Spec file cleanups.
181
182* Tue Sep  5 2006 Matthias Clasen <mclasen@redhat.com> - 2.12.1-1.fc6
183- Update to 2.12.1
184- Require pkgconfig for the -devel package
185
186* Sun Aug 27 2006 Matthias Clasen <mclasen@redhat.com> - 2.11.4-1.fc6
187- Update to 2.11.4
188- Use pre-built docs
189
190* Mon Aug 21 2006 Matthias Clasen <mclasen@redhat.com> - 2.11.3-1.fc6
191- Update to 2.11.3
192
193* Sun Aug 13 2006 Matthias Clasen <mclasen@redhat.com> - 2.11.2-2.fc6
194- BR libxslt
195
196* Sun Aug 13 2006 Matthias Clasen <mclasen@redhat.com> - 2.11.2-1.fc6
197- Update to 2.11.2
198
199* Wed Jul 19 2006 Jesse Keating <jkeating@redhat.com> - 2.11.0-2
200- rebuild
201
202* Wed Jul 12 2006 Matthias Clasen <mclasen@redhat.com> - 2.11.0-1
203- Update to 2.11.0
204
205* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.10.1-3
206- rebuild
207- Add missing br libtool
208
209* Fri May 19 2006 John (J5) Palmieri <johnp@redhat.com> - 2.10.1-2
210- Cleanup
211
212* Fri May 12 2006 John (J5) Palmieri <johnp@redhat.com> - 2.10.1-1
213- Initial package
Note: See TracBrowser for help on using the repository browser.