source: projects/specs/trunk/p/ppp/ppp-vl.spec @ 8909

Revision 8909, 12.3 KB checked in by tomop, 10 years ago (diff)

ppp-2.4.7-1

Line 
1%bcond_with ifupdown
2
3%define _tmpfilesdir %{_sysconfdir}/tmpfiles.d
4
5Summary: The PPP (Point-to-Point Protocol) daemon.
6Summary(ja): PPP (Point-to-Point Protocol) デーモン
7Name: ppp
8Version: 2.4.7
9Release: 1%{?_dist_release}
10License: BSD and LGPLv2+ and GPLv2+ and Public Domain
11Group: System Environment/Daemons
12URL: http://www.samba.org/ppp
13
14Source0: ftp://ftp.samba.org/pub/ppp/ppp-%{version}.tar.gz
15Source1: ppp-pam.conf
16Source2: ppp-logrotate.conf
17Source3: ppp-tmpfiles.conf
18Source4: ip-down
19Source5: ip-down.ipv6to4
20Source6: ip-up
21Source7: ip-up.ipv6to4
22Source8: ipv6-down
23Source9: ipv6-up
24Source10: ifup-ppp
25Source11: ifdown-ppp
26Source12: ppp-watch.tar.xz
27
28# Fedora-specific
29Patch0001: 0001-build-sys-use-gcc-as-our-compiler-of-choice.patch
30Patch0002: 0002-build-sys-enable-PAM-support.patch
31Patch0003: 0003-build-sys-utilize-compiler-flags-handed-to-us-by-rpm.patch
32Patch0004: 0004-doc-add-configuration-samples.patch
33Patch0005: 0005-build-sys-don-t-hardcode-LIBDIR-but-set-it-according.patch
34Patch0006: 0006-scritps-use-change_resolv_conf-function.patch
35Patch0007: 0007-build-sys-don-t-strip-binaries-during-installation.patch
36Patch0008: 0008-build-sys-use-prefix-usr-instead-of-usr-local.patch
37Patch0009: 0009-pppd-introduce-ipv6-accept-remote.patch
38Patch0010: 0010-build-sys-enable-CBCP.patch
39Patch0011: 0011-build-sys-don-t-put-connect-errors-log-to-etc-ppp.patch
40Patch0012: 0012-pppd-we-don-t-want-to-accidentally-leak-fds.patch
41Patch0013: 0013-everywhere-O_CLOEXEC-harder.patch
42Patch0014: 0014-everywhere-use-SOCK_CLOEXEC-when-creating-socket.patch
43Patch0015: 0015-pppd-move-pppd-database-to-var-run-ppp.patch
44Patch0016: 0016-rp-pppoe-add-manpage-for-pppoe-discovery.patch
45Patch0017: 0017-pppd-rebase-EAP-TLS-patch-v0.994.patch
46Patch0018: 0018-scritps-fix-ip-up.local-sample.patch
47Patch0019: 0019-sys-linux-rework-get_first_ethernet.patch
48Patch0020: 0020-pppd-put-lock-files-in-var-lock-ppp.patch
49Patch0021: 0021-build-sys-compile-pppol2tp-plugin-with-RPM_OPT_FLAGS.patch
50Patch0022: 0022-build-sys-compile-pppol2tp-with-multilink-support.patch
51Patch0023: 0023-build-sys-install-rp-pppoe-plugin-files-with-standar.patch
52Patch0024: 0024-build-sys-install-pppoatm-plugin-files-with-standard.patch
53Patch0025: 0025-pppd-install-pppd-binary-using-standard-perms-755.patch
54
55BuildRoot: %{_tmppath}/%{name}-%{version}-root
56BuildRequires: glib2-devel, libpcap >= 0.8.3, eudev-libudev-devel, openssl-devel, pam-devel
57#Requires: glibc >= 2.0.6, /etc/pam.d/system-auth
58Requires: glibc >= 2.0.6, pam >= 1.0
59Requires(pre): shadow-utils
60
61Vendor: Project Vine
62Distribution: Vine Linux
63Packager: daisuke
64
65%description
66The ppp package contains the PPP (Point-to-Point Protocol) daemon and
67documentation for PPP support.  The PPP protocol provides a method for
68transmitting datagrams over serial point-to-point links. PPP is
69usually used to dial in to an ISP (Internet Service Provider) or other
70organization over a modem and phone line.
71
72%description -l ja
73ppp パッケージには PPP (Point-to-Point Protocol) デーモンと
74PPP を使う為のドキュメントが収められています.PPP プロトコルを
75使うとシリアルな point-to-point 接続上でデータグラムを転送する
76事が出来ます.この PPP は一般的には ISP (Internet Service Provider) 等に
77モデムを介した電話回線で接続する際に使われます.
78
79
80%package devel
81Summary: Headers for ppp plugin development
82SUmmary(ja): ppp プラグイン開発用ヘッダファイル
83Group: Development/Libraries
84
85%description devel
86This package contains the header files for building plugins for ppp.
87
88%description -l ja devel
89このパッケージには ppp のプラグインを開発するためのヘッダファイルが
90含まれています。
91
92%prep
93%setup  -q
94%autopatch -p1
95
96tar -xJf %{SOURCE12}
97
98%build
99export RPM_OPT_FLAGS="$RPM_OPT_FLAGS -fPIC -Wall"
100%configure
101make %{?_smp_mflags}
102make -C ppp-watch %{?_smp_mflags}
103
104%install
105[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
106
107%ifarch x86_64
108make INSTROOT=%{buildroot} install install-etcppp LIBDIR=$RPM_BUILD_ROOT%{_libdir}/pppd/%{version}
109%else
110make INSTROOT=%{buildroot} install install-etcppp
111%endif
112
113find scripts -type f | xargs chmod a-x
114
115make ROOT=%{buildroot} -C ppp-watch install
116
117# create log files dir
118mv -f %{buildroot}/usr/var %{buildroot}/
119
120# install pam config
121install -d %{buildroot}%{_sysconfdir}/pam.d
122install -m 644 %{SOURCE1} %{buildroot}%{_sysconfdir}/pam.d/ppp
123
124# install logrotate script
125install -d %{buildroot}%{_sysconfdir}/logrotate.d
126install -p %{SOURCE2} %{buildroot}%{_sysconfdir}/logrotate.d/ppp
127
128# install tmpfiles drop-in
129install -d %{buildroot}%{_tmpfilesdir}
130install -p %{SOURCE3} %{buildroot}%{_tmpfilesdir}/ppp.conf
131
132# install scripts (previously owned by initscripts package)
133install -d %{buildroot}%{_sysconfdir}/ppp
134%if %{with ifupdown}
135install -p %{SOURCE4} %{buildroot}%{_sysconfdir}/ppp/ip-down
136install -p %{SOURCE5} %{buildroot}%{_sysconfdir}/ppp/ip-down.ipv6to4
137install -p %{SOURCE6} %{buildroot}%{_sysconfdir}/ppp/ip-up
138install -p %{SOURCE7} %{buildroot}%{_sysconfdir}/ppp/ip-up.ipv6to4
139install -p %{SOURCE8} %{buildroot}%{_sysconfdir}/ppp/ipv6-down
140install -p %{SOURCE9} %{buildroot}%{_sysconfdir}/ppp/ipv6-up
141%endif
142
143%if %{with ifupdown}
144install -d %{buildroot}%{_sysconfdir}/sysconfig/network-scripts/
145install -p %{SOURCE10} %{buildroot}%{_sysconfdir}/sysconfig/network-scripts/ifup-ppp
146install -p %{SOURCE11} %{buildroot}%{_sysconfdir}/sysconfig/network-scripts/ifdown-ppp
147%endif
148
149
150%clean
151rm -rf %{buildroot}
152
153
154%pre
155/usr/bin/getent group dip >/dev/null 2>&1 || /usr/sbin/groupadd -r -g 40 dip >/dev/null 2>&1 || :
156
157
158%files
159%defattr(-,root,root)
160%doc FAQ README README.cbcp README.linux README.MPPE README.MSCHAP80 README.MSCHAP81 README.pwfd README.pppoe scripts sample README.eap-tls
161%{_sbindir}/*
162%{_libdir}/pppd
163%{_mandir}/man8/chat.8*
164%{_mandir}/man8/ppp-watch.8*
165%{_mandir}/man8/pppd.8*
166%{_mandir}/man8/pppdump.8*
167%{_mandir}/man8/pppstats.8*
168%{_mandir}/man8/pppd-radattr.8*
169%{_mandir}/man8/pppd-radius.8*
170%{_mandir}/man8/pppoe-discovery.8*
171%dir /etc/ppp
172%config(noreplace) /etc/ppp/*
173%config(noreplace) /etc/pam.d/ppp
174%config(noreplace) /etc/logrotate.d/ppp
175%{_tmpfilesdir}/ppp.conf
176%ghost %dir %{_localstatedir}/run/ppp
177%ghost %dir %{_localstatedir}/lock/ppp
178%attr(700, root, root) %dir %{_localstatedir}/log/ppp
179
180%if %{with ifupdown}
181/etc/sysconfig/network-scripts/ifup-ppp
182/etc/sysconfig/network-scripts/ifdown-ppp
183%endif
184
185%files devel
186%defattr(-,root,root)
187%{_includedir}/pppd
188%doc PLUGINS
189
190
191%changelog
192* Tue Aug 19 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.7-1
193- new upstream release.
194
195* Tue Jun 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.6-2
196- change BuildRequires: eudev-libudev-devel instead of libudev-devel
197
198* Wed Jun 18 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.6-1
199- new upstream release.
200- replaceed all patches.
201
202* Tue Sep 06 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.5-4
203- added /var/run/ppp to %%files. (BTS:1215)
204- added /var/log/ppp to %%files.
205
206* Mon Apr 25 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.5-3
207- remove include/linux/if_pppol2tp.h to build pppoe plugin
208- update License tag
209
210* Fri Apr 08 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.5-2
211- rebuilt with new toolchain.
212
213* Mon Mar 08 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.5-1
214- new upstream release.
215- replaced all patches with Fedora's.
216- replaced 'BuildPreReq:' with 'BuildRequires:'.
217
218* Sun Aug 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.4-4
219- update pam.d/ppp to fix pam-1.0
220
221* Thu Aug 14 2008 Shu KONNO <owa@bg.wakwak.com> 2.4.4-3
222- added option LIBDIR at makeinstall for x86_64
223
224* Thu Jul 31 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.4-2
225- add -devel subpackage to develop ppp plugins
226
227* Wed Jun 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.4.4-1
228- update Source1 for pam-1.0.1
229- import several patches from Fedora 2.4.4-7
230
231* Sat Jul  7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.4-0vl1
232- new upstream release
233- rebuilt with new toolchain and environment
234- added URL (also URL of Source0)
235
236* Fri Nov 17 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.4.3-0vl2
237- use License: instead of Copyright:
238
239* Mon Jan 24 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.4.3-0vl1
240- new upstream release.
241- replace patch0.
242
243* Wed Aug 11 2004 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.4.2-0vl0
244- new upstream release.
245- remove patch 2-4 (no longer needed).
246
247* Sat Mar 15 2003 <ryo1@bc.wakwak.com> 2.4.1-0vl2
248- rebuild with new toolchains
249
250* Sun Jun 10 2001 <sagami@vinelinux.org>
251- 2.4.1-0vl1: update to 2.4.1
252
253* Thu Jan 25 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
254- 2.4.0-2vl1
255- based on 2.4.0-2 from Rawhide
256- added Japanese summary and description
257- Requires: /etc/pam.d/system-auth -> pam >= 0.72
258  (for better compatibility with apt for rpm)
259
260* Fri Dec  1 2000 Nalin Dahyabhai <nalin@redhat.com>
261- rebuild in new environment
262
263* Thu Nov  9 2000 Nalin Dahyabhai <nalin@redhat.com>
264- update to 2.4.0
265
266* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
267- automatic rebuild
268
269* Mon Jun  5 2000 Nalin Dahyabhai <nalin@redhat.com>
270- move man pages to %{_mandir}
271
272* Thu Jun  1 2000 Nalin Dahyabhai <nalin@redhat.com>
273- change perms using defattr
274- modify PAM setup to use system-auth
275
276* Sun Mar 26 2000 Florian La Roche <Florian.La Roche@redhat.com>
277- change to root:root perms
278
279* Mon Mar 06 2000 Nalin Dahyabhai <nalin@redhat.com>
280- reaper bugs verified as fixed
281- check pam_open_session result code (bug #9966)
282
283* Mon Feb 07 2000 Nalin Dahyabhai <nalin@redhat.com>
284- take a shot at the wrong reaper bugs (#8153, #5290)
285
286* Thu Feb 03 2000 Nalin Dahyabhai <nalin@redhat.com>
287- free ride through the build system (release 2)
288
289* Tue Jan 18 2000 Nalin Dahyabhai <nalin@redhat.com>
290- Update to 2.3.11
291
292* Sat Nov 06 1999 Michael K. Johnson <johnsonm@redhat.com>
293- Better fix for both problems
294
295* Fri Nov 05 1999 Michael K. Johnson <johnsonm@redhat.com>
296- fix for double-dial problem
297- fix for requiring a controlling terminal problem
298
299* Sun Sep 19 1999 Preston Brown <pbrown@redhat.com>
300- 2.3.10 bugfix release
301
302* Fri Aug 13 1999 Michael K. Johnson <johnsonm@redhat.com>
303- New version 2.3.9 required for kernel 2.3.13 and will be required
304  for new initscripts.  auth patch removed; 2.3.9 does the same thing
305  more readably than the previous patch.
306
307* Thu Jun 24 1999 Cristian Gafton <gafton@redhat.com>
308- add pppdump
309
310* Fri Apr 09 1999 Cristian Gafton <gafton@redhat.com>
311- force pppd use the glibc's logwtmp instead of implementing its own
312
313* Thu Apr 01 1999 Preston Brown <pbrown@redhat.com>
314- version 2.3.7 bugfix release
315
316* Tue Mar 23 1999 Cristian Gafton <gafton@redhat.com>
317- version 2.3.6
318
319* Mon Mar 22 1999 Michael Johnson <johnsonm@redhat.com>
320- auth patch
321
322* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
323- auto rebuild in the new build environment (release 3)
324
325* Thu Jan 07 1999 Cristian Gafton <gafton@redhat.com>
326- build for glibc 2.1
327
328* Fri Jun  5 1998 Jeff Johnson <jbj@redhat.com>
329- updated to 2.3.5.
330
331* Tue May 19 1998 Prospector System <bugs@redhat.com>
332- translations modified for de
333
334* Fri May  8 1998 Jakub Jelinek <jj@ultra.linux.cz>
335- make it run with kernels 2.1.100 and above.
336
337* Fri Apr 24 1998 Prospector System <bugs@redhat.com>
338- translations modified for de, fr, tr
339
340* Wed Mar 18 1998 Cristian Gafton <gafton@redhat.com>
341- requires glibc 2.0.6 or later
342
343* Wed Mar 18 1998 Michael K. Johnson <johnsonm@redhat.com>
344- updated PAM patch to not turn off wtmp/utmp/syslog logging.
345
346* Wed Jan  7 1998 Cristian Gafton <gafton@redhat.com>
347- added the /etc/pam.d config file
348- updated PAM patch to include session support
349
350* Tue Jan  6 1998 Cristian Gafton <gafton@redhat.com>
351- updated to ppp-2.3.3, build against glibc-2.0.6 - previous patches not
352  required any more.
353- added buildroot
354- fixed the PAM support, which was really, completely broken and against any
355  standards (session support is still not here... :-( )
356- we build against running kernel and pray that it will work
357- added a samples patch; updated glibc patch
358
359* Thu Dec 18 1997 Erik Troan <ewt@redhat.com>
360- added a patch to use our own route.h, rather then glibc's (which has
361  alignment problems on Alpha's) -- I only applied this patch on the Alpha,
362  though it should be safe everywhere
363
364* Fri Oct 10 1997 Erik Troan <ewt@redhat.com>
365- turned off the execute bit for scripts in /usr/doc
366
367* Fri Jul 18 1997 Erik Troan <ewt@redhat.com>
368- built against glibc
369
370* Tue Mar 25 1997 Erik Troan <ewt@redhat.com>
371- Integrated new patch from David Mosberger
372- Improved description
373
Note: See TracBrowser for help on using the repository browser.