source: projects/specs/trunk/p/ppp/ppp-vl.spec @ 10291

Revision 10291, 12.4 KB checked in by Takemikaduchi, 8 years ago (diff)

gnubiff,httping,lftp,libarchive,libgadu,libgit2,mosh: new upstream release
others: rebuild

Line 
1%bcond_with ifupdown
2
3%define _tmpfilesdir %{_sysconfdir}/tmpfiles.d
4
5Summary: The PPP (Point-to-Point Protocol) daemon.
6Summary(ja): PPP (Point-to-Point Protocol) デーモン
7Name: ppp
8Version: 2.4.7
9Release: 2%{?_dist_release}
10License: BSD and LGPLv2+ and GPLv2+ and Public Domain
11Group: System Environment/Daemons
12URL: http://www.samba.org/ppp
13
14Source0: ftp://ftp.samba.org/pub/ppp/ppp-%{version}.tar.gz
15Source1: ppp-pam.conf
16Source2: ppp-logrotate.conf
17Source3: ppp-tmpfiles.conf
18Source4: ip-down
19Source5: ip-down.ipv6to4
20Source6: ip-up
21Source7: ip-up.ipv6to4
22Source8: ipv6-down
23Source9: ipv6-up
24Source10: ifup-ppp
25Source11: ifdown-ppp
26Source12: ppp-watch.tar.xz
27
28# Fedora-specific
29Patch0001: 0001-build-sys-use-gcc-as-our-compiler-of-choice.patch
30Patch0002: 0002-build-sys-enable-PAM-support.patch
31Patch0003: 0003-build-sys-utilize-compiler-flags-handed-to-us-by-rpm.patch
32Patch0004: 0004-doc-add-configuration-samples.patch
33Patch0005: 0005-build-sys-don-t-hardcode-LIBDIR-but-set-it-according.patch
34Patch0006: 0006-scritps-use-change_resolv_conf-function.patch
35Patch0007: 0007-build-sys-don-t-strip-binaries-during-installation.patch
36Patch0008: 0008-build-sys-use-prefix-usr-instead-of-usr-local.patch
37Patch0009: 0009-pppd-introduce-ipv6-accept-remote.patch
38Patch0010: 0010-build-sys-enable-CBCP.patch
39Patch0011: 0011-build-sys-don-t-put-connect-errors-log-to-etc-ppp.patch
40Patch0012: 0012-pppd-we-don-t-want-to-accidentally-leak-fds.patch
41Patch0013: 0013-everywhere-O_CLOEXEC-harder.patch
42Patch0014: 0014-everywhere-use-SOCK_CLOEXEC-when-creating-socket.patch
43Patch0015: 0015-pppd-move-pppd-database-to-var-run-ppp.patch
44Patch0016: 0016-rp-pppoe-add-manpage-for-pppoe-discovery.patch
45Patch0017: 0017-pppd-rebase-EAP-TLS-patch-v0.994.patch
46Patch0018: 0018-scritps-fix-ip-up.local-sample.patch
47Patch0019: 0019-sys-linux-rework-get_first_ethernet.patch
48Patch0020: 0020-pppd-put-lock-files-in-var-lock-ppp.patch
49Patch0021: 0021-build-sys-compile-pppol2tp-plugin-with-RPM_OPT_FLAGS.patch
50Patch0022: 0022-build-sys-compile-pppol2tp-with-multilink-support.patch
51Patch0023: 0023-build-sys-install-rp-pppoe-plugin-files-with-standar.patch
52Patch0024: 0024-build-sys-install-pppoatm-plugin-files-with-standard.patch
53Patch0025: 0025-pppd-install-pppd-binary-using-standard-perms-755.patch
54
55BuildRoot: %{_tmppath}/%{name}-%{version}-root
56BuildRequires: glib2-devel, libpcap >= 0.8.3, eudev-libudev-devel, openssl-devel, pam-devel
57#Requires: glibc >= 2.0.6, /etc/pam.d/system-auth
58Requires: glibc >= 2.0.6, pam >= 1.0
59Requires(pre): shadow-utils
60
61Vendor: Project Vine
62Distribution: Vine Linux
63Packager: daisuke
64
65%description
66The ppp package contains the PPP (Point-to-Point Protocol) daemon and
67documentation for PPP support.  The PPP protocol provides a method for
68transmitting datagrams over serial point-to-point links. PPP is
69usually used to dial in to an ISP (Internet Service Provider) or other
70organization over a modem and phone line.
71
72%description -l ja
73ppp パッケージには PPP (Point-to-Point Protocol) デーモンと
74PPP を使う為のドキュメントが収められています.PPP プロトコルを
75使うとシリアルな point-to-point 接続上でデータグラムを転送する
76事が出来ます.この PPP は一般的には ISP (Internet Service Provider) 等に
77モデムを介した電話回線で接続する際に使われます.
78
79
80%package devel
81Summary: Headers for ppp plugin development
82SUmmary(ja): ppp プラグイン開発用ヘッダファイル
83Group: Development/Libraries
84
85%description devel
86This package contains the header files for building plugins for ppp.
87
88%description -l ja devel
89このパッケージには ppp のプラグインを開発するためのヘッダファイルが
90含まれています。
91
92%prep
93%setup  -q
94%autopatch -p1
95
96tar -xJf %{SOURCE12}
97
98%build
99export RPM_OPT_FLAGS="$RPM_OPT_FLAGS -fPIC -Wall"
100%configure
101make %{?_smp_mflags}
102make -C ppp-watch %{?_smp_mflags}
103
104%install
105[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
106
107%ifarch x86_64
108make INSTROOT=%{buildroot} install install-etcppp LIBDIR=$RPM_BUILD_ROOT%{_libdir}/pppd/%{version}
109%else
110make INSTROOT=%{buildroot} install install-etcppp
111%endif
112
113find scripts -type f | xargs chmod a-x
114
115make ROOT=%{buildroot} -C ppp-watch install
116
117# create log files dir
118mv -f %{buildroot}/usr/var %{buildroot}/
119
120# install pam config
121install -d %{buildroot}%{_sysconfdir}/pam.d
122install -m 644 %{SOURCE1} %{buildroot}%{_sysconfdir}/pam.d/ppp
123
124# install logrotate script
125install -d %{buildroot}%{_sysconfdir}/logrotate.d
126install -p %{SOURCE2} %{buildroot}%{_sysconfdir}/logrotate.d/ppp
127
128# install tmpfiles drop-in
129install -d %{buildroot}%{_tmpfilesdir}
130install -p %{SOURCE3} %{buildroot}%{_tmpfilesdir}/ppp.conf
131
132# install scripts (previously owned by initscripts package)
133install -d %{buildroot}%{_sysconfdir}/ppp
134%if %{with ifupdown}
135install -p %{SOURCE4} %{buildroot}%{_sysconfdir}/ppp/ip-down
136install -p %{SOURCE5} %{buildroot}%{_sysconfdir}/ppp/ip-down.ipv6to4
137install -p %{SOURCE6} %{buildroot}%{_sysconfdir}/ppp/ip-up
138install -p %{SOURCE7} %{buildroot}%{_sysconfdir}/ppp/ip-up.ipv6to4
139install -p %{SOURCE8} %{buildroot}%{_sysconfdir}/ppp/ipv6-down
140install -p %{SOURCE9} %{buildroot}%{_sysconfdir}/ppp/ipv6-up
141%endif
142
143%if %{with ifupdown}
144install -d %{buildroot}%{_sysconfdir}/sysconfig/network-scripts/
145install -p %{SOURCE10} %{buildroot}%{_sysconfdir}/sysconfig/network-scripts/ifup-ppp
146install -p %{SOURCE11} %{buildroot}%{_sysconfdir}/sysconfig/network-scripts/ifdown-ppp
147%endif
148
149
150%clean
151rm -rf %{buildroot}
152
153
154%pre
155/usr/bin/getent group dip >/dev/null 2>&1 || /usr/sbin/groupadd -r -g 40 dip >/dev/null 2>&1 || :
156
157
158%files
159%defattr(-,root,root)
160%doc FAQ README README.cbcp README.linux README.MPPE README.MSCHAP80 README.MSCHAP81 README.pwfd README.pppoe scripts sample README.eap-tls
161%{_sbindir}/*
162%{_libdir}/pppd
163%{_mandir}/man8/chat.8*
164%{_mandir}/man8/ppp-watch.8*
165%{_mandir}/man8/pppd.8*
166%{_mandir}/man8/pppdump.8*
167%{_mandir}/man8/pppstats.8*
168%{_mandir}/man8/pppd-radattr.8*
169%{_mandir}/man8/pppd-radius.8*
170%{_mandir}/man8/pppoe-discovery.8*
171%dir /etc/ppp
172%config(noreplace) /etc/ppp/*
173%config(noreplace) /etc/pam.d/ppp
174%config(noreplace) /etc/logrotate.d/ppp
175%{_tmpfilesdir}/ppp.conf
176%ghost %dir %{_localstatedir}/run/ppp
177%ghost %dir %{_localstatedir}/lock/ppp
178%attr(700, root, root) %dir %{_localstatedir}/log/ppp
179
180%if %{with ifupdown}
181/etc/sysconfig/network-scripts/ifup-ppp
182/etc/sysconfig/network-scripts/ifdown-ppp
183%endif
184
185%files devel
186%defattr(-,root,root)
187%{_includedir}/pppd
188%doc PLUGINS
189
190
191%changelog
192* Sun May 15 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.7-2
193- rebuild with openssl-1.0.2
194
195* Tue Aug 19 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.7-1
196- new upstream release.
197
198* Tue Jun 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.6-2
199- change BuildRequires: eudev-libudev-devel instead of libudev-devel
200
201* Wed Jun 18 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.6-1
202- new upstream release.
203- replaceed all patches.
204
205* Tue Sep 06 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.5-4
206- added /var/run/ppp to %%files. (BTS:1215)
207- added /var/log/ppp to %%files.
208
209* Mon Apr 25 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.5-3
210- remove include/linux/if_pppol2tp.h to build pppoe plugin
211- update License tag
212
213* Fri Apr 08 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.5-2
214- rebuilt with new toolchain.
215
216* Mon Mar 08 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.5-1
217- new upstream release.
218- replaced all patches with Fedora's.
219- replaced 'BuildPreReq:' with 'BuildRequires:'.
220
221* Sun Aug 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.4-4
222- update pam.d/ppp to fix pam-1.0
223
224* Thu Aug 14 2008 Shu KONNO <owa@bg.wakwak.com> 2.4.4-3
225- added option LIBDIR at makeinstall for x86_64
226
227* Thu Jul 31 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.4-2
228- add -devel subpackage to develop ppp plugins
229
230* Wed Jun 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.4.4-1
231- update Source1 for pam-1.0.1
232- import several patches from Fedora 2.4.4-7
233
234* Sat Jul  7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.4-0vl1
235- new upstream release
236- rebuilt with new toolchain and environment
237- added URL (also URL of Source0)
238
239* Fri Nov 17 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.4.3-0vl2
240- use License: instead of Copyright:
241
242* Mon Jan 24 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.4.3-0vl1
243- new upstream release.
244- replace patch0.
245
246* Wed Aug 11 2004 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.4.2-0vl0
247- new upstream release.
248- remove patch 2-4 (no longer needed).
249
250* Sat Mar 15 2003 <ryo1@bc.wakwak.com> 2.4.1-0vl2
251- rebuild with new toolchains
252
253* Sun Jun 10 2001 <sagami@vinelinux.org>
254- 2.4.1-0vl1: update to 2.4.1
255
256* Thu Jan 25 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
257- 2.4.0-2vl1
258- based on 2.4.0-2 from Rawhide
259- added Japanese summary and description
260- Requires: /etc/pam.d/system-auth -> pam >= 0.72
261  (for better compatibility with apt for rpm)
262
263* Fri Dec  1 2000 Nalin Dahyabhai <nalin@redhat.com>
264- rebuild in new environment
265
266* Thu Nov  9 2000 Nalin Dahyabhai <nalin@redhat.com>
267- update to 2.4.0
268
269* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
270- automatic rebuild
271
272* Mon Jun  5 2000 Nalin Dahyabhai <nalin@redhat.com>
273- move man pages to %{_mandir}
274
275* Thu Jun  1 2000 Nalin Dahyabhai <nalin@redhat.com>
276- change perms using defattr
277- modify PAM setup to use system-auth
278
279* Sun Mar 26 2000 Florian La Roche <Florian.La Roche@redhat.com>
280- change to root:root perms
281
282* Mon Mar 06 2000 Nalin Dahyabhai <nalin@redhat.com>
283- reaper bugs verified as fixed
284- check pam_open_session result code (bug #9966)
285
286* Mon Feb 07 2000 Nalin Dahyabhai <nalin@redhat.com>
287- take a shot at the wrong reaper bugs (#8153, #5290)
288
289* Thu Feb 03 2000 Nalin Dahyabhai <nalin@redhat.com>
290- free ride through the build system (release 2)
291
292* Tue Jan 18 2000 Nalin Dahyabhai <nalin@redhat.com>
293- Update to 2.3.11
294
295* Sat Nov 06 1999 Michael K. Johnson <johnsonm@redhat.com>
296- Better fix for both problems
297
298* Fri Nov 05 1999 Michael K. Johnson <johnsonm@redhat.com>
299- fix for double-dial problem
300- fix for requiring a controlling terminal problem
301
302* Sun Sep 19 1999 Preston Brown <pbrown@redhat.com>
303- 2.3.10 bugfix release
304
305* Fri Aug 13 1999 Michael K. Johnson <johnsonm@redhat.com>
306- New version 2.3.9 required for kernel 2.3.13 and will be required
307  for new initscripts.  auth patch removed; 2.3.9 does the same thing
308  more readably than the previous patch.
309
310* Thu Jun 24 1999 Cristian Gafton <gafton@redhat.com>
311- add pppdump
312
313* Fri Apr 09 1999 Cristian Gafton <gafton@redhat.com>
314- force pppd use the glibc's logwtmp instead of implementing its own
315
316* Thu Apr 01 1999 Preston Brown <pbrown@redhat.com>
317- version 2.3.7 bugfix release
318
319* Tue Mar 23 1999 Cristian Gafton <gafton@redhat.com>
320- version 2.3.6
321
322* Mon Mar 22 1999 Michael Johnson <johnsonm@redhat.com>
323- auth patch
324
325* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
326- auto rebuild in the new build environment (release 3)
327
328* Thu Jan 07 1999 Cristian Gafton <gafton@redhat.com>
329- build for glibc 2.1
330
331* Fri Jun  5 1998 Jeff Johnson <jbj@redhat.com>
332- updated to 2.3.5.
333
334* Tue May 19 1998 Prospector System <bugs@redhat.com>
335- translations modified for de
336
337* Fri May  8 1998 Jakub Jelinek <jj@ultra.linux.cz>
338- make it run with kernels 2.1.100 and above.
339
340* Fri Apr 24 1998 Prospector System <bugs@redhat.com>
341- translations modified for de, fr, tr
342
343* Wed Mar 18 1998 Cristian Gafton <gafton@redhat.com>
344- requires glibc 2.0.6 or later
345
346* Wed Mar 18 1998 Michael K. Johnson <johnsonm@redhat.com>
347- updated PAM patch to not turn off wtmp/utmp/syslog logging.
348
349* Wed Jan  7 1998 Cristian Gafton <gafton@redhat.com>
350- added the /etc/pam.d config file
351- updated PAM patch to include session support
352
353* Tue Jan  6 1998 Cristian Gafton <gafton@redhat.com>
354- updated to ppp-2.3.3, build against glibc-2.0.6 - previous patches not
355  required any more.
356- added buildroot
357- fixed the PAM support, which was really, completely broken and against any
358  standards (session support is still not here... :-( )
359- we build against running kernel and pray that it will work
360- added a samples patch; updated glibc patch
361
362* Thu Dec 18 1997 Erik Troan <ewt@redhat.com>
363- added a patch to use our own route.h, rather then glibc's (which has
364  alignment problems on Alpha's) -- I only applied this patch on the Alpha,
365  though it should be safe everywhere
366
367* Fri Oct 10 1997 Erik Troan <ewt@redhat.com>
368- turned off the execute bit for scripts in /usr/doc
369
370* Fri Jul 18 1997 Erik Troan <ewt@redhat.com>
371- built against glibc
372
373* Tue Mar 25 1997 Erik Troan <ewt@redhat.com>
374- Integrated new patch from David Mosberger
375- Improved description
376
Note: See TracBrowser for help on using the repository browser.