source: projects/specs/trunk/p/ppp/ppp-vl.spec @ 12529

Revision 12529, 12.6 KB checked in by tomop, 3 years ago (diff)

updated 5 packages

ModemManager?-1.14.10-1

NetworkManager-1.28.0-1

libpcap-1.10.0-1

ppp-2.4.9-1

xl2tpd-1.3.16-1

Line 
1%bcond_with systemd
2%bcond_with ifupdown
3
4Summary: The PPP (Point-to-Point Protocol) daemon.
5Summary(ja): PPP (Point-to-Point Protocol) デーモン
6Name: ppp
7Version: 2.4.9
8Release: 1%{?_dist_release}%{?with_systemd:.systemd}
9Group: system
10Vendor: Project Vine
11Distribution: Vine Linux
12Packager: daisuke
13
14License: BSD and LGPLv2+ and GPLv2+ and Public Domain
15URL: https://github.com/paulusmack/ppp
16
17Source0: https://github.com/paulusmack/ppp/archive/ppp-%{version}.tar.gz
18Source1: ppp-pam.conf
19Source2: ppp-logrotate.conf
20Source3: ppp-tmpfiles.conf
21Source4: ip-down
22Source5: ip-down.ipv6to4
23Source6: ip-up
24Source7: ip-up.ipv6to4
25Source8: ipv6-down
26Source9: ipv6-up
27Source10: ifup-ppp
28Source11: ifdown-ppp
29Source12: ppp-watch.tar.xz
30
31# Fedora-specific
32Patch0002:     ppp-2.4.9-config.patch
33Patch0004:     0004-doc-add-configuration-samples.patch
34Patch0005:     ppp-2.4.9-build-sys-don-t-hardcode-LIBDIR-but-set-it-according.patch
35Patch0006:     0006-scritps-use-change_resolv_conf-function.patch
36Patch0011:     0011-build-sys-don-t-put-connect-errors-log-to-etc-ppp.patch
37Patch0012:     ppp-2.4.8-pppd-we-don-t-want-to-accidentally-leak-fds.patch
38Patch0013:     ppp-2.4.9-everywhere-O_CLOEXEC-harder.patch
39Patch0014:     0014-everywhere-use-SOCK_CLOEXEC-when-creating-socket.patch
40Patch0015:     0015-pppd-move-pppd-database-to-var-run-ppp.patch
41Patch0016:     0016-rp-pppoe-add-manpage-for-pppoe-discovery.patch
42Patch0018:     0018-scritps-fix-ip-up.local-sample.patch
43Patch0020:     0020-pppd-put-lock-files-in-var-lock-ppp.patch
44Patch0023:     0023-build-sys-install-rp-pppoe-plugin-files-with-standar.patch
45Patch0024:     0024-build-sys-install-pppoatm-plugin-files-with-standard.patch
46Patch0025:     ppp-2.4.8-pppd-install-pppd-binary-using-standard-perms-755.patch
47Patch0026:     ppp-2.4.9-configure-cflags-allow-commas.patch
48
49BuildRoot: %{_tmppath}/%{name}-%{version}-root
50BuildRequires: glib2-devel, libpcap-devel, openssl-devel, pam-devel
51%if %{with systemd}
52BuildRequires: systemd-devel
53%else
54BuildRequires: eudev-libudev-devel
55%endif
56
57#Requires: glibc >= 2.0.6, /etc/pam.d/system-auth
58Requires: glibc >= 2.0.6, pam >= 1.0
59Requires(pre): shadow-utils
60
61%description
62The ppp package contains the PPP (Point-to-Point Protocol) daemon and
63documentation for PPP support.  The PPP protocol provides a method for
64transmitting datagrams over serial point-to-point links. PPP is
65usually used to dial in to an ISP (Internet Service Provider) or other
66organization over a modem and phone line.
67
68%description -l ja
69ppp パッケージには PPP (Point-to-Point Protocol) デーモンと
70PPP を使う為のドキュメントが収められています.PPP プロトコルを
71使うとシリアルな point-to-point 接続上でデータグラムを転送する
72事が出来ます.この PPP は一般的には ISP (Internet Service Provider) 等に
73モデムを介した電話回線で接続する際に使われます.
74
75
76%package devel
77Summary: Headers for ppp plugin development
78SUmmary(ja): ppp プラグイン開発用ヘッダファイル
79Group: programming
80
81%description devel
82This package contains the header files for building plugins for ppp.
83
84%description -l ja devel
85このパッケージには ppp のプラグインを開発するためのヘッダファイルが
86含まれています。
87
88
89%debug_package
90
91
92%prep
93%setup  -q -n ppp-ppp-%{version}
94%autopatch -p1
95
96tar -xJf %{SOURCE12}
97
98
99%build
100export RPM_OPT_FLAGS="$RPM_OPT_FLAGS -fPIC -Wall -fno-strict-aliasing"
101%configure
102make %{?_smp_mflags}
103make -C ppp-watch %{?_smp_mflags}
104
105
106%install
107[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
108
109%ifarch x86_64
110make INSTROOT=%{buildroot} install install-etcppp LIBDIR=$RPM_BUILD_ROOT%{_libdir}/pppd/%{version}
111%else
112make INSTROOT=%{buildroot} install install-etcppp
113%endif
114
115find scripts -type f | xargs chmod a-x
116
117make ROOT=%{buildroot} -C ppp-watch install
118
119# create log files dir
120mv -f %{buildroot}/usr/var %{buildroot}/
121
122# install pam config
123install -d %{buildroot}%{_sysconfdir}/pam.d
124install -m 644 %{SOURCE1} %{buildroot}%{_sysconfdir}/pam.d/ppp
125
126# install logrotate script
127install -d %{buildroot}%{_sysconfdir}/logrotate.d
128install -m 644 -p %{SOURCE2} %{buildroot}%{_sysconfdir}/logrotate.d/ppp
129
130%if %{with systemd}
131# install tmpfiles drop-in
132install -d %{buildroot}%{_tmpfilesdir}
133install -p %{SOURCE3} %{buildroot}%{_tmpfilesdir}/ppp.conf
134%endif
135
136# install scripts (previously owned by initscripts package)
137install -d %{buildroot}%{_sysconfdir}/ppp
138%if %{with ifupdown}
139install -p %{SOURCE4} %{buildroot}%{_sysconfdir}/ppp/ip-down
140install -p %{SOURCE5} %{buildroot}%{_sysconfdir}/ppp/ip-down.ipv6to4
141install -p %{SOURCE6} %{buildroot}%{_sysconfdir}/ppp/ip-up
142install -p %{SOURCE7} %{buildroot}%{_sysconfdir}/ppp/ip-up.ipv6to4
143install -p %{SOURCE8} %{buildroot}%{_sysconfdir}/ppp/ipv6-down
144install -p %{SOURCE9} %{buildroot}%{_sysconfdir}/ppp/ipv6-up
145%endif
146
147%if %{with ifupdown}
148install -d %{buildroot}%{_sysconfdir}/sysconfig/network-scripts/
149install -p %{SOURCE10} %{buildroot}%{_sysconfdir}/sysconfig/network-scripts/ifup-ppp
150install -p %{SOURCE11} %{buildroot}%{_sysconfdir}/sysconfig/network-scripts/ifdown-ppp
151%endif
152
153
154%clean
155rm -rf %{buildroot}
156
157
158%pre
159/usr/bin/getent group dip >/dev/null 2>&1 || /usr/sbin/groupadd -r -g 40 dip >/dev/null 2>&1 || :
160
161%if %{with systemd}
162%post
163%tmpfiles_create ppp.conf
164%endif
165
166%files
167%defattr(-,root,root)
168%doc FAQ README README.cbcp README.linux README.MPPE README.MSCHAP80 README.MSCHAP81 README.pwfd README.pppoe scripts sample README.eap-tls
169%{_sbindir}/*
170%{_libdir}/pppd
171%{_mandir}/man8/chat.8*
172%{_mandir}/man8/ppp-watch.8*
173%{_mandir}/man8/pppd.8*
174%{_mandir}/man8/pppdump.8*
175%{_mandir}/man8/pppstats.8*
176%{_mandir}/man8/pppd-radattr.8*
177%{_mandir}/man8/pppd-radius.8*
178%{_mandir}/man8/pppoe-discovery.8*
179%dir /etc/ppp
180%config(noreplace) /etc/ppp/*
181%config(noreplace) /etc/pam.d/ppp
182%config(noreplace) /etc/logrotate.d/ppp
183%if %{with systemd}
184%{_tmpfilesdir}/ppp.conf
185%endif
186%ghost %dir %{_localstatedir}/run/ppp
187%ghost %dir %{_localstatedir}/lock/ppp
188%attr(700, root, root) %dir %{_localstatedir}/log/ppp
189
190%if %{with ifupdown}
191/etc/sysconfig/network-scripts/ifup-ppp
192/etc/sysconfig/network-scripts/ifdown-ppp
193%endif
194
195%files devel
196%defattr(-,root,root)
197%{_includedir}/pppd
198%doc PLUGINS
199
200
201%changelog
202* Mon Feb 15 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.9-1
203- new upstream release.
204- updated patches.
205
206* Thu Mar 19 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.8-1
207- new upstream release.
208- updated patches.
209
210* Sun Nov 18 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.7-4
211- rebuilt with openssl-1.1.1.
212- dropped Patch17.
213- imported Patch26-30 from rawhide.
214
215* Sun Jun 19 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.7-3
216- changed permissions for /etc/logrotate.d/ppp from 755 to 644.
217
218* Sun May 15 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.7-2
219- rebuild with openssl-1.0.2
220
221* Tue Aug 19 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.7-1
222- new upstream release.
223
224* Tue Jun 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.6-2
225- change BuildRequires: eudev-libudev-devel instead of libudev-devel
226
227* Wed Jun 18 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.6-1
228- new upstream release.
229- replaceed all patches.
230
231* Tue Sep 06 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.5-4
232- added /var/run/ppp to %%files. (BTS:1215)
233- added /var/log/ppp to %%files.
234
235* Mon Apr 25 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.5-3
236- remove include/linux/if_pppol2tp.h to build pppoe plugin
237- update License tag
238
239* Fri Apr 08 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.5-2
240- rebuilt with new toolchain.
241
242* Mon Mar 08 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.5-1
243- new upstream release.
244- replaced all patches with Fedora's.
245- replaced 'BuildPreReq:' with 'BuildRequires:'.
246
247* Sun Aug 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.4-4
248- update pam.d/ppp to fix pam-1.0
249
250* Thu Aug 14 2008 Shu KONNO <owa@bg.wakwak.com> 2.4.4-3
251- added option LIBDIR at makeinstall for x86_64
252
253* Thu Jul 31 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.4-2
254- add -devel subpackage to develop ppp plugins
255
256* Wed Jun 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.4.4-1
257- update Source1 for pam-1.0.1
258- import several patches from Fedora 2.4.4-7
259
260* Sat Jul  7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.4-0vl1
261- new upstream release
262- rebuilt with new toolchain and environment
263- added URL (also URL of Source0)
264
265* Fri Nov 17 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.4.3-0vl2
266- use License: instead of Copyright:
267
268* Mon Jan 24 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.4.3-0vl1
269- new upstream release.
270- replace patch0.
271
272* Wed Aug 11 2004 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.4.2-0vl0
273- new upstream release.
274- remove patch 2-4 (no longer needed).
275
276* Sat Mar 15 2003 <ryo1@bc.wakwak.com> 2.4.1-0vl2
277- rebuild with new toolchains
278
279* Sun Jun 10 2001 <sagami@vinelinux.org>
280- 2.4.1-0vl1: update to 2.4.1
281
282* Thu Jan 25 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
283- 2.4.0-2vl1
284- based on 2.4.0-2 from Rawhide
285- added Japanese summary and description
286- Requires: /etc/pam.d/system-auth -> pam >= 0.72
287  (for better compatibility with apt for rpm)
288
289* Fri Dec  1 2000 Nalin Dahyabhai <nalin@redhat.com>
290- rebuild in new environment
291
292* Thu Nov  9 2000 Nalin Dahyabhai <nalin@redhat.com>
293- update to 2.4.0
294
295* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
296- automatic rebuild
297
298* Mon Jun  5 2000 Nalin Dahyabhai <nalin@redhat.com>
299- move man pages to %{_mandir}
300
301* Thu Jun  1 2000 Nalin Dahyabhai <nalin@redhat.com>
302- change perms using defattr
303- modify PAM setup to use system-auth
304
305* Sun Mar 26 2000 Florian La Roche <Florian.La Roche@redhat.com>
306- change to root:root perms
307
308* Mon Mar 06 2000 Nalin Dahyabhai <nalin@redhat.com>
309- reaper bugs verified as fixed
310- check pam_open_session result code (bug #9966)
311
312* Mon Feb 07 2000 Nalin Dahyabhai <nalin@redhat.com>
313- take a shot at the wrong reaper bugs (#8153, #5290)
314
315* Thu Feb 03 2000 Nalin Dahyabhai <nalin@redhat.com>
316- free ride through the build system (release 2)
317
318* Tue Jan 18 2000 Nalin Dahyabhai <nalin@redhat.com>
319- Update to 2.3.11
320
321* Sat Nov 06 1999 Michael K. Johnson <johnsonm@redhat.com>
322- Better fix for both problems
323
324* Fri Nov 05 1999 Michael K. Johnson <johnsonm@redhat.com>
325- fix for double-dial problem
326- fix for requiring a controlling terminal problem
327
328* Sun Sep 19 1999 Preston Brown <pbrown@redhat.com>
329- 2.3.10 bugfix release
330
331* Fri Aug 13 1999 Michael K. Johnson <johnsonm@redhat.com>
332- New version 2.3.9 required for kernel 2.3.13 and will be required
333  for new initscripts.  auth patch removed; 2.3.9 does the same thing
334  more readably than the previous patch.
335
336* Thu Jun 24 1999 Cristian Gafton <gafton@redhat.com>
337- add pppdump
338
339* Fri Apr 09 1999 Cristian Gafton <gafton@redhat.com>
340- force pppd use the glibc's logwtmp instead of implementing its own
341
342* Thu Apr 01 1999 Preston Brown <pbrown@redhat.com>
343- version 2.3.7 bugfix release
344
345* Tue Mar 23 1999 Cristian Gafton <gafton@redhat.com>
346- version 2.3.6
347
348* Mon Mar 22 1999 Michael Johnson <johnsonm@redhat.com>
349- auth patch
350
351* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
352- auto rebuild in the new build environment (release 3)
353
354* Thu Jan 07 1999 Cristian Gafton <gafton@redhat.com>
355- build for glibc 2.1
356
357* Fri Jun  5 1998 Jeff Johnson <jbj@redhat.com>
358- updated to 2.3.5.
359
360* Tue May 19 1998 Prospector System <bugs@redhat.com>
361- translations modified for de
362
363* Fri May  8 1998 Jakub Jelinek <jj@ultra.linux.cz>
364- make it run with kernels 2.1.100 and above.
365
366* Fri Apr 24 1998 Prospector System <bugs@redhat.com>
367- translations modified for de, fr, tr
368
369* Wed Mar 18 1998 Cristian Gafton <gafton@redhat.com>
370- requires glibc 2.0.6 or later
371
372* Wed Mar 18 1998 Michael K. Johnson <johnsonm@redhat.com>
373- updated PAM patch to not turn off wtmp/utmp/syslog logging.
374
375* Wed Jan  7 1998 Cristian Gafton <gafton@redhat.com>
376- added the /etc/pam.d config file
377- updated PAM patch to include session support
378
379* Tue Jan  6 1998 Cristian Gafton <gafton@redhat.com>
380- updated to ppp-2.3.3, build against glibc-2.0.6 - previous patches not
381  required any more.
382- added buildroot
383- fixed the PAM support, which was really, completely broken and against any
384  standards (session support is still not here... :-( )
385- we build against running kernel and pray that it will work
386- added a samples patch; updated glibc patch
387
388* Thu Dec 18 1997 Erik Troan <ewt@redhat.com>
389- added a patch to use our own route.h, rather then glibc's (which has
390  alignment problems on Alpha's) -- I only applied this patch on the Alpha,
391  though it should be safe everywhere
392
393* Fri Oct 10 1997 Erik Troan <ewt@redhat.com>
394- turned off the execute bit for scripts in /usr/doc
395
396* Fri Jul 18 1997 Erik Troan <ewt@redhat.com>
397- built against glibc
398
399* Tue Mar 25 1997 Erik Troan <ewt@redhat.com>
400- Integrated new patch from David Mosberger
401- Improved description
402
Note: See TracBrowser for help on using the repository browser.