source: projects/specs/trunk/p/popt/popt-vl.spec @ 8191

Revision 8191, 8.2 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release or rebuild

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2Summary:        C library for parsing command line parameters
3Summary(ja):    コマンドラインパラメータを文法解析するためのCライブラリ
4Name:           popt
5Version:        1.16
6Release:        2%{?_dist_release}
7License:        MIT
8Group:          System Environment/Libraries
9URL:            http://www.rpm5.org/
10Source0:        http://www.rpm5.org/files/%{name}/%{name}-%{version}.tar.gz
11BuildRequires:  gettext, doxygen, graphviz
12BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
13
14Vendor: Project Vine
15Distribution: Vine Linux
16
17%description
18Popt is a C library for parsing command line parameters. Popt was
19heavily influenced by the getopt() and getopt_long() functions, but
20it improves on them by allowing more powerful argument expansion.
21Popt can parse arbitrary argv[] style arrays and automatically set
22variables based on command line arguments. Popt allows command line
23arguments to be aliased via configuration files and includes utility
24functions for parsing arbitrary strings into argv[] arrays using
25shell-like rules.
26
27%description -l ja
28Poptはコマンドパラメータを文法解析するためのCライブラリです。
29Poptは getopt()やgetopt_long()関数の影響を強く受けていますが、
30もっと強力な引数の拡張を施すことによって、それらをもっと進化
31させています。Poptは 任意の argv[]形式配列を解析して、コマンド
32ライン引数に基づいて変数を自動的に設定します。
33Poptは、コマンドライン引数を設定ファイルによってエイリアス化を
34許可したり、シェルライクな方針を用いた任意の文字列を文法解析し
35てargv[]配列に変換したりするユーティリティ関数を含んでいます。
36
37
38%package devel
39Summary:        Development files for the popt library
40Summary(ja):    popt ライブラリの開発ファイル
41Group:          Development/Libraries
42Requires:       %{name} = %{version}-%{release}
43
44%description devel
45The popt-devel package includes header files and libraries necessary
46for developing programs which use the popt C library. It contains the
47API documentation of the popt library, too.
48
49
50%package static
51Summary: Static library for %{name}
52Summary(ja): %{name} のスタティックライブラリ
53Group: Development/Libraries
54Requires: %{name} = %{version}-%{release}
55
56%description static
57The %{name}-static package contains the static library for %{name}.
58
59
60%package -n compat32-%{name}
61Summary: A C library for parsing command line parameters.
62Summary(ja): コマンドラインパラメータを文法解析するためのCライブラリ
63Group: Development/Libraries
64Requires: %{name} = %{version}-%{release}
65
66%description -n compat32-%{name}
67Popt is a C library for parsing command line parameters. Popt was
68heavily influenced by the getopt() and getopt_long() functions, but it
69improves on them by allowing more powerful argument expansion. Popt
70can parse arbitrary argv[] style arrays and automatically set
71variables based on command line arguments. Popt allows command line
72arguments to be aliased via configuration files and includes utility
73functions for parsing arbitrary strings into argv[] arrays using
74shell-like rules.
75
76%description -n compat32-%{name} -l ja
77Poptはコマンドパラメータを文法解析するためのCライブラリです。
78Poptは getopt()やgetopt_long()関数の影響を強く受けていますが、
79もっと強力な引数の拡張を施すことによって、それらをもっと進化
80させています。Poptは 任意の argv[]形式配列を解析して、コマンド
81ライン引数に基づいて変数を自動的に設定します。
82Poptは、コマンドライン引数を設定ファイルによってエイリアス化を
83許可したり、シェルライクな方針を用いた任意の文字列を文法解析し
84てargv[]配列に変換したりするユーティリティ関数を含んでいます。
85
86%package -n compat32-%{name}-devel
87Summary:        Development files for the popt library
88Summary(ja):    popt ライブラリの開発ファイル
89Group:          Development/Libraries
90Requires:       compat32-%{name} = %{version}-%{release}
91Requires:       %{name}-devel = %{version}-%{release}
92
93%description -n compat32-%{name}-devel
94The popt-devel package includes header files and libraries necessary
95for developing programs which use the popt C library. It contains the
96API documentation of the popt library, too.
97
98%prep
99%setup -q
100sed -i "s|libdir=@libdir@|libdir=@prefix@@libdir@|" popt.pc.in
101%ifarch x86_64
102sed -i "s|/lib/pkgconfig|/lib64/pkgconfig|" Makefile.am
103sed -i "s|/lib/pkgconfig|/lib64/pkgconfig|" Makefile.in
104%endif
105
106%build
107%configure --libdir=/%{_lib}
108make %{?_smp_mflags}
109doxygen
110
111%install
112rm -rf $RPM_BUILD_ROOT
113make DESTDIR=$RPM_BUILD_ROOT install
114
115# Move libpopt.{so,a} to %{_libdir}
116rm -f $RPM_BUILD_ROOT/%{_lib}/libpopt.{la,so}
117pushd $RPM_BUILD_ROOT/%{_lib}
118mkdir -p $RPM_BUILD_ROOT%{_libdir}
119ln -sf ../../%{_lib}/$(ls libpopt.so.?.?.?) $RPM_BUILD_ROOT%{_libdir}/libpopt.so
120popd
121mv -f $RPM_BUILD_ROOT/%{_lib}/libpopt.a $RPM_BUILD_ROOT%{_libdir}/libpopt.a
122
123# Multiple popt configurations are possible
124mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/popt.d
125
126%find_lang %{name}
127
128%clean
129rm -rf $RPM_BUILD_ROOT
130
131%post -p /sbin/ldconfig
132
133%postun -p /sbin/ldconfig
134
135%post -n compat32-%{name} -p /sbin/ldconfig
136
137%postun -n compat32-%{name} -p /sbin/ldconfig
138
139%files -f %{name}.lang
140%defattr(-,root,root)
141%doc CHANGES COPYING
142%{_sysconfdir}/popt.d
143/%{_lib}/libpopt.so.*
144
145%files devel
146%defattr(-,root,root)
147%doc README doxygen/html
148%{_libdir}/libpopt.so
149%{_libdir}/pkgconfig/popt.pc
150%{_includedir}/popt.h
151%{_mandir}/man3/popt.3*
152
153%files static
154%defattr(-,root,root)
155%{_libdir}/libpopt.a
156
157%if %{build_compat32}
158%files -n compat32-%{name}
159%defattr(-,root,root)
160/%{_lib}/libpopt.so.*
161
162%files -n compat32-%{name}-devel
163%defattr(-,root,root)
164%{_libdir}/libpopt.so
165%endif
166
167
168%changelog
169* Wed Jan 15 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.16-2
170- rebuild with VineSeed environment
171
172* Sat Nov 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.16-1
173- update to 1.16
174- create %{name}-static sub package
175
176* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> - 1.14-5
177- rebuilt with rpm-4.8.1-3
178
179* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.14-4
180- rebuilt with new toolchain
181
182* Sun Jun 28 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.14-3
183- updated Requires: and %%files section on compat32 subpackages
184
185* Mon Jun 08 2009 Shu KONNO <owa@bg.wakwak.com> 1.14-2
186- added %%define build_compat32
187- fixed compat32 directories
188
189* Mon Aug 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.14-1
190- initial build for Vine Linux
191  - splitted out from rpm, based on rpm5.org source.
192- move libpopt to /lib[64] from /usr/lib[64]
193  - initscripts-8 uses libpopt.
194
195* Sun May 25 2008 Robert Scheck <robert@fedoraproject.org> 1.13-4
196- Solved multilib problems at doxygen generated files (#342921)
197
198* Wed Feb 20 2008 Robert Scheck <robert@fedoraproject.org> 1.13-3
199- Revert the broken bind_textdomain_codeset() patch (#433324)
200
201* Thu Feb 14 2008 Robert Scheck <robert@fedoraproject.org> 1.13-2
202- Added patch to work around missing bind_textdomain_codeset()
203
204* Sun Dec 30 2007 Robert Scheck <robert@fedoraproject.org> 1.13-1
205- Upgrade to 1.13 (#290531, #332201, #425803)
206- Solved multilib problems at doxygen generated files (#342921)
207
208* Thu Aug 23 2007 Robert Scheck <robert@fedoraproject.org> 1.12-3
209- Added buildrequirement to graphviz (#249352)
210- Backported bugfixes from CVS (#102254, #135428 and #178413)
211
212* Sun Aug 12 2007 Robert Scheck <robert@fedoraproject.org> 1.12-2
213- Move libpopt to /lib[64] (#249814)
214- Generate API documentation, added buildrequirement to doxygen
215
216* Mon Jul 23 2007 Robert Scheck <robert@fedoraproject.org> 1.12-1
217- Changes to match with Fedora Packaging Guidelines (#249352)
218
219* Tue Jul 10 2007 Jeff Johnson <jbj@rpm5.org>
220- release popt-1.12 through rpm5.org.
221
222* Sat Jun  9 2007 Jeff Johnson <jbj@rpm5.org>
223- release popt-1.11 through rpm5.org.
224
225* Thu Dec 10 1998 Michael Johnson <johnsonm@redhat.com>
226- released 1.2.2; see CHANGES
227
228* Tue Nov 17 1998 Michael K. Johnson <johnsonm@redhat.com>
229- added man page to default install
230
231* Thu Oct 22 1998 Erik Troan <ewt@redhat.com>
232- see CHANGES file for 1.2
233
234* Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
235- added ./configure step to spec file
Note: See TracBrowser for help on using the repository browser.