source: projects/specs/trunk/p/popt/popt-vl.spec @ 12536

Revision 12536, 8.4 KB checked in by tomop, 3 years ago (diff)

popt-1.18-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary:        C library for parsing command line parameters
4Summary(ja):    コマンドラインパラメータを文法解析するためのCライブラリ
5Name:           popt
6Version:        1.18
7Release:        1%{?_dist_release}
8Group:          System Environment/Libraries
9Vendor:         Project Vine
10Distribution:   Vine Linux
11
12License:        MIT
13URL:            https://github.com/rpm-software-management/popt/
14Source0:        http://ftp.rpm.org/popt/releases/popt-1.x/%{name}-%{version}.tar.gz
15
16BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
17BuildRequires:  gettext
18
19%description
20Popt is a C library for parsing command line parameters. Popt was
21heavily influenced by the getopt() and getopt_long() functions, but
22it improves on them by allowing more powerful argument expansion.
23Popt can parse arbitrary argv[] style arrays and automatically set
24variables based on command line arguments. Popt allows command line
25arguments to be aliased via configuration files and includes utility
26functions for parsing arbitrary strings into argv[] arrays using
27shell-like rules.
28
29%description -l ja
30Poptはコマンドパラメータを文法解析するためのCライブラリです。
31Poptは getopt()やgetopt_long()関数の影響を強く受けていますが、
32もっと強力な引数の拡張を施すことによって、それらをもっと進化
33させています。Poptは 任意の argv[]形式配列を解析して、コマンド
34ライン引数に基づいて変数を自動的に設定します。
35Poptは、コマンドライン引数を設定ファイルによってエイリアス化を
36許可したり、シェルライクな方針を用いた任意の文字列を文法解析し
37てargv[]配列に変換したりするユーティリティ関数を含んでいます。
38
39
40%package devel
41Summary:        Development files for the popt library
42Summary(ja):    popt ライブラリの開発ファイル
43Group:          programming
44Requires:       %{name} = %{version}-%{release}
45
46%description devel
47The popt-devel package includes header files and libraries necessary
48for developing programs which use the popt C library. It contains the
49API documentation of the popt library, too.
50
51
52%package static
53Summary: Static library for %{name}
54Summary(ja): %{name} のスタティックライブラリ
55Group: programming
56Requires: %{name} = %{version}-%{release}
57
58%description static
59The %{name}-static package contains the static library for %{name}.
60
61
62%package -n compat32-%{name}
63Summary: A C library for parsing command line parameters.
64Summary(ja): コマンドラインパラメータを文法解析するためのCライブラリ
65Group: system
66Requires: %{name} = %{version}-%{release}
67
68%description -n compat32-%{name}
69Popt is a C library for parsing command line parameters. Popt was
70heavily influenced by the getopt() and getopt_long() functions, but it
71improves on them by allowing more powerful argument expansion. Popt
72can parse arbitrary argv[] style arrays and automatically set
73variables based on command line arguments. Popt allows command line
74arguments to be aliased via configuration files and includes utility
75functions for parsing arbitrary strings into argv[] arrays using
76shell-like rules.
77
78%description -n compat32-%{name} -l ja
79Poptはコマンドパラメータを文法解析するためのCライブラリです。
80Poptは getopt()やgetopt_long()関数の影響を強く受けていますが、
81もっと強力な引数の拡張を施すことによって、それらをもっと進化
82させています。Poptは 任意の argv[]形式配列を解析して、コマンド
83ライン引数に基づいて変数を自動的に設定します。
84Poptは、コマンドライン引数を設定ファイルによってエイリアス化を
85許可したり、シェルライクな方針を用いた任意の文字列を文法解析し
86てargv[]配列に変換したりするユーティリティ関数を含んでいます。
87
88
89%package -n compat32-%{name}-devel
90Summary:        Development files for the popt library
91Summary(ja):    popt ライブラリの開発ファイル
92Group:          programming
93Requires:       compat32-%{name} = %{version}-%{release}
94Requires:       %{name}-devel = %{version}-%{release}
95
96%description -n compat32-%{name}-devel
97The popt-devel package includes header files and libraries necessary
98for developing programs which use the popt C library. It contains the
99API documentation of the popt library, too.
100
101
102%debug_package
103
104
105%prep
106%autosetup
107sed -i "s|libdir=@libdir@|libdir=@prefix@@libdir@|" popt.pc.in
108%ifarch x86_64
109#sed -i "s|/lib/pkgconfig|/lib64/pkgconfig|" Makefile.am
110#sed -i "s|/lib/pkgconfig|/lib64/pkgconfig|" Makefile.in
111%endif
112
113
114%build
115%configure --libdir=/%{_lib}
116make %{?_smp_mflags}
117
118
119%install
120rm -rf $RPM_BUILD_ROOT
121make DESTDIR=$RPM_BUILD_ROOT install
122
123# Move libpopt.{so,a} to %{_libdir}
124rm -f $RPM_BUILD_ROOT/%{_lib}/libpopt.{la,so}
125pushd $RPM_BUILD_ROOT/%{_lib}
126mkdir -p $RPM_BUILD_ROOT%{_libdir}
127ln -sf ../../%{_lib}/$(ls libpopt.so.?.?.?) $RPM_BUILD_ROOT%{_libdir}/libpopt.so
128popd
129mv -f $RPM_BUILD_ROOT/%{_lib}/libpopt.a $RPM_BUILD_ROOT%{_libdir}/libpopt.a
130
131mv -f $RPM_BUILD_ROOT/%{_lib}/pkgconfig $RPM_BUILD_ROOT%{_libdir}/
132
133# Multiple popt configurations are possible
134mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/popt.d
135
136%find_lang %{name}
137
138
139%check
140make check
141
142
143%clean
144rm -rf $RPM_BUILD_ROOT
145
146
147%post -p /sbin/ldconfig
148%postun -p /sbin/ldconfig
149
150%post -n compat32-%{name} -p /sbin/ldconfig
151%postun -n compat32-%{name} -p /sbin/ldconfig
152
153
154%files -f %{name}.lang
155%defattr(-,root,root)
156%license COPYING
157%doc CHANGES
158%{_sysconfdir}/popt.d
159/%{_lib}/libpopt.so.*
160
161%files devel
162%defattr(-,root,root)
163%doc README
164%{_libdir}/libpopt.so
165%{_libdir}/pkgconfig/popt.pc
166%{_includedir}/popt.h
167%{_mandir}/man3/popt.3*
168
169%files static
170%defattr(-,root,root)
171%{_libdir}/libpopt.a
172
173%if %{build_compat32}
174%files -n compat32-%{name}
175%defattr(-,root,root)
176/%{_lib}/libpopt.so.*
177
178%files -n compat32-%{name}-devel
179%defattr(-,root,root)
180%{_libdir}/libpopt.so
181%endif
182
183
184%changelog
185* Fri Feb 19 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.18-1
186- new upstream release.
187- dropped all patches.
188
189* Sun Sep 15 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.16-3
190- imported Patch0-5 from rawhide.
191
192* Wed Jan 15 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.16-2
193- rebuild with VineSeed environment
194
195* Sat Nov 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.16-1
196- update to 1.16
197- create %{name}-static sub package
198
199* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> - 1.14-5
200- rebuilt with rpm-4.8.1-3
201
202* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.14-4
203- rebuilt with new toolchain
204
205* Sun Jun 28 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.14-3
206- updated Requires: and %%files section on compat32 subpackages
207
208* Mon Jun 08 2009 Shu KONNO <owa@bg.wakwak.com> 1.14-2
209- added %%define build_compat32
210- fixed compat32 directories
211
212* Mon Aug 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.14-1
213- initial build for Vine Linux
214  - splitted out from rpm, based on rpm5.org source.
215- move libpopt to /lib[64] from /usr/lib[64]
216  - initscripts-8 uses libpopt.
217
218* Sun May 25 2008 Robert Scheck <robert@fedoraproject.org> 1.13-4
219- Solved multilib problems at doxygen generated files (#342921)
220
221* Wed Feb 20 2008 Robert Scheck <robert@fedoraproject.org> 1.13-3
222- Revert the broken bind_textdomain_codeset() patch (#433324)
223
224* Thu Feb 14 2008 Robert Scheck <robert@fedoraproject.org> 1.13-2
225- Added patch to work around missing bind_textdomain_codeset()
226
227* Sun Dec 30 2007 Robert Scheck <robert@fedoraproject.org> 1.13-1
228- Upgrade to 1.13 (#290531, #332201, #425803)
229- Solved multilib problems at doxygen generated files (#342921)
230
231* Thu Aug 23 2007 Robert Scheck <robert@fedoraproject.org> 1.12-3
232- Added buildrequirement to graphviz (#249352)
233- Backported bugfixes from CVS (#102254, #135428 and #178413)
234
235* Sun Aug 12 2007 Robert Scheck <robert@fedoraproject.org> 1.12-2
236- Move libpopt to /lib[64] (#249814)
237- Generate API documentation, added buildrequirement to doxygen
238
239* Mon Jul 23 2007 Robert Scheck <robert@fedoraproject.org> 1.12-1
240- Changes to match with Fedora Packaging Guidelines (#249352)
241
242* Tue Jul 10 2007 Jeff Johnson <jbj@rpm5.org>
243- release popt-1.12 through rpm5.org.
244
245* Sat Jun  9 2007 Jeff Johnson <jbj@rpm5.org>
246- release popt-1.11 through rpm5.org.
247
248* Thu Dec 10 1998 Michael Johnson <johnsonm@redhat.com>
249- released 1.2.2; see CHANGES
250
251* Tue Nov 17 1998 Michael K. Johnson <johnsonm@redhat.com>
252- added man page to default install
253
254* Thu Oct 22 1998 Erik Troan <ewt@redhat.com>
255- see CHANGES file for 1.2
256
257* Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
258- added ./configure step to spec file
Note: See TracBrowser for help on using the repository browser.