source: projects/specs/trunk/p/popt/popt-vl.spec @ 7064

Revision 7064, 8.0 KB checked in by Takemikaduchi, 12 years ago (diff)

new upstream release

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2Summary:        C library for parsing command line parameters
3Summary(ja):    コマンドラインパラメータを文法解析するためのCライブラリ
4Name:           popt
5Version:        1.16
6Release:        1%{?_dist_release}
7License:        MIT
8Group:          System Environment/Libraries
9URL:            http://www.rpm5.org/
10Source0:        http://www.rpm5.org/files/%{name}/%{name}-%{version}.tar.gz
11BuildRequires:  gettext, doxygen, graphviz
12BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
13
14%description
15Popt is a C library for parsing command line parameters. Popt was
16heavily influenced by the getopt() and getopt_long() functions, but
17it improves on them by allowing more powerful argument expansion.
18Popt can parse arbitrary argv[] style arrays and automatically set
19variables based on command line arguments. Popt allows command line
20arguments to be aliased via configuration files and includes utility
21functions for parsing arbitrary strings into argv[] arrays using
22shell-like rules.
23
24%description -l ja
25Poptはコマンドパラメータを文法解析するためのCライブラリです。
26Poptは getopt()やgetopt_long()関数の影響を強く受けていますが、
27もっと強力な引数の拡張を施すことによって、それらをもっと進化
28させています。Poptは 任意の argv[]形式配列を解析して、コマンド
29ライン引数に基づいて変数を自動的に設定します。
30Poptは、コマンドライン引数を設定ファイルによってエイリアス化を
31許可したり、シェルライクな方針を用いた任意の文字列を文法解析し
32てargv[]配列に変換したりするユーティリティ関数を含んでいます。
33
34
35%package devel
36Summary:        Development files for the popt library
37Summary(ja):    popt ライブラリの開発ファイル
38Group:          Development/Libraries
39Requires:       %{name} = %{version}-%{release}
40
41%description devel
42The popt-devel package includes header files and libraries necessary
43for developing programs which use the popt C library. It contains the
44API documentation of the popt library, too.
45
46
47%package static
48Summary: Static library for %{name}
49Summary(ja): %{name} のスタティックライブラリ
50Group: Development/Libraries
51Requires: %{name} = %{version}-%{release}
52
53%description static
54The %{name}-static package contains the static library for %{name}.
55
56
57%package -n compat32-%{name}
58Summary: A C library for parsing command line parameters.
59Summary(ja): コマンドラインパラメータを文法解析するためのCライブラリ
60Group: Development/Libraries
61Requires: %{name} = %{version}-%{release}
62
63%description -n compat32-%{name}
64Popt is a C library for parsing command line parameters. Popt was
65heavily influenced by the getopt() and getopt_long() functions, but it
66improves on them by allowing more powerful argument expansion. Popt
67can parse arbitrary argv[] style arrays and automatically set
68variables based on command line arguments. Popt allows command line
69arguments to be aliased via configuration files and includes utility
70functions for parsing arbitrary strings into argv[] arrays using
71shell-like rules.
72
73%description -n compat32-%{name} -l ja
74Poptはコマンドパラメータを文法解析するためのCライブラリです。
75Poptは getopt()やgetopt_long()関数の影響を強く受けていますが、
76もっと強力な引数の拡張を施すことによって、それらをもっと進化
77させています。Poptは 任意の argv[]形式配列を解析して、コマンド
78ライン引数に基づいて変数を自動的に設定します。
79Poptは、コマンドライン引数を設定ファイルによってエイリアス化を
80許可したり、シェルライクな方針を用いた任意の文字列を文法解析し
81てargv[]配列に変換したりするユーティリティ関数を含んでいます。
82
83%package -n compat32-%{name}-devel
84Summary:        Development files for the popt library
85Summary(ja):    popt ライブラリの開発ファイル
86Group:          Development/Libraries
87Requires:       compat32-%{name} = %{version}-%{release}
88Requires:       %{name}-devel = %{version}-%{release}
89
90%description -n compat32-%{name}-devel
91The popt-devel package includes header files and libraries necessary
92for developing programs which use the popt C library. It contains the
93API documentation of the popt library, too.
94
95%prep
96%setup -q
97sed -i "s|libdir=@libdir@|libdir=@prefix@@libdir@|" popt.pc.in
98%ifarch x86_64
99sed -i "s|/lib/pkgconfig|/lib64/pkgconfig|" Makefile.am
100sed -i "s|/lib/pkgconfig|/lib64/pkgconfig|" Makefile.in
101%endif
102
103%build
104%configure --libdir=/%{_lib}
105make %{?_smp_mflags}
106doxygen
107
108%install
109rm -rf $RPM_BUILD_ROOT
110make DESTDIR=$RPM_BUILD_ROOT install
111
112# Move libpopt.{so,a} to %{_libdir}
113rm -f $RPM_BUILD_ROOT/%{_lib}/libpopt.{la,so}
114pushd $RPM_BUILD_ROOT/%{_lib}
115mkdir -p $RPM_BUILD_ROOT%{_libdir}
116ln -sf ../../%{_lib}/$(ls libpopt.so.?.?.?) $RPM_BUILD_ROOT%{_libdir}/libpopt.so
117popd
118mv -f $RPM_BUILD_ROOT/%{_lib}/libpopt.a $RPM_BUILD_ROOT%{_libdir}/libpopt.a
119
120# Multiple popt configurations are possible
121mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/popt.d
122
123%find_lang %{name}
124
125%clean
126rm -rf $RPM_BUILD_ROOT
127
128%post -p /sbin/ldconfig
129
130%postun -p /sbin/ldconfig
131
132%post -n compat32-%{name} -p /sbin/ldconfig
133
134%postun -n compat32-%{name} -p /sbin/ldconfig
135
136%files -f %{name}.lang
137%defattr(-,root,root)
138%doc CHANGES COPYING
139%{_sysconfdir}/popt.d
140/%{_lib}/libpopt.so.*
141
142%files devel
143%defattr(-,root,root)
144%doc README doxygen/html
145%{_libdir}/libpopt.so
146%{_libdir}/pkgconfig/popt.pc
147%{_includedir}/popt.h
148%{_mandir}/man3/popt.3*
149
150%files static
151%defattr(-,root,root)
152%{_libdir}/libpopt.a
153
154%if %{build_compat32}
155%files -n compat32-%{name}
156%defattr(-,root,root)
157/%{_lib}/libpopt.so.*
158
159%files -n compat32-%{name}-devel
160%defattr(-,root,root)
161%{_libdir}/libpopt.so
162%endif
163
164
165%changelog
166* Sat Nov 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.16-1
167- update to 1.16
168- create %{name}-static sub package
169
170* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> - 1.14-5
171- rebuilt with rpm-4.8.1-3
172
173* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.14-4
174- rebuilt with new toolchain
175
176* Sun Jun 28 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.14-3
177- updated Requires: and %%files section on compat32 subpackages
178
179* Mon Jun 08 2009 Shu KONNO <owa@bg.wakwak.com> 1.14-2
180- added %%define build_compat32
181- fixed compat32 directories
182
183* Mon Aug 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.14-1
184- initial build for Vine Linux
185  - splitted out from rpm, based on rpm5.org source.
186- move libpopt to /lib[64] from /usr/lib[64]
187  - initscripts-8 uses libpopt.
188
189* Sun May 25 2008 Robert Scheck <robert@fedoraproject.org> 1.13-4
190- Solved multilib problems at doxygen generated files (#342921)
191
192* Wed Feb 20 2008 Robert Scheck <robert@fedoraproject.org> 1.13-3
193- Revert the broken bind_textdomain_codeset() patch (#433324)
194
195* Thu Feb 14 2008 Robert Scheck <robert@fedoraproject.org> 1.13-2
196- Added patch to work around missing bind_textdomain_codeset()
197
198* Sun Dec 30 2007 Robert Scheck <robert@fedoraproject.org> 1.13-1
199- Upgrade to 1.13 (#290531, #332201, #425803)
200- Solved multilib problems at doxygen generated files (#342921)
201
202* Thu Aug 23 2007 Robert Scheck <robert@fedoraproject.org> 1.12-3
203- Added buildrequirement to graphviz (#249352)
204- Backported bugfixes from CVS (#102254, #135428 and #178413)
205
206* Sun Aug 12 2007 Robert Scheck <robert@fedoraproject.org> 1.12-2
207- Move libpopt to /lib[64] (#249814)
208- Generate API documentation, added buildrequirement to doxygen
209
210* Mon Jul 23 2007 Robert Scheck <robert@fedoraproject.org> 1.12-1
211- Changes to match with Fedora Packaging Guidelines (#249352)
212
213* Tue Jul 10 2007 Jeff Johnson <jbj@rpm5.org>
214- release popt-1.12 through rpm5.org.
215
216* Sat Jun  9 2007 Jeff Johnson <jbj@rpm5.org>
217- release popt-1.11 through rpm5.org.
218
219* Thu Dec 10 1998 Michael Johnson <johnsonm@redhat.com>
220- released 1.2.2; see CHANGES
221
222* Tue Nov 17 1998 Michael K. Johnson <johnsonm@redhat.com>
223- added man page to default install
224
225* Thu Oct 22 1998 Erik Troan <ewt@redhat.com>
226- see CHANGES file for 1.2
227
228* Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
229- added ./configure step to spec file
Note: See TracBrowser for help on using the repository browser.