source: projects/specs/trunk/p/pkgconfig/pkgconfig-vl.spec @ 8191

Revision 8191, 5.8 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release or rebuild

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: A tool for determining compilation options.
4Summary(ja): コンパイルオプションを決定するためのツール
5Name: pkgconfig
6Version: 0.28
7Release: 2%{?_dist_release}
8Epoch: 1
9
10Group: Development/Tools
11License: GPLv2
12Source: http://pkgconfig.freedesktop.org/releases/pkg-config-%{version}.tar.gz
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15BuildRequires: glib2-devel
16BuildRequires: popt-devel
17
18Vendor: Project Vine
19Distribution: Vine Linux
20
21%description
22The pkgconfig tool determines compilation options. For each required
23library, it reads the configuration file and outputs the necessary
24compiler and linker flags.
25
26%description -l ja
27pkgconfigは、コンパイルオプションを決定するツールです。それぞれ必
28要なライブラリ向けにその設定ファイルを読み込み、必要なコンパイラ
29フラグとリンカフラグを出力します。
30
31
32## to build compat32 for x86_64 architecture support
33%package -n compat32-%{name}
34Summary: A tool for determining compilation options.
35Summary(ja): コンパイルオプションを決定するためのツール
36Group: Development/Tools
37
38%description -n compat32-%{name}
39The pkgconfig tool determines compilation options. For each required
40library, it reads the configuration file and outputs the necessary
41compiler and linker flags.
42
43
44%prep
45%setup -q -n pkg-config-%{version}
46
47%build
48%configure \
49    --with-installed-glib \
50    --with-installed-popt
51
52make
53
54%install
55rm -rf $RPM_BUILD_ROOT
56%makeinstall
57
58mkdir -p $RPM_BUILD_ROOT%{_libdir}/pkgconfig
59mkdir -p $RPM_BUILD_ROOT%{_datadir}/pkgconfig
60#strip $RPM_BUILD_ROOT%{_bindir}/*
61
62rm -rf $RPM_BUILD_ROOT%{_docdir}/pkg-config
63
64%if %{build_compat32}
65%__cp -a %{buildroot}%{_bindir}/pkg-config %{buildroot}%{_bindir}/pkg-config-32
66%endif
67
68%clean
69rm -rf $RPM_BUILD_ROOT
70
71%files
72%defattr(-,root,root)
73%doc AUTHORS COPYING ChangeLog NEWS README pkg-config-guide.html
74%{_bindir}/pkg-config
75%{_bindir}/%{_target_cpu}-%{_vendor}-%{_target_os}%{_gnu}-pkg-config
76%dir %{_libdir}/pkgconfig
77%dir %{_datadir}/pkgconfig
78%{_datadir}/aclocal/*.m4
79%{_mandir}/*/*
80
81%if %{build_compat32}
82%files -n compat32-%{name}
83%defattr(-,root,root)
84%{_bindir}/pkg-config-32
85%dir %{_libdir}/pkgconfig
86%endif
87
88
89%changelog
90* Wed Jan 15 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:0.28-2
91- new upstream release
92
93* Sun Mar 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:0.28-1
94- new upstream release
95
96* Sat Nov 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:0.27-1
97- new upstream release
98
99* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 1:0.25-2
100- rebuilt with rpm-4.8.1-3
101
102* Thu Sep 16 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:0.25-1
103- new upstream release
104- added BR: glib2-devel, popt-devel to build with installed libraries
105
106* Mon Jul 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:0.23-5
107- rebuild to fix the package built with broken environment.
108
109* Sun Jul 05 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1:0.23-4
110- corrected to copy pkg-config to pkg-config-32 for %%if %%{build_compat32} case
111
112* Sun Jul 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:0.23-3
113- removed %%if !%%{build_compat32} case condition
114
115* Mon Apr 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:0.23-2
116- spec in utf-8
117
118* Fri May 16 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:0.23-1
119- applied new versioning policy
120
121* Wed Mar  5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:0.23-0vl1
122- new upstream release
123
124* Sun Aug 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:0.22-0vl1
125- new upstream release
126
127* Fri Aug 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1:0.20-0vl3
128- fix compat32 package
129  - rename %%{_bindir}/pkg-config to %%{_bindir}/pkg-config-32
130  - add %%{_bindir}/pkg-config-32
131- not srtip at %%install, it should be done by %__install_spec_post
132
133* Tue Feb 28 2006 Shu KONNO <owa@bg.wakwak.com>
134- added compat32-* packages for x86_64 architecture support
135
136* Wed Nov 16 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:0.20-0vl1
137- new upstream release
138
139* Wed Aug 17 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:0.19-0vl1
140- new upstream release
141
142* Sun Apr 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:0.17.2-0vl1
143- new upstream release
144- added Japanese description (from vinedocs.sourceforge.jp)
145
146* Thu Jun 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1:0.15.0-0vl2
147- add Epoch: 1 to be able to upgrade from VinePlus package.
148
149* Thu Jan 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.15.0-0vl1
150- new upstream release
151
152* Thu Dec 12 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.14.0-1vl1
153- rebuild for Vine Linux
154
155* Fri Nov  8 2002 Havoc Pennington <hp@redhat.com>
156- 0.14
157
158* Tue Oct  8 2002 Havoc Pennington <hp@redhat.com>
159- use libdir, so we do move .pc files to /usr/lib64
160
161* Tue Oct  8 2002 Havoc Pennington <hp@redhat.com>
162- use prefix/lib not libdir, so we don't move .pc files to /usr/lib64
163
164* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
165- automated rebuild
166
167* Thu May 23 2002 Tim Powers <timp@redhat.com>
168- automated rebuild
169
170* Thu Mar  7 2002 Havoc Pennington <hp@redhat.com>
171- 0.12.0
172
173* Thu Feb  7 2002 Havoc Pennington <hp@redhat.com>
174- 0.11.0
175
176* Sun Feb  3 2002 Havoc Pennington <hp@redhat.com>
177- backbuild in gnomehide
178
179* Sun Feb  3 2002 Havoc Pennington <hp@redhat.com>
180- 0.10.0
181
182* Sun Feb  3 2002 Havoc Pennington <hp@redhat.com>
183- 0.9.0
184
185* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
186- automated rebuild
187
188* Wed Jun 13 2001 Florian La Roche <Florian.LaRoche@redhat.de>
189- call libtoolize to make porting to new archs easier
190
191* Thu Jun 07 2001 Havoc Pennington <hp@redhat.com>
192- put pkg.m4 in file list
193
194* Wed Jun 06 2001 Havoc Pennington <hp@redhat.com>
195- Upgrade to 0.7
196- add man page
197
198* Wed Jan 03 2001 Havoc Pennington <hp@redhat.com>
199- Upgrade to 0.5
200
201* Thu Dec 14 2000 Bill Nottingham <notting@redhat.com>
202- rebuild because of broken fileutils
203
204* Wed Oct 04 2000 Owen Taylor <otaylor@redhat.com>
205- Initial package
Note: See TracBrowser for help on using the repository browser.