source: projects/specs/trunk/p/pkgconfig/pkgconfig-vl.spec @ 7583

Revision 7583, 5.6 KB checked in by Takemikaduchi, 11 years ago (diff)

new upstream release

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: A tool for determining compilation options.
4Summary(ja): コンパイルオプションを決定するためのツール
5Name: pkgconfig
6Version: 0.28
7Release: 1%{?_dist_release}
8Epoch: 1
9
10Group: Development/Tools
11License: GPLv2
12Source: http://pkgconfig.freedesktop.org/releases/pkg-config-%{version}.tar.gz
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15BuildRequires: glib2-devel
16BuildRequires: popt-devel
17
18%description
19The pkgconfig tool determines compilation options. For each required
20library, it reads the configuration file and outputs the necessary
21compiler and linker flags.
22
23%description -l ja
24pkgconfigは、コンパイルオプションを決定するツールです。それぞれ必
25要なライブラリ向けにその設定ファイルを読み込み、必要なコンパイラ
26フラグとリンカフラグを出力します。
27
28
29## to build compat32 for x86_64 architecture support
30%package -n compat32-%{name}
31Summary: A tool for determining compilation options.
32Summary(ja): コンパイルオプションを決定するためのツール
33Group: Development/Tools
34
35%description -n compat32-%{name}
36The pkgconfig tool determines compilation options. For each required
37library, it reads the configuration file and outputs the necessary
38compiler and linker flags.
39
40
41%prep
42%setup -q -n pkg-config-%{version}
43
44%build
45%configure \
46    --with-installed-glib \
47    --with-installed-popt
48
49make
50
51%install
52rm -rf $RPM_BUILD_ROOT
53%makeinstall
54
55mkdir -p $RPM_BUILD_ROOT%{_libdir}/pkgconfig
56mkdir -p $RPM_BUILD_ROOT%{_datadir}/pkgconfig
57#strip $RPM_BUILD_ROOT%{_bindir}/*
58
59rm -rf $RPM_BUILD_ROOT%{_docdir}/pkg-config
60
61%if %{build_compat32}
62%__cp -a %{buildroot}%{_bindir}/pkg-config %{buildroot}%{_bindir}/pkg-config-32
63%endif
64
65%clean
66rm -rf $RPM_BUILD_ROOT
67
68%files
69%defattr(-,root,root)
70%doc AUTHORS COPYING ChangeLog NEWS README pkg-config-guide.html
71%{_bindir}/pkg-config
72%{_bindir}/%{_target_cpu}-%{_vendor}-%{_target_os}%{_gnu}-pkg-config
73%dir %{_libdir}/pkgconfig
74%dir %{_datadir}/pkgconfig
75%{_datadir}/aclocal/*.m4
76%{_mandir}/*/*
77
78%if %{build_compat32}
79%files -n compat32-%{name}
80%defattr(-,root,root)
81%{_bindir}/pkg-config-32
82%dir %{_libdir}/pkgconfig
83%endif
84
85
86%changelog
87* Sun Mar 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:0.28-1
88- new upstream release
89
90* Sat Nov 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:0.27-1
91- new upstream release
92
93* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 1:0.25-2
94- rebuilt with rpm-4.8.1-3
95
96* Thu Sep 16 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:0.25-1
97- new upstream release
98- added BR: glib2-devel, popt-devel to build with installed libraries
99
100* Mon Jul 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:0.23-5
101- rebuild to fix the package built with broken environment.
102
103* Sun Jul 05 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1:0.23-4
104- corrected to copy pkg-config to pkg-config-32 for %%if %%{build_compat32} case
105
106* Sun Jul 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:0.23-3
107- removed %%if !%%{build_compat32} case condition
108
109* Mon Apr 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:0.23-2
110- spec in utf-8
111
112* Fri May 16 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:0.23-1
113- applied new versioning policy
114
115* Wed Mar  5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:0.23-0vl1
116- new upstream release
117
118* Sun Aug 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:0.22-0vl1
119- new upstream release
120
121* Fri Aug 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1:0.20-0vl3
122- fix compat32 package
123  - rename %%{_bindir}/pkg-config to %%{_bindir}/pkg-config-32
124  - add %%{_bindir}/pkg-config-32
125- not srtip at %%install, it should be done by %__install_spec_post
126
127* Tue Feb 28 2006 Shu KONNO <owa@bg.wakwak.com>
128- added compat32-* packages for x86_64 architecture support
129
130* Wed Nov 16 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:0.20-0vl1
131- new upstream release
132
133* Wed Aug 17 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:0.19-0vl1
134- new upstream release
135
136* Sun Apr 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:0.17.2-0vl1
137- new upstream release
138- added Japanese description (from vinedocs.sourceforge.jp)
139
140* Thu Jun 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1:0.15.0-0vl2
141- add Epoch: 1 to be able to upgrade from VinePlus package.
142
143* Thu Jan 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.15.0-0vl1
144- new upstream release
145
146* Thu Dec 12 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.14.0-1vl1
147- rebuild for Vine Linux
148
149* Fri Nov  8 2002 Havoc Pennington <hp@redhat.com>
150- 0.14
151
152* Tue Oct  8 2002 Havoc Pennington <hp@redhat.com>
153- use libdir, so we do move .pc files to /usr/lib64
154
155* Tue Oct  8 2002 Havoc Pennington <hp@redhat.com>
156- use prefix/lib not libdir, so we don't move .pc files to /usr/lib64
157
158* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
159- automated rebuild
160
161* Thu May 23 2002 Tim Powers <timp@redhat.com>
162- automated rebuild
163
164* Thu Mar  7 2002 Havoc Pennington <hp@redhat.com>
165- 0.12.0
166
167* Thu Feb  7 2002 Havoc Pennington <hp@redhat.com>
168- 0.11.0
169
170* Sun Feb  3 2002 Havoc Pennington <hp@redhat.com>
171- backbuild in gnomehide
172
173* Sun Feb  3 2002 Havoc Pennington <hp@redhat.com>
174- 0.10.0
175
176* Sun Feb  3 2002 Havoc Pennington <hp@redhat.com>
177- 0.9.0
178
179* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
180- automated rebuild
181
182* Wed Jun 13 2001 Florian La Roche <Florian.LaRoche@redhat.de>
183- call libtoolize to make porting to new archs easier
184
185* Thu Jun 07 2001 Havoc Pennington <hp@redhat.com>
186- put pkg.m4 in file list
187
188* Wed Jun 06 2001 Havoc Pennington <hp@redhat.com>
189- Upgrade to 0.7
190- add man page
191
192* Wed Jan 03 2001 Havoc Pennington <hp@redhat.com>
193- Upgrade to 0.5
194
195* Thu Dec 14 2000 Bill Nottingham <notting@redhat.com>
196- rebuild because of broken fileutils
197
198* Wed Oct 04 2000 Owen Taylor <otaylor@redhat.com>
199- Initial package
Note: See TracBrowser for help on using the repository browser.