source: projects/specs/trunk/p/pkgconfig/pkgconfig-vl.spec @ 12337

Revision 12337, 6.0 KB checked in by tomop, 4 years ago (diff)

updated 9 packages

bzip2-1.0.8-1

coreutils-8.32-1

dconf-0.36.0-1

gnome-calculator-3.30.1-1

gtksourceview3-3.24.11-1

libbytesize-2.2-1

libcroco-0.6.13-1

pkgconfig-0.29.2-1

which-2.21-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: A tool for determining compilation options.
4Summary(ja): コンパイルオプションを決定するためのツール
5Name: pkgconfig
6Version: 0.29.2
7Release: 1%{?_dist_release}
8Epoch: 1
9
10Group: Development/Tools
11License: GPLv2
12URL: https://www.freedesktop.org/wiki/Software/pkg-config/
13Source: https://pkg-config.freedesktop.org/releases/pkg-config-%{version}.tar.gz
14
15BuildRoot: %{_tmppath}/%{name}-%{version}-root
16BuildRequires: glib2-devel
17BuildRequires: popt-devel
18
19Vendor: Project Vine
20Distribution: Vine Linux
21
22%description
23The pkgconfig tool determines compilation options. For each required
24library, it reads the configuration file and outputs the necessary
25compiler and linker flags.
26
27%description -l ja
28pkgconfigは、コンパイルオプションを決定するツールです。それぞれ必
29要なライブラリ向けにその設定ファイルを読み込み、必要なコンパイラ
30フラグとリンカフラグを出力します。
31
32
33## to build compat32 for x86_64 architecture support
34%package -n compat32-%{name}
35Summary: A tool for determining compilation options.
36Summary(ja): コンパイルオプションを決定するためのツール
37Group: Development/Tools
38
39%description -n compat32-%{name}
40The pkgconfig tool determines compilation options. For each required
41library, it reads the configuration file and outputs the necessary
42compiler and linker flags.
43
44
45%prep
46%setup -q -n pkg-config-%{version}
47
48%build
49%configure \
50    --with-installed-glib \
51    --with-installed-popt
52
53make
54
55%install
56rm -rf $RPM_BUILD_ROOT
57%makeinstall
58
59mkdir -p $RPM_BUILD_ROOT%{_libdir}/pkgconfig
60mkdir -p $RPM_BUILD_ROOT%{_datadir}/pkgconfig
61#strip $RPM_BUILD_ROOT%{_bindir}/*
62
63rm -rf $RPM_BUILD_ROOT%{_docdir}/pkg-config
64
65%if %{build_compat32}
66%__cp -a %{buildroot}%{_bindir}/pkg-config %{buildroot}%{_bindir}/pkg-config-32
67%endif
68
69%clean
70rm -rf $RPM_BUILD_ROOT
71
72%files
73%defattr(-,root,root)
74%license COPYING
75%doc AUTHORS ChangeLog NEWS README pkg-config-guide.html
76%{_bindir}/pkg-config
77%{_bindir}/%{_target_cpu}-%{_vendor}-%{_target_os}%{_gnu}-pkg-config
78%dir %{_libdir}/pkgconfig
79%dir %{_datadir}/pkgconfig
80%{_datadir}/aclocal/*.m4
81%{_mandir}/*/*
82
83%if %{build_compat32}
84%files -n compat32-%{name}
85%defattr(-,root,root)
86%{_bindir}/pkg-config-32
87%dir %{_libdir}/pkgconfig
88%endif
89
90
91%changelog
92* Wed Mar 18 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1:0.29.2-1
93- new upstream release.
94
95* Sun Apr 24 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:0.29.1-1
96- new upstream release
97
98* Sat Oct 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:0.29-1
99- new upstream release
100
101* Sun Mar 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:0.28-1
102- new upstream release
103
104* Sat Nov 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:0.27-1
105- new upstream release
106
107* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 1:0.25-2
108- rebuilt with rpm-4.8.1-3
109
110* Thu Sep 16 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:0.25-1
111- new upstream release
112- added BR: glib2-devel, popt-devel to build with installed libraries
113
114* Mon Jul 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:0.23-5
115- rebuild to fix the package built with broken environment.
116
117* Sun Jul 05 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1:0.23-4
118- corrected to copy pkg-config to pkg-config-32 for %%if %%{build_compat32} case
119
120* Sun Jul 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:0.23-3
121- removed %%if !%%{build_compat32} case condition
122
123* Mon Apr 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:0.23-2
124- spec in utf-8
125
126* Fri May 16 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:0.23-1
127- applied new versioning policy
128
129* Wed Mar  5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:0.23-0vl1
130- new upstream release
131
132* Sun Aug 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:0.22-0vl1
133- new upstream release
134
135* Fri Aug 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1:0.20-0vl3
136- fix compat32 package
137  - rename %%{_bindir}/pkg-config to %%{_bindir}/pkg-config-32
138  - add %%{_bindir}/pkg-config-32
139- not srtip at %%install, it should be done by %__install_spec_post
140
141* Tue Feb 28 2006 Shu KONNO <owa@bg.wakwak.com>
142- added compat32-* packages for x86_64 architecture support
143
144* Wed Nov 16 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:0.20-0vl1
145- new upstream release
146
147* Wed Aug 17 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:0.19-0vl1
148- new upstream release
149
150* Sun Apr 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:0.17.2-0vl1
151- new upstream release
152- added Japanese description (from vinedocs.sourceforge.jp)
153
154* Thu Jun 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1:0.15.0-0vl2
155- add Epoch: 1 to be able to upgrade from VinePlus package.
156
157* Thu Jan 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.15.0-0vl1
158- new upstream release
159
160* Thu Dec 12 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.14.0-1vl1
161- rebuild for Vine Linux
162
163* Fri Nov  8 2002 Havoc Pennington <hp@redhat.com>
164- 0.14
165
166* Tue Oct  8 2002 Havoc Pennington <hp@redhat.com>
167- use libdir, so we do move .pc files to /usr/lib64
168
169* Tue Oct  8 2002 Havoc Pennington <hp@redhat.com>
170- use prefix/lib not libdir, so we don't move .pc files to /usr/lib64
171
172* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
173- automated rebuild
174
175* Thu May 23 2002 Tim Powers <timp@redhat.com>
176- automated rebuild
177
178* Thu Mar  7 2002 Havoc Pennington <hp@redhat.com>
179- 0.12.0
180
181* Thu Feb  7 2002 Havoc Pennington <hp@redhat.com>
182- 0.11.0
183
184* Sun Feb  3 2002 Havoc Pennington <hp@redhat.com>
185- backbuild in gnomehide
186
187* Sun Feb  3 2002 Havoc Pennington <hp@redhat.com>
188- 0.10.0
189
190* Sun Feb  3 2002 Havoc Pennington <hp@redhat.com>
191- 0.9.0
192
193* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
194- automated rebuild
195
196* Wed Jun 13 2001 Florian La Roche <Florian.LaRoche@redhat.de>
197- call libtoolize to make porting to new archs easier
198
199* Thu Jun 07 2001 Havoc Pennington <hp@redhat.com>
200- put pkg.m4 in file list
201
202* Wed Jun 06 2001 Havoc Pennington <hp@redhat.com>
203- Upgrade to 0.7
204- add man page
205
206* Wed Jan 03 2001 Havoc Pennington <hp@redhat.com>
207- Upgrade to 0.5
208
209* Thu Dec 14 2000 Bill Nottingham <notting@redhat.com>
210- rebuild because of broken fileutils
211
212* Wed Oct 04 2000 Owen Taylor <otaylor@redhat.com>
213- Initial package
Note: See TracBrowser for help on using the repository browser.