source: projects/specs/trunk/p/pkgconfig/pkgconfig-vl.spec @ 521

Revision 521, 4.8 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: A tool for determining compilation options.
4Summary(ja): コンパイルオプションを決定するためのツール
5Name: pkgconfig
6Version: 0.23
7Release: 5%{?_dist_release}
8Epoch: 1
9License: GPL
10Group: Development/Tools
11Source: http://pkgconfig.freedesktop.org/releases/pkg-config-%{version}.tar.gz
12BuildRoot: %{_tmppath}/%{name}-%{version}-root
13
14%description
15The pkgconfig tool determines compilation options. For each required
16library, it reads the configuration file and outputs the necessary
17compiler and linker flags.
18
19%description -l ja
20pkgconfigは、コンパイルオプションを決定するツールです。それぞれ必
21要なライブラリ向けにその設定ファイルを読み込み、必要なコンパイラ
22フラグとリンカフラグを出力します。
23
24
25## to build compat32 for x86_64 architecture support
26%package -n compat32-%{name}
27Summary: A tool for determining compilation options.
28Group: Development/Tools
29
30%description -n compat32-%{name}
31The pkgconfig tool determines compilation options. For each required
32library, it reads the configuration file and outputs the necessary
33compiler and linker flags.
34
35
36%prep
37%setup -q -n pkg-config-%{version}
38
39%build
40%configure
41make
42
43%install
44rm -rf $RPM_BUILD_ROOT
45%makeinstall
46mkdir -p $RPM_BUILD_ROOT%{_libdir}/pkgconfig
47#strip $RPM_BUILD_ROOT%{_bindir}/*
48
49%if %{build_compat32}
50%__cp -a %{buildroot}%{_bindir}/pkg-config %{buildroot}%{_bindir}/pkg-config-32
51%endif
52
53%clean
54rm -rf $RPM_BUILD_ROOT
55
56%files
57%defattr(-,root,root)
58%doc AUTHORS COPYING ChangeLog NEWS README
59%{_bindir}/pkg-config
60%dir %{_libdir}/pkgconfig
61%{_datadir}/aclocal/*.m4
62%{_mandir}/*/*
63
64%if %{build_compat32}
65%files -n compat32-%{name}
66%defattr(-,root,root)
67%{_bindir}/pkg-config-32
68%dir %{_libdir}/pkgconfig
69%endif
70
71
72%changelog
73* Mon Jul 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:0.23-5
74- rebuild to fix the package built with broken environment.
75
76* Sun Jul 05 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1:0.23-4
77- corrected to copy pkg-config to pkg-config-32 for %%if %%{build_compat32} case
78
79* Sun Jul 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:0.23-3
80- removed %%if !%%{build_compat32} case condition
81
82* Mon Apr 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:0.23-2
83- spec in utf-8
84
85* Fri May 16 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:0.23-1
86- applied new versioning policy
87
88* Wed Mar  5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:0.23-0vl1
89- new upstream release
90
91* Sun Aug 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:0.22-0vl1
92- new upstream release
93
94* Fri Aug 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1:0.20-0vl3
95- fix compat32 package
96  - rename %%{_bindir}/pkg-config to %%{_bindir}/pkg-config-32
97  - add %%{_bindir}/pkg-config-32
98- not srtip at %%install, it should be done by %__install_spec_post
99
100* Tue Feb 28 2006 Shu KONNO <owa@bg.wakwak.com>
101- added compat32-* packages for x86_64 architecture support
102
103* Wed Nov 16 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:0.20-0vl1
104- new upstream release
105
106* Wed Aug 17 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:0.19-0vl1
107- new upstream release
108
109* Sun Apr 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:0.17.2-0vl1
110- new upstream release
111- added Japanese description (from vinedocs.sourceforge.jp)
112
113* Thu Jun 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1:0.15.0-0vl2
114- add Epoch: 1 to be able to upgrade from VinePlus package.
115
116* Thu Jan 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.15.0-0vl1
117- new upstream release
118
119* Thu Dec 12 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.14.0-1vl1
120- rebuild for Vine Linux
121
122* Fri Nov  8 2002 Havoc Pennington <hp@redhat.com>
123- 0.14
124
125* Tue Oct  8 2002 Havoc Pennington <hp@redhat.com>
126- use libdir, so we do move .pc files to /usr/lib64
127
128* Tue Oct  8 2002 Havoc Pennington <hp@redhat.com>
129- use prefix/lib not libdir, so we don't move .pc files to /usr/lib64
130
131* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
132- automated rebuild
133
134* Thu May 23 2002 Tim Powers <timp@redhat.com>
135- automated rebuild
136
137* Thu Mar  7 2002 Havoc Pennington <hp@redhat.com>
138- 0.12.0
139
140* Thu Feb  7 2002 Havoc Pennington <hp@redhat.com>
141- 0.11.0
142
143* Sun Feb  3 2002 Havoc Pennington <hp@redhat.com>
144- backbuild in gnomehide
145
146* Sun Feb  3 2002 Havoc Pennington <hp@redhat.com>
147- 0.10.0
148
149* Sun Feb  3 2002 Havoc Pennington <hp@redhat.com>
150- 0.9.0
151
152* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
153- automated rebuild
154
155* Wed Jun 13 2001 Florian La Roche <Florian.LaRoche@redhat.de>
156- call libtoolize to make porting to new archs easier
157
158* Thu Jun 07 2001 Havoc Pennington <hp@redhat.com>
159- put pkg.m4 in file list
160
161* Wed Jun 06 2001 Havoc Pennington <hp@redhat.com>
162- Upgrade to 0.7
163- add man page
164
165* Wed Jan 03 2001 Havoc Pennington <hp@redhat.com>
166- Upgrade to 0.5
167
168* Thu Dec 14 2000 Bill Nottingham <notting@redhat.com>
169- rebuild because of broken fileutils
170
171* Wed Oct 04 2000 Owen Taylor <otaylor@redhat.com>
172- Initial package
Note: See TracBrowser for help on using the repository browser.