source: projects/specs/trunk/p/pkgconfig/pkgconfig-vl.spec @ 1813

Revision 1813, 5.3 KB checked in by inagaki, 14 years ago (diff)

updated: desktop-file-utils, pkgconfig

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: A tool for determining compilation options.
4Summary(ja): コンパイルオプションを決定するためのツール
5Name: pkgconfig
6Version: 0.25
7Release: 1%{?_dist_release}
8Epoch: 1
9
10Group: Development/Tools
11License: GPLv2
12Source: http://pkgconfig.freedesktop.org/releases/pkg-config-%{version}.tar.gz
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15BuildRequires: glib2-devel
16BuildRequires: popt-devel
17
18%description
19The pkgconfig tool determines compilation options. For each required
20library, it reads the configuration file and outputs the necessary
21compiler and linker flags.
22
23%description -l ja
24pkgconfigは、コンパイルオプションを決定するツールです。それぞれ必
25要なライブラリ向けにその設定ファイルを読み込み、必要なコンパイラ
26フラグとリンカフラグを出力します。
27
28
29## to build compat32 for x86_64 architecture support
30%package -n compat32-%{name}
31Summary: A tool for determining compilation options.
32Summary(ja): コンパイルオプションを決定するためのツール
33Group: Development/Tools
34
35%description -n compat32-%{name}
36The pkgconfig tool determines compilation options. For each required
37library, it reads the configuration file and outputs the necessary
38compiler and linker flags.
39
40
41%prep
42%setup -q -n pkg-config-%{version}
43
44%build
45%configure \
46    --with-installed-glib \
47    --with-installed-popt
48
49make
50
51%install
52rm -rf $RPM_BUILD_ROOT
53%makeinstall
54
55mkdir -p $RPM_BUILD_ROOT%{_libdir}/pkgconfig
56mkdir -p $RPM_BUILD_ROOT%{_datadir}/pkgconfig
57#strip $RPM_BUILD_ROOT%{_bindir}/*
58
59rm -rf $RPM_BUILD_ROOT%{_docdir}/pkg-config
60
61%if %{build_compat32}
62%__cp -a %{buildroot}%{_bindir}/pkg-config %{buildroot}%{_bindir}/pkg-config-32
63%endif
64
65%clean
66rm -rf $RPM_BUILD_ROOT
67
68%files
69%defattr(-,root,root)
70%doc AUTHORS COPYING ChangeLog NEWS README pkg-config-guide.html
71%{_bindir}/pkg-config
72%dir %{_libdir}/pkgconfig
73%dir %{_datadir}/pkgconfig
74%{_datadir}/aclocal/*.m4
75%{_mandir}/*/*
76
77%if %{build_compat32}
78%files -n compat32-%{name}
79%defattr(-,root,root)
80%{_bindir}/pkg-config-32
81%dir %{_libdir}/pkgconfig
82%endif
83
84
85%changelog
86* Thu Sep 16 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:0.25-1
87- new upstream release
88- added BR: glib2-devel, popt-devel to build with installed libraries
89
90* Mon Jul 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:0.23-5
91- rebuild to fix the package built with broken environment.
92
93* Sun Jul 05 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1:0.23-4
94- corrected to copy pkg-config to pkg-config-32 for %%if %%{build_compat32} case
95
96* Sun Jul 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:0.23-3
97- removed %%if !%%{build_compat32} case condition
98
99* Mon Apr 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:0.23-2
100- spec in utf-8
101
102* Fri May 16 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:0.23-1
103- applied new versioning policy
104
105* Wed Mar  5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:0.23-0vl1
106- new upstream release
107
108* Sun Aug 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:0.22-0vl1
109- new upstream release
110
111* Fri Aug 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1:0.20-0vl3
112- fix compat32 package
113  - rename %%{_bindir}/pkg-config to %%{_bindir}/pkg-config-32
114  - add %%{_bindir}/pkg-config-32
115- not srtip at %%install, it should be done by %__install_spec_post
116
117* Tue Feb 28 2006 Shu KONNO <owa@bg.wakwak.com>
118- added compat32-* packages for x86_64 architecture support
119
120* Wed Nov 16 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:0.20-0vl1
121- new upstream release
122
123* Wed Aug 17 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:0.19-0vl1
124- new upstream release
125
126* Sun Apr 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:0.17.2-0vl1
127- new upstream release
128- added Japanese description (from vinedocs.sourceforge.jp)
129
130* Thu Jun 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1:0.15.0-0vl2
131- add Epoch: 1 to be able to upgrade from VinePlus package.
132
133* Thu Jan 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.15.0-0vl1
134- new upstream release
135
136* Thu Dec 12 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.14.0-1vl1
137- rebuild for Vine Linux
138
139* Fri Nov  8 2002 Havoc Pennington <hp@redhat.com>
140- 0.14
141
142* Tue Oct  8 2002 Havoc Pennington <hp@redhat.com>
143- use libdir, so we do move .pc files to /usr/lib64
144
145* Tue Oct  8 2002 Havoc Pennington <hp@redhat.com>
146- use prefix/lib not libdir, so we don't move .pc files to /usr/lib64
147
148* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
149- automated rebuild
150
151* Thu May 23 2002 Tim Powers <timp@redhat.com>
152- automated rebuild
153
154* Thu Mar  7 2002 Havoc Pennington <hp@redhat.com>
155- 0.12.0
156
157* Thu Feb  7 2002 Havoc Pennington <hp@redhat.com>
158- 0.11.0
159
160* Sun Feb  3 2002 Havoc Pennington <hp@redhat.com>
161- backbuild in gnomehide
162
163* Sun Feb  3 2002 Havoc Pennington <hp@redhat.com>
164- 0.10.0
165
166* Sun Feb  3 2002 Havoc Pennington <hp@redhat.com>
167- 0.9.0
168
169* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
170- automated rebuild
171
172* Wed Jun 13 2001 Florian La Roche <Florian.LaRoche@redhat.de>
173- call libtoolize to make porting to new archs easier
174
175* Thu Jun 07 2001 Havoc Pennington <hp@redhat.com>
176- put pkg.m4 in file list
177
178* Wed Jun 06 2001 Havoc Pennington <hp@redhat.com>
179- Upgrade to 0.7
180- add man page
181
182* Wed Jan 03 2001 Havoc Pennington <hp@redhat.com>
183- Upgrade to 0.5
184
185* Thu Dec 14 2000 Bill Nottingham <notting@redhat.com>
186- rebuild because of broken fileutils
187
188* Wed Oct 04 2000 Owen Taylor <otaylor@redhat.com>
189- Initial package
Note: See TracBrowser for help on using the repository browser.