source: projects/specs/trunk/p/perl-DBD-SQLite/perl-DBD-SQLite-vl.spec @ 9022

Revision 9022, 4.2 KB checked in by inagaki, 10 years ago (diff)

2014-10-25 Ryoichi INAGAKI <ryo1@…>

  • perl modules: rebuilt and update


Line 
1%define module  DBD-SQLite
2%define name    perl-%{module}
3%define version 1.42
4%define release 1%{_dist_release}
5
6Name:           %{name}
7Version:        %{version}
8Release:        %{release}
9Summary:        Self Contained RDBMS in a DBI Driver
10
11License:        Artistic or GPL+
12Group:          Development/Libraries
13URL:            http://search.cpan.org/dist/%{module}/
14Source:         ftp://ftp.perl.org/pub/CPAN/modules/by-module/DBD/%{module}-%{version}.tar.gz
15
16Buildroot:      %{_tmppath}/%{name}-%{version}
17BuildRequires:  perl(DBI) >= 1.57
18BuildRequires:  sqlite3-devel   
19Requires:       perl(DBI) >= 1.57
20Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
21
22Vendor:         Project Vine
23Distribution:   Vine Linux
24
25%description
26SQLite is a small fast embedded SQL database engine.
27
28DBD::SQLite embeds that database engine into a DBD driver, so
29if you want a relational database for your project, but don't
30want to install a large RDBMS system like MySQL or PostgreSQL,
31then DBD::SQLite may be just what you need.
32
33It supports quite a lot of features, such as transactions (atomic
34commit and rollback), indexes, DBA-free operation, a large subset
35of SQL92 supported, and more.
36
37#'
38%prep
39%setup -q -n %{module}-%{version}
40
41%build
42CFLAGS="%{optflags}" %{__perl} Makefile.PL INSTALLDIRS="vendor"
43make %{?_smp_mflags}
44
45%check
46make test
47
48%install
49rm -rf %{buildroot}
50make pure_install PERL_INSTALL_ROOT=%{buildroot}
51find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
52find %{buildroot} -type f -name '*.bs' -empty -exec rm -f {} ';'
53find %{buildroot} -type d -depth -exec rmdir {} 2>/dev/null ';'
54chmod -R u+w %{buildroot}/*
55
56%clean
57rm -rf %{buildroot}
58
59%files
60%defattr(-,root,root)
61%doc README* Changes
62%{perl_vendorarch}/DBD
63%{perl_vendorarch}/auto/DBD
64%{_mandir}/*/*
65
66%changelog
67* Sat Oct 11 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.42-1
68- new upstream release
69
70* Fri Jun 27 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.31-2
71- build with Perl 5.16
72- add Requires: MODULE_COMPAT_*
73
74* Thu Mar 31 2011 IWAI, Masaharu <iwai@alib.jp> 1.31-1
75- new upstream release
76- update {Build,}Requires: perl-DBI version: sync upstream
77
78* Fri May 02 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.14-1vl5
79- rebuild with perl 5.10
80- new versioning policy
81
82* Mon Mar 10 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.14-0vl1
83- rebuild for VineSeed
84- disable test
85
86* Sat Mar 08 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.14-0vl0.43
87- add Requires: perl(DBI) >= 1.03
88
89* Sun Mar 02 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.14-0vl0.42
90- new upstream release
91- built for Vine 4.2 testing
92
93* Sun Dec 17 2006 Guillaume Rousse <guillomovitch@mandriva.org> 1.13-2mdv2007.0
94+ Revision: 98263
95- fix build dependencies
96
97* Sat Dec 16 2006 Guillaume Rousse <guillomovitch@mandriva.org> 1.13-1mdv2007.1
98+ Revision: 98198
99- new version
100
101* Mon Aug 07 2006 Olivier Thauvin <nanardon@mandriva.org> 1.12-2mdv2007.0
102+ Revision: 53730
103- rebuild
104- Import perl-DBD-SQLite
105
106
107* Thu Apr 13 2006 Guillaume Rousse <guillomovitch@mandriva.org> 1.12-1mdk
108- New release 1.12
109- better source URL
110- better buildrequires syntax
111
112* Tue Dec 20 2005 Guillaume Rousse <guillomovitch@mandriva.org> 1.11-1mdk
113- new version
114- fix directory ownership
115
116* Mon Sep 26 2005 Guillaume Rousse <guillomovitch@mandriva.org> 1.09-2mdk
117- rebuild to link against external library
118- spec cleanup
119- %%mkrel
120
121* Tue Jun 21 2005 Rafael Garcia-Suarez <rgarciasuarez@mandriva.com> 1.09-1mdk
122- 1.09
123- spec cleanups
124
125* Mon Mar 14 2005 Rafael Garcia-Suarez <rgarciasuarez@mandrakesoft.com> 1.08-1mdk
126- new veresion 1.08
127
128* Mon Nov 15 2004 Rafael Garcia-Suarez <rgarciasuarez@mandrakesoft.com> 1.07-2mdk
129- rebuild for new perl
130- remove README.urpmi
131
132* Thu Oct 14 2004 Rafael Garcia-Suarez <rgarciasuarez@mandrakesoft.com> 1.07-1mdk
133- 1.07.
134
135* Tue Aug 10 2004 Rafael Garcia-Suarez <rgarciasuarez@mandrakesoft.com> 1.03-1mdk
136- 1.03.
137- Remove patch 1.
138
139* Wed Jul 28 2004 Rafael Garcia-Suarez <rgarciasuarez@mandrakesoft.com> 1.00-1mdk
140- 1.00, incompatible format with previous versions.
141- Remove MANIFEST, add README.update.urpmi.
142- Patch to prevent interactivity in Makefile.PL
143
144* Mon May 17 2004 Olivier Thauvin <thauvin@aerov.jussieu.fr> 0.31-2mdk
145- Fix compile FLAGS
146
147* Fri Nov 01 2002 Olivier Thauvin <thauvin@aerov.jussieu.fr> 0.31-1mdk
148- first version of rpm.
Note: See TracBrowser for help on using the repository browser.