source: projects/specs/trunk/p/perl-DBD-SQLite/perl-DBD-SQLite-vl.spec @ 8639

Revision 8639, 3.9 KB checked in by iwaim, 10 years ago (diff)

perl-DBD-SQLite 1.31-2

Line 
1%define module  DBD-SQLite
2%define name    perl-%{module}
3%define version 1.31
4%define release 2%{_dist_release}
5
6Name:           %{name}
7Version:        %{version}
8Release:        %{release}
9Summary:        Self Contained RDBMS in a DBI Driver
10License:        GPL
11URL:            http://search.cpan.org/dist/%{module}/
12Source:         ftp://ftp.perl.org/pub/CPAN/modules/by-module/DBD/%{module}-%{version}.tar.gz
13Group:          Development/Languages
14Requires:       perl(DBI) >= 1.57
15Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
16
17BuildRequires:  perl(DBI) >= 1.57
18BuildRequires:  sqlite3-devel   
19Buildroot:      %{_tmppath}/%{name}-%{version}
20
21Vendor:         Project Vine
22Distribution:   Vine Linux
23
24%description
25SQLite is a small fast embedded SQL database engine.
26
27DBD::SQLite embeds that database engine into a DBD driver, so
28if you want a relational database for your project, but don't
29want to install a large RDBMS system like MySQL or PostgreSQL,
30then DBD::SQLite may be just what you need.
31
32It supports quite a lot of features, such as transactions (atomic
33commit and rollback), indexes, DBA-free operation, a large subset
34of SQL92 supported, and more.
35
36#'
37%prep
38%setup -q -n %{module}-%{version}
39
40%build
41CFLAGS="%{optflags}" %{__perl} Makefile.PL INSTALLDIRS="vendor" PREFIX="%{buildroot}%{_prefix}"
42%{__make}
43
44# %check
45# %{__make} test
46
47%install
48rm -rf %{buildroot}
49%makeinstall
50rm -f %{buildroot}%{perl_vendorarch}/auto/*/*/.packlist
51
52%clean
53rm -rf %{buildroot}
54
55%files
56%defattr(-,root,root)
57%doc README* Changes
58%{perl_vendorarch}/DBD
59%{perl_vendorarch}/auto/DBD
60%{_mandir}/*/*
61
62%changelog
63* Fri Jun 27 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.31-2
64- build with Perl 5.16
65- add Requires: MODULE_COMPAT_*
66
67* Thu Mar 31 2011 IWAI, Masaharu <iwai@alib.jp> 1.31-1
68- new upstream release
69- update {Build,}Requires: perl-DBI version: sync upstream
70
71* Fri May 02 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.14-1vl5
72- rebuild with perl 5.10
73- new versioning policy
74
75* Mon Mar 10 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.14-0vl1
76- rebuild for VineSeed
77- disable test
78
79* Sat Mar 08 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.14-0vl0.43
80- add Requires: perl(DBI) >= 1.03
81
82* Sun Mar 02 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.14-0vl0.42
83- new upstream release
84- built for Vine 4.2 testing
85
86* Sun Dec 17 2006 Guillaume Rousse <guillomovitch@mandriva.org> 1.13-2mdv2007.0
87+ Revision: 98263
88- fix build dependencies
89
90* Sat Dec 16 2006 Guillaume Rousse <guillomovitch@mandriva.org> 1.13-1mdv2007.1
91+ Revision: 98198
92- new version
93
94* Mon Aug 07 2006 Olivier Thauvin <nanardon@mandriva.org> 1.12-2mdv2007.0
95+ Revision: 53730
96- rebuild
97- Import perl-DBD-SQLite
98
99
100* Thu Apr 13 2006 Guillaume Rousse <guillomovitch@mandriva.org> 1.12-1mdk
101- New release 1.12
102- better source URL
103- better buildrequires syntax
104
105* Tue Dec 20 2005 Guillaume Rousse <guillomovitch@mandriva.org> 1.11-1mdk
106- new version
107- fix directory ownership
108
109* Mon Sep 26 2005 Guillaume Rousse <guillomovitch@mandriva.org> 1.09-2mdk
110- rebuild to link against external library
111- spec cleanup
112- %%mkrel
113
114* Tue Jun 21 2005 Rafael Garcia-Suarez <rgarciasuarez@mandriva.com> 1.09-1mdk
115- 1.09
116- spec cleanups
117
118* Mon Mar 14 2005 Rafael Garcia-Suarez <rgarciasuarez@mandrakesoft.com> 1.08-1mdk
119- new veresion 1.08
120
121* Mon Nov 15 2004 Rafael Garcia-Suarez <rgarciasuarez@mandrakesoft.com> 1.07-2mdk
122- rebuild for new perl
123- remove README.urpmi
124
125* Thu Oct 14 2004 Rafael Garcia-Suarez <rgarciasuarez@mandrakesoft.com> 1.07-1mdk
126- 1.07.
127
128* Tue Aug 10 2004 Rafael Garcia-Suarez <rgarciasuarez@mandrakesoft.com> 1.03-1mdk
129- 1.03.
130- Remove patch 1.
131
132* Wed Jul 28 2004 Rafael Garcia-Suarez <rgarciasuarez@mandrakesoft.com> 1.00-1mdk
133- 1.00, incompatible format with previous versions.
134- Remove MANIFEST, add README.update.urpmi.
135- Patch to prevent interactivity in Makefile.PL
136
137* Mon May 17 2004 Olivier Thauvin <thauvin@aerov.jussieu.fr> 0.31-2mdk
138- Fix compile FLAGS
139
140* Fri Nov 01 2002 Olivier Thauvin <thauvin@aerov.jussieu.fr> 0.31-1mdk
141- first version of rpm.
Note: See TracBrowser for help on using the repository browser.