source: projects/specs/trunk/p/perl-DBD-SQLite/perl-DBD-SQLite-vl.spec @ 12120

Revision 12120, 4.4 KB checked in by tomop, 5 years ago (diff)

perl-5.26 and friends

Line 
1%define module  DBD-SQLite
2%define name    perl-%{module}
3%define version 1.62
4%define release 1%{_dist_release}
5
6Name:           %{name}
7Version:        %{version}
8Release:        %{release}
9Summary:        Self Contained RDBMS in a DBI Driver
10
11License:        Artistic or GPL+
12Group:          Development/Libraries
13URL:            http://search.cpan.org/dist/%{module}/
14Source:         ftp://ftp.perl.org/pub/CPAN/modules/by-module/DBD/%{module}-%{version}.tar.gz
15
16Buildroot:      %{_tmppath}/%{name}-%{version}
17BuildRequires:  perl(DBI)
18BuildRequires:  sqlite3-devel   
19BuildRequires:  libxcrypt-devel
20Requires:       perl(DBI)
21Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
22
23Vendor:         Project Vine
24Distribution:   Vine Linux
25
26%description
27SQLite is a small fast embedded SQL database engine.
28
29DBD::SQLite embeds that database engine into a DBD driver, so
30if you want a relational database for your project, but don't
31want to install a large RDBMS system like MySQL or PostgreSQL,
32then DBD::SQLite may be just what you need.
33
34It supports quite a lot of features, such as transactions (atomic
35commit and rollback), indexes, DBA-free operation, a large subset
36of SQL92 supported, and more.
37
38#'
39%prep
40%setup -q -n %{module}-%{version}
41
42%build
43CFLAGS="%{optflags}" %{__perl} Makefile.PL INSTALLDIRS="vendor"
44make %{?_smp_mflags}
45
46%check
47make test
48
49%install
50rm -rf %{buildroot}
51make pure_install PERL_INSTALL_ROOT=%{buildroot}
52find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
53find %{buildroot} -type f -name '*.bs' -empty -exec rm -f {} ';'
54find %{buildroot} -type d -depth -exec rmdir {} 2>/dev/null ';'
55chmod -R u+w %{buildroot}/*
56
57rm -rf %{buildroot}%{perl_vendorarch}/auto/share
58
59%clean
60rm -rf %{buildroot}
61
62%files
63%defattr(-,root,root)
64%doc README* Changes
65%{perl_vendorarch}/DBD
66%{perl_vendorarch}/auto/DBD
67%{_mandir}/*/*
68
69%changelog
70* Fri May 17 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.62-1
71- new upstream release.
72- rebuilt with perl-5.26.
73- added BR:libxcrypt-devel.
74
75* Sat Oct 11 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.42-1
76- new upstream release
77
78* Fri Jun 27 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.31-2
79- build with Perl 5.16
80- add Requires: MODULE_COMPAT_*
81
82* Thu Mar 31 2011 IWAI, Masaharu <iwai@alib.jp> 1.31-1
83- new upstream release
84- update {Build,}Requires: perl-DBI version: sync upstream
85
86* Fri May 02 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.14-1vl5
87- rebuild with perl 5.10
88- new versioning policy
89
90* Mon Mar 10 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.14-0vl1
91- rebuild for VineSeed
92- disable test
93
94* Sat Mar 08 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.14-0vl0.43
95- add Requires: perl(DBI) >= 1.03
96
97* Sun Mar 02 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.14-0vl0.42
98- new upstream release
99- built for Vine 4.2 testing
100
101* Sun Dec 17 2006 Guillaume Rousse <guillomovitch@mandriva.org> 1.13-2mdv2007.0
102+ Revision: 98263
103- fix build dependencies
104
105* Sat Dec 16 2006 Guillaume Rousse <guillomovitch@mandriva.org> 1.13-1mdv2007.1
106+ Revision: 98198
107- new version
108
109* Mon Aug 07 2006 Olivier Thauvin <nanardon@mandriva.org> 1.12-2mdv2007.0
110+ Revision: 53730
111- rebuild
112- Import perl-DBD-SQLite
113
114
115* Thu Apr 13 2006 Guillaume Rousse <guillomovitch@mandriva.org> 1.12-1mdk
116- New release 1.12
117- better source URL
118- better buildrequires syntax
119
120* Tue Dec 20 2005 Guillaume Rousse <guillomovitch@mandriva.org> 1.11-1mdk
121- new version
122- fix directory ownership
123
124* Mon Sep 26 2005 Guillaume Rousse <guillomovitch@mandriva.org> 1.09-2mdk
125- rebuild to link against external library
126- spec cleanup
127- %%mkrel
128
129* Tue Jun 21 2005 Rafael Garcia-Suarez <rgarciasuarez@mandriva.com> 1.09-1mdk
130- 1.09
131- spec cleanups
132
133* Mon Mar 14 2005 Rafael Garcia-Suarez <rgarciasuarez@mandrakesoft.com> 1.08-1mdk
134- new veresion 1.08
135
136* Mon Nov 15 2004 Rafael Garcia-Suarez <rgarciasuarez@mandrakesoft.com> 1.07-2mdk
137- rebuild for new perl
138- remove README.urpmi
139
140* Thu Oct 14 2004 Rafael Garcia-Suarez <rgarciasuarez@mandrakesoft.com> 1.07-1mdk
141- 1.07.
142
143* Tue Aug 10 2004 Rafael Garcia-Suarez <rgarciasuarez@mandrakesoft.com> 1.03-1mdk
144- 1.03.
145- Remove patch 1.
146
147* Wed Jul 28 2004 Rafael Garcia-Suarez <rgarciasuarez@mandrakesoft.com> 1.00-1mdk
148- 1.00, incompatible format with previous versions.
149- Remove MANIFEST, add README.update.urpmi.
150- Patch to prevent interactivity in Makefile.PL
151
152* Mon May 17 2004 Olivier Thauvin <thauvin@aerov.jussieu.fr> 0.31-2mdk
153- Fix compile FLAGS
154
155* Fri Nov 01 2002 Olivier Thauvin <thauvin@aerov.jussieu.fr> 0.31-1mdk
156- first version of rpm.
Note: See TracBrowser for help on using the repository browser.