source: projects/specs/trunk/p/peco/peco-vl.spec @ 9998

Revision 9998, 2.0 KB checked in by iwaim, 8 years ago (diff)

peco 0.3.5-4

Line 
1%define pkg_version 0.3.5
2%define pkg_release 4%{?_dist_release}
3
4%global gopath %{_datadir}/gocode
5
6Summary:          Simplistic interactive filtering tool
7Summary(ja):      シンプルな対話式フィルタリングツール
8Name:             peco
9Version:          %{pkg_version}
10Release:          %{pkg_release}
11
12License:          MIT License
13Group:            Applications/Text
14URL:              https://github.com/peco/peco
15Source:           https://github.com/peco/peco/archive/v%{version}.tar.gz#/peco-%{version}.tar.gz
16
17BuildRoot: %{_tmppath}/%{pkg_name}-%{version}-root
18BuildRequires: golang
19BuildRequires: golang(github.com/google/btree)
20BuildRequires: golang(github.com/mattn/go-runewidth)
21BuildRequires: golang(github.com/jessevdk/go-flags)
22BuildRequires: golang(github.com/nsf/termbox-go)
23
24Vendor: Project Vine
25Distribution: Vine Linux
26Packager: Toshiaki Ara <ara_t@384.jp>
27
28%description
29peco is a simplistic interactive filtering tool
30based on a python tool, percol, and written in Go.
31
32%description -l ja
33pecoはシンプルな対話式フィルタリングツールであり、
34Pyhon製のpercolをGo言語で実装したプログラムです。
35
36
37%prep
38%{__rm} -rf ${RPM_BUILD_ROOT}
39
40%setup -q
41
42%build
43export BUILD_DIR=$(pwd)/.build
44export GOPATH=$BUILD_DIR:%{gopath}
45
46%{__mkdir_p} $BUILD_DIR/src/github.com/peco/peco
47%{__cp} -r * $BUILD_DIR/src/github.com/peco/peco
48go build cmd/peco/peco.go
49
50%install
51%{__mkdir} -p ${RPM_BUILD_ROOT}%{_bindir}
52%{__install} -m 755 peco ${RPM_BUILD_ROOT}%{_bindir}
53
54%clean
55%{__rm} -rf ${RPM_BUILD_ROOT}
56
57
58%files
59%defattr(-, root, root)
60%doc LICENSE
61%doc README.md Changes
62%{_bindir}/
63
64
65%changelog
66* Fri Jan 29 2016 Toshiaki Ara <ara_t@384.jp> 0.3.5-4
67- defile %%{gopath}
68
69* Mon Jan 25 2016 IWAI, Masaharu <iwaim.sub@gmail.com> 0.3.5-3
70- using golang-* RPM packages for BuildRequires
71 - stop 'go get' in build section
72- update build section
73- add LICENSE, README.md and Changes
74
75* Tue Jan 19 2016 Toshiaki Ara <ara_t@384.jp> 0.3.5-2
76- build with Go
77- change spec file
78
79* Sun Jan 17 2016 Toshiaki Ara <ara_t@384.jp> 0.3.5-1
80- new package
81
Note: See TracBrowser for help on using the repository browser.