source: projects/specs/trunk/p/peco/peco-vl.spec @ 11712

Revision 11712, 2.5 KB checked in by ara_t, 6 years ago (diff)

peco: update to 0.5.3

Line 
1%define pkg_name    peco
2%define pkg_version 0.5.3
3%define pkg_release 1%{?_dist_release}
4
5%global gopath %{_datadir}/gocode
6
7Summary:     Simplistic interactive filtering tool
8Summary(ja): シンプルな対話式フィルタリングツール
9Name:        %{pkg_name}
10Version:     %{pkg_version}
11Release:     %{pkg_release}
12
13License: MIT License
14Group:   Applications/Text
15URL:     https://github.com/peco/peco
16Source:  https://github.com/peco/peco/archive/v%{version}.tar.gz#/peco-%{version}.tar.gz
17
18BuildRoot: %{_tmppath}/%{pkg_name}-%{version}-root
19BuildRequires: golang
20BuildRequires: golang(github.com/google/btree)
21BuildRequires: golang(github.com/mattn/go-runewidth)
22BuildRequires: golang(github.com/jessevdk/go-flags)
23BuildRequires: golang(github.com/nsf/termbox-go)
24BuildRequires: golang(github.com/pkg/errors)
25BuildRequires: golang(github.com/lestrrat/go-pdebug)
26
27Vendor: Project Vine
28Distribution: Vine Linux
29Packager: ara_t
30
31
32%description
33peco is a simplistic interactive filtering tool
34based on a python tool, percol, and written in Go.
35
36%description -l ja
37pecoはシンプルな対話式フィルタリングツールであり、
38Python製のpercolをGo言語で実装したプログラムです。
39
40
41%prep
42%{__rm} -rf ${RPM_BUILD_ROOT}
43
44%setup -q
45
46%build
47export BUILD_DIR=$(pwd)/.build
48export GOPATH=${BUILD_DIR}:%{gopath}
49
50%{__mkdir_p} ${BUILD_DIR}/src/github.com/peco/peco
51%{__cp} -r * ${BUILD_DIR}/src/github.com/peco/peco
52cd ${BUILD_DIR}/src/github.com/peco/peco
53go build cmd/peco/peco.go
54
55%install
56%{__mkdir_p} ${RPM_BUILD_ROOT}%{_bindir}
57export BUILD_DIR=$(pwd)/.build
58cd ${BUILD_DIR}/src/github.com/peco/peco
59%{__install} -m 755 peco ${RPM_BUILD_ROOT}%{_bindir}
60
61%clean
62%{__rm} -rf ${RPM_BUILD_ROOT}
63
64
65%files
66%defattr(-, root, root)
67%doc LICENSE
68%doc README.md Changes
69%{_bindir}/
70
71
72%changelog
73* Sat Jun 09 2018 Toshiaki Ara <ara_t@384.jp> 0.5.3-1
74- update to 0.5.3
75
76* Wed Jun 07 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 0.5.1-1
77- update to 0.5.1
78- update BuildRequires
79
80* Wed May 11 2016 Toshiaki Ara <ara_t@384.jp> 0.3.6-1
81- update to 0.3.6
82
83* Sun Apr 10 2016 Toshiaki Ara <ara_t@384.jp> 0.3.5-5
84- correct SPEC file
85
86* Fri Jan 29 2016 Toshiaki Ara <ara_t@384.jp> 0.3.5-4
87- defile %%{gopath}
88
89* Mon Jan 25 2016 IWAI, Masaharu <iwaim.sub@gmail.com> 0.3.5-3
90- using golang-* RPM packages for BuildRequires
91 - stop 'go get' in build section
92- update build section
93- add LICENSE, README.md and Changes
94
95* Tue Jan 19 2016 Toshiaki Ara <ara_t@384.jp> 0.3.5-2
96- build with Go
97- change spec file
98
99* Sun Jan 17 2016 Toshiaki Ara <ara_t@384.jp> 0.3.5-1
100- new package
101
Note: See TracBrowser for help on using the repository browser.