source: projects/specs/trunk/p/peco/peco-vl.spec @ 9990

Revision 9990, 1.9 KB checked in by iwaim, 8 years ago (diff)

peco 0.3.5-3

Line 
1%define pkg_version 0.3.5
2%define pkg_release 3%{?_dist_release}
3
4Summary:          Simplistic interactive filtering tool
5Summary(ja):      シンプルな対話式フィルタリングツール
6Name:             peco
7Version:          %{pkg_version}
8Release:          %{pkg_release}
9
10License:          MIT License
11Group:            Applications/Text
12URL:              https://github.com/peco/peco
13Source:           https://github.com/peco/peco/archive/v%{version}.tar.gz#/peco-%{version}.tar.gz
14
15BuildRoot: %{_tmppath}/%{pkg_name}-%{version}-root
16BuildRequires: golang
17BuildRequires: golang(github.com/google/btree)
18BuildRequires: golang(github.com/mattn/go-runewidth)
19BuildRequires: golang(github.com/jessevdk/go-flags)
20BuildRequires: golang(github.com/nsf/termbox-go)
21
22Vendor: Project Vine
23Distribution: Vine Linux
24Packager: Toshiaki Ara <ara_t@384.jp>
25
26%description
27peco is a simplistic interactive filtering tool
28based on a python tool, percol, and written in Go.
29
30%description -l ja
31pecoはシンプルな対話式フィルタリングツールであり、
32Pyhon製のpercolをGo言語で実装したプログラムです。
33
34
35%prep
36%{__rm} -rf ${RPM_BUILD_ROOT}
37
38%setup -q
39
40%build
41export BUILD_DIR=$(pwd)/.build
42export GOPATH=$BUILD_DIR:%{gopath}
43
44%{__mkdir_p} $BUILD_DIR/src/github.com/peco/peco
45%{__cp} -r * $BUILD_DIR/src/github.com/peco/peco
46go build cmd/peco/peco.go
47
48%install
49%{__mkdir} -p ${RPM_BUILD_ROOT}%{_bindir}
50%{__install} -m 755 peco ${RPM_BUILD_ROOT}%{_bindir}
51
52%clean
53%{__rm} -rf ${RPM_BUILD_ROOT}
54
55
56%files
57%defattr(-, root, root)
58%doc LICENSE
59%doc README.md Changes
60%{_bindir}/
61
62
63%changelog
64* Mon Jan 25 2016 IWAI, Masaharu <iwaim.sub@gmail.com> 0.3.5-3
65- using golang-* RPM packages for BuildRequires
66 - stop 'go get' in build section
67- update build section
68- add LICENSE, README.md and Changes
69
70* Tue Jan 19 2016 Toshiaki Ara <ara_t@384.jp> 0.3.5-2
71- build with Go
72- change spec file
73
74* Sun Jan 17 2016 Toshiaki Ara <ara_t@384.jp> 0.3.5-1
75- new package
76
Note: See TracBrowser for help on using the repository browser.